Problèmes et questions concernant l'édition KDE.
Répondre

Options du clavier sous KDE

#1Messageil y a 7 mois

Bonjour,

Dans les options du clavier sous KDE, il se trouve une disposition qui m'intéresse très fortement et c'est "Utiliser la barre d'espacement pour insérer une espace insécable"
Image

Mais une question : qu'est-ce que les niveaux 2, 3,4, etc. ?

J'ai cherché sur le Net, mais je n'ai rien trouvé de précis.

Merci de votre aide.

Options du clavier sous KDE

#2Messageil y a 7 mois

C’est la terminologie utilisée par xkeyboard pour définir les différents caractères accessibles sur une touche pour un mapping clavier via, éventuellement, une ou plusieurs autres touches. Prenons l’exemple le mapping “Français (variante)” sur la touche “é” :
- Niveau 1 → é (touche sans modificateur)
- Niveau 2 → 2 (Shift+touche, en standard)
- Niveau 3 → ~ (AltGr+touche, en standard)
- Niveau 4 → É (AltGr+Shift+touche, en standard)

xkeyboard utilise cette terminologie car les modificateurs peuvent être eux-même paramétrés (tu peux très bien définir la touche VerrMaj comme étant le modificateur pour atteindre le niveau 3, par exemple)

Options du clavier sous KDE

#3Messageil y a 7 mois

Merci celix, j'ai tout compris.

Mais je ne sais pas ce que j'ai fait. La disposition du clavier en elle-même n'a pas changé →clavier belge.
Sauf que ma touche AltGr droite, qui me permettait de faire l'arobase, me fait maintenant un ². Or, j'ai remis dans "Périphériques d'entrée" → "Clavier", tout à "Réglage par défaut", mais cette touche ne me donne plus les mêmes réglages qu'auparavant.

Par exemple l'arobase me fait ² et l'accolade droite me donne : → (AltGr + accolade droite).

Puis tout autre chose qui ne fonctionne pas bien chez moi : dans "Configuration du système", lorsque je veux changer d'option, par exemple passer de Espace de travail à Personnalisation et même à l'intérieur de ces menus, il y a bien une minute qui se passe avant que le changement de menu (sous-menu) ne s'effectue et les deux choix demandés demeurent en surbrillance.
Que se passe-t-il ?

Troisième et dernière chose, dans "Espace de travail" → "Comportement de l'espace de travail" → "Effets de bureau", rien ne fonctionne comme demandé : "Ornements", par exemple. J'ai coché "Fenêtre en gélatine" et "Tomber en ruine". Rien ne se passe. Même chose pour "Gestion des fenêtres", j'ai coché "Cube de bureaux" et "Empilement en perspective" : rien ne se passe.
Donc, même question que la précédante.

Merci à tout les utilisateurs de KDE que je trouve malgré tout merveilleux.

Je ne regrette pas d'être passé de XFCE, bureau pour lequel j'étais un inconditionnel, à KDE. :gsourire::gsourire:

Options du clavier sous KDE

#4Messageil y a 7 mois

normalement plasma est fluide :o
verifier si baloo est désactivé(voir aide -h pour déactiver)

 balooctl status
Pour tes effets, je suppose que tu n'as pas de compositeur :pleure:
vérifier qdbus org.kde.KWin /Compositor active
démarrer qdbus org.kde.KWin /Compositor resume ou bascule on/off : ALT +SHIFT + F12
pourquoi pas démarré qdbus org.kde.KWin /Compositor compositingNotPossibleReason
ps: la même chose en graphique dans nos paramètres kde (matériel - affichage - compositeur)

Options du clavier sous KDE

#5Messageil y a 7 mois

Pour ce qui est du problème de clavier, il faut vérifier, outre que c’est bien le clavier belge qui est sélectionné, qu’il s’agit de la bonne variante. Ici, pour le clavier belge (que je n’utilise pas, au demeurant), j’ai les variantes disponibles suivantes :
- Défaut
- Belge (Sun 6/7)
- Belge (Wang 724 azerty)
- Belge (sans touche morte)
- Belge (touches mortes Sun)
- Belge (variante ISO)
- Belge (variante)
- Belge (variante, Latin-9 uniquement)
- Belge (variante, touches mortes Sun)

Options du clavier sous KDE

#6Messageil y a 7 mois

papajoke a écrit : il y a 7 mois normalement plasma est fluide :o
verifier si baloo est désactivé(voir aide -h pour déactiver)

 balooctl status
Pour tes effets, je suppose que tu n'as pas de compositeur :pleure:
vérifier qdbus org.kde.KWin /Compositor active
démarrer qdbus org.kde.KWin /Compositor resume ou bascule on/off : ALT +SHIFT + F12
pourquoi pas démarré qdbus org.kde.KWin /Compositor compositingNotPossibleReason
ps: la même chose en graphique dans nos paramètres kde (matériel - affichage - compositeur)
Baloo fonctionne bien.
Je l'ai stoppé par :
sudo balooctl disable
Par contre j'ai un message de compositor : ;rale:;rale:
qdbus org.kde.KWin /Compositor compositingNotPossibleReason
OpenGL compositing (the default) has crashed KWin in the past.
This was most likely due to a driver bug.[p]If you think that you have meanwhile upgraded to a stable driver,
you can reset this protection but be aware that this might result in an immediate crash! Alternatively, you might want to use the XRender backend instead.

Il m'est impossible de le démarrer :

[obelix@obelix-ManjaroKDE ~]$ qdbus org.kde.KWin /Compositor resume
[obelix@obelix-ManjaroKDE ~]$ qdbus org.kde.KWin /Compositor active
false
Et j'ai bien un message d'erreur pour mon pilote graphique :
Le compositeur OpenGL (par défaut) a rendu KWin instable par le passé.
Ceci était très probablement dû à un bogue dans le pilote graphique.
Si vous pensez avoir entre temps effectué une mise à jour vers un pilote stable,
vous pouvez réinitialiser cette protection, mais soyez conscient que cela peut aboutir à un plantage immédiat !
Sinon, vous pouvez utiliser plutôt le moteur Xrender.
Mais là au niveau de ma carte NVDIA, je ne sais pas quoi faire.
Je me souviens que sous XFCE, le système m'avais mis la 430. KDE m'a mis la 418. Je ne peux, dans les paramètres de la carte graphique mettre la 430 qui pourtant est bien présente dans la liste.

@cellix : mon clavier, je ne sais pourquoi, est revenu à la normale : merci à toi :wink::wink:
Répondre