Questions sur l'installation et la configuration de Manjaro Linux.
Répondre

Toutes les entrées dans menu GRUB en double

#1Messageil y a 6 mois

J'ai une anomalie depuis quelque temps dans mon menu GRUB qui me met toutes les entrées en double : c'est à dire que chaque possibilité pour Manjaro est proposée deux fois, que le boot sur Windows 10 apparaît deux fois ainsi que MXlinux et Ubuntu que je teste sur d'autres partitions.

Ce n'est pas vraiment gênant puisque tout fonctionne, mais le moins qu'on puisse dire, c'est que ça ne fait pas propre ;rale::Rouleau:

Toutes les entrées dans menu GRUB en double

#2Messageil y a 6 mois

Bonjour, cela me fait penser à ces nombreux problèmes de grub, liés à ce logiciel très peu recommandable qu'est "grub-customizer". L'aurai tu installé ?

Toutes les entrées dans menu GRUB en double

#3Messageil y a 6 mois

Effectivement, Erwan j'ai installé Grub Customizer

Je l'ai peut-être utilisé une fois et depuis j'ai oublié qu'il était là. Mais la piste que tu suggères est peut-être la bonne. Que me conseilles-tu de faire?

Toutes les entrées dans menu GRUB en double

#4Messageil y a 6 mois

Je commencerai par désinstaller grub-customizer ainsi que ses eventuelles dépendances : sudo pacman -Rsn grub-customizer puis tenter de réinstaller grub en croisant les doigts pour que le fichier original soit régénéré.

Toutes les entrées dans menu GRUB en double

#5Messageil y a 6 mois

Après avoir désinstaller Grub Customizer et toutes ses dépendances, avoir rebooté et réinstallé Grub, la commande update-grub génère à nouveau les entrées en double. :Rouleau:

Toutes les entrées dans menu GRUB en double

#6Messageil y a 6 mois

Donne déjà le retour de ces deux commandes (entre balises code), la première pour vérifier si des arguments spécifiques sont présents dans ton grub et la seconde pour voir s'il existe un /etc/default/grub.pacnew dans ton système de fichier. L'idée est d'écraser ton fichier de grub actuel par le grub.pacnew éventuellement modifié. ;)

cat /etc/default/grub.pacnew

find /etc -regextype posix-extended -regex ".+\.pac(new|save)" 2> /dev/null

Toutes les entrées dans menu GRUB en double

#7Messageil y a 6 mois

Voici le retour de la première commande

GRUB_DEFAULT=saved
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"
Et voici ensuite le retour de la deuxième commande

/etc/pacman.conf.pacnew
/etc/default/grub.pacsave
/etc/default/grub.pacnew
/etc/sane.d/dll.conf.pacnew
/etc/pamac.conf.pacnew

Toutes les entrées dans menu GRUB en double

#8Messageil y a 6 mois

Ok, je constate qu'il existe un fichier de sauvegarde de grub, sans doute créé à la date de l'utilisation première de grub-customizer. Je te suggère de renomer le fichier courant ainsi que le .pacnew. Ce qui peut se faire en une seule commande :

mv /etc/default/grub /etc/default/grub.old && mv /etc/default/grub.pacnew /etc/default/grub
Sans garantie d'une résolution complète de ton problème car j'ignore la profondeur d'incrustation de grub-customizer dans le processus de démarrage.

Toutes les entrées dans menu GRUB en double

#9Messageil y a 6 mois

Désolé Erwan, mais le mal est plus profond que ce que nous pouvions espérer.

L'application des procédures que tu m'as proposées n'a pas pour l'instant résolu le PB

Merci pour tes efforts :sourire:

Toutes les entrées dans menu GRUB en double

#10Messageil y a 6 mois

Contrairement à l'idée première qui était de considérer que Grub-Customizer était mon ennemi ou le coupable, c'est grâce à cette application que j'ai tout remis en ordre très proprement car le PB était dans grub.cfg qui était "pollué" par plusieurs installations.
J'ai pu rétablir mes entrées, réaffecter le fond d'écran du menu de démarrage de "manjaro-live", BREF j'ai maintenant un menu grub propre performant et esthétique. :sourire::sourire:

Encore MERCI pour les conseils qui m'ont poussé à faire des recherches plus approfondies et à trouver par moi même une solution acceptable, à défaut d'être parfaitement académique

Répondre