Problèmes et questions concernant le noyau et le support matériel.

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#21Messageil y a 1 mois

nouveau souci avec la maj d'octobre : cette fois-ci impossible d'imprimer et l'erreur est Filter Failed....
Du coup j'ai tout remis à niveau et suis revenu avec un cups, libcups et cups-filters à jour
.....
résultat retour cas départ, ppd file en erreur impossible d'installer l'imprimante. Cette fois j'ai suivi ces instructions et pour moi celà fonctionne :
I have had the same error ("successful-ok-ignored-or-substituted-attributes") recently, after trying to re-setup my HP Deskjet 2676 which stopped working (maybe an update?).

From trying to add it via CUPS, I figured it had something to do with a PPD file, which is stored at "/usr/share/ppd/HP/something.ppd.gz". Unzip it via gunzip, then running "cupstestppd" on it showed some errors. Removing the lines which it shows errors on then using this PPD file instead of the original worked for me.

Hope this helps smile
j'espère que ça aidera....

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#22Messageil y a 1 mois

Salut gnulux,
Même problème mon imprimante HP ne fonctionne plus et j'avais aussi bloqué les mises a jour de CUPS, par contre tu pourrais être plus explicite sur la nouvelle marche a suivre, je suis pas sur d'avoir tout compris :saispas:
D’avance merci

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#23Messageil y a 1 mois

oui désolé c'est vrai que j'ai été light en explication....
Bref :
1/ D'abord remettre à niveau les paquest cups, libcups et cups-filters : en root tu ouvres /etc/pacman.conf et tu commentes (en ajoutant un # en début de ligne) la ligne qui commence par "IgnorePkg"
2/ mets à jour ton pc : pacman -Syyu et tu devrais avoir la mise à jour des 3 paquets concernés

3/On rentre dans le dur : tu vas dans le répertoire "/usr/share/ppd/HP/"

cd /usr/share/ppd/HP/
4/trouve le fichier qui t’intéresse :

ls *envy*5000*
--> tu as un retour un seul fichier : hp-envy_5000_series.ppd.gz

5/ par précaution, fais une copie de sauvegarde :

cp hp-envy_5000_series.ppd.gz hp-envy_5000_series.ppd.gz_init
6/dé-zip le fichier :

gzip -d hp-envy_5000_series.ppd.gz
7/il est temps de corriger le fichier ppd décompressé. Tu passes cette commande :

cupstestppd hp-envy_5000_series.ppd
p-envy_5000_series.ppd: ÉCHEC
      **FAIL**  Unable to open PPD file - Mot-clé d’option interdit on line 198.
                REF: Page 19, section 3.3.
Tu ouvres ce fichier et tu enlèves la ligne 198.
Puis tu recommences tant que la commande t'indiques des lignes en erreur. En gros j'ai efface les lignes 198, 256,312 et 367. 2 fois en fait car elle marche par 2 ces lignes. Pour être plus clair il faut effacer les lignes 198,199,256,257,312,313,367 et 368.

8/Tu compresses le nouveau fichier :

gzip hp-envy_5000_series.ppd
9/ ajoutes ton imprimante avec ce nouveau fichier ppd et ça devrait fonctionner.

Voila bon courage

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#24Messageil y a 1 mois

Un grand merci a toi gnulux :clap
ça a fonctionné :bien

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#25Messageil y a 1 mois

chouette, content que ça fonctionne...
:bien

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#26Messageil y a 1 mois

Merci pour les recherches.... je passe en "résolu" et souhaite bon vent à tous !

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#27Messageil y a 1 mois

Bonjour à tous !

J'ai installée Manjaro à mon père, mais pas de bol, il a une envy 5030 donc même probleme que vous, j'ai tenté la procédure, cela n'a pas fonctionné.

Je vais tenter de downgrader les 3 paquets ( cups, cups-filters et libcups ), on verra bien, j’espère que la correction de ce bug ne va pas tarder, car c'est quand très ennuyeux.

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#28Messageil y a 3 jours

:salut:
Depuis la première "résolution" de ce problème avec la méthode proposé par gnulux j'ai dû l'appliquer trois fois et cela a mes trois machines Manjaro :oops:
N'y aurait t-il une solution pour figer ce problème une fois pour toute ?

C'est vraiment dommage voilà six mois que j'utilise Manjaro gnome est je l'adore vraiment ! (je viens d'Ubuntu depuis la version 10.04).
Je l'ai installer sur mon fixe et portable sur portable de ma femme et je vais probablement l’installer sur le fixe de ma fille. Presque la seul fausse note avec quelques mystères sur la configuration de Samba, mais ça c'est normal Samba se configure toujours avec la volonté du Saint-Esprit :rigole::rigole::rigole:

Donc si quelqu'un a une solution durable , je suis preneur :bien

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#29Messageil y a 3 jours

bonjour,

Il est en fait possible d'automatiser cette manipulation
1) créer un script (bash ou autre) et si on désire aller plus loin,
2) assigner un hook pacman sur le fichier hp-envy_5000_series.ppd.gz qui va déclencher ce script
Donc pérenne dans le temps, puisque l'on modifie automatiquement le fichier (si erreurs) à chaque mise à jour

script du type :

fichier="/tmp/hp-envy_5000_series.ppd"
gunzip -c /usr/share/ppd/HP/hp-envy_5000_series.ppd.gz > "$fichier"
while true; do
    err=$(cupstestppd "$fichier" | awk -F'line' '/\*\*FAIL.*line/ {print $2}')
    err="${err##* }"
    err="${err//./}"
    [[ "$err" == "0" ]] && exit 2
    [[ -z "$err" ]] && break    # OK plus d'erreurs avec une ligne donnée
    if (( err > 0 )); then
        echo ":: commenter la ligne: ${err} ..."
        sed -i "${err}s|^\*|\*\% |" "$fichier"
    fi
done
gzip "$fichier"
ls -l /tmp/*.ppd.gz
#cp -v /tmp/hp-envy_5000_series.ppd.gz /usr/share/ppd/HP/hp-envy_5000_series.ppd.gz 
ps: je n'ai aucune compétence en .ppd donc je ne sais si ce script fonctionne...

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#30Messageil y a 2 jours

le problème papajoke c'est que je n'est pas vue dernièrement une mise a jour de ppd a moins que je l'ai louper...

et a ce propos quel est la commande pour lister les dernières mise a jour effectuer ?

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#31Messageil y a 2 jours

pourquoi ce serait un problème si justement il n'y a pas de mise à jour du paquet ?

pacman -Qo /usr/share/ppd/HP/hp-envy_5000_series.ppd.gz
/usr/share/ppd/HP/hp-envy_5000_series.ppd.gz appartient à hplip 1:3.19.11-4
c'est donc le paquet hplip, tu peux (pour test) le réinstaller manuellement autant de fois que tu le désires

Pour voir la dernière date ou il a été installé tu as pacman -Qi hplip qui va te renseigner : retourne "installé le ..."
Et sinon, tout est dans les logs ! tu peux faire un grep sur les logs de pacman : grep "upgrade.*hplib" /var/log/pacman.log

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#32Messageil y a 2 jours

La dernière date ou a été installé hplip c'est le 14 novembre chez moi, mais il me semble bien que l'imprimante a été utilisé après cette date, mais dans le doute pour le moment j'ai bloqué la mise a jour sur ce paquet.Quand j'aurais plus de temps je creuserais plus.
Merci papajoke :bien

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#33Messageil y a 2 jours

Mais en fait c'est cups qui interprète ce fichier ppd ? Donc le bug peut-être dans cups qui fait une mauvaise lecture et non dans la validité de ppd :saispas:
ps: dans le script j'utilise cupstestppd qui lui fait partie de cups

Il y a un (seul) sujet à l'inter sur hp-envy-5000-printer ou apparemment réinstaller cups a résolu le Schmilblick ...

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#34Messageil y a 2 jours

la mise a jour de cups date du 28 octobre :?

sur mon PC portable j'ai une fresh install et il y a le même problème mais je ferais un essai de désinstallation et réinstallation de cups (mon imprimante est une deskjet 2620)

Répondre