Actualités & Annonces de l'équipe de développement et des administrateurs du forum.
Répondre

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#1Messageil y a 3 mois

Bonjour à toutes et à tous :bjr:

Une mise à jour est annoncée

Bonjour la communauté, je suis heureux d'annoncer une autre mise à jour stable !
Elle contient les modifications suivantes:
  • Nous envoyons un autre ensemble de versions ponctuelles du noyau , y compris nos noyaux en temps réel ,
  • Les navigateurs palemoon , chrome et falkon ont été mis à jour
  • De plus, notre outil de sauvegarde système backintime a été renouvelé, ce qui était très demandé.
  • Après Archlinux, nous avons finalement abandonné qt4 . Aucune raison de s'inquiéter si vous utilisez toujours une application dépendante héritée de qt4, car vous pouvez bien sûr garder votre qt4 installé pour le moment.
  • Calamares a été mis à jour et reconstruit contre kpmcore 4.0
  • Le paquet Grub a été repensé pour prendre également en charge les installations UEFI 32 bits. Espérons que le bogue des langues est également résolu par ceci.
  • l'iso KDE-Dev a été mis à jour et donc tous les paquets KDE-Git également. KDE-Dev avec un nouveau système de notification . Vous pouvez l'essayer avec notre ISO .
  • La plupart de nos noyaux ont été mis à jour. Certains pourraient avoir remarqué que dmesg est maintenant limité à root.
  • Nous avons ajouté linux52 dans son instantané git actuel. Quelques extramodules construits, mais pas encore tous !
  • XFCE-GTK3 a eu des paquets renouvelés. Le problème avec Nvidia et XFWM4-GTK3 a été résolu.
  • De plus, Gnome a été mis à jour à la version 3.32.2 avec les extensions de Gnome nécessaires.
  • Plasma est maintenant à 5.15.5 et KDE Applications est maintenant à 19.04.1
  • LibreOffice still est maintenant en 6.1.6
  • Bash a des correctifs de sécurité
  • Systemd a été mis à jour
  • Deepin propose de nouveaux paquets pour offrir une meilleure expérience
  • Mesa est maintenant à 19.0.4
  • Pour tous ceux qui utilisent Haskell , vous trouverez maintenant les dernières mises à jour dans nos pensions.

N'hésitez pas à nous donner vos commentaires sur les modifications apportées aux dépôts.


-------------------------------------------------------------------------------------
Mise à jour possible par pamac, octopi ou par pacman (de préférence) :

sudo pacman-mirrors -f0 && sudo pacman -Syyu
-------------------------------------------------------------------------------------

Noyaux pris en charge :
  • linux316 3.16.67
  • linux318 3.18.139 [EOL] En fin de vie
  • linux44 4.4.179 (no legacy nvidia-340 module!)
  • linux49 4.9.175
  • linux414 4.14.118
  • linux419 4.19.42
  • linux420 4.20.17 [EOL] En fin de vie
  • linux50 5.0.15
  • linux51 5.1.1 (quelques extramodules disponibles, mais pas tous!)
  • linux51 5.2-rc0 (quelques extramodules disponibles, mais pas tous!) (expérimental)
  • linux419-rt 4.19.37_rt19
  • linux50-rt 5.0.14_rt9
Les changements en détail :
  • community x86_64: 1722 nouveaux et 1725 paquets retirés
  • core x86_64: 40 nouveaux et 38 paquets retirés
  • extra x86_64: 834 nouveaux et 921 paquets retirés
  • multilib x86_64: 26 nouveaux et 47 paquets retirés
Une liste détaillée des changements peut être trouvée ici

44 paquets supprimés:

appmenu-qt4 chromium-chromevox fcitx-qt4 fetter firefox-kde-opensuse freemat gambas3-gb-qt4 gambas3-gb-qt4-ext gebabbel gedit-code-assistance gimp-gtk3 ibus-qt irssi-otr keepassx keepassx2 libdbusmenu-qt4 libechonest liblastfm-qt4 liblightdm-qt4 libmygpo-qt4 libringclient linux419-rt-rtl8723bu linux44-nvidia-340xx pamac-classic pamac-dev pamac-dev-tray-appindicator projectm-jack projectm-libvisual projectm-qt projectm-test python2-lttngust python2-osc-lib python2-plop python2-secretstorage python2-vcrpy qjson qmpdclient qtcurve-qt4 qwt5 qwtplot3d ring-daemon ring-gnome sni-qt v4l2ucp
54 nouveaux paquets

brave:  Web browser that blocks ads and trackers by default (latest binary release).
brave-beta:  Web browser that blocks ads and trackers by default (latest binary release).
cage:  A kiosk compositor for Wayland
fatresize:  A utility to resize FAT filesystems using libparted
ffnvcodec-headers8.1:  FFmpeg version of headers required to interface with Nvidias codec APIs
fluajho:  A simple sf2 soundfont host/player
hunspell-pt_br:  Brazillian Portuguese grammar, spelling and hyphenation checker to hunspell
kodi-bin:  x11 kodi binary
kodi-gbm:  gbm kodi binary
kodi-wayland:  wayland kodi binary
libmfx:  Intel Media SDK dispatcher library
linux316-virtualbox-host-modules:  Host kernel modules for VirtualBox
linux51-acpi_call:  A linux kernel module that enables calls to ACPI methods through /proc/acpi/call
linux51-bbswitch:  kernel module allowing to switch dedicated graphics card on Optimus laptops
linux51-broadcom-wl:  Broadcom 802.11 Linux STA wireless driver BCM43142.
linux51-ndiswrapper:  Module for NDIS (Windows Network Drivers) drivers supplied by vendors.
linux51-nvidia:  NVIDIA drivers for linux.
linux51-nvidiabl:  Driver to adjust display backlight on modern mobile NVidia graphics adapters.
linux51-r8168:  A kernel module for Realtek 8168 network cards
linux51-rtl8723bu:  A kernel module for Realtek 8723bu network cards
linux51-tp_smapi:  Modules for ThinkPad SMAPI functionality
linux51-vhba-module:  Kernel module that emulates SCSI devices
linux51-virtualbox-guest-modules:  Guest kernel modules for VirtualBox
linux51-virtualbox-host-modules:  Host kernel modules for VirtualBox
linux52:  The Linux52 kernel and modules
linux52-acpi_call:  A linux kernel module that enables calls to ACPI methods through /proc/acpi/call
linux52-bbswitch:  kernel module allowing to switch dedicated graphics card on Optimus laptops
linux52-broadcom-wl:  Broadcom 802.11 Linux STA wireless driver BCM43142.
linux52-headers:  Header files and scripts for building modules for Linux52 kernel
linux52-ndiswrapper:  Module for NDIS (Windows Network Drivers) drivers supplied by vendors.
linux52-nvidia:  NVIDIA drivers for linux.
linux52-nvidiabl:  Driver to adjust display backlight on modern mobile NVidia graphics adapters.
linux52-r8168:  A kernel module for Realtek 8168 network cards
linux52-vhba-module:  Kernel module that emulates SCSI devices
linux52-virtualbox-guest-modules:  Guest kernel modules for VirtualBox
linux52-virtualbox-host-modules:  Host kernel modules for VirtualBox
nextcloud-app-deck:  Kanban style organization tool aimed at personal planning and project organization
nextcloud-app-news:  An RSS/Atom feed aggregator
ocs-store:  Store Frontend and Management Application for opendesktop.org
openbox-themes:  Various themes for the Openbox window manager.
pantheon-camera:  The Pantheon Camera Application
patroneo:  An easy to use pattern based midi sequencer
php-imagick:  PHP extension to create and modify images using the ImageMagick library
pyenv:  Easily switch between multiple versions of Python
python2-purl:  An immutable URL class for easy URL-building and manipulation
python-pillow-simd:  Python Imaging Library (PIL) fork. Pillow fork for better image processing performance.
python-purl:  An immutable URL class for easy URL-building and manipulation
python-ueberzug:  ueberzug is an python script which aims to replace w3mimgdisplay
rapydscript-ng:  Pythonic JavaScript that doesnt suck
rofi-pass:  bash script to handle pass storages in a convenient way
rspamd:  Fast, free and open-source spam filtering system
sd:  Intuitive find & replace
waylandpp:  Wayland C++ bindings
yq:  Command-line YAML processor - jq wrapper for YAML documents
-------------------------------------------------------------------------------------


-------------------------------------------------------------------------------------
ERREUR : conflit de fichiers
Si lors de la mise à jour vous avez le type d'erreur comme ci-dessous (tlp est un exemple) :

erreur : la validation de la transaction a échoué (conflit de fichiers)
tlp : /etc/acpi/thinkpad est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.
il convient de passer la commande suivante en l'adaptant à votre cas particulier :

sudo pacman -S nom_paquet --overwrite '/etc/acpi/thinkpad'
Ensuite, vous pouvez faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
ERREUR de clés
Si lors de la mise à jour vous avez des problèmes de clés, essayez de passer les commandes suivantes :

sudo pacman-mirrors -g
sudo pacman -Syy
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
Ensuite, vous devriez pouvoir faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#2Messageil y a 3 mois

En premier lieu voici un bug de votre site :

[phpBB Debug] PHP Warning: in file [ROOT]/ext/derky/sortablescaptcha/captcha/sortables.php on line 14: Declaration of derky/sortablescaptcha/captcha/sortables::acp_page($id, &$module) should be compatible with phpbb/captcha/plugins/qa::acp_page($id, $module)
[phpBB Debug] PHP Warning: in file [ROOT]/ext/derky/sortablescaptcha/captcha/sortables.php on line 14: Declaration of derky/sortablescaptcha/captcha/sortables::acp_question_list(&$module) should be compatible with phpbb/captcha/plugins/qa::acp_question_list($module)
Maintenant pour cette mise à jour je suis content que le support UEFI 32bit soit pris en charge cela permet d'avoir de petit pc pas chère.
Aussi j'ai lancé la mise à jour avant de partir au travail mais en gros je verrais ce midi seul bémol pas de kernel 5.1 avec tout les modules.

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#3Messageil y a 3 mois

@liberodark.
:salut:
Merci pour le retour. Nous venons de faire une mise à jour majeure de phpBB et tous les modules ne sont pas encore à jour.
Ça devrait se corriger assez rapidement.

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#4Messageil y a 3 mois

Fait et RAS pour le moment.

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#5Messageil y a 3 mois

Bonjour :salut:

Mise à jour de 180 paquets (1,1 Go – Xfce) effectuée sans heurt via TTY et pacman. RAS avant et après redémarrage. :bien

Merci ! :merci:

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#6Messageil y a 3 mois

Hello,
[137 paquets pour 856mo]
un pacman -Syyu dans le terminal + reboot = RAS
Installation de Linux 5.1, pour le moment tout va bien. :café:

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#7Messageil y a 3 mois

Bonjour,

Mise à jour de 215 paquets sous KDE en TTY, RAS :bien

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#8Messageil y a 3 mois

Bonsoir.

plus d'un go de mise à jour et aucun problème. effectué en TTY et donc plus sûr.
Merci à ceux qui rendent cela possible.

stéphane

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#9Messageil y a 3 mois

Bonsoir
263 paquets (931 Mo) pour Kde en TTY et redémarrage impeccable
Encore un gros boulot des équipes :merci:

Michel

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#10Messageil y a 3 mois

Bonsoir à tous.
Mise à jour de 184 paquets sous Kde par le terminal , reboot et ras jusqu'a maintenant. :sourire:

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#11Messageil y a 3 mois

Aucun soucis sur les vm ou en dur.

Par contre j'ai du installer qjason depuis aur et je n'ai aucune idée de pourquoi.

Il me la demander en lien avec qt4 me semble car il était écris durant la compilation. Et vu que qt4 passe sur aur je pense que cela a un lien .

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#12Messageil y a 3 mois

Le démarrage bloque a: STARTED TLP SYSTEM STARTUP/SHUTDOWN

Donc je n'ai plus de System qui boot correct.

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#13Messageil y a 3 mois

bonjour tals012

Il doit être possible de se connecter via tty 😇
Vous pouvez passer en TTY [Ctrl]+[Alt]+[F2...F6]
Connectez-vous en utilisateur, pas en root.

startx
--> C'est bon; C'est votre DM qui fait des siennes
94837

Une fois connecté en tty, regarder les logs avec journald

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#14Messageil y a 3 mois

tals012 a écrit :
il y a 3 mois
Le démarrage bloque a: STARTED TLP SYSTEM STARTUP/SHUTDOWN

Donc je n'ai plus de System qui boot correct.
sans doute une perte de driver video nvidia

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#15Messageil y a 3 mois

Bonjour,
Tout ok avec 115 et 100 paquets sur Xfce et par tty.
Merci à vous et bon week-end à tous. :bjr:

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#16Messageil y a 3 mois

Maj perfect chez moi sous Linux 4.19.42-1-MANJARO.
J'avais récemment un problème avec la gestion du double écran (je commençais à penser qu'un de mes écrans était naze), mais il est résolu avec cette maj.

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#17Messageil y a 3 mois

Bonjour,
Mise à jour de 98 paquets via pacman (environ 1,5Go installé) sous LXDE/Openbox noyau 4.20.17-1.
Pas de problème apparent :sourire:
Merci aux mainteneurs :bien

[Stable] Mise à jour 17/05/2019 - Kernels, Grub, KDE, Deepin, Gnome, XFCE, LibreOffice, Bash, Systemd

#18Messageil y a 3 mois

268 Paquets pour 1,2 giga, ( 3 problèmes ) mise à jour par TTY.

J'ai quand même eu un truc bizarre, mon fichier base de donnée de keepassXC à été corrompu, il fonctionnait avant la mise à jour, j'ai résolu le problème car mon coté parano de la sauvegarde ma été très utile :gsourire:
Bref je sais pas si c'est lié, mise a jour nickel, merci a toute l’équipe..

Édit: Il y a un bug avec clémentine qt5 (lecteur audio et podcast ) le lancement se passe bien, puis si on ferme ou rétrécit la fenêtre, a la réouverture on a le contour de la fenêtre mais rien dedans :saispas:

Image

EDIT 22/05

J'ai 3 Problèmes :

1 ) BUG KeepassXC continue a me faire des bases de données corrompu.
2 ) Problème de connexion par Ethernet avec networkmanager lors d'un réveil, icône réseau tourne et tourne, une déconnexion ne suffit pas, il faut un reboot pour retrouvé la connexion.
3 ) Bug Clémentine

C'est la 1ere fois que je suis embêté ( un peu ) avec une mise a jour.

Répondre