Questions générales sur Manjaro Linux.
S'il vous plaît, avant de poster, essayez la fonction de recherche du forum.
Répondre

Testing en stable

#1Messageil y a 2 semaines

Bonjour,

Suite aux dernières mises à jour de "Testing", j'aimerais repasser en "stable".

Mais la commande $ sudo pacman-mirrors -g -b stable, me retourne l'erreur "stable" inconnu.

Je sais que je dois décommenter les dépôts "testing" dans /etc/pacman-conf, mais je ne le trouve pas.

De plus dans pacman-mirrors info, je ne vois pas ces deux paramètres -g et -b :

USAGE:
 pacman-mirrors [-h] [-f [NUMBER]] [-i [-d]] [-m METHOD]
		[-c COUNTRY [COUNTRY...] | [--geoip]]
		[-l] [-lc] [-q] [-t SECONDS] [-v] [-n]
		[--api] [-S/-B BRANCH] [-p PREFIX]
			[-P PROTO [PROTO...]] [-R] [-U URL]
En voici une copie :

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

[core]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[extra]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[community]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

[multilib]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs
Quelles lignes dois-je commenter avant de passer la commande pacman -Syuu ?

Merci.

Testing en stable

#2Messageil y a 2 semaines

:bjr:sudo nano /etc/pacman-mirrors.conf puis tu repères cette ligne (n°6) et tu la modifies : Branch = unstable

Ensuite et en root, un petit pacman-mirrors -c France,Germany suivi d'un pacman -Syyuu et tout devrait rentrer dans l'ordre. :wink:

Testing en stable

#3Messageil y a 2 semaines

obelix1502 a écrit :
il y a 2 semaines
je ne vois pas ces deux paramètres -g et -b :

USAGE:
 pacman-mirrors ... [-S/-B BRANCH] ...
Moi, je vois -B dans ton retour :wink:

Testing en stable

#4Messageil y a 2 semaines

Merci, c'est fait.

j'avais déjà trouvé la réponse dans le Wiki. :gsourire::clap

Mais comment faire pour ignorer la mise à jour de xfmw4-gtk3 (la dernière qui pose problème dans XFCE) ?

Car pamac reste en rouge... ;rale:;rale:

Testing en stable

#5Messageil y a 2 semaines

papajoke a écrit :
il y a 2 semaines
obelix1502 a écrit :
il y a 2 semaines
je ne vois pas ces deux paramètres -g et -b :

USAGE:
 pacman-mirrors ... [-S/-B BRANCH] ...
Moi, je vois -B dans ton retour :wink:
Pourquoi -g et -b équivalent à -S/-B ?

Testing en stable

#6Messageil y a 2 semaines

tu ajoutes (si n'existe pas) une ligne dans /etc/pacman.conf

IgnorePkg   = xxxxxxxx
xxx est le nom de ton paquet


----
wiki non à jour ! maintenant c'est -B (ou --set-branch) et; -g n'a rien a voir, c'est --geoip donc choisir un miroir en fonction de son ip

Testing en stable

#7Messageil y a 2 semaines

Merci papajoke, c'est fait.

Mais il va falloir suivre sur ce forum s'il y a une correction au bug, sinon pour les prochaines mises à jour, il va toujours ignorer ce paquet xfmw4-gtk3... :triste::triste:

Testing en stable

#8Messageil y a 2 semaines

A mon avis, ce bug sera rapidement corrigé, donc je préfère laisser pamac en rouge :wink:

Testing en stable

#9Messageil y a 2 semaines

En parle-t'on à l'inter ? J'ai fait une recherche, mais n'ai rien trouvé.

Répondre