Postez ici vos trucs & astuces.
Répondre

rtcwake pour réveiller votre ordi à une heure précise

#1Messageil y a 2 mois

Bonjour tout le monde!
Rtcwake permet de réveiller un ordi même s'il est complètement arrêté (shutdown). Je ne vais pas me lancer dans de longues explications étant donné qu'une simple recherche dans votre moteur préféré vous donnera des milliers de réponses sur son fonctionnement. Rtcwake permet aussi de réveiller un système en veille ou en hibernation.
Voici quelques lignes de commandes que j'utilise fréquemment, mais il y en a bcp d'autres...

sudo rtcwake -m no --date tomorrow 06:00:00
sudo rtcwake -m show
sudo rtcwake -m disable

no signifie que l'ordi ne va pas s'arrêter tout seul. Il faudra le faire manuellement.
show permet de montrer la dernière programmation (une nouvelle remplace la précédente)
disable permet de désactiver une programmation

Pour d'autres options, faites bien-sûr man rtcwake
On peut utiliser Rtcwake dans Cron mais aussi dans des scripts.
Rtcwake est généralement préinstallé.

Par contre (c'est ce qui m'amène...), j'ai une erreur lorsque je programme le démarrage pour 7 h du matin (par exemple... peu importe l'heure) et même si je mets simplement "tomorrow". J'ai fait de nombreuses et longues recherches (et des essais) notamment sur des sites en Anglais, sans succès. Quelque soit l'heure demandée, il me le programme pour 04:00:00 ! Any idea?
Notez que j'ai vérifié mon fuseau horaire: pas de problème: America/Marigot (AST). Par contre, je n'arrive plus à accéder au Bios pour y vérifier l'heure. Je précise aussi que mon vieux laptop Acer Aspire fonctionne bien pour un test avec shutdown immédiat et démarrage automatique 1 mn plus tard.

$ sudo rtcwake -m no --date tomorrow 07:00:00

rtcwake : « wakeup » (réveil) avec /dev/rtc0 à Fri Dec 28 04:00:00 2018

Pour tester votre PC, tapez simplement:

$ sudo rtcwake -m off -s 60

Cela le fait s'arrêter immédiatement et (en principe) redémarrer dans 60 secondes. On peut remplacer "off" par "mem" pour une simple mise en veille. Source: https://www.maketecheasier.com/alarm-au ... -on-linux/. Certains ordis peuvent ne pas fonctionner avec "off" mais avec "mem".

Man:
http://fr.manpages.org/rtcwake/8

Répondre