Problèmes et questions concernant les éditions Gnome, Deepin et Budgie.
Répondre

Config clavier bizarre suite à une MAJ

#1Messageil y a 7 mois

Bonjour,

J'ai fait une grosse MAJ il y a deux jours et depuis, la partie droite de mon clavier n'écrit plus des caractères cohérents.
La seule solution pour me connecter est d'appuyer sur la touche "Fn" de mon clavier en tapant mon mot de passe (une chance que j'ai trouvé ce moyen).
Si je passe en TTY2, je m'aperçois que les caractères de la partie gauche sont les bons mais la partie droite n'affiche que des symboles étranges genre ^D ou [C.
Une fois connecté, la config est normale et les options dans les paramètres sont inchangées. Si je modifie ces options et que je remets les bonnes, le comportement reste le meme.

Y a-t-il un fichier de config clavier pour l'écran de connexion? Je suis sous Deepin.

Config clavier bizarre suite à une MAJ

#2Messageil y a 7 mois


Config clavier bizarre suite à une MAJ

#3Messageil y a 7 mois

Merci de ton aide.

J'ai pas compris ce que je dois chercher dans le premier lien.

Pour le deuxième lien, je ne sais pas quoi faire du script, où le copier, etc. Il est mentionné de vérifier le contenu du script qui peut etre potentiellement dangereux et je ne sais pas faire cela.

Config clavier bizarre suite à une MAJ

#4Messageil y a 7 mois

Curieux . Ne peux-tu pas gérer ça depuis manjaro-settings-manager ?
Sinon, essaye kbctl -l fr Il faudra peut-être installer le paquet keyboardctl.

Config clavier bizarre suite à une MAJ

#5Messageil y a 7 mois

Blasted_pingin a écrit :
il y a 7 mois
Merci de ton aide.

J'ai pas compris ce que je dois chercher dans le premier lien.

Pour le deuxième lien, je ne sais pas quoi faire du script, où le copier, etc. Il est mentionné de vérifier le contenu du script qui peut etre potentiellement dangereux et je ne sais pas faire cela.
avec le 2eme lien , tu créé dans ton répertoire ,
le script suivant locale-check.sh
avec la copie en intégralité du texte issu du lien en bas de page
tu vérifie ensuite que tu as bien les droits pour le lancer ls & chmod x+ si besoin
et tu auras la réponse a ton problème , à savoir ce qui ne va pas pour la config clavier

c'est le retour d’exécution qui va nous aider ici

le 1er lien , tu lis tranquillement les topics , tu comprendra que l'origine des locales sont en fait multiples a plusieurs endroits

@steph si cela était si simple , c'est pour cela que l'on ne peut donner aucune réponse correct sans retour de vérification de la part de pingin

Config clavier bizarre suite à une MAJ

#6Messageil y a 6 mois

J'ai lancé le script, voici le retour:

bash locale-check.sh
 * Parent:    1002 /usr/bin/startdde
 * Terminal:  2970 deepin-terminal
 * Shell:     2975 /bin/bash

Looks good. ♥
 * You are using the fr_FR.UTF-8 locale.
 * Shell's locale matches terminal's locale.
 * Terminal's locale matches parent process locale.
Je précise que j'ai un clavier à la disposition belge mais pour le reste je souhaite utiliser les locales FR.

Config clavier bizarre suite à une MAJ

#7Messageil y a 6 mois

Je cherche toujours une solution, si jamais quelqu'un a une idée.

Répondre