Questions sur l'installation et la configuration de Manjaro Linux.
Répondre

[résolu] erreur au boot

#1Messageil y a 2 mois

bonjour à toutes et à tous,

peut-être pas dans la bonne section, redirigerez-moi si nécessaire

soucis après dernière maj ( le 8/9 ) qui s'était bien déroulé
mais... est-ce lié ?

au démarrage donc :

waiting 10 seconds for device /dev/disk/by-label/lnxSwap...
waiting 10 seconds for device /dev/disk/by-label/lnxRoot
ERROR : device 'LABEL=lnxRoot' not found. Skipping fsck...
...
[rootfs ]#
et ce, avec les kernel 19 ou 18
sur un disque dur externe

reboot avec "fallback initramfs" : ça démarre

tout allait parfaitement hier

vous pouvez me dire d'où cela vient ? comment rectifier ?

au cas où :
fstab

LABEL=lnxRoot / ext4 defaults,noatime 0 1
LABEL=lnxSwap swap swap defaults,noatime 0 0
LABEL=lnxHome /home ext4 defaults,noatime 0 2
LABEL=lnxExt /run/media/bul/ext ext4 defaults,noatime 0 2


grub :

GRUB_DEFAULT=saved
GRUB_TIMEOUT=60
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="root=LABEL=lnxRoot resume=LABEL=lnxSwap selinux=0 loglevel=3 fsck.mode=skip"
GRUB_CMDLINE_LINUX=""
GRUB_DISABLE_OS_PROBER=true
GRUB_SAVEDEFAULT=true
GRUB_PRELOAD_MODULES="part_gpt part_msdos"
GRUB_TERMINAL_INPUT=console
GRUB_GFXMODE=auto
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_DISABLE_RECOVERY=true
GRUB_BACKGROUND="/usr/share/grub/backgroundgrub.png"
sur un autre pc, système équivalent, disque dur interne, tout baigne

merci d'avance
@+
Modifié en dernier par bul le 20 Oct 2018, 08:55, modifié 2 fois.

[résolu] erreur au boot

#2Messageil y a 2 mois

Bonjour.
Essaye de relancer sudo mkinitcpio -P depuis le noyau fallback.

[résolu] erreur au boot

#3Messageil y a 2 mois

merci de votre intervention
mkinitcpio -P fait
même punition au reboot

[résolu] erreur au boot

#4Messageil y a 2 mois

Ce qui est curieux, c'est que ça boot normalement depuis le fallback alors que celui-ci est recrée en même temps que le noyau courant et est appelé sur le même volume /boot dans lnxRoot que le bootloader ne voit pas. Normalement, on ne renseigne pas le label du volume, mais la notation (0;1) pour /dev/sda par exemple.
Aurais-tu branché ce disque externe sur un port usb ancien ? Sur quel volume est le bootloader ?
Essaye de nouveau sudo update-grub depuis la distro maître, celle qui tient grub.

[résolu] erreur au boot

#5Messageil y a 2 mois

seul un disque dur externe est connecté
( problème hard sur celui interne et enlevé il y a bien longtemps )
j'ai essayé sur tous les ports usb
retenté update-grub malgré essais précédents
rien n'y fait
>>ça boot normalement depuis le fallback
ben oui..

on peut tenter d'autres choses ?
j'aimerais bien comprendre avant de réinstaller
( et ça ne fonctionnerait peut-être pas ! )

[résolu] erreur au boot

#6Messageil y a 2 mois

Je pense qu'un module nécessaire à ta CG n'est présent qu'en mode fallback. Dans ce cas, il faudra attendre une mise à jour du kernel:
Donne nous sudo cat /boot/grub/grub.cfg |grep linux et inxi -Fxxx

[résolu] erreur au boot

#7Messageil y a 2 mois

>>Je pense qu'un module nécessaire à ta CG n'est présent qu'en mode fallback.
>>Dans ce cas, il faudra attendre une mise à jour du kernel:
crottes de biques. 18 et 19 pas ok ni l'un ni l'autre ?

grub.cfg

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Manjaro Linux' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-0df0d2c6-a8df-4396-8a1c-4057547ffe3a' {
	linux	/boot/vmlinuz-4.19-x86_64 rw  root=LABEL=lnxRoot resume=LABEL=lnxSwap selinux=0 loglevel=3 fsck.mode=skip
submenu 'Options avancées pour Manjaro Linux' $menuentry_id_option 'gnulinux-advanced-0df0d2c6-a8df-4396-8a1c-4057547ffe3a' {
	menuentry 'Manjaro Linux (Kernel: 4.19rc7.1007.g0238df6-1-MANJARO x64)' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.19rc7.1007.g0238df6-1-MANJARO x64-advanced-0df0d2c6-a8df-4396-8a1c-4057547ffe3a' {
		linux	/boot/vmlinuz-4.19-x86_64 rw  root=LABEL=lnxRoot resume=LABEL=lnxSwap selinux=0 loglevel=3 fsck.mode=skip
	menuentry 'Manjaro Linux (Kernel: 4.19rc7.1007.g0238df6-1-MANJARO x64 - fallback initramfs)' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.19rc7.1007.g0238df6-1-MANJARO x64-fallback-0df0d2c6-a8df-4396-8a1c-4057547ffe3a' {
		linux	/boot/vmlinuz-4.19-x86_64 rw  root=LABEL=lnxRoot resume=LABEL=lnxSwap selinux=0 loglevel=3 fsck.mode=skip
	menuentry 'Manjaro Linux (Kernel: 4.18.12-1-MANJARO x64)' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.18.12-1-MANJARO x64-advanced-0df0d2c6-a8df-4396-8a1c-4057547ffe3a' {
		linux	/boot/vmlinuz-4.18-x86_64 rw  root=LABEL=lnxRoot resume=LABEL=lnxSwap selinux=0 loglevel=3 fsck.mode=skip
	menuentry 'Manjaro Linux (Kernel: 4.18.12-1-MANJARO x64 - fallback initramfs)' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.18.12-1-MANJARO x64-fallback-0df0d2c6-a8df-4396-8a1c-4057547ffe3a' {
		linux	/boot/vmlinuz-4.18-x86_64 rw  root=LABEL=lnxRoot resume=LABEL=lnxSwap selinux=0 loglevel=3 fsck.mode=skip
### END /etc/grub.d/10_linux ###
### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###
        linux16 /boot/memtest86+/memtest.bin 
inxi

System:
  Host: ddusb Kernel: 4.19.0-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.12.4 tk: Gtk 2.24.32 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: TOSHIBA product: SATELLITE C55-A v: PSCJEE-023009FR 
  serial: <root required> 
  Mobo: TOSHIBA model: Portable PC v: MP serial: <root required> 
  UEFI: INSYDE v: 1.40 date: 04/28/2014 
CPU:
  Topology: Dual Core model: Intel Celeron N2820 bits: 64 type: MCP 
  arch: Silvermont rev: 3 L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 8534 
  Speed: 533 MHz min/max: 533/2399 MHz Core speeds (MHz): 1: 533 2: 533 
Graphics:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display 
  vendor: Toshiba America Info Systems driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:0f31 
  Display: x11 server: X.org 1.20.1 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel Bay Trail v: 4.2 Mesa 18.2.2 
  compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio 
  vendor: Toshiba America Info Systems driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 chip ID: 8086:0f04 
  Sound Server: ALSA v: k4.19.0-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Lite-On driver: ath9k v: kernel port: 2000 bus ID: 01:00.0 
  chip ID: 168c:0036 
  IF: wlp1s0 state: up mac: 28:e3:47:b9:07:04 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet 
  vendor: Toshiba America Info Systems driver: r8169 v: kernel port: 1000 
  bus ID: 02:00.0 chip ID: 10ec:8136 
  IF: enp2s0 state: down mac: 00:8c:fa:98:7e:e0 
Drives:
  Local Storage: total: 298.09 GiB used: 41.04 GiB (13.8%) 
  ID-1: /dev/sda type: USB vendor: GOODRAM model: USB to S-ATA 
  size: 298.09 GiB serial: 0000000000005722 rev: TB05 scheme: GPT 
Partition:
  ID-1: / size: 31.25 GiB used: 5.69 GiB (18.2%) fs: ext4 dev: /dev/sda2 
  ID-2: /home size: 93.99 GiB used: 17.85 GiB (19.0%) fs: ext4 
  dev: /dev/sda4 
  ID-3: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 46.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 131 Uptime: 2m Memory: 3.74 GiB used: 238.5 MiB (6.2%) 
  Init: systemd v: 239 Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 
  running in: sakura inxi: 3.0.26 
@+

[résolu] erreur au boot

#8Messageil y a 2 mois

Hormis la détection par label au lieu de l'uuid, je ne vois rien d'anormal.
Les quelques posts sur l'inter et sur Arch concernant le démarrage uniquement en fallback semblent s'être résolu tout seul...
Le noyau n'est pas en cause , mais la méthode de détection des modules, oui, ce qui me fait penser que ce problème devrait se régler lors d'une mise à jour du kernel et/ou de Grub..
Là, je me répète , ce qui n'est pas normal, c'est que le bootloader ne voit pas le volume /boot de ton dd externe en mode normal, mais le voit en mode fallback alors que le volume est le même.
Rester sur le fallback n'est pas un problème en soit, si ce n'est que l'image du kernel est un peu plus lourde a charger.

[résolu] erreur au boot

#9Messageil y a 2 mois

bien, je vais patienter jusqu'à une maj
espérons que cela arrive bientôt et règle
merci

edit : vous aviez raison, plus de souci avec drnière maj ( le 20/10/2018 )

Répondre