Actualités & Annonces de l'équipe de développement et des administrateurs du forum.

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#1Messageil y a 1 an

Bonjour à toutes et à tous :bjr:

Une mise à jour est annoncée

Alors, qu'est-ce qu'on a avec celle-ci ?
  • Pamac a un mode cli amélioré
  • Mesa a été mis à jour vers la v18.1.4 qui apporte des correctifs pour radeon et intel.
  • Nous avons ajouté les derniers noyaux
  • Mise à jour certains de nos thèmes
  • Ajout quelques patches et tweaks à GTK3-Classic
  • VirtualBox a été mis à jour vers la version 5.2.16.
  • Nous avons ajouté les dernières sorties ponctuelles ([1][2][2]) de la série PulseAudio v12.
  • Les frameworks KDE ont été mis à jour vers la v5.48.0.
  • KDE a été mis à jour avec Plasma et Apps.
  • Ajout d'autres paquets Cinnamon, Gnome et Deepin.
  • Stefano a réussi à ajouter notre nouveau thème plasma5-theme-adaptabreath pour KDE.
  • Nous avons surtout travaillé sur nos profils et nos thèmes.
  • Nous avons mis à jour les navigateurs Palemoon et Firefox
  • php a été mis à jour
  • python et haskell updates/rebuilds.
Nous espérons qu'avec tous ces changements, Manjaro sera plus efficace pour vous tous.

Si vous êtes curieux de connaître l'état de développement de la prochaine version 18.0 de Manjaro-Illyria, vous avez maintenant la possibilité de télécharger une version beta-build de Manjaro-Xfce 18.0 incluant les derniers paquets xfce-gtk3 ainsi que nos plus récents efforts de style :



Nos fans de KDE peuvent essayer notre beta-build avec la dernière version 5.13 de KDE à la place.

Traduit avec www.DeepL.com/Translator

N'hésitez pas à nous donner vos commentaires sur les modifications apportées aux dépôts.


-------------------------------------------------------------------------------------
Mise à jour possible par pamac, octopi ou par pacman (de préférence) :

sudo pacman-mirrors -f0 && sudo pacman -Syyu && yaourt -Sua
-------------------------------------------------------------------------------------


État des miroirs actuellement :


Noyaux pris en charge :
  • linux316 3.16.57
  • linux318 3.18.115 [EOL] En fin de vie
  • linux41 4.1.52 [EOL] En fin de vie
  • linux44 4.4.141
  • linux49 4.9.113
  • linux414 4.14.56
  • linux415 4.15.18 [EOL] En fin de vie
  • linux416 4.16.18 [EOL] En fin de vie
  • linux417 4.17.7
  • linux418 4.18-rc5 (expérimental)
  • linux414-rt 4.14.52_rt34
  • linux416-rt 4.16.18_rt10
Les changements en détail :
  • community x86_64: 883 nouveaux et 875 paquets retirés
  • core x86_64: 28 nouveaux et 28 paquets retirés
  • extra x86_64: 729 nouveaux et 774 paquets retirés
  • multilib x86_64: 28 nouveaux et 26 paquets retirés
Une liste détaillée des changements peut être trouvée ici

-------------------------------------------------------------------------------------


-------------------------------------------------------------------------------------
ERREUR : conflit de fichiers
Si lors de la mise à jour vous avez le type d'erreur comme ci-dessous (tlp est un exemple) :

erreur : la validation de la transaction a échoué (conflit de fichiers)
tlp : /etc/acpi/events/thinkpad-radiosw est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.
il convient de passer la commande suivante en l'adaptant à votre cas particulier :

sudo pacman -S --force tlp
Ensuite, vous pouvez faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
ERREUR de clés
Si lors de la mise à jour vous avez des problèmes de clés, essayez de passer les commandes suivantes :

sudo pacman-mirrors -g
sudo pacman -Syy
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
Ensuite, vous devriez pouvoir faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#2Messageil y a 1 an

Mise à jour effectuée ce matin pour Xfce, RAS.
Tout fonctionne après un redémarrage :bien

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#3Messageil y a 1 an

Bonjour,
J'ai lancé la màj via pamac qui m'a sorti plusieurs erreurs, genre "paquet corrompu" et autres joyeusetés.
Après relance de pamac, pamac a demandé d'installer 2 librairies python et tout s'est ensuite bien passé. :saispas:
Bizarre, vous avez dit bizarre :sourire:

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#4Messageil y a 1 an

bonjour !
mise à jour effectuée sans encombre, 472mo et vbox qui marche d'enfer.
bref bonheur encore une foi !
très bonne journée à tous et toutes ou le contraire.

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#5Messageil y a 1 an

Mise à jour impossible car conflits de fichiers :(
J'ai utilisé l'option --force mais ça ne risquera plus d'être possible dans le futur.

Obsolescence programmée ? :censure::roll:

sudo pacman -S --force libutf8proc
[sudo] Mot de passe de jadmin : 
avertissement : l’option --force est obsolète ; utilisez --overwrite à la place
résolution des dépendances…
recherche des conflits entre paquets…

Paquets (1) libutf8proc-2.1.1-4

Taille totale installée :    0,32 MiB
Taille de mise à jour nette :  0,00 MiB

:: Procéder à l’installation ? [O/n] 
(1/1) vérification des clés dans le trousseau                                                    [--------------------------------------------------------] 100%
(1/1) vérification de l’intégrité des paquets                                                    [--------------------------------------------------------] 100%
(1/1) chargement des fichiers des paquets                                                        [--------------------------------------------------------] 100%
(1/1) analyse des conflits entre fichiers                                                        [--------------------------------------------------------] 100%
(1/1) vérification de l’espace disque disponible                                                 [--------------------------------------------------------] 100%
:: Traitement des changements du paquet…
(1/1) mise à jour de libutf8proc                                                                 [--------------------------------------------------------] 100%
:: Exécution des crochets de post-transaction…
(1/1) Arming ConditionNeedsUpdate...
J'ai bien essayé d'utiliser l'option --overwrite /chemin/vers/fichier mais ça ne m'a pas l'air évident car il a continué à me dire que des fichiers étaient en conflits.

Du coup, retour à l'ancienne méthode obsolète et... ça marche :biere: .

EDIT :
1 - Redémarrage à chaud : résolution d'écran en 800 * 600 sans étirement mais affichage brouillé. Ça n'a pas eu l'air de le déranger outre mesure ! Redémarrage à froid pour réparer ça :geek: .

2 - Le paramètre d'affichage ne fonctionne plus :?

 xfce4-display-settings 
Gtk-Message: 11:05:24.124: GtkDialog mapped without a transient parent. This is discouraged.
Erreur de segmentation (core dumped)
3 - Pareil que (2) pour les paramètres de nvidia

nvidia-settings 

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system
Heureusement que ce n'est pas bloquant :shock:
Dernière modification par monsieur Q le 22 Jui 2018, 10:07, modifié 1 fois.

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#6Messageil y a 1 an


[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#7Messageil y a 1 an

Salut,

126 paquets mis à jour sans souci.

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#8Messageil y a 1 an

papajoke a écrit :
il y a 1 an
bonjour

oui, ce conflit libutf8proc était annoncé par archlinux (avec la nouvelle syntaxe)
Le problème est que j'ai du revenir à l'ancienne syntaxe car la nouvelle ne faisait aucun effet :saispas:

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#9Messageil y a 1 an

les drivers nvidia & bumblebee posent de plus en plus de problèmes
on attends le passage généralisé de prime

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#10Messageil y a 1 an

C'est vraiment pénible ce genre de détails. Je sens que ça va se finir en installation toute neuve si je dois re-basculer vers prime.

Au moins, ça me tiendra trois fois plus de temps que le PC professionnel avec W10 pro qui plante tous les 4 matins et doit être réinstallé tous les 4~6 mois :mrgreen: .

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#11Messageil y a 1 an

Bonjour.
Il suffit juste de lire l'erreur et de faire --overwrite <fichier qui pose problème>.
Il n'y a pas de règles absolue car nous avons tous des machines ou des environnements différents.

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#12Messageil y a 1 an

Bonjour à tous,
monsieur Q a écrit :22/7/18 10:50
Mise à jour impossible car conflits de fichiers [...] C'est vraiment pénible
Oui... mais l'annonce de la mise à jour venait tout juste d'être faite (22/7/18 10:23), à peinte trente minutes.
Moi qui ne me sens pas suffisamment costaud pour essuyer les plâtres, je ne me précipite pas à ce point :sourire:
D'ailleurs, je viens quand même d'effectuer très tôt (trop tôt pour moi) cette mise à jour et j'ai pu bénéficier d'une version rustinée comme on peut le constater (==> Fix libutf8proc upgrade) dans cet extrait de trace :

:: Some packages should be upgraded first...

résolution des dépendances…
recherche des conflits entre paquets…

Paquets (1) manjaro-system-20180716-1

Taille totale du téléchargement :  0,02 MiB
Taille totale installée :        0,01 MiB
Taille de mise à jour nette :    0,00 MiB

:: Procéder à l’installation ? [O/n]

:: Récupération des paquets…

 manjaro-system-20180716-1-any                                        16,8 KiB   841K/s 00:00 [######################################################] 100%
(1/1) vérification des clés dans le trousseau                                                 [######################################################] 100%
(1/1) vérification de l’intégrité des paquets                                                 [######################################################] 100%
(1/1) chargement des fichiers des paquets                                                     [######################################################] 100%
(1/1) analyse des conflits entre fichiers                                                     [######################################################] 100%
(1/1) vérification de l’espace disque disponible                                              [######################################################] 100%

:: Traitement des changements du paquet…

(1/1) mise à jour de manjaro-system                                                           [######################################################] 100%

==> Fix libutf8proc upgrade ...

résolution des dépendances…
recherche des conflits entre paquets…

Paquets (1) libutf8proc-2.1.1-4

Taille totale du téléchargement :  0,05 MiB
Taille totale installée :        0,32 MiB
Taille de mise à jour nette :    0,00 MiB

:: Procéder à l’installation ? [O/n]

:: Récupération des paquets…

téléchargement de libutf8proc-2.1.1-4-x86_64.pkg.tar.xz…
vérification de l’intégrité des paquets…
analyse de l’intégrité des paquets…
chargement des fichiers des paquets…
recherche des conflits entre fichiers…
vérification de l’espace disque disponible…

:: Traitement des changements du paquet…

mise à jour de libutf8proc…

:: Exécution des crochets de post-transaction…

(1/1) Arming ConditionNeedsUpdate...

:: Exécution des crochets de post-transaction…

(1/1) Arming ConditionNeedsUpdate...

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#13Messageil y a 1 an

Ce n'est pas la première fois qu'ils font des correctifs suite aux retours des premières personnes qui ont fait la mise à jour.

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#14Messageil y a 1 an

:bjr:
183 paquets....
Tout est Ok :bien
:merci:

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#15Messageil y a 1 an

Bonjour à tous, tout est Ok pour moi après redémarrage, sous xfce ou en session openbox et pareil pour fluxbox ou en session compiz/cairo-dock...
Consomme même encore un peu moins de ram... quel que soit le gestionnaire de fenêtre utilisé ! Chapeau :bien
Encore un grand merci à tous les développeurs/contributeurs de cette belle aventure!

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#16Messageil y a 1 an

:bjr: tout le monde
314 paquets pour KDE, et redémarrage nickel/chrome
Sacré boulot de la part des équipes :clap
Michel

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#17Messageil y a 1 an

bonsoir

nouvelle mise à jour de 66 paquets.
on va bien voir, je vais éditer ce message quand cela sera fait.

très bonne soirée à tous et toutes

stéphane

edit: aucun problème après cette seconde mise à jour :) très bonne journée à tous et toutes
Dernière modification par yogib33r le 23 Jui 2018, 06:44, modifié 1 fois.

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#18Messageil y a 1 an

mise a jour sous xfce 56 paquets
sans aucun problèmes
:salut:

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#19Messageil y a 1 an

Bonjour le Monde,
112 paquets sur xfce, no souci et redémarrage excellent.
Merci de vos constants progrès.

[Stable] Mise à jour 22/07/2018 - Kernels, KDE, Gnome, Deepin, Mesa, Navigateurs, PHP

#20Messageil y a 1 an

Bonjour,

117 paquet sous Gnome sur mes 2 PC et tout est parfait !

Merci à tous et un grand :clap:bien

Répondre