Questions sur l'installation et la configuration de Manjaro Linux.

[Installation] Erreur lors du partitionnement

#1Messageil y a 3 mois

Bonjour :)

j'ai un petit problème d'installation. J'étais sous fedora 27 et j'ai voulus changer pour manjaro, je l'avais tester il y a longtemps et j'en ai un bon souvenir.
Bref, j'ai gravé sur un CD l'image ISO de manjaro gnome current release. Je l'ai boot sur mon ordi, jusque là tout se passe bien. Puis je vais sur l'installeur je remplis le tout et je précise que je veux effacer les données du disque pour installer manjaro par dessus.

Image

Mais quand je lance l'installation, ça me met cette erreur la :

Image

Donc je suis aller voir dans gparted et ça ressemble à ça, il y a un cadenas et je ne peux rien toucher sur la partition /dev/sda2 :

Image

Vous avez une solution pour pallier à ce problème, j'aimerai ne pas avoir à racheter un Hard drive ! :3

Edit : Pour le cadenas, c'est parce que la partition était "monté", je l'ai "démonté" mais toujours la même erreur lors de l'installation.

[Installation] Erreur lors du partitionnement

#2Messageil y a 3 mois

Bonjour, le mieux est de préparer ta ou tes partition(s) avant l'installation. Méthode avec gparted à partir du live :

1) menu "périphérique" créer une table de partitions (ceci effacera toutes les partoches existantes ainsi que les données)
2) menu "partition" "nouvelle" puis créer une partition format ext4.

Bien entendu on peut faire la même chose en ligne de commande mais, si tu es à l'aise avec gparted c'est parfait.

Ensuite tu peux relancer l'installateur ;)

Attention : Cette méthode vaut pour les machines non-uefi (boot-legacy)

[Edit] : L'installateur ne peut pas travailler sur une partition montée. Donc, on démonte et on reprend l'installation ;)

[Installation] Erreur lors du partitionnement

#3Messageil y a 3 mois

bonjour, merci de ta réponse :)

je vais essayé mais je ne peux pas juste formater en ext4 la partition /dev/sda2 ? :)

EDIT : Ça a marché, j'ai juste eu a créer une nouvelle partition avec ta technique :) merci beaucoup !

[Installation] Erreur lors du partitionnement

#4Messageil y a 3 mois

Tu peux, en effet, formater cette partition et installer Manjaro dessus mais les 1 go de sda1 seront perdus. Perso, dans l'ordre, je supprimerai /dev/sda1 puis /dev/sda2 avant de créer une seule et unique partition en ext4. C'est toi qui voit :wink:

[Installation] Erreur lors du partitionnement

#5Messageil y a 3 mois

Bonjour ,

effectivement Manjaro - Calamarès ne gère pas de façon automatique les partitions lvm ,
d'où l'erreur rencontré

[Installation] Erreur lors du partitionnement

#6Messageil y a 3 mois

ah je vois mieux pourquoi. Mais a présent j'ai un autres probleme. En effet tout a fonctionné, j'ai fait toute l'installation sans encombre et donc derniere etape "veuillez redémarrer l'OS". Ce que je fais sans plus attendre et là, j'ai ça sur mon écran :

Image

Donc je reboot sur le CD pour voir si j'ai pas louper quelque chose et quand j'ouvre gparted sur le live, je vois ça :

Image

tout m'a bien pourtant je ne comprends pas pourquoi il me dis qu'il n'y a aucun OS...

[Installation] Erreur lors du partitionnement

#7Messageil y a 3 mois

peux tu nous fournir
le retour , avec la clé USB install

inxi -Fxxxz
parted -l
par hasard tu as bien coché la partition / avec Boot lors de l'installation ?

[Installation] Erreur lors du partitionnement

#8Messageil y a 3 mois

Es-tu certain d'avoir coché l'installation de grub ? Ce grub est-il installé sur /dev/sda/ (mbr) ou /dev/sda1 (pas bon) ?

A partir du live-cd essaye de booter sur le système installé.

[Installation] Erreur lors du partitionnement

#9Messageil y a 3 mois

quand vous dites grub/boot, c'est bien le chargeur de démarrage (dans l'installation française) ?

EDIT :

[manjaro@manjaro-gnome ~]$ inxi -Fxxxz
System:
  Host: manjaro-gnome Kernel: 4.14.39-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 7.3.1 Desktop: Gnome 3.28.1 info: gnome-shell dm: gdm 
  Distro: Manjaro Linux 17.1.10 Hakoila 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP ProBook 430 G2 
  v: A3009DD10303 serial: N/A Chassis: type: 10 serial: N/A 
  Mobo: Hewlett-Packard model: 2246 v: KBC Version 59.22 serial: N/A 
  BIOS: Hewlett-Packard v: M73 Ver. 01.15 date: 07/24/2015 
Battery:
  ID-1: BAT0 charge: 34.1 Wh condition: 35.3/35.3 Wh (100%) volts: 16.8/14.8 
  model: Hewlett-Packard Primary type: Li-ion serial: <filter> 
  status: Unknown 
CPU:
  Topology: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP 
  arch: Broadwell rev: 4 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17566 
  Speed: 1198 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 1198 2: 1198 
  3: 1197 4: 1198 
Graphics:
  Card-1: Intel HD Graphics 5500 driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:1616 
  Display: x11 server: N/A driver: i915 compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) 
  v: 4.5 Mesa 18.0.3 compat-v: 3.0 direct render: Yes 
Audio:
  Card-1: Intel Broadwell-U Audio driver: snd_hda_intel v: kernel 
  bus ID: 00:03.0 chip ID: 8086:160c 
  Card-2: Intel Wildcat Point-LP High Definition Audio driver: snd_hda_intel 
  v: kernel bus ID: 00:1b.0 chip ID: 8086:9ca0 
  Sound Server: ALSA v: k4.14.39-1-MANJARO 
Network:
  Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 v: 2.3LK-NAPI port: 4000 bus ID: 08:00.0 chip ID: 10ec:8168 
  IF: enp8s0 state: down mac: <filter> 
  Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be 
  v: kernel port: 3000 bus ID: 09:00.0 chip ID: 10ec:b723 
  IF: wlo1 state: down mac: <filter> 
Drives:
  HDD Total Size: 223.57 GiB used: 223.57 GiB (0.0%) 
  ID-1: /dev/sda model: SanDisk_SDSSDA24 size: 223.57 GiB serial: <filter> 
  rev: 30RL scheme: MBR 
Partition:
  ID-1: / size: 5.76 GiB used: 52.1 MiB (0.9%) fs: overlay dev: ERR-102 
Sensors:
  System Temperatures: cpu: 40.0 C mobo: 0.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 177 Uptime: 5m Memory: 7.69 GiB used: 738.8 MiB (9.4%) 
  Init: systemd v: 238 Compilers: gcc: N/A Shell: bash v: 4.4.19 
  running in: gnome-terminal inxi: 3.0.07 

[manjaro@manjaro-gnome ~]$ parted -l
Modèle: ATA SanDisk SDSSDA24 (scsi)
Disque /dev/sda : 240GB
Taille des secteurs (logiques/physiques): 512B/512B
Table de partitions : msdos
Disk Flags: 

Numéro  Début   Fin    Taille  Type     Système de fichiers  Fanions
 1      1049kB  231GB  231GB   primary  ext4
 2      231GB   240GB  9449MB  primary  linux-swap(v1)


Avertissement: Impossible d'ouvrir /dev/sr0 en lecture-écriture (Système de
fichiers accessible en lecture seulement). /dev/sr0 a été ouvert en lecture
seule.
Erreur: La partition ne peut pas être en dehors du disque !
Voila, sinon j'ai tenté de réinstaller Manjaro avec comme chargeur de démarrage : "partition systeme (/)" alors qu'avant c'était "Master boot record de ATA SanDisk SDSSDA24 (/dev/sda)". Mais je ne sais pas si c'est ça.

[Installation] Erreur lors du partitionnement

#10Messageil y a 3 mois

ce que tu peux faire ,
tu démarre sur la clé USB
tu ouvre le terminal

manjaro-chroot -a ( tu reponds 1 )
parted -l ( tu verifie que le disque est bien sda )
grub-install /dev/sda
grub-install --recheck /dev/sda
update-grub
exit ( quitte le chroot , *obligatoire* )
puis tu redemarre

[Installation] Erreur lors du partitionnement

#11Messageil y a 3 mois

Voila, sinon j'ai tenté de réinstaller Manjaro avec comme chargeur de démarrage : "partition systeme (/)" alors qu'avant c'était "Master boot record de ATA SanDisk SDSSDA24 (/dev/sda)". Mais je ne sais pas si c'est ça.
En principe le chargeur de démarrage d'un Linux en solo s'installe sur le MBR du disque, donc sur le premier secteur (amorçage) de /dev/sda/. Passe en chroot comme préconisé plus haut par stephane et réinstalle grub.

[Installation] Erreur lors du partitionnement

#12Messageil y a 3 mois

Alors, je viens de relancer l'installation et le résumé est le suivant :

Image

Puis a la fin le succés :

Image

Après j'ai ouvert un terminal et tapé ça :

[manjaro@manjaro-gnome ~]$ manjaro-chroot -a
==> Mounting (ManjaroLinux) [/dev/sda1]
 --> mount: [/mnt]
[manjaro-gnome /]# parted -l
Model: ATA SanDisk SDSSDA24 (scsi)
Disk /dev/sda: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type     File system     Flags
 1      1049kB  231GB  231GB   primary  ext4
 2      231GB   240GB  9449MB  primary  linux-swap(v1)


Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0
has been opened read-only.
Error: Can't have a partition outside the disk!
Ignore/Cancel? c                                                          
Model: TSSTcorp CDDVDW SE-208DB (scsi)
Disk /dev/sr0: 1915MB
Sector size (logical/physical): 2048B/2048B
Partition Table: unknown
Disk Flags: 

[manjaro-gnome /]# grub-install /dev/sda
Installing for i386-pc platform.
Installation finished. No error reported.
[manjaro-gnome /]# grub-install --recheck /dev/sda
Installing for i386-pc platform.
Installation finished. No error reported.
[manjaro-gnome /]# update-grub
Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
[manjaro-gnome /]# exit
exit
 --> umount: [/mnt]
[manjaro@manjaro-gnome ~]$ 
Je vais voir si ça fonctionne :)

EDIT : toujours le meme message "Please install an operating system on your hard disk"...

[Installation] Erreur lors du partitionnement

#13Messageil y a 3 mois

avec la clé install USB , tu vois bien le disque sda proposé pour le boot ?


[Installation] Erreur lors du partitionnement

#15Messageil y a 3 mois

lorsque tu démarre sur la clé install USB
avant de lancer , tu peut voir s'il te propose les disques ou alors de démarrer sur la clé USB
Modifié en dernier par stephane le 12 Jui 2018, 20:43, modifié 1 fois.

[Installation] Erreur lors du partitionnement

#16Messageil y a 3 mois

Dans le BIOS, je choisis entre boot sur l'USB ou sur l'hard drive

[Installation] Erreur lors du partitionnement

#17Messageil y a 3 mois

alors si tu choisis hard drive , cela devrait être ton disque , et tu va démarrer dessus

je tiens à préciser que le démarrage par la clé USB est particulière ,
soit MBR ( nom complet )
soit EFI ( indiqué par partition 2 )

point important concernant certains fabricants d'ordinateur ou portable ,
c'est de plus en plus verrouillé par Microsoft - windows que cela soit en EFI ou MBR
depuis 2017 la tendance est apparu
Modifié en dernier par stephane le 12 Jui 2018, 21:46, modifié 1 fois.

[Installation] Erreur lors du partitionnement

#18Messageil y a 3 mois

alors quand je vais dans le Bios, je tombe la dessus :

Image

Puis quand je clique sur exit, j'arrive sur le BIOS et dans les "boot options" j'ai :

Image

et quand je clique sur notebook Hard Drive, j'ai toujours le meme message "Please install an operating system on your hard drive".

[Installation] Erreur lors du partitionnement

#19Messageil y a 3 mois

ok je viens de voir ,
install en EFI

donc tu lance clé USB install sur la partition 2 , en efi
et tu prends option Free drivers

si cela fonctionne ,
--> 1) tu effectue avec Gparted un formatage en GPT
--> 2) tu créé partition 100Mo /boot/efi en FAT32 avec option Boot, esp coché
--> 3) tu créé le reste en / en ext4
puis tu lance installation , tu monte les points de montage /boot/efi et / tu verifie bien option boot,esp coché
et il doit te proposer d'installer EFI ( et non MBR )

[Installation] Erreur lors du partitionnement

#20Messageil y a 3 mois

Modifié en dernier par Erwan le 13 Jui 2018, 09:10, modifié 1 fois.
Raison :code 5

Répondre