Actualités & Annonces de l'équipe de développement et des administrateurs du forum.

gksu, c'est fini ??

#21Messageil y a 1 an

lemust83 a écrit :
il y a 1 an
Ça veut donc dire que tu as composé un PKGBUILD ad-hoc qui pourrait aider ou que tu as installé Xampp directement via les sources avec # make install ; dans ce cas, je doute que ça fonctionne encore longtemps....
Non j'ai utiliser l'installeur : https://www.apachefriends.org/xampp-fil ... taller.run

Apres c'est un installeur à la windows suivant suivant qui installe sur opt/xampp/...
Après j'ai pris le .policy issu d'aur et j'ai juste modifier l'ajout de message fr et je l'ai mis a la mano dans usr/share/polkit

Je pense que ca sera perenne vu que c'est tellement générique comme fichier ce policy. Meme si je change de version via soit un nouveau run du site officiel soit via aur ben le .policy changera pas vu que xampp sera toujours installé au meme endroit.

Quant à mon .desktop il changera pas non plus meme si je met à jour la version, elle sera tjs installé au même endroit.


En clair je n'ai ni fais de pkgbuild ni fait une compil à la mano des sources. C'est bien trop compliqué pour mon niveau de Linux. Je suis resté à quelque chose de simple.

gksu, c'est fini ??

#22Messageil y a 1 an

Je ne comprends pas vos propos.
Il est vrai que je n'ai pas lu toute la conversation mais chez moi :
Image

gksu, c'est fini ??

#23Messageil y a 1 an

Salut Obélix, je viens de vérifier sur le pc de ma femme (stable) et bien non gksu n'est plus dans les dépôts officiels :

pacman -Ss gksu
community/zensu 0.1-1
    A simple gksu replacement using zenity, yad or spacefm
mais présent (pour combien de temps ?) dans Aur (n°3) :

yaourt gksu
1 community/zensu 0.1-1
    A simple gksu replacement using zenity, yad or spacefm
2 aur/caja-gksu-dev 1.17.0-1 (0) (0,00)
    Privilege granting extension for Caja using gksu (GTK3 version)
3 aur/gksu 2.0.2-6 [installed] (7) (6,26)
    A graphical frontend for su
4 aur/gksu-polkit-git 2:0.0.2.r3.gd7e3160-1 (15) (1,67)
    Replacement for gksu that uses PolicyKit
5 aur/gtksu-git 0.0.r98.9372747-1 (0) (0,00)
    A Qt5-based replacement for gksu
6 aur/libgksu 2.0.12-8 [installed] (7) (6,35)
    gksu authorization library
7 aur/libgksu-colormap-fix 2.0.12-6 (2) (0,00)
    gksu authorization library (with libgksu-rgba-fix.diff patch)
==> Numéro(s) des paquets à installer (ex: 1 2 3 ou 1-3)
==> ----------------------------------------------------
Fais un yaourt -Qam et tu constateras qu'il est bien installé mais "délocalisé" dans Aur ;)

gksu, c'est fini ??

#24Messageil y a 1 an

Oui mais :

pacman -Qam gksu
pacman : option invalide -- 'a'
et

 pacman -Qm gksu
gksu 2.0.2-6
:saispas::saispas:

gksu, c'est fini ??

#25Messageil y a 1 an

:salut: En effet, petite erreur de ma part, il s'agissait plutôt de yaourt -Qam Désolé, je rectifie sur mon post précédent. :sourire:

gksu, c'est fini ??

#26Messageil y a 1 an

en fait obelix, en plus de yaourt, tu pouvais le voir dans ta copie écran, il n'y a rien dans la colonne dépôt car ils ne sont plus dans les dépôts de manjaro (ni archlinux)
Lorsqu'un paquet n'est plus dans les dépôts il n'est pas automatiquement désinstallé sur notre machine.

gksu, c'est fini ??

#27Messageil y a 1 an

Smurf a écrit :
il y a 1 an
Pour l'instant c'est bon, mais le jour où les distributions majeures passeront à Wayland j'espère que pkexec sera fonctionnel sans intervention de l'utilisateur.
Résolu pour mon cas perso, j'ai trouvé ce paquet récent, sur Aur qui permet de créer les actions .policy de manière transparente et conviviale et pour ceux qui le souhaitent, des raccourcis de bureau pour lancer les applis en root directement à partir du menu. :bien

Reste plus qu'à virer gksu que l'on doit classer, désormais, dans les paquets "mourants". :pleure:

gksu, c'est fini ??

#28Messageil y a 1 an

:bjr:
Erwan a écrit :Résolu pour mon cas perso, j'ai trouvé ce paquet récent, sur Aur qui permet de créer les actions .policy de manière transparente et conviviale et pour ceux qui le souhaitent, des raccourcis de bureau pour lancer les applis en root directement à partir du menu. :bien
C'est fou ce que le hasard fait bien les choses :rigole:

gksu, c'est fini ??

#29Messageil y a 1 an

lemust83 a écrit :
il y a 1 an
:bjr:
C'est fou ce que le hasard fait bien les choses :rigole:
:gsourire:
Je ne crois pas trop au hasard mais davantage à une loi physique naturelle. Les programmes ont une vie plus ou moins longue mais disparaissent parfois lorsqu'ils ne sont plus maintenus (gksu) ou font double-emploi (gksu) avec d'autres programmes (polkit) qui peuvent présenter, eux mêmes, quelques lacunes de conception ou de configuration trop complexe, créant de fait une impasse à leur utilisation par le plus grand nombre (pkexec). Ce nouveau programme a le mérite de rendre accessible "polkit et ses actions" par tous et, in-extenso, de redonner la main aux utilisateurs. Les développeurs de notre distribution ne peuvent pas tout faire. Les scripts de "manjaro-system" représentent déjà un filtre important qui permet d'éviter la plupart des écueils propres à la distribution Arch ; Alors si des membres de la communauté (au sens large) prennent des initiatives, de nature à fixer ce qui ne passe pas dans le "manjaro-filtre", je ne vais pas m'en plaindre, bien au contraire. :wink:

Pour ceux qui souhaite l'installer : pkcreate -p mousepad permet de créer une action et éventuellement, un lanceur graphique (dans l'exemple ici : mousepad en root). Pour le reste, c'est assez convivial, le programme recherche le paquet, vous demande d'entrer le numéro puis installe l'action et le lanceur si besoin est. L'affaire est pliée en 5 secondes. Reste plus qu'à faire un pkexec mousepad ou rechercher dans le menu, le lanceur graphique root de mousepad et d'entrer le MDP dans la fenêtre popup qui s'ouvre. Pour supprimer les actions crées et lister les options disponibles, consulter l'aide : pkcreate -h

gksu, c'est fini ??

#30Messageil y a 1 an

Erwan a écrit :
il y a 1 an
Je ne crois pas trop au hasard mais davantage à une loi physique naturelle. Les programmes ont une vie plus ou moins longue mais disparaissent parfois lorsqu'ils ne sont plus maintenus (gksu) ou font double-emploi (gksu) avec d'autres programmes (polkit) qui peuvent présenter, eux mêmes, quelques lacunes de conception ou de configuration trop complexe, créant de fait une impasse à leur utilisation par le plus grand nombre (pkexec).
Pour moi c'est plutôt l'inverse, c'est le hasard qui fait que des logiciels dont tout le monde se moquait, comme polkit ou logind, au point que certains de leurs développeurs avaient jeté l'éponge, sont redevenu actifs, personne n'avait prévu que systemd serait utilisé par les distributions majeures. Ces logiciels ont survécu en devenant des dépendances de systemd, obligeant aussi les anti-systemd à les maintenir sans dépendance systemd.

Quand j'ai débuté sous Linux, lancer une appli graphique sous root c'était mal, le serveur X n'est pas fiable niveau sécurité, gksu n'était qu'un pis aller qui n'aurait pas du durer aussi longtemps, d'autant plus qu'il n'est plus maintenu depuis un moment.

gksu, c'est fini ??

#31Messageil y a 1 an

Bonjour, un petit déterrage de topic pour signaler ce paquet qui permet d'utiliser, comme par le passé, la commande gksu puisque ces quatre lettres son gravées dans la pierre de nos mémoires linuxiennes :sourire: Voici donc la chose que l'on peut installer :

community/gksu-polkit 0.0.3-1
    Replacement for gksu that uses PolicyKit
Cependant, je me suis posé la question : Pourquoi installer un nouveau paquet alors que l'on peut avoir le même résultat par un simple alias ? :?
En effet cet alias dans le ~/.bashrc vous donnera exactement le même résultat : alias gksu='pkexec' Alors, gardons nos vieilles habitudes mais avec modération, hein ;)

gksu, c'est fini ??

#32Messageil y a 11 mois

Bonjour tout le monde,

J'ai fait des essais en console avec pkexec et sa fonctionne nickel. Par contre pour un lanceur dans le menu Whisker (j'ai remplacé par exemple gksudo /opt/freefilesync/FreeFileSync par pkexec /opt/freefilesync/FreeFileSync) rien ne se passe :saispas:
Je suis pas sûr de tout saisir…

Répondre