Problèmes et questions sur les environnements graphiques et les applications.
Répondre

[Aur] Erreurs multiples Pamac

#1Messageil y a 5 mois

Bonsoir,

Avec pamac-aur, j'ai plusieurs erreurs.
À part m'afficher les mises à jour, il ne veut plus rien me faire. Je dois tout faire en commandes. Vous me direz que c'est pas plus mal, mais c'est parfois ennuyant.
Je ne peux plus installer de paquets : "l'identification a échoué".
Si je veux mettre à jour la base de données : rien ne se passe.
J'avais lu sur un autre post : L'identification a échoué, qu'il fallait mettre le paquet mate-polkit mais je suis sous XFCE. Donc je pense qu'il n'est pas recommandé ? Ou...
Merci à tous. :gsourire:
Modifié en dernier par Erwan le 18 Avr 2018, 10:53, modifié 1 fois.
Raison :paquet Aur

[Aur] Erreurs multiples Pamac

#2Messageil y a 5 mois

Bonjour obelix,

Vu dans les commentaires [Aur] :
le problème se trouve dans le fichier pamac-manager.desktop... sans les permissions root, le programme est incapable de faire quoi que ce soit donc peut-être le changer pour l'ouvrir avec gksu ? Changer la ligne 'Exec=pamac-manager' en 'Exec=gksu pamac-manager' fait que ça marche pour moi...


Sinon, il existe aussi (heureusement) une version officielle de pamac, opérationnelle et stable :

1 extra/pamac 6.2.7-1
    A Gtk3 frontend for libalpm


Evidemment, chacun fait comme bon lui semble mais, je ne vois pas trop pourquoi tu t'embêtes avec pamac puisque tu te débrouilles très bien avec la ligne de commande qui présente l'avantage d'être bien plus puissante/rapide et moins gourmande en ressources qu'une interface graphique. :confus:

[Aur] Erreurs multiples Pamac

#3Messageil y a 5 mois

bonjour

Quel intérêt d'utiliser pamac-aur, il n'est pas optimisé pour manjaro ! autant prendre notre version officielle.

On ne devrait pas lancer pamac avec ***su, il utilise polkit ; la grosse différence c'est que polkit demande le mot de passe uniquement pour une action et le programme lui reste avec des droits utilisateurs. Si lancé en su, du coup pas sûr que l'on puisse compiler un programme aur ?
une version xfce existe fait une recherche "xfce-polkit"

ps: utiliser un gui ou yaourt(autres) ... c'est un choix personnel, la version console permet juste plus de paramètres ce qui peut-être utile parfois.

[Aur] Erreurs multiples Pamac

#4Messageil y a 5 mois

J'ai la même chose avec le pamac officiel, c'est pour cela que j'avais essayé celui d'aur.

J'ai installé xfce-polkit, mais cela ne change rien.

Je le trouvais pratique pour désinstaller en une seule fois les paquets orphelins car je ne sais pas comment le faire en une seule fois avec pcman.

Si je recherche les orphelins avec pacman -Qdtq, comment en une seule commande désinstaller son résultat ?

[Aur] Erreurs multiples Pamac

#5Messageil y a 5 mois

Bonjour.
Tu fais sudo -Rs $(pacman-Qdtq).
Perso, je me suis fait cette fonction que je colle dans le .bashrc:

    orphelins() {
      if [[ ! -n $(pacman -Qdt) ]]; then
        echo "No orphans to remove."
      else
        sudo pacman -Rs $(pacman -Qdtq)
      fi
    }
Après ressource du bash, tu tape orphrelins et c'est parti :bien

[Aur] Erreurs multiples Pamac

#6Messageil y a 4 mois

Merci lemust.
Il va falloir que j'étudie sérieusement les scripts.
Mais c'est le temps qui me manque :pleure:
Je mets donc ce sujet comme résolu : j'utilise le terminal et c'est tout. :gsourire:

Répondre