Problèmes et questions concernant l'édition XFCE.
Répondre

Problème d'affichage sur second écran vertical

#1Messageil y a 4 mois

Bonjour à tous,
Premier post sur ce forum, j'espère ne pas être passé à côté d'un post pertinent malgré mes recherches ici et ailleurs.
Voici mon problème, j'ai un second écran que j'ai pour habitude de mettre à la verticale, cependant même après en avoir fait la rotation il ne fonctionne pas correctement.
La souris passe bien de l'un à l'autre par le bon bord mais les fenêtres restent dans le sens normal.
Le plus bizarre c'est que quand j'ai tenté de prendre un screenshot pour vous en faire la démonstration, il apparait correctement.

Voici la sortie de xrandr:
─$ xrandr
Screen 0: minimum 8 x 8, current 3000 x 1920, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
1920x1080 60.00*+
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
eDP-1-2 disconnected (normal left inverted right x axis y axis)
HDMI-1-1 connected 1080x1920+1920+0 left (normal left inverted right x axis y axis) 527mm x 296mm
1920x1080 74.97*+ 60.00 50.00 59.94
1920x1080i 60.00 50.00 59.94
1680x1050 59.88
1280x1024 60.02
1440x900 59.90
1280x800 59.91
1152x864 75.00
1280x720 60.00 50.00 59.94
1024x768 70.07 60.00
800x600 60.32 56.25
720x576 50.00
720x480 60.00 59.94
640x480 66.67 60.00 59.94
720x400 70.08


Et les images pour illustrer tout ça (le screenshot puis la photo):
Image

Image

En espérant que vous aurez une piste pour m'aider, n'hésitez pas à me dire de quelles infos supplémentaires vous auriez besoin ! Merci d'avance

Problème d'affichage sur second écran vertical

#2Messageil y a 4 mois

Bonjour,

Je viens de faire des essaies et votre xrandr semble correcte.
Je fais les modifications depuis le panneau de configuration d'affichage,
Vous le faites en ligne de commande ?

Problème d'affichage sur second écran vertical

#3Messageil y a 4 mois

Bonjour et merci pour votre réponse.
J'ai essayé de faire la modification via xrandr (donc en ligne de commande), via arandr ainsi qu'en utilisant xfce4-display-settings mais rien n'y fait.
Le résultat est toujours le meme.

Problème d'affichage sur second écran vertical

#4Messageil y a 4 mois

Bonjour,
Désolé j'étais bien occupé ces derniers jours.
Question qui peut paraitre idiote après reflexion ^^ mais je prefère la poser quand même ca sera fait :
- Est-ce que l'écran a une fonction de pivotage ? (et on aurai des fenetres renversés par l'ecran alors que c'est déjà fait sur linux, ce qui expliquerai la différence avec l'impression écran)

- essayez avec un autre écran ?

- renversez votre écran principal et mettez droit votre écran secondaire, pour voir les réactions et déduire le probleme.

- paramétrer un tableau de bord et voir comment il réagit (peut-être que le probleme vient du gestionnaire de fenêtres ?)

Problème d'affichage sur second écran vertical

#5Messageil y a 3 mois

Bonjour Dtneo,
Pas de problème, désolé également pour le temps de réponse, le temps de tester tout ça.
Donc pour résumer mon écran n'a pas de fonction de pivotage intégrée et le tableau de bord apparaissait bien au bas de l’écran sur un screenshot, tout en restant invisible sur l’écran car hors cadre.
J'ai également tenté de renverser l’écran principal pour voir comment cela réagissait, l’écran principal effectuait la rotation convenablement contrairement au second écran.
La seule chose que je n'ai pas pu tester c'est avec un autre écran, je n'en avais pas sous la main.

Cependant j'ai réussi résoudre mon problème à l'instant, en effet j'ai changé pour un driver non-free et cela fonctionne parfaitement. Dommage pour le driver free...et j'aimerais bien comprendre pourquoi cela fonctionne avec le non-free.

En attendant merci Dtneo pour l'aide fournie !
Répondre