Actualités & Annonces de l'équipe de développement et des administrateurs du forum.

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#21Messageil y a 1 mois

alkiros a écrit : il y a 1 mois C'est grave docteur? :saispas:
Je suis à peu près sûr que non. D'une part, selon le Wiki, l'USB n'est pas encore géré par mhwd, d'autre part, si j'en crois ce message récent du forum anglophone, ça veut dire que tout ce qui utilise l'USB dans ta configuration fonctionne grâce au noyau directement. En tout cas, si tu n'as rien de branché via USB qui dysfonctionne, je ne m'inquiéterais pas plus (et c'est d'ailleurs ce que je fais, car j'ai le même message ^^).

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#22Messageil y a 1 mois

Herve33 a écrit : il y a 1 mois
bicounet18 a écrit : il y a 1 mois Mise à jour 5.10.7 sous Xfce 4.16 et reboot sans aucun souci.
Comment passer sur le pilote Nvidia 460 en ligne de commande ?

Merci.
Bonjour,
regarde ici si ça peut t'aider:
https://forum.manjaro.org/t/resolue-mar ... ia/44842/3
@+
Avec l'outil graphique, j'ai désinstallé video-hybrid-intel-nvidia-prime

> Removing video-hybrid-intel-nvidia-prime...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-hybrid-intel-nvidia-prime/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
checking dependencies...
:: ffmpeg optionally requires nvidia-utils: Nvidia NVDEC/NVENC support
:: gst-plugins-bad optionally requires nvidia-utils: nvcodec plugin
:: lib32-vulkan-icd-loader optionally requires lib32-vulkan-driver: packaged vulkan driver
:: steam-manjaro optionally requires vulkan-driver: packaged vulkan driver
:: steam-manjaro optionally requires lib32-vulkan-driver: packaged vulkan driver (32bit)
:: vulkan-icd-loader optionally requires vulkan-driver: packaged vulkan driver
Packages (5) lib32-nvidia-utils-460.32.03-1  linux510-nvidia-460.32.03-6  linux54-nvidia-460.32.03-3  nvidia-prime-1.0-4  nvidia-utils-460.32.03-1
Total Removed Size:  472.26 MiB
:: Do you want to remove these packages? [Y/n] 
:: Processing package changes...
removing linux54-nvidia...
removing linux510-nvidia...
removing lib32-nvidia-utils...
xorg configuration symlink valid...
removing nvidia-prime...
removing nvidia-utils...
xorg configuration symlink valid...
:: Running post-transaction hooks...
(1/4) Reloading system manager configuration...
(2/4) Arming ConditionNeedsUpdate...
(3/4) Updating module dependencies...
(4/4) Updating the desktop file MIME type cache...
'/etc/X11/xorg.conf.d/90-mhwd.conf' symlink is invalid! Removing it...
> Successfully removed video-hybrid-intel-nvidia-prime
Puis installé de NVIDIA-390

Waiting for user input...
Starting
> Installing video-nvidia-390xx...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-390xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
:: Synchronizing package databases...
 core is up to date
 extra is up to date
downloading community.db...
 multilib is up to date
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: eglexternalplatform will be installed before its nvidia-390xx-utils dependency

Packages (6) egl-wayland-1.1.6-1  eglexternalplatform-1.1-2  lib32-nvidia-390xx-utils-390.141-1  linux510-nvidia-390xx-390.141-6  linux54-nvidia-390xx-390.141-3  nvidia-390xx-utils-390.141-1

Total Download Size:    60.39 MiB
Total Installed Size:  226.14 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading eglexternalplatform-1.1-2-any.pkg.tar.zst...
downloading egl-wayland-1.1.6-1-x86_64.pkg.tar.zst...
downloading nvidia-390xx-utils-390.141-1-x86_64.pkg.tar.zst...
downloading linux510-nvidia-390xx-390.141-6-x86_64.pkg.tar.zst...
downloading linux54-nvidia-390xx-390.141-3-x86_64.pkg.tar.zst...
downloading lib32-nvidia-390xx-utils-390.141-1-x86_64.pkg.tar.zst...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
:: Processing package changes...
installing eglexternalplatform...
installing egl-wayland...
installing nvidia-390xx-utils...
==> If you run into trouble with CUDA not being available, run nvidia-modprobe first.
Optional dependencies for nvidia-390xx-utils
    gtk2: nvidia-settings [installed]
    xorg-server-devel: nvidia-xconfig [installed]
    opencl-nvidia: OpenCL support [installed]
installing lib32-nvidia-390xx-utils...
Optional dependencies for lib32-nvidia-390xx-utils
    lib32-opencl-nvidia
installing linux510-nvidia-390xx...
In order to use nvidia module, reboot the system.
installing linux54-nvidia-390xx...
In order to use nvidia module, reboot the system.
:: Running post-transaction hooks...
(1/5) Creating system user accounts...
(2/5) Reloading system manager configuration...
(3/5) Arming ConditionNeedsUpdate...
(4/5) Updating module dependencies...
(5/5) Updating the desktop file MIME type cache...
nvidia-390xx-utils: install reason has been set to 'explicitly installed'
lib32-nvidia-390xx-utils: install reason has been set to 'explicitly installed'
linux510-nvidia-390xx: install reason has been set to 'explicitly installed'
linux54-nvidia-390xx: install reason has been set to 'explicitly installed'
xorg configuration file: '/etc/X11/mhwd.d/nvidia.conf'
> Successfully installed video-nvidia-390xx
sudo mhwd -li

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
    video-nvidia-390xx            2020.11.30               false            PCI
     video-modesetting            2020.01.13                true            PCI
Au reboot, plantage de Display manager et le systeme reste figée (sur 5.10 et 5.4) !!!
Merci pour votre aide.
Dernière modification par bicounet18il y a 1 mois, modifié au total 2 fois.

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#23Messageil y a 1 mois

Emanuelo a écrit : il y a 1 mois
alkiros a écrit : il y a 1 mois C'est grave docteur? :saispas:
Je suis à peu près sûr que non. D'une part, selon le Wiki, l'USB n'est pas encore géré par mhwd, d'autre part, si j'en crois ce message récent du forum anglophone, ça veut dire que tout ce qui utilise l'USB dans ta configuration fonctionne grâce au noyau directement. En tout cas, si tu n'as rien de branché via USB qui dysfonctionne, je ne m'inquiéterais pas plus (et c'est d'ailleurs ce que je fais, car j'ai le même message ^^).
Merci, je m'en doutais un peu, me voilà rassuré! Je vais donc faire comme toi, ignorer ce message. :merci:

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#24Messageil y a 1 mois

Ça y est, ma deuxième màj avec Manjaro et cette fois sans soucis (xfce). :-)

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#25Messageil y a 1 mois

Bonjour Al :bjr:
Non, c'est juste qu'ils ont prévu le cas de carte graphique USB comme des Hub DVI ou autres...
Image
Un "Warning" n'est qu'un avertissement, pas une erreur.

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#26Messageil y a 1 mois

Salut lemust, merci pour l'info et bonne journée à toi.
lemust83 a écrit : il y a 1 mois Bonjour Al :bjr:
Non, c'est juste qu'ils ont prévu le cas de carte graphique USB comme des Hub DVI ou autres...
Image
Un "Warning" n'est qu'un avertissement, pas une erreur.

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#27Messageil y a 1 mois

Salut, :salut:

Maj de Deepin. Obligation de passer en mode secours afin de se connecter. Mais il vit ses dernières heures. :pleure::pleure::mrgreen:
Maj de Cinnamon de +de 500 paquets. Redemarrage ras.

Problème pour l'impression mais pas pour scanner. :saispas::saispas:

Impossible de se connecter à CUPS (pour une fois que j'avais envie/besoin). :shock:

Gatouillant pas encore trop, et après une recherche des services de systemctl concernant l'absence de cups '(pour rappel =>systemctl status :gsourire: )
je me suis souvenu de ce post.

Donc j'ai désactivé tous les services de cups qui n'étaient pas en fait activé (d'ou certainement mon incapacité à avoir CUPS dans Firefox) puis activation de ces services.

[olivier@thorielle ~]$ sudo systemctl disable --now org.cups.cupsd.socket
Removed /etc/systemd/system/sockets.target.wants/org.cups.cupsd.socket.
Failed to stop org.cups.cupsd.socket: Unit org.cups.cupsd.socket not loaded.
[olivier@thorielle ~]$ sudo systemctl disable --now org.cups.cupsd.service
Removed /etc/systemd/system/printer.target.wants/org.cups.cupsd.service.
Failed to stop org.cups.cupsd.service: Unit org.cups.cupsd.service not loaded.
[olivier@thorielle ~]$ sudo systemctl disable --now org.cups.cupsd.path
Removed /etc/systemd/system/multi-user.target.wants/org.cups.cupsd.path.
Failed to stop org.cups.cupsd.path: Unit org.cups.cupsd.path not loaded.
[olivier@thorielle ~]$ sudo systemctl enable --now cups.service
Created symlink /etc/systemd/system/printer.target.wants/cups.service → /usr/lib/systemd/system/cups.service.
Created symlink /etc/systemd/system/sockets.target.wants/cups.socket → /usr/lib/systemd/system/cups.socket.
Created symlink /etc/systemd/system/multi-user.target.wants/cups.path → /usr/lib/systemd/system/cups.path.
[olivier@thorielle ~]$ sudo systemctl enable --now cups.socket
[olivier@thorielle ~]$ sudo systemctl enable --now cups.path
Ensuite, j'ai été obligé d'aller dans le menu Configuration de l'impression puis déverrouiller afin de pouvoir , après avoir sélectionné mon imprimante, dans le menu Imprimante. Dans celui-ci, j'ai activé l'imprimante qui apparament c'était désactivée toute seule. Et tout roule.

C'est juste un memo pour ceux et celles qui aurait ce petit soucis qui peut se régler en 10 secondes , à condition de savoir :pappy: . :lol::lol:

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#28Messageil y a 1 mois

Mise à jour sans problème (noyau 5.10.7-3, XFCE)
Merci !

...à l'exception du pilote nvidia non pris en compte par les applis concernées (par exemple 0ad)
Problème résolu comme lors de la précédente mise à jour en complétant ce fichier comme suit :
/usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    ModulePath "/usr/lib/nvidia/xorg"
    ModulePath "/usr/lib/xorg/modules"
EndSection
Question : faudra-t-il le faire à chaque mise à jour du pilote ?

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#29Messageil y a 1 mois

Bonjour.
Pour être franc, je ne sais pas, mais je pense que tant que que ce fichier ne sera pas écrasé volontairement, il n'y a a de risque. Les fichiers .pacnew ou .pacorig par exemple demandent une intervention de l'administrateur pour être gérés. Voir le wiki d'Arch

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#30Messageil y a 1 mois

:salut: ce fichier nvidia conf n'est pas marqué en sauvegarde dans le pkgbuild, par conséquent : pas de .pacnew et écrasement du fichier local par le fichier du paquet ... donc ta modif par rapport à l'original c'est de supprimer la ligne Option "PrimaryGPU" "yes" ?

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#31Messageil y a 1 mois

Non, ma modif c'est de rajouter ces deux lignes au fichier /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf
ModulePath "/usr/lib/nvidia/xorg"
ModulePath "/usr/lib/xorg/modules"
la ligne Option "PrimaryGPU" "yes" était déjà absente.
Les modules ne sont pas chargés je suppose après la mise à jour (nvidia-390 chez moi). Je teste avec 0ad qui demande une bonne accélération graphique. Sans cette modif, c'est llvmpipe qui est utilisé à la place de nvidia. Avec la modif c'est réparé. J'avais eu le même souci lors de la dernière mise à jour fin décembre (cf. le message dans le topic "actualités").

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#32Messageil y a 4 semaines

:salut: grosse maj faite ce soir ... et pas trop bien passée :
passage à linux510 mais linux510-r8168 n'a pas été installé automatiquement :oops: donc pas de réseau avec 510 mais heureusement ok avec l'autre noyau linux54

ps: quelle idée de ne pas utiliser le r8169 (comme sur mon archlinux) :mrgreen:

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#33Messageil y a 4 semaines

Mise à jour sous gnome sans problème que ce soit sur mon portable Lenovo X25à et mon PC fixe (I7 CAM Asus A67 et CG AMD)

Merci à l'équipe

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#34Messageil y a 4 semaines

Je viens de voir qu'une petite MÀJ proposait Firefox 85 et surtout sudo 1.9.5. Est-ce un correctif pour cette faille dont je viens d'entendre parler ?

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#35Messageil y a 4 semaines

:salut: tout à fait
voir l'historique du paquet archlinux:
new upstream release with security fixes

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#36Messageil y a 4 semaines

Merci :-) .

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#37Messageil y a 4 semaines

Heuuuuu....

erreur : erreur GPGME : Pas de données
erreur : erreur GPGME : Pas de données
erreur : erreur GPGME : Pas de données
erreur : erreur GPGME : Pas de données
:: Synchronisation des bases de données de paquets…
 core                                                              167,6 KiB  1926 KiB/s 00:00 [########################################################] 100%
 core.sig                                                         1057,0   B  0,00   B/s 00:00 [########################################################] 100%
erreur : erreur GPGME : Pas de données
erreur : la mise à jour de core a échoué (base de données non valide ou corrompue (signature PGP))
 extra                                                            1992,1 KiB  10,4 MiB/s 00:00 [########################################################] 100%
 extra.sig                                                        1057,0   B  0,00   B/s 00:00 [########################################################] 100%
erreur : erreur GPGME : Pas de données
erreur : la mise à jour de extra a échoué (base de données non valide ou corrompue (signature PGP))
 community                                                           6,4 MiB  7,30 MiB/s 00:01 [########################################################] 100%
 community.sig                                                    1057,0   B  0,00   B/s 00:00 [########################################################] 100%
erreur : erreur GPGME : Pas de données
erreur : la mise à jour de community a échoué (base de données non valide ou corrompue (signature PGP))
 multilib                                                          181,8 KiB  59,2 MiB/s 00:00 [########################################################] 100%
 multilib.sig                                                     1057,0   B  0,00   B/s 00:00 [########################################################] 100%
erreur : erreur GPGME : Pas de données
erreur : la mise à jour de multilib a échoué (base de données non valide ou corrompue (signature PGP))
erreur : la synchronisation de toutes les bases de données a échoué
Comment est-ce possible ?

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#38Messageil y a 4 semaines

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#39Messageil y a 4 semaines

En fait, non ;)

Pacman -Sy fait une update de base mais n'y arrive pas à cause de la vérification de clés.
Sauf si dans pacman.conf

#SigLevel = Never
Et

sudo pacman-key --refresh-keys
me renvoie

gpg: WARNING: server 'dirmngr' is older than us (2.2.25 < 2.2.26)
gpg: Note: Outdated servers may lack important security fixes.
gpg: Note: Use the command "gpgconf --kill all" to restart them.
gpg: refreshing 148 keys from hkp://pool.sks-keyservers.net
gpg: échec de rafraîchissement par le serveur de clefs : Aucun serveur de clefs disponible
==> ERREUR : Une clé locale spécifiée n’a pas pu être mise à jour depuis le serveur.
Quoi que je fasse de proposé, je tourne en rond. :triste:

[Stable] Mise à jour 19/01/2021 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

#40Messageil y a 4 semaines

Ayééé.
En mettant SigLevel à Never dans pacman.conf, je peux exécuter

sudo pacman -Syy
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
Bon maintenant, c'est la dernière commande qui tourne depuis 5 minutes sans rien faire. :tetu!

Ca y est, les clés se sont actualisées.
Bon, je remets SigLevel à PackageRequired dans pacman.conf, ... ben rebelote.

erreur : erreur GPGME : Pas de données
erreur : erreur GPGME : Pas de données
erreur : erreur GPGME : Pas de données
:: Synchronisation des bases de données de paquets…
 core                                                              167,6 KiB  1995 KiB/s 00:00 [########################################################] 100%
 core.sig                                                         1057,0   B  0,00   B/s 00:00 [########################################################] 100%
erreur : erreur GPGME : Pas de données
erreur : la mise à jour de core a échoué (base de données non valide ou corrompue (signature PGP))
 extra                                                            1992,1 KiB  9,58 MiB/s 00:00 [########################################################] 100%
 extra.sig                                                        1057,0   B  0,00   B/s 00:00 [########################################################] 100%
erreur : erreur GPGME : Pas de données
erreur : la mise à jour de extra a échoué (base de données non valide ou corrompue (signature PGP))
 community                                                           6,4 MiB  8,62 MiB/s 00:01 [########################################################] 100%
 multilib                                                          181,8 KiB  59,2 MiB/s 00:00 [########################################################] 100%
 multilib.sig                                                     1057,0   B  0,00   B/s 00:00 [########################################################] 100%
erreur : erreur GPGME : Pas de données
erreur : la mise à jour de multilib a échoué (base de données non valide ou corrompue (signature PGP))
erreur : la synchronisation de toutes les bases de données a échoué
Répondre