Discussions et informations sur ce qui se passe dans le monde de l'informatique.
Répondre

le probleme des versions GTK , Qt , gnome & wayland et leur evolution 2021

#1Messageil y a 1 mois

bonjour

rappel dans le cas de Solus et Bungie
il s'agit d'un développement par solus de leur propre solution pour
- Gtk3 , Gnome

suite à la lecture détaillé de ce sujet
https://joshuastrobl.com/2021/09/14/bui ... ecosystem/

il apparaît que :
- gtk4 et plus , rend obsolète certaines fonctionnalités de GTK3 , et a supprimé des Api X11
- gnome a figé sur adwaita & libadwaita leur partie gestionnaire affichage avec absence de widgets ( ou équivalent )
- Qt pose le problème de version & licence ( et sans doutes des évolutions qui concernent plus KDE )

et l'avenir n'est pas radieux pour les années a venir ,
donc je pense que les DE comme Xfce , Gnome2 , Maté vont restés sous Gtk3 et la question de Wayland se pose pour ces bureaux ( sans parler des fonctionnalités possible ou pas )
- gnome & KDE vont s'orienter plus vers Wayland ( abandon de X11 )
- attention pour wayland drivers nvidia 470 et plus REQUIS pour la suite ( pas de support pour les anciennes cartes sauf mode "nouveau" )

nb: bien que cela concerne la gestion Bungie , il y a pas mal de chose qui concerne les autres bureaux ce qui donc reste valable pour les autres distributions, ils s'orientent de leur côté vers une solution EFL
Dernière modification par stephaneil y a 1 mois, modifié au total 1 fois.

le probleme des versions GTK , Qt , gnome & wayland et leur evolution 2021

#2Messageil y a 1 mois

:salut:
stephane a écrit : il y a 1 mois gtk4 et plus , rend obsolète certaines fonctionnalités de GTK3
j'ai fait quelques tests il y a quelques mois pour porter des apps de gtk3 en gtk4 et ce n'est clairement pas simple : énormément de choses dans l'api ont disparues avec gtk 4 ( " Stop using... Stop using... ") pour au final, avoir beaucoup moins de libertés pour le développeur ;rale:
https://docs.gtk.org/gtk4/migrating-3to4.html
Répondre