Problèmes et questions concernant l'édition Mate.

Contenu du "centre de contrôle" quasi vide

#1Messageil y a 1 mois

Bonjour,

Depuis quelque temps, je n'ai plus accès au "centre de contrôle". Dès lors que je le lance dans le terminal j'obtiens :

yvance@yvance ~> mate-control-center
**
libslab:ERROR:app-shell.c:694:create_application_category_sections: assertion failed: (app_data->categories_list != NULL)

Bail out! libslab:ERROR:app-shell.c:694:create_application_category_sections: assertion failed: (app_data->categories_list != NULL)

fish: Job 1, 'mate-control-center' terminated by signal SIGABRT (Abandon)
J'ai bien fait une demande sur le forum anglais, mais là-bas aucune réponse, alors je me tourne vers vous qui sait avec un peu de chance.

Ceci dit, même un recherche sur le net donne quasi aucun résultat.

Bon après ce n'est pas un drame non plus, tant que le reste est fonctionnel.

Merci
Dernière modification par Yvance77il y a 1 mois, modifié au total 1 fois.

Contenu du "centre de contrôle" quasi vide

#2Messageil y a 1 mois

Suite à la dernière mise à jour il y a un peu de progrès. Limité toutefois

Image

J'ai le "control-center" qui se lance, mais il est quasi vide.

En revanche ici c'est pas terrible :

yvance@yvance ~> cat .xsession-errors
Avertissement du gestionnaire de fenêtres : Log level 128: unsetenv() is not thread-safe and should not be used after threads are created

(caja:1107): Gtk-WARNING **: 06:24:07.517: Failed to register client: GDBus.Error:org.gnome.SessionManager.AlreadyRegistered: Unable to register client
blueman-applet 06.24.08 WARNING  PluginManager:148 __load_plugin: Not loading PPPSupport because its conflict has higher priority
blueman-applet 06.24.08 WARNING  PluginManager:148 __load_plugin: Not loading DhcpClient because its conflict has higher priority
[1841:1841:0520/062435.333276:ERROR:extension_error_controller.cc(46)] Blocklisted extension: emipoepfakonicaobeeejombhfkbicld
[1841:1841:0520/062435.333526:ERROR:extension_error_controller.cc(46)] Blocklisted extension: emipoepfakonicaobeeejombhfkbicld
[1841:1841:0520/062437.460992:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: The message port closed before a response was received.", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
** Message: 06:24:38.015: updates_checker.vala:71: check updates
** Message: 06:24:38.386: updates_checker.vala:101: 0 updates found
Fontconfig error: Cannot load default config file: No such file: (null)
[1841:1841:0520/062700.057545:ERROR:extension_error_controller.cc(46)] Blocklisted extension: emipoepfakonicaobeeejombhfkbicld
[1841:1841:0520/062916.347499:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: The message port closed before a response was received.", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[1841:1841:0520/062916.347550:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: The message port closed before a response was received.", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
** Message: 06:35:19.144: PANEL_ORIENTATION_TOP
** Message: 06:35:44.316: PANEL_ORIENTATION_TOP

(mate-terminal:2966): GLib-GIO-WARNING **: 06:36:35.399: Failed to parse translated string 'Terminal' for key 'title' in schema 'org.mate.terminal.profile': 0:expected value

(mate-terminal:2966): GLib-GIO-WARNING **: 06:36:35.400: Using untranslated default instead.

(mate-terminal:2966): GLib-GIO-WARNING **: 06:36:35.400: Failed to parse translated string '[UTF-8,current,ISO-8859-15,ISO-8859-1]' for key 'active-encodings' in schema 'org.mate.terminal.global': 1:expected value

(mate-terminal:2966): GLib-GIO-WARNING **: 06:36:35.400: Using untranslated default instead.
Avertissement du gestionnaire de fenêtres : Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x4c000f8 (.bash_hist)
Avertissement du gestionnaire de fenêtres : meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
** Message: 06:39:42.934: PANEL_ORIENTATION_TOP

(mate-terminal:3367): GLib-GIO-WARNING **: 06:40:52.546: Failed to parse translated string 'Terminal' for key 'title' in schema 'org.mate.terminal.profile': 0:expected value

(mate-terminal:3367): GLib-GIO-WARNING **: 06:40:52.546: Using untranslated default instead.

Contenu du "centre de contrôle" quasi vide

#3Messageil y a 1 mois

en faisant des recherches
pacman -Si ou yat ( ou Trizen ) -Si
mate-control-center pas de dépendance avec libslab

la version dans AUR libslab utilise que le GTK2 ( pas le GTK3 )

que donne pacman -Qdt ?

Contenu du "centre de contrôle" quasi vide

#4Messageil y a 1 mois

stephane a écrit : il y a 1 mois que donne pacman -Qdt ?
Bonjour Stéphane,

yvance@yvance ~> sudo pacman -Qdt
[sudo] Mot de passe de yvance : 
cmake 3.20.2-1
gnome-common 3.18.0-4
gnome-perl 1.045-8
gtkspell3 3.0.10-2
lib32-alsa-oss 1.1.8-2
lib32-lz4 1.9.3-1
lib32-openal 1.21.1-1
mhwd-nvidia-340xx 340.108-1
perl-extutils-depends 0.8000-4
perl-extutils-pkgconfig 1.16-7
perl-test-needs 0.002006-3
perl-test-pod 1.52-5
python-asn1crypto 1.4.0-3
xorg-server-xvfb 1.20.11-1
yvance@yvance ~> 

Contenu du "centre de contrôle" quasi vide

#5Messageil y a 1 mois

pour chaque ligne tu vas vérifier le retour de

pactree -r <élément à supprimer>
sudo pacman -Rsn <élément à supprimer>
tu devrais avoir que l'élément a supprimer , s'il en propose d'autres ce n'est pas bon
dans ce cas tu appliquera

sudo pacman -Rs<élément à supprimer>
essaye
pactree -r libslab
Dernière modification par stephaneil y a 1 mois, modifié au total 1 fois.

Contenu du "centre de contrôle" quasi vide

#6Messageil y a 1 mois

yvance@yvance ~ [127]> pactree -r libstab
error: package 'libstab' not found
yvance@yvance ~ [1]>
PS : il faut faire cela ligne à ligne ?

yvance@yvance ~ [1]> sudo pactree -r gtkdpell3 3.0.10-2
pactree v1.4.0

A simple dependency tree viewer.

Usage: pactree [options] PACKAGE

  -a, --ascii            use ASCII characters for tree formatting
  -b, --dbpath <path>    set an alternate database location
  -c, --color            colorize output
  -d, --depth <#>        limit the depth of recursion
  -g, --graph            generate output for graphviz's dot
  -h, --help             display this help message
  -l, --linear           enable linear output
  -r, --reverse          list packages that depend on the named package
  -s, --sync             search sync databases instead of local
  -u, --unique           show dependencies with no duplicates (implies -l)
  -o, --optional[=DEPTH] controls at which depth to stop printing optional deps
                         (-1 for no limit)
  -v, --version          display the version
      --config <path>    set an alternate configuration file
      --debug            display debug messages
      --gpgdir <path>    set an alternate home directory for GnuPG
yvance@yvance ~ [1]> 

Contenu du "centre de contrôle" quasi vide

#7Messageil y a 1 mois

pactree -r libslab ( ne pas mettre la version après ! )

reponse : oui !

Contenu du "centre de contrôle" quasi vide

#8Messageil y a 1 mois

yvance@yvance ~> spt1 cmake
[sudo] Mot de passe de yvance : 
cmake
yvance@yvance ~> spt1 gnome-common
gnome-common
yvance@yvance ~> spt1 gnome-perl
gnome-perl
yvance@yvance ~> spt1 gtkspell3
gtkspell3
yvance@yvance ~> spt1 lib32-alsa-oss
lib32-alsa-oss
yvance@yvance ~> spt1 lib32-lz4
lib32-lz4
yvance@yvance ~> spt1 lib32-openal
lib32-openal
yvance@yvance ~> spt1 mhwd-nvidia-340xx
mhwd-nvidia-340xx
yvance@yvance ~ [1]> spt1 perl-extutils-depends
perl-extutils-depends
yvance@yvance ~> spt1 perl-extutils-pkgconfig
perl-extutils-pkgconfig
yvance@yvance ~> spt1 perl-test-pod
perl-test-pod
yvance@yvance ~> spt1 python-asn1crypto
python-asn1crypto
yvance@yvance ~> spt1 xorg-server-xvfb
xorg-server-xvfb
Tout semble OK ?

Contenu du "centre de contrôle" quasi vide

#9Messageil y a 1 mois

oui tu peux les supprimer

Contenu du "centre de contrôle" quasi vide

#10Messageil y a 1 mois

Re,

J'ai refait la commande initiale, et deux autres paquets sont apparus. J'ai supprimé également, et désormais c'est propre.

yvance@yvance ~> sudo pacman -Qdt
lib32-fluidsynth 2.1.8-1
perl-test-needs 0.002006-3
yvance@yvance ~> spt3 lib32-fluidsynth
vérification des dépendances…
:: lib32-alsa-plugins peut nécessiter lib32-jack: for pcm_jack plugin

Paquets (6) lib32-db-5.3.28-4  lib32-jack-0.125.0-3  lib32-libinstpatch-1.1.6-1
            lib32-portaudio-1:19.7.0-1  lib32-sdl2-2.0.14-1  lib32-fluidsynth-2.1.8-1

Taille totale supprimée :  7,37 MiB

:: Voulez-vous désinstaller ces paquets ? [O/n] o
:: Traitement des changements du paquet…
(1/6) désinstallation de lib32-fluidsynth              [############################] 100%
(2/6) désinstallation de lib32-sdl2                    [############################] 100%
(3/6) désinstallation de lib32-portaudio               [############################] 100%
(4/6) désinstallation de lib32-libinstpatch            [############################] 100%
(5/6) désinstallation de lib32-jack                    [############################] 100%
(6/6) désinstallation de lib32-db                      [############################] 100%
:: Exécution des crochets de post-transaction…
(1/2) Arming ConditionNeedsUpdate...
(2/2) Removing unnecessary cached files (keeping the latest two)…
==> no candidate packages found for pruning
yvance@yvance ~> spt3 perl-test-needs
vérification des dépendances…

Paquets (1) perl-test-needs-0.002006-3

Taille totale supprimée :  0,01 MiB

:: Voulez-vous désinstaller ces paquets ? [O/n] o
:: Traitement des changements du paquet…
(1/1) désinstallation de perl-test-needs               [############################] 100%
:: Exécution des crochets de post-transaction…
(1/2) Arming ConditionNeedsUpdate...
(2/2) Removing unnecessary cached files (keeping the latest two)…
==> no candidate packages found for pruning
yvance@yvance ~> sudo pacman -Qdt
yvance@yvance ~ [1]> 
Que faire à partir de là ? Je n'ai pas rebooté pour information

Merci

Contenu du "centre de contrôle" quasi vide

#11Messageil y a 1 mois

tu redémarre , et vérifie le résultat pour le centre de contrôle

Contenu du "centre de contrôle" quasi vide

#12Messageil y a 1 mois

Bonjour,

Malheureusement rien de plus :?:

Image

Contenu du "centre de contrôle" quasi vide

#13Messageil y a 1 mois

que donne
pactree - r libslab ?

essaye

sudo pacman -Rsn mate-control-center
sudo pacman -S mate-control-center

Contenu du "centre de contrôle" quasi vide

#14Messageil y a 1 mois

stephane a écrit : il y a 1 mois que donne
pactree - r libslab ?
Re,

Cela :

Bienvenue dans fish, le shell amical et interactif
Type `help` for instructions on how to use fish
yvance@yvance ~> sudo pactree -r libslab
[sudo] Mot de passe de yvance : 
error: package 'libslab' not found
yvance@yvance ~ [1]> sudo pacman -Rsn mate-control-center
vérification des dépendances…

Paquets (4) libxpresent-1.0.0+2+gdd6771c-2  marco-1.24.2-1  mate-settings-daemon-1.24.2-1
            mate-control-center-1.24.2-1

Taille totale supprimée :  24,29 MiB

:: Voulez-vous désinstaller ces paquets ? [O/n] o
:: Traitement des changements du paquet…
(1/4) désinstallation de mate-control-center           [############################] 100%
(2/4) désinstallation de mate-settings-daemon          [############################] 100%
(3/4) désinstallation de marco                         [############################] 100%
(4/4) désinstallation de libxpresent                   [############################] 100%
:: Exécution des crochets de post-transaction…
(1/8) Reloading device manager configuration...
(2/8) Arming ConditionNeedsUpdate...
(3/8) Removing unnecessary cached files (keeping the latest two)…
==> no candidate packages found for pruning
(4/8) Reloading system bus configuration...
(5/8) Compiling GSettings XML schema files...
(6/8) Updating icon theme caches...
(7/8) Updating the desktop file MIME type cache...
(8/8) Updating the MIME type database...
yvance@yvance ~> sudo pacman -S mate-control-center
résolution des dépendances…
recherche des conflits entre paquets…

Paquets (4) libxpresent-1.0.0+2+gdd6771c-2  marco-1.24.2-1  mate-settings-daemon-1.24.2-1
            mate-control-center-1.24.2-1

Taille totale installée :  24,29 MiB

:: Procéder à l’installation ? [O/n] o
(4/4) vérification des clés dans le trousseau          [############################] 100%
(4/4) vérification de l’intégrité des paquets          [############################] 100%
(4/4) chargement des fichiers des paquets              [############################] 100%
(4/4) analyse des conflits entre fichiers              [############################] 100%
(4/4) vérification de l’espace disque disponible       [############################] 100%
:: Traitement des changements du paquet…
(1/4) installation de mate-settings-daemon             [############################] 100%
Dépendances optionnelles pour mate-settings-daemon
    libcanberra-pulse: PulseAudio support [installé]
    pulseaudio-alsa: PulseAudio support [installé]
(2/4) installation de libxpresent                      [############################] 100%
(3/4) installation de marco                            [############################] 100%
(4/4) installation de mate-control-center              [############################] 100%
:: Exécution des crochets de post-transaction…
(1/8) Reloading device manager configuration...
(2/8) Arming ConditionNeedsUpdate...
(3/8) Removing unnecessary cached files (keeping the latest two)…
==> no candidate packages found for pruning
(4/8) Reloading system bus configuration...
(5/8) Compiling GSettings XML schema files...
(6/8) Updating icon theme caches...
(7/8) Updating the desktop file MIME type cache...
(8/8) Updating the MIME type database...
yvance@yvance ~> 
Et toujours la même chose

Contenu du "centre de contrôle" quasi vide

#15Messageil y a 1 mois

tu as tout cette liste installé

Dépend de : mate-menus mate-settings-daemon marco libxss
mate-desktop gettext

Contenu du "centre de contrôle" quasi vide

#16Messageil y a 1 mois

Stéphane bonsoir,

Je ne comprends pas le sens de ta réponse

Contenu du "centre de contrôle" quasi vide

#17Messageil y a 4 semaines

bonsoir
issu de archlinux ( endeavourOs ) j'ai ceci en liste de paquets

Image

Image

Image

effectue une verification paquet par paquet
( pacman -Qs mate et pacman -Qi mate-control-center )

Contenu du "centre de contrôle" quasi vide

#18Messageil y a 4 semaines

as tu ces pakage installé

pacman -Qi mate-menus 
pacman -Qi mate-settings-daemon
pacman -Qi marco 
pacman -Qi ibxss
pacman -Qi gettext

Contenu du "centre de contrôle" quasi vide

#19Messageil y a 4 semaines

Bonjour

Tous y sont :

yvance@yvance ~> pacman -Qs mate
local/atril 1.24.1-1 (mate-extra)
    MATE document viewer
local/caja 1.24.1-1 (mate)
    File manager for the MATE desktop
local/caja-image-converter 1.24.1-1 (mate-extra)
    A Caja extension for simple image conversions
local/caja-open-terminal 1.24.1-1 (mate-extra)
    A Caja extension for opening terminals in arbitrary local paths
local/caja-wallpaper 1.24.1-1 (mate-extra)
    A Caja extension to quickly set wallpaper
local/engrampa 1.24.2-1 (mate-extra)
    Archive manipulator for MATE
local/eom 1.24.2-1 (mate-extra)
    An image viewing and cataloging program for MATE
local/grub-themes-solarized-dark-materialized 1.0-2
    Solarized-Dark-Materialized grub2 theme
local/libmatekbd 1.24.1-1
    MATE keyboard library
local/libmatemixer 1.24.1-1
    Mixer library for MATE Desktop
local/libmateweather 1.24.1-1
    Provides access to weather information from the Internet.
local/marco 1.24.2-1 (mate)
    A window manager for MATE
local/matcha-gtk-theme 20210424-1
    A flat design themes for GNOME, MATE, Openbox, Unity, XFCE, Budgie
local/mate-applet-dock 20.04.0-1
    Application dock for the MATE panel
local/mate-applets 1.24.1-1 (mate-extra)
    Applets for MATE panel
local/mate-backgrounds 1.24.2-1 (mate)
    Background images and data for MATE
local/mate-calc 1.24.2-1 (mate-extra)
    Calculator for the MATE desktop environment
local/mate-common 1.24.2-1
    Common development macros for MATE
local/mate-control-center 1.24.2-1 (mate)
    The Control Center for MATE
local/mate-desktop 1.24.1-1 (mate)
    Library with common API for various MATE modules
local/mate-icon-theme 1.24.0-1 (mate)
    MATE icon theme
local/mate-media 1.24.1-1 (mate-extra)
    MATE Media Tools
local/mate-menus 1.24.1-1 (mate)
    MATE menu specifications
local/mate-panel 1.24.2-1 (mate)
    The MATE Panel
local/mate-polkit-gtk2 1.14.0-2 (mate-gtk2)
    PolicyKit integration for the MATE desktop (GTK2 version)
local/mate-power-manager 1.24.3-1 (mate-extra)
    Power management tool for the MATE desktop
local/mate-screensaver 1.24.2-1 (mate-extra)
    Screensaver for MATE
local/mate-session-manager 1.24.3-1 (mate)
    The MATE Session Handler
local/mate-settings-daemon 1.24.2-1 (mate)
    The MATE Settings daemon
local/mate-system-monitor 1.24.2-1 (mate-extra)
    A system monitor for MATE
local/mate-terminal 1.24.1-1 (mate-extra)
    The MATE Terminal Emulator
local/mate-themes 3.22.22-1 (mate)
    Default themes for the MATE desktop
local/mate-tweak 21.04.2-1
    Tweak tool for MATE, a fork of MintDesktop.
local/mate-user-guide 1.24.0-1 (mate)
    MATE User Guide
local/mate-utils 1.24.0-1 (mate-extra)
    Common MATE utilities for viewing disk usage, logs and fonts, taking screenshots,
    managing dictionaries and searching files
local/mozo 1.24.1-1 (mate-extra)
    MATE menu editing tool
local/pluma 1.24.2-1 (mate-extra)
    A powerful text editor for MATE
local/vala-panel-appmenu-mate 0.7.3.2.r0.gca3dfe4-1
    AppMenu (Global Menu) plugin for mate-panel
yvance@yvance ~> 

yvance@yvance ~> pacman -Qi mate-control-center
Nom                      : mate-control-center
Version                  : 1.24.2-1
Description              : The Control Center for MATE
Architecture             : x86_64
URL                      : https://mate-desktop.org
Licences                 : GPL
Groupes                  : mate
Fournit                  : --
Dépend de                : mate-menus  mate-settings-daemon  marco  libxss  mate-desktop
                           gettext
Dépendances opt.         : --
Requis par               : --
Optionnel pour           : --
Est en conflit avec      : mate-control-center-gtk3
Remplace                 : mate-control-center-gtk3
Taille installée         : 14,71 MiB
Paqueteur                : Antonio Rojas <arojas@archlinux.org>
Compilé le               : sam. 17 avril 2021 06:55:50
Installé le              : ven. 21 mai 2021 08:45:44
Motif d’installation     : Explicitement installé
Script d’installation    : Non
Validé par               : Signature

Contenu du "centre de contrôle" quasi vide

#20Messageil y a 4 semaines

anomalie sur mate-polkit-gtk2 ( tout est en gtk3 , donc sans suffixe )
a faire en terminal ( je serai tenté par un -Rs , par chroot plutot , parce que ce peut casser , puis option -S )

sudo pacman -R mate-polkit-gtk2
sudo pacman -S mate-polkit
Répondre