Tout ce qui concerne internet
Répondre

localhost : connexion refusée

#1Messageil y a 8 mois

Bonjour à tous,

je me connecte à rutorrent sur mon pc via https://localhost/rutorrent/ mais je n'ai plus accès a localhost tout d'un coup.

wget 127.0.0.1
--2021-02-02 19:09:33--  http://127.0.0.1/
Connexion à 127.0.0.1:80… échec : Connexion refusée.

ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host 
valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether d4:5d:64:37:d1:ae brd ff:ff:ff:ff:ff:ff
inet 192.168.0.14/24 brd 192.168.0.255 scope global dynamic noprefixroute enp3s0
valid_lft 85965sec preferred_lft 85965sec
inet6 fe80::6d44:9a8a:d042:4481/64 scope link noprefixroute 
valid_lft forever preferred_lft forever

ip route show table local
broadcast 127.0.0.0 dev lo proto kernel scope link src 127.0.0.1 
local 127.0.0.0/8 dev lo proto kernel scope host src 127.0.0.1 
local 127.0.0.1 dev lo proto kernel scope host src 127.0.0.1 
broadcast 127.255.255.255 dev lo proto kernel scope link src 127.0.0.1 
broadcast 192.168.0.0 dev enp3s0 proto kernel scope link src 192.168.0.14 
local 192.168.0.14 dev enp3s0 proto kernel scope host src 192.168.0.14 
broadcast 192.168.0.255 dev enp3s0 proto kernel scope link src 192.168.0.14 

ping 127.0.0.1
PING 127.0.0.1 (127.0.0.1) 56(84) octets de données.
64 octets de 127.0.0.1 : icmp_seq=1 ttl=64 temps=0.026 ms
64 octets de 127.0.0.1 : icmp_seq=2 ttl=64 temps=0.032 ms
64 octets de 127.0.0.1 : icmp_seq=3 ttl=64 temps=0.039 ms
64 octets de 127.0.0.1 : icmp_seq=4 ttl=64 temps=0.034 ms
64 octets de 127.0.0.1 : icmp_seq=5 ttl=64 temps=0.036 ms
^C
--- statistiques ping 127.0.0.1 ---
5 paquets transmis, 5 reçus, 0% packet loss, time 4164ms
rtt min/avg/max/mdev = 0.026/0.033/0.039/0.004 ms
contenu de /etc/hosts:

GNU nano 5.5                               /etc/hosts                                        
# Static table lookup for hostnames.
# See hosts(5) for details.
j'ai tenté d'ajouter 127.0.0.1 localhost dans le fichier hosts mais aucun changement.
je n'ai pas installé de pare feu
je suis connecté sur enp3s0 en ethernet

si quelqu'un a une idée je suis preneur. merci

localhost : connexion refusée

#2Messageil y a 8 mois

Salut.

En premier lieu, tu mentionnes https, mais ta commande wget prend du http.
Suivant ce que tu as configuré sur ton serveur http, vouloir du http alors que le serveur ne donne que du https, peut justement renvoyer connexion refusée.

localhost : connexion refusée

#3Messageil y a 8 mois

Salut, merci pour ta réponse.

que ce soit http ou https ça ne fonctionne pas.
je précise que je suis sur mon ordi fixe et que ça a cessé de fonctionner d'un coup sans rien faire à part peut être les mise à jour du système.

localhost : connexion refusée

#4Messageil y a 8 mois

Bonjour.
Pas assez calé en réseau, j'utilise pour les tests du forum en localhost docker et notamment docker-compose qui permet de mettre en conteneur des images serveur.
En gros, on n'installe pas le serveur en dur, mais on se sert du kernel pour gérer des scripts qui "génèrent" un serveur physique en /tmp.
Pas sur que ça réponde à ta question, mais une rolling en serveur n'est pas une bonne idée, d'où l'utilisation d'images docker "clef en main".

localhost : connexion refusée

#5Messageil y a 8 mois

Bonjour,

pour vous dire que le problème est resolu.
ça venait d'apache et le passage de php7 à php8.

dans /etc/httpd/conf/httpd.conf j'ai du modifier

Include conf/extra/php7_module.conf
en

Include conf/extra/php_module.conf
et

LoadModule php_module modules/libphp7.so
en

LoadModule php_module modules/libphp.so
et tout roule à nouveau :sourire::sourire::sourire:

https://php.watch/versions/8.0/mod_php-rename
Répondre