Tout ce qui concerne internet
Répondre

Connexion wifi / netctl

#1Messageil y a 7 mois

Bonjour à tous :salut:

Alors j'avais un problème : lorsque je sortais de veille, une fois sur deux, ça mettait "équipement wifi désactivé" et impossible de me connecter au wifi sans redémarrer.

En voulant résoudre ce problème, je l'ai apparemment empiré.

La commande

systemctl enable netctl-auto@wlp2s0.service
(que je n'aurais sûrement pas dû taper :tetu! ) a créé un autre problème : dès que je démarre l'ordi, au lieu de se connecter automatiquement, ça me demande le mot de passe (qui est pré-rempli), je mets OK mais ça me le redemande une dizaine de fois avant de se connecter.

Du coup je vais dans les préférences wifi, je mets "oublier le réseau" et je refais une procédure de connexion. Là, il me demande le mot de passe, je remplis le champ, et il me redemande plein de fois le mot de passe (qui est pré-rempli les fois suivantes) sans jamais se connecter.

Est-ce que c'est bien netctl qui gère le réseau dans manjaro ?
Qu'est-ce que je peux faire ?

J'ai un Lenovo Yoga 520 14IKB avec un i7 8550u et 16gb de ram. Manjaro Gnome parfaitement à jour y est installé.
Je ne sais pas si c'est normal mais /etc/netctl/hooks ainsi que /etc/netctl/interfaces sont vides.
Merci d'avance pour votre aide.

Connexion wifi / netctl

#2Messageil y a 7 mois

Bonjour.
Un seul service de réseau peut être activé.
Honnêtement, NetworkManager est très au point aujourd'hui .
Perso, je désactiverais netctl-auto@wlp2s0.service et réactiverais NetworkManager.service .

Connexion wifi / netctl

#3Messageil y a 7 mois

Merci beaucoup pour ta réponse rapide.

Donc

systemctl disable netctl-auto@wlp2s0.service
et

systemctl enable NetworkManager.service
, c'est ça ? Je ne suis pas sûr des commandes exactes.

Connexion wifi / netctl

#4Messageil y a 7 mois

Merci @lemust83.

Problème résolu, c'était bien deux services de réseau activés en même temps car

systemctl is-active NetworkManager.service
me retourne "active".

Du coup je vais essayer de faire un

systemctl restart NetworkManager.service
si j'ai de nouveau le problème de wifi en sortie de veille et je vous tient au courant.

Répondre