Problèmes et questions sur les environnements graphiques et les applications.

Souci Thunderbird + Démarrage

#141Messageil y a 1 mois

Ouh là là ! Qu'est-ce que c'est que ce miracle !???
Ta dernière manipulation a fonctionné lemust83 !!!!!!!!! :clap:clap:clap:pompom::pompom::pompom::pompom::pompom::pompom::pompom:
Oh bon sang ! :maître::maître::maître::maître::maître:
Je fais quoi maintenant ?

Edit: çà veut dire que c'est bon ? est-ce que le problème est résolu ? Je tente de relancer l'ordi ou pas ?
Dernière modification par Jen1321il y a 1 mois, modifié au total 1 fois.

Souci Thunderbird + Démarrage

#142Messageil y a 1 mois

Bon, :bien
Tu réinstalle grub qui est complètement foiré .

sudo pacman -S grub --overwrite '*'
sudo mkinicpio -P
grub-mkconfig -o /boot/grub/grub.cfg
Avant de rebooter, donne le contenu de /etc/fstab.
Denis-pom a vu juste, il y a un souci avec ta swap.

Edit: Je pense que c'est LightDM qui nous emm :censure: de
Si tu n'as que Manjaro et un seul utilisateur, on peut s'en passer.

Souci Thunderbird + Démarrage

#143Messageil y a 1 mois

Oh là là que d'émotions !!! Vous êtes supers franchement !
Merci merci merci :clap:clap:clap:clap:clap:clap
Le Grub est complètement foiré... bon ok, je fais ta dernière manip et je reviens :sourire:
Euh je fais çà tel quel (la clé n'est plus là) ? Euh oui j'imagine... Pfff j'en tremble je ne sais plus où j'habite :lol:

Souci Thunderbird + Démarrage

#144Messageil y a 1 mois

Je réinstalle Grub tout de suite ou on s'occupe du cas de LightDM ?

Souci Thunderbird + Démarrage

#145Messageil y a 1 mois

On verra plus tard.
Au pire, tu sais booter depuis Grub.maintenant.
Sinon, regarde ici:
71395

Souci Thunderbird + Démarrage

#146Messageil y a 1 mois

Voilààà...

[jen@jen ~]$ sudo pacman -S grub --overwrite '*'
[sudo] Mot de passe de jen : 
avertissement : grub-2.04-13 est à jour -- réinstallation
résolution des dépendances…
recherche des conflits entre paquets…

Paquets (1) grub-2.04-13

Taille totale installée :    49,03 MiB
Taille de mise à jour nette :   0,00 MiB

:: Procéder à l’installation ? [O/n] O
(1/1) vérification des clés dans le trousseau      [######################] 100%
(1/1) vérification de l’intégrité des paquets      [######################] 100%
(1/1) chargement des fichiers des paquets          [######################] 100%
(1/1) analyse des conflits entre fichiers          [######################] 100%
(1/1) vérification de l’espace disque disponible   [######################] 100%
:: Traitement des changements du paquet…
(1/1) réinstallation grub                          [######################] 100%
:: Exécution des crochets de post-transaction…
(1/2) Arming ConditionNeedsUpdate...
(2/2) Updating the info directory file...
[jen@jen ~]$ sudo mkinicpio -P
sudo: mkinicpio : commande introuvable
[jen@jen ~]$ sudo mkinitcpio -P
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'default'
  -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64.img
==> Starting build: 4.19.165-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'fallback'
  -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64-fallback.img -S autodetect
==> Starting build: 4.19.165-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64-fallback.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'default'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64.img
==> Starting build: 5.4.87-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.4-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'fallback'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64-fallback.img -S autodetect
==> Starting build: 5.4.87-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.4-x86_64-fallback.img
==> Image generation successful
[jen@jen ~]$ grub-mkconfig -o /boot/grub/grub.cfg
grub-mkconfig : seul le superutilisateur peut exécuter cela
[jen@jen ~]$ sudo grub-mkconfig -o /boot/grub/grub.cfg
Création du fichier de configuration GRUB…
Thème trouvé : /usr/share/grub/themes/manjaro/theme.txt
Image Linux trouvée : /boot/vmlinuz-5.4-x86_64
Image mémoire initiale trouvée : /boot/amd-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Image Linux trouvée : /boot/vmlinuz-4.19-x86_64
Image mémoire initiale trouvée : /boot/amd-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
fait
[jen@jen ~]$ 

Image

Ok pour LightDM, je peux rebooter alors ?
Oui je sais maintenant booter par le Grub, merci infiniment pour ce que vous m'avez appris aujourd'hui :sourire:

Souci Thunderbird + Démarrage

#147Messageil y a 1 mois

si c'est bon tu nous donnera ensuite

sudo systemd-analyze blame 

Souci Thunderbird + Démarrage

#148Messageil y a 1 mois

stephane a écrit : il y a 1 mois si c'est bon tu nous donnera ensuite

sudo systemd-analyze blame 
Bon j'ai relancé l'ordi, çà n'a pas été (même chanson que d'habitude... gris, noir, gris et rien) j'ai donc refait le truc du boot par le Grub.

Voilà Stéphane :

[jen@jen ~]$ sudo systemd-analyze blame
[sudo] Mot de passe de jen : 
4.840s apparmor.service                                                         
3.488s lvm2-monitor.service                                                     
3.394s dev-sda1.device                                                          
1.381s snapd.service                                                            
1.357s tlp.service                                                              
1.342s systemd-random-seed.service                                              
 943ms cups.service                                                             
 701ms upower.service                                                           
 588ms systemd-journald.service                                                 
 575ms polkit.service                                                           
 539ms systemd-timesyncd.service                                                
 521ms systemd-udev-trigger.service                                             
 485ms systemd-udevd.service                                                    
 455ms systemd-logind.service                                                   
 385ms user@1000.service                                                        
 363ms udisks2.service                                                          
 326ms modprobe@drm.service                                                     
 318ms avahi-daemon.service                                                     
 263ms NetworkManager.service                                                   
 235ms ModemManager.service                                                     
 136ms systemd-journal-flush.service                                            
 120ms modprobe@fuse.service                                                    
 116ms sys-kernel-tracing.mount                                                 
lines 1-23



Et la fin...

116ms sys-kernel-tracing.mount                                                 
 114ms dev-mqueue.mount                                                         
 112ms kmod-static-nodes.service                                                
 112ms dev-hugepages.mount                                                      
 111ms sys-kernel-debug.mount                                                   
 103ms modprobe@configfs.service                                                
  96ms bluetooth.service                                                        
  96ms systemd-modules-load.service                                             
  93ms systemd-rfkill.service                                                   
  93ms ufw.service                                                              
  91ms colord.service                                                           
  84ms linux-module-cleanup.service                                             
  78ms systemd-tmpfiles-setup.service                                           
  75ms systemd-remount-fs.service                                               
  73ms systemd-tmpfiles-setup-dev.service                                       
  68ms sys-fs-fuse-connections.mount                                            
  67ms snapd.apparmor.service                                                   
  64ms systemd-sysctl.service                                                   
  59ms accounts-daemon.service                                                  
  58ms sys-kernel-config.mount                                                  
  50ms user-runtime-dir@1000.service                                            
  38ms wpa_supplicant.service                                                   
  35ms dev-disk-by\x2duuid-c42854a7\x2d078f\x2d48ed\x2db457\x2d64f2d06f141f.swap
  32ms systemd-user-sessions.service                                            
  32ms systemd-update-utmp.service                                              
  19ms systemd-backlight@backlight:radeon_bl0.service                           
  18ms tmp.mount                                                                
  17ms systemd-backlight@backlight:acpi_video0.service                          
  13ms rtkit-daemon.service                                                     
   7ms snapd.socket                                                             
lines 30-52/52 (END)

Souci Thunderbird + Démarrage

#149Messageil y a 1 mois

Pour la partition SWAP je dois faire quelque chose ?

Souci Thunderbird + Démarrage

#150Messageil y a 1 mois

alors pour le swap

fourni

sudo lsblk -fs
sudo cat /etc/fstab

Souci Thunderbird + Démarrage

#151Messageil y a 1 mois

[jen@jen ~]$ sudo lsblk -fs
[sudo] Mot de passe de jen : 
NAME FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda1 ext4   1.0         cc5a4e52-b45a-4d1a-8bc6-d6f52ce2ad05  343,4G    19% /
└─sda
                                                                            
sda2 swap   1           c42854a7-078f-48ed-b457-64f2d06f141f                [SWAP]
└─sda
                                                                            
sr0                                                                         
[jen@jen ~]$ sudo cat /etc/fstab
# <file system> <mount point> <type> <options> <dump> <pass>

UUID=cc5a4e52-b45a-4d1a-8bc6-d6f52ce2ad05	/	ext4	defaults,noatime0	1
UUID=c42854a7-078f-48ed-b457-64f2d06f141f	swap	swap	defaults,noatime0	0
[jen@jen ~]$ 

Souci Thunderbird + Démarrage

#152Messageil y a 1 mois

service a arrêter

sudo systemctl mask lvm2-monitor.service
sudo systemctl mask ModemManager.service    
pour les options de démarrage , fourni
la partie système uniquement

inxi -Fza --no-host
et derniere question utilise tu snap ?

Souci Thunderbird + Démarrage

#153Messageil y a 1 mois

stephane a écrit : il y a 1 mois service a arrêter

sudo systemctl mask lvm2-monitor.service
sudo systemctl mask ModemManager.service    
pour les options de démarrage , fourni
la partie système uniquement

inxi -Fza --no-host
et derniere question utilise tu snap ?
J'ai masqué les deux services que tu m'as indiqués.
Snapchat ? Non non je n'utilise pas çà...

Graphics:
  Device-1: AMD Mullins [Radeon R2 Graphics] vendor: Toshiba driver: radeon 
  v: kernel alternate: amdgpu bus ID: 00:01.0 chip ID: 1002:9853 
  Device-2: IMC Networks TOSHIBA Web Camera - HD type: USB driver: uvcvideo 
  bus ID: 4-1.2:4 chip ID: 13d3:5652 serial: <filter> 
  Display: server: X.Org 1.20.10 driver: ati,radeon 
  unloaded: modesetting,vesa alternate: fbdev display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4") 
  s-diag: 485mm (19.1") 
  Monitor-1: eDP res: 1600x900 hz: 60 dpi: 106 size: 382x215mm (15.0x8.5") 
  diag: 438mm (17.3") 
  OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.4.87-1-MANJARO LLVM 11.0.0) 
  v: 4.5 Mesa 20.3.2 direct render: Yes 
Audio:
  Device-1: AMD Kabini HDMI/DP Audio vendor: Toshiba driver: snd_hda_intel 
  v: kernel bus ID: 00:01.1 chip ID: 1002:9840 
  Device-2: AMD FCH Azalia vendor: Toshiba driver: snd_hda_intel v: kernel 
  bus ID: 00:14.2 chip ID: 1022:780d 
  Sound Server: ALSA v: k5.4.87-1-MANJARO 
Network:
  Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter 
  driver: rtl8723be v: kernel port: e000 bus ID: 01:00.0 chip ID: 10ec:b723 
  IF: wlp1s0 state: down mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Toshiba 
  driver: r8169 v: kernel port: d000 bus ID: 02:00.0 chip ID: 10ec:8136 
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 84.04 GiB (18.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD1 
  size: 465.76 GiB block size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s serial: <filter> rev: 033 
Partition:
  ID-1: / raw size: 458.55 GiB size: 450.35 GiB (98.21%) 
  used: 84.04 GiB (18.7%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 7.21 GiB used: 0 KiB (0.0%) 
  priority: -2 dev: /dev/sda2 maj-min: 8:2 
Sensors:
  System Temperatures: cpu: 37.8 C mobo: N/A gpu: radeon temp: 39.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 155 Uptime: 47m wakeups: 1 Memory: 3.28 GiB 
  used: 1.97 GiB (60.0%) Init: systemd v: 247 Compilers: gcc: N/A Packages: 
  pacman: 1205 lib: 389 flatpak: 0 Shell: Bash v: 5.1.0 
  running in: xfce4-terminal inxi: 3.2.01 
[jen@jen ~]$ 

Souci Thunderbird + Démarrage

#154Messageil y a 1 mois

c'est cette partie que je souhaite avoir

System:
  Host: mjro Kernel: 5.10.5-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=aa940861-9549-4d9c-8a95-6e556d073aa5 ro quiet acpi=debug 
  rcu_nocbs=0_11 systemd.unified_cgroup_hierarchy=true scsi_mod.use_blk_mq=1 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 

Souci Thunderbird + Démarrage

#155Messageil y a 1 mois

Oh pardon !

[jen@jen ~]$ inxi -Fza --no-host
System:
  Kernel: 5.4.87-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=cc5a4e52-b45a-4d1a-8bc6-d6f52ce2ad05 rw quiet apparmor=1 
  security=apparmor resume=UUID=c42854a7-078f-48ed-b457-64f2d06f141f rw 3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 

Souci Thunderbird + Démarrage

#156Messageil y a 1 mois

ok on va arrêter les snap

sudo systemctl stop apparmor.service 
sudo systemctl stop snap.service
sudo systemctl mask apparmor.service 
sudo systemctl mask snap.service
ensuite tu modifie /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT=

sudo nano /etc/default/grub ( Ctrl+X pour sauver )
sudo update-grub

tu supprime
apparmor=1 security=apparmor
udev.log_priority=3

tu ajoute
systemd.unified_cgroup_hierarchy=true

et tu redemarre

Souci Thunderbird + Démarrage

#157Messageil y a 1 mois

[jen@jen ~]$ sudo systemctl mask  apparmor.service
[sudo] Mot de passe de jen : 
Created symlink /etc/systemd/system/apparmor.service → /dev/null.
[jen@jen ~]$ sudo systemctl mask  snap.service
Unit snap.service does not exist, proceeding anyway.
Created symlink /etc/systemd/system/snap.service → /dev/null.
[jen@jen ~]$ 
Cà c'est fait, merci pour snapchat que je n'utiliserai jamais :wink:

edit : j'ai ajouté les commandes "stop" pour les deux (apparmor et snap).

Ouh là attends pour la suite çà se complique...
A la place de sudo nano est-ce que je peux ouvrir le fichier avec mousepad ?
Genre comme çà :




Image

Je supprime apparmor=1 en gardant "quiet.." ?
Et j'ajoute "systemd.unified_cgroup_hierarchy=true" à quel niveau ? Sur la même ligne ou tout à la fin ?

Souci Thunderbird + Démarrage

#158Messageil y a 1 mois

Elle est là la ligne complète :

Image

  GNU nano 5.4                                                      /etc/default/grub                                                                
GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor resume=UUID=c42854a7-078f-48ed-b457-64f2d06f141f udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console
Question formulée autrement, je garde "GRB_CMDLINE_LINUX_DEFAULT=" je garde resume=UUID=********" et je rajoute la dernière partie à la suite ?
Dernière modification par Jen1321il y a 1 mois, modifié au total 1 fois.

Souci Thunderbird + Démarrage

#159Messageil y a 1 mois

tu supprime et tu ajoute a la fin (flèche a droite)
oui tu dois garder RESUME=UUID=...


pense aussi a mettre
GRUB_TIMEOUT_STYLE=menu

Souci Thunderbird + Démarrage

#160Messageil y a 1 mois

GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=c42854a7-078f-48ed-b457-64f2d06f141f systemd.unified_cgroup_hierarchy=true"

Comme çà ? Sans "quiet" après le = ?
Pardon je ne suis vraiment pas douée :oops:
Répondre