Problèmes et questions concernant le noyau et le support matériel.
Répondre

Kernel 5.10 ; 5.9 ; 5.8 ne boot pas

#1Messageil y a 2 mois

Bonjour toutes et tous,
Avant toute chose je vous souhaite une excellente et bonne année a vous:)


J’ai un problème de kernel depuis quelques temps, en fait, depuis la sortie du kernel 5.8. Il m’était impossible de booter dessus (écran noir ; curseur clignotant), depuis à la sortie du kernel 5.9 (même problème) avec une petite différence j’ai eu la surprise de voir deux menu grub (voir les images).
ImageImage

J’ai essayé de trouver d’où venait le problème mais sans plus.. mon système fonctionné très bien avec le kernel 5.7 :) donc je démarré dessus… le véritable problem a commence hier après la mise a jour, le kernel 5.10 a était installé et le kernel 5.7 supprimé ! Donc au démarrage de celui ci écran noir et curseur qui clignote :( la même chose que le linux58/linux59.
ImageImageImage

Je boot actuellement sur le kernel 5.4 que je trouve un peu lent au démarrage ; j’utilise une tour Acer M7811.
Est ce que quelqu’un a une idée

Je veux précisé que j’ai un pc portable asus et lui fonctionne très bien avec tous les kernels.

Kernel 5.10 ; 5.9 ; 5.8 ne boot pas

#2Messageil y a 2 mois

bonjour

soit par TTY , ( Ctrl+Alt+Fn ) , soit avec USB iso manjaro et chroot , peux tu nous fournir

inxi -Fza
sudo mhwd-kernel -li
sudo mhwd -li
sudo ls /etc/mkinitcpio.d/*.preset 
pour la partie boot , ce ne sont pas des lignes en doubles ,
tu as :
- la ligne pour une version noyau
- la ligne pour cette meme version en mode failsafe

Kernel 5.10 ; 5.9 ; 5.8 ne boot pas

#3Messageil y a 2 mois

Bonjour,
Dans l'annonce de la dernière mise à jour, tu as la liste des noyaux supportés :
Noyaux pris en charge :
linux44 4.4.248
linux49 4.9.248
linux414 4.14.212
linux419 4.19.163
linux54 5.4.85
linux59 5.9.16 [EOL] En fin de vie
linux510 5.10.2
linux54-rt 5.4.82_rt45
linux59-rt 5.9.1_rt19
Tu devrais déjà supprimer de tes systèmes ceux qui ne sont plus supportés, voire également les -rt (real time) à moins que tu n'en aies vraiment besoin. N'oublie pas aussi que le 5.9 est en fin de vie ...
Denis

Kernel 5.10 ; 5.9 ; 5.8 ne boot pas

#4Messageil y a 2 mois

bonsoir a vous :bjr:
non j'en ai pas besoin, je vais supprimer le 5.9 toute suite :)
puis je vais en passer en mode tty pour les retours, a toute suite :)

Kernel 5.10 ; 5.9 ; 5.8 ne boot pas

#5Messageil y a 2 mois

euuh.. j'ai lancé la command inxi -Fza , mais comment je peux copie le résulta dans un fichier txt ?? :roll:

Kernel 5.10 ; 5.9 ; 5.8 ne boot pas

#6Messageil y a 2 mois

alors si tu démarre avec un noyau 5.4
que tu ouvre le terminal
et un navigateur sur ce topic
tu peux bien faire un copier / coller non ?

Kernel 5.10 ; 5.9 ; 5.8 ne boot pas

#7Messageil y a 2 mois

avec une konsole oui (moi je suis passé par ctrl alt fn)
retour sur inxi -Fza

inxi -Fza
System:    Kernel: 5.4.85-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/vmlinuz-5.4-x86_64 
           root=UUID=42f70544-0948-4761-bb4b-b884784efefb rw quiet 
           Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 
           dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: Acer product: Aspire M7811 v: N/A serial: <filter> 
           Chassis: type: 3 serial: <filter> 
           Mobo: Acer model: H57M01 serial: <filter> BIOS: American Megatrends 
           v: P01-A1L date: 12/07/2009 
CPU:       Info: Dual Core model: Intel Core i3 530 bits: 64 type: MT MCP arch: Nehalem 
           family: 6 model-id: 25 (37) stepping: 2 microcode: 11 L2 cache: 4 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23418 
           Speed: 1211 MHz min/max: 1200/2933 MHz Core speeds (MHz): 1: 1211 2: 1209 
           3: 1224 4: 1255 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf 
           mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds 
           status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 
           mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
           IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GT215 [GeForce GT 340] vendor: PC Partner Limited / Sapphire 
           driver: nvidia v: 340.108 alternate: nouveau bus ID: 01:00.0 
           chip ID: 10de:0ca4 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: nvidia 
           display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 93 s-size: 524x292mm (20.6x11.5") 
           s-diag: 600mm (23.6") 
           Monitor-1: VGA-0 res: 1920x1080 hz: 60 dpi: 94 size: 521x293mm (20.5x11.5") 
           diag: 598mm (23.5") 
           OpenGL: renderer: GeForce GT 340/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108 
           direct render: Yes 
Audio:     Device-1: Intel 5 Series/3400 Series High Definition Audio 
           vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:3b56 
           Device-2: NVIDIA High Definition Audio vendor: PC Partner Limited / Sapphire 
           driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0be4 
           Sound Server: ALSA v: k5.4.85-1-MANJARO 
Network:   Device-1: Intel 82578DC Gigabit Network vendor: Acer Incorporated ALI 
           driver: e1000e v: 3.2.6-k port: bc00 bus ID: 00:19.0 chip ID: 8086:10f0 
           IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Ralink RT2790 Wireless 802.11n 1T/2R PCIe vendor: Lite-On 
           driver: rt2800pci v: 2.3.0 port: d400 bus ID: 04:00.0 chip ID: 1814:0781 
           IF: wlp4s0 state: down mac: <filter> 
Drives:    Local Storage: total: 3.64 TiB used: 823.96 GiB (22.1%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EADS-22M2B0 
           size: 931.51 GiB block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
           serial: <filter> rev: 0A01 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3000DM001-1ER166 
           size: 2.73 TiB block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s 
           serial: <filter> rev: CC26 
Partition: ID-1: / raw size: 70 GiB size: 68.4 GiB (97.72%) used: 31 GiB (45.3%) 
           fs: ext4 dev: /dev/sda3 maj-min: 8:3 
           ID-2: /boot raw size: 512 MiB size: 487.9 MiB (95.30%) 
           used: 134.5 MiB (27.6%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw size: 852.21 GiB size: 837.83 GiB (98.31%) 
           used: 792.83 GiB (94.6%) fs: ext4 dev: /dev/sda4 maj-min: 8:4 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 
           dev: /dev/sda2 maj-min: 8:2 
Sensors:   System Temperatures: cpu: 39.0 C mobo: N/A gpu: nvidia temp: 45 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 30% 
Info:      Processes: 187 Uptime: 14m wakeups: 0 Memory: 7.71 GiB used: 2 GiB (25.9%) 
           Init: systemd v: 247 Compilers: gcc: 10.2.0 clang: 11.0.0 Packages: 1778 
           pacman: 1770 lib: 484 flatpak: 8 Shell: Bash v: 5.1.0 running in: konsole 
           inxi: 3.2.01
retour sudo mhwd-kernel -li

sudo mhwd-kernel -li
Currently running: 5.4.85-1-MANJARO (linux54)
The following kernels are installed in your system:
   * linux419
   * linux510
   * linux54
retour sur sudo mhwd -li

sudo mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI


Warning: No installed USB configs!
retour sur sudo ls /etc/mkinitcpio.d/*.preset

sudo ls /etc/mkinitcpio.d/*.preset
/etc/mkinitcpio.d/linux419.preset  /etc/mkinitcpio.d/linux54.preset
/etc/mkinitcpio.d/linux510.preset
Voilà :sourire:

Kernel 5.10 ; 5.9 ; 5.8 ne boot pas

#8Messageil y a 2 mois

Kernel 5.10 ; 5.9 ; 5.8 ne boot pas

#9Messageil y a 2 mois

bonsoir a tous
(pardon pour le retard j'ai un petit souci perso)

alors voilà je donne le retour pour les personne qui on une nvidia 340 (geforce gt 340)
la solution fonctionne, le pc démarre sur le kernel 5.10
c'est parfait :bien
par contre si j'essaie de une mise a niveau du pilote, ça passe pas
Image
j'ai cette error
Image
c'est pas jolie jolie :maisnon: par de kwin, les fenetres sont :?
j'ai essayer de trouver une solution ; sinon faut que je change de carte graphique :saispas:

Kernel 5.10 ; 5.9 ; 5.8 ne boot pas

#10Messageil y a 1 mois

bonsoir a tous, j'espère que vous allez bien

Alors alors.. je viens de faire une grosse mise à jour et ça a réglé le problem de kwin :gsourire:
Merci Stephane pour ton lien :):clap

J'espère que ça aidera d'autres personne :bien
Répondre