Problèmes et questions concernant le noyau et le support matériel.
Répondre

Freeze... crash... mes nerfs aussi !

#1Messageil y a 2 ans

Salut,

Voilà que mes problèmes de freeze et crash recommencent ! J'ai quitté en février OpenSUSE (avec ces mêmes soucis), et avec Manjaro j'étais à peu près tranquille et voilà que ça recommence sérieusement depuis fin juin.
Pratiquement tous les jours maintenant une ou deux fois, soit un freeze total (obligé de faire reset) soit un crash et ça redémarre tout seul...
Depuis je n'arrête pas de changer de noyaux, et de jongler aussi entre OpenGL et XRender !
là aujourd'hui suis même passé carrément au 4.19.126 !
Je ne sais plus où donner de la tête, c'est vraiment énervant de voir interrompre ce que l'on fait et de devoir redémarrer.

Avez-vous une idée ? Ya toujours ce souci avec le Ryzen ?
Image

Freeze... crash... mes nerfs aussi !

#2Messageil y a 2 ans

bonjour
reste avec un noyau 419 ou 5.4 ( voir 5.6 si cela fonctionne EndOfLife )
as tu tenté avec les options suivantes , au démarrage du noyau
“iommu=soft and idle=nowait”

Freeze... crash... mes nerfs aussi !

#3Messageil y a 2 ans

J'ai bien sûr essayé auparavant 5.6 et 5.4 et même 5.7...

Non, je ne connais pas “iommu=soft and idle=nowait”, qu'est-ce que c'est ? et comment y accède-t-on ?

Freeze... crash... mes nerfs aussi !

#4Messageil y a 2 ans

Freeze... crash... mes nerfs aussi !

#5Messageil y a 2 ans

Hier j'avais regardé le lien que tu m'avais fourni, et n'ayant pas tout compris, voici juste ce que j'ai fait :

* ajouter "idle=nomwait" dans le fichier /stc/default/grub
* installer zenstates-git mais je n'ai pas compris quoi faire ensuite...
* j'ai cherché dans UEFI l'option Power Supply Idle Control pour régler sur Typical Current Idle mais je ne le trouve pas. De même pour activer iommu, je ne vois pas où ça se trouve...

Il y a 1 heure, nouvelle freeze, à peine 2 jours tranquille avec le 4.19. Suis reparti avec le 5.4...

Freeze... crash... mes nerfs aussi !

#6Messageil y a 2 ans

bonjour

Tu peux aussi avoir des "freeze" parce que ton linux est saturé ... nous n'avons pas d'infos sur ta mémoire, il faut donc aussi contrôler tes ressources machines ram et cpu en cours d'utilisation

Freeze... crash... mes nerfs aussi !

#7Messageil y a 2 ans

c'est des freeze sur les cartes meres et CPU ryzen + le probleme de mauvais drivers pour amdgpu
c'est pas ce qu'il manque en ce moment sur le forum inter.

Freeze... crash... mes nerfs aussi !

#8Messageil y a 2 ans

Bonjour,

Déjà une freeze et un crash pour aujourd'hui ! Vraiment chiant !
Suis repassé avec le kernel 5.7.0-3.

Depuis le temps que ce problème est connu, pourquoi n'est-il pas encore résolu à ce jour ?

Y aurait-il par hasard une distribution Linux qui ne connaîtrait pas ce souci ?

_____________________________________________________________________________________
Je viens de tomber sur cette video qui apparemment résoudrait le problème :

https://www.youtube.com/watch?v=Xy53NpcRiz4

Malheureusement mon anglais n'est pas à la hauteur pour tout comprendre.

Freeze... crash... mes nerfs aussi !

#9Messageil y a 2 ans

bonjour

je conseille de vérifier
1) version firmware Bios a jour

2)les modifications pour le paramètre boot linux est à faire dans le fichier

sudo nano /etc/default/grub 
sudo update-grub
3) demander sur d'autres forums spécialisés ( pour cette gestion ) pour les options Bios
mon avis personnelle et que cette gestion spécifique à Ryzen 3 n'est PAS TOTALEMENT IMPLEMENTE ou GERE au niveau power manager sous linux

4) si tu as une tour , supprime tlp dans ce cas pour verifier

5) attention version MINIMUM pour Ryzen 3 il me semble c'est à partir de 5.4 LTS , pas en dessous
( ancienne version Ryzen 2 et moins avec la 4.19 )

Freeze... crash... mes nerfs aussi !

#10Messageil y a 2 ans

Bonjour,

1) j'avais déjà fait une MAJ du BIOS l'année dernière quand j'étais sous OpenSuse... je ne pense pas qu'il y ait du nouveau de ce côté.

3) je continue à explorer la question sur le net...

4) tlp n'est pas installé sur mon ordi (effectivement une tour)

Merci pour ton aide en attendant...

Freeze... crash... mes nerfs aussi !

#11Messageil y a 2 ans

attendre prochaine version Kernel 5.7.8 minimum
certains remontent moins de soucis
( en cours en Testing )

Freeze... crash... mes nerfs aussi !

#12Messageil y a 2 ans

OK merci...

Hier après-midi j'ai réussi à activer iommu et Typical Current Idle dans le BIOS/UEFI
> Advanced > CPU Configuration > AMD CBS

et laissé le kernel 5.7.0... depuis ça va, pas de souci pour l'instant, je touche du bois. :lol:

Je vous tiens au courant....
Répondre