Problèmes et questions concernant le noyau et le support matériel.

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#1Messageil y a 6 mois

Amis de Manjaro bonjour,

Cela fait longtemps que j'utilise Manjaro et c'est la première fois que j'ai recours au Forum parce que depuis la mise à jour d'aujourd'hui, je suis dans le jus !

Lorsque j'ai voulu imprimer avec ma HP Envy 5030, la tâche est envoyée mais reste "bloquée" en file d'attente. En allant dans la config de l'imprimante, un message genre "PPD corrompu" est apparu (je ne me souviens pas du terme exact). J'ai supprimé l'imprimante pour la réinstaller depuis l'interface web Cups et le message suivant apparait :

Impossible d’ajouter l’imprimante : Unable to copy PPD file.
Est-ce que quelqu'un a le même problème avec une imprimante HP ?

Quelqu'un sait quoi faire ?

D'avance merci de votre aide,

Johnny
Dernière modification par leubajdjl le 06 Sep 2019, 06:33, modifié 1 fois.

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#2Messageil y a 6 mois

Salut,

As-tu installé hplip ?
La version présente dans les dépôts est la dernière version.
Mon imprimante je l'ai installé sans passer par Cups. L'installation c'est faite toute seule, enregistrement dans Cups y compris dès que je l'ai connecté.

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#3Messageil y a 6 mois

Voici le message d'erreur que me donne HPLIP lors de l'installation de l'imprimante :

Printer queue setup failed.
Error : successful-ok-ignored-or-substituted-attributes
Petite précision, j'ai une autre partition sur laquelle j'ai une Manjaro en "Testing". Ce problème d'imprimante était apparu lors de la mise à jour d'il y a 2 semaines... et je n'ai pas réussi à corriger. Je m'étais dit que s'agissant d'une "testing" cela faisait partie des risques et j'avais de toute façon ma "Stable" qui fonctionnait parfaitement pour le travail quotidien.

Une idée sur ce qui se passe ?
Dernière modification par leubajdjl le 06 Sep 2019, 06:33, modifié 1 fois.

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#4Messageil y a 6 mois


Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#5Messageil y a 6 mois

J'ai consulté le lien, essayé de supprimer/réinstaller CUPS et HPLIP... rien n'y fait :(

Une autre idée ?

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#6Messageil y a 6 mois

Es tu connecté en root dans l'interface Cups ? On ne peut le faire si on rentre son username (pourtant proposé par défaut)au lieu de root.

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#7Messageil y a 6 mois

Que j'essaie avec root ou avec mon username dans l'interface web cups... ne change rien.

J'ai essayé de supprimer hplip et de le réinstaller manuellement par le terminal en téléchargeant la dernière version chez HP. L'installation produit plusieurs erreurs que j'ai copié au fur et à mesure (peut-être qu'il y a quelque chose d'utile la-dedans) :

Running 'sudo pacman -S --noconfirm libcups2-dev'
Please wait, this may take several minutes...
error: Package install command failed with error code 1
note: Some packages may not get installed on python3 due to distro incompatibilites

Running 'sudo pacman -S --noconfirm cups-bsd'
Please wait, this may take several minutes...
error: Package install command failed with error code 1
note: Some packages may not get installed on python3 due to distro incompatibilites

Running 'sudo pacman -S --noconfirm cups-client'
Please wait, this may take several minutes...
error: Package install command failed with error code 1
note: Some packages may not get installed on python3 due to distro incompatibilites

Running 'sudo pacman -S --noconfirm python-dbus.mainloop.pyqt5'
Please wait, this may take several minutes...
error: Package install command failed with error code 1
note: Some packages may not get installed on python3 due to distro incompatibilites

warning: An optional dependency 'python3-notify2 (Python libnotify - Python bindings for the libnotify Desktop notifications)' is still missing.
warning: Some features may not function as expected.
D'autres suggestions ?
Dernière modification par leubajdjl le 06 Sep 2019, 06:32, modifié 1 fois.

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#8Messageil y a 6 mois

Apparemment , ce pilote nécessite python3.

sudo pacman -S python3
Merci de mettre les retours de commandes entre balises code [</>]

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#9Messageil y a 6 mois

J'ai installé Python3 et l'installation manuelle de HPLIP ne me fait plus d'erreur si ce n'est ceci à la fin :

Adding print queue to CUPS:
Device URI: hp:/usb/ENVY_5000_series?serial=TH83J5H162
Queue name: ENVY_5000
PPD file: drv:///hp/hpcups.drv/hp-envy_5000_series.ppd
Location: 
Information: 
error: Printer queue setup failed. Error : successful-ok-ignored-or-substituted-attributes 
error: hp-setup failed. Please run hp-setup manually.
Malheureusement, l'installation de l'imprimante via CUPS ou HPLIP donne toujours les mêmes messages d'erreur.

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#10Messageil y a 6 mois

Bonjour,
J'ai vu passer ce message, concernant cups, dans les logs de pacman :
>>please run /usr/bin/cups-genppdupdate
>>and restart cups daemon
Quel retour as-tu sur cette commande :

sudo /usr/bin/cups-genppdupdate
?


Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#12Messageil y a 6 mois

Normal, ta commande n'est pas bonne, copie et colle celle que je t'ai donné (ci-dessus) directement dans le terminal :wink:

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#13Messageil y a 6 mois

Salut a vous,
première pour moi aussi sur le forum.
Sur Manjaro depuis peu, je viens d'Ubuntu depuis la 10.04. Voilà pour les présentations :gsourire:

j'ai également le même problème mais comme j'utilise Timeshift je suis revenu a un instantané avant la mise a jour du 05/09 et j' ai empêcher les mise a jour des trois paquets en cause dans /etc/pacman.conf

IgnorePkg = cups cups-filters libcups

En attendant mieux ... merci si quelqu'un a une autre solution
Daniel

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#14Messageil y a 6 mois

Erwan a écrit :
il y a 6 mois
Normal, ta commande n'est pas bonne, copie et colle celle que je t'ai donné (ci-dessus) directement dans le terminal :wink:
Je fais pourtant exactement (copié/collé) la commande que tu m'as indiqué :

[xxxxx@xxxxx ~]$ sudo /usr/bin/cups-genppdupdate
[sudo] Mot de passe de xxxxx : 
sudo: /usr/bin/cups-genppdupdate : commande introuvable
[xxxxx@xxxxx ~]$ 
Est-tu sûr de cette commande ou ais-je besoin d'installer quelque chose pour qu'elle fonctionne ?

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#15Messageil y a 6 mois

Bonjour, ton retour suggère fortement qu'il n'y a aucun fichier "ppd" dans ton système. :saispas: Réinstaller ton imprimante me semble indispensable.

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#16Messageil y a 6 mois

Réinstaller mon imprimante... c'est ce que j'essaie de faire depuis 2 jours et la raison de mon post. L'installation, que ce soit avec l'interface CUPS ou avec HPLIP me donne des messages d'erreur que je résume ci-dessous :

Dans CUPS :

Impossible d’ajouter l’imprimante : Unable to copy PPD file.
Dans HPLIP :

Printer queue setup failed.
Error : successful-ok-ignored-or-substituted-attributes
Je rappelle que j'ai déjà désinstallé/réinstallé CUPS et HPLIP sans que cela change quoi que ce soit. Comme l'indique "Daniel68", il semble que les paquets "cups cups-filters libcups" ont été mis à jour lors de la "Stable update" et que depuis, certains utilisateurs de Manjaro ne peuvent ni imprimer ni réinstaller leur imprimante.

J'ai une seconde imprimante (Brother DCP-9020CDW) avec semble-t-il le même problème donc cela ne semble pas se limiter à HP.

A contrecoeur, j'ai dû supprimer ma "Manjaro testing" pour installer en urgence une "Ubuntu LTS" pour pouvoir imprimer puisque je ne peux plus le faire avec Manjaro (en attendant une solution pour que ma "Manjaro stable" soit à nouveau capable d'imprimer).

Si quelqu'un à une idée sur le moyen de réinstaller complètement les PPD... je suis preneur.

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#17Messageil y a 6 mois

J'ai exactement le même souci sur un pc avec la même imprimante.
Il semble vraiment y avoir un souci avec cups...

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#18Messageil y a 6 mois

bon j'ai rétrograder les 3 paquets concernés et oh magie , je retrouve mon imprimante.

Pour ceux intéressés, j'ai suivi ces instructions : viewtopic.php?t=4493
et j'ai downgrader les paquets cups, cups-filters et libcups

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#19Messageil y a 6 mois

Merci pour cette info gnulux :bien ,
je viens de tester downgrade ça peut être utile :merci:

Imprimante HP ne fonctionne plus et ne s'installe plus depuis le "Stable Update" du 5 septembre 2019

#20Messageil y a 6 mois

Bon, j'ai réinstallé intégralement ma Manjaro Stable, histoire d'être à 100% sûr que le problème ne venait pas d'une mauvaise manipulation de ma part. Résultat après l'installation fraîche, et la mise à jour des derniers paquets : l'imprimante HP ENVY 5030 s'installe mais n'imprime pas, et lorsque je veux accèder aux paramètres, elle me dit que le PPD est endommagé. Il est à relever que "scanner" fonctionne, c'est seulement l'impression qui ne se lance pas.

En revanche, j'ai installé sans le moindre souci une Brother DCP-9020CDW avec laquelle je peux imprimer. Donc le problème se situe plutôt du côté du driver HP (ou plus précisèment du PPD). J'ai lancé la commande suivante sans résultat :

sudo /usr/bin/cups-genppdupdate
[sudo] Mot de passe de xxxxxxx : 
Did not update any PPD files
Il ne reste plus qu'à espèrer que nos gentils développeurs corrigeront ce bug (très embêtant sur une version "Stable").

Merci à tous ceux qui ont essayé d'aider :)

Répondre