Problèmes et questions concernant le noyau et le support matériel.
Répondre

Second écran non détecté, reste noir (NVIDIA OPTIMUS)

#1Messageil y a 3 semaines

Bonjour,
j'ai acheté un nouveau Portable AMD/NVIDIA (config en signature), mis sous KDE Manjaro.
Je souhaite exploiter au mieux la carte NVIDIA, avec un second écran.
Avec le driver nouveau, les 2 écrans (portable et annexe) sont détectés et utilisables.
Avec le driver Nvidia, seul l'écran du portable est affiché. Le second est détecté, mais même en l'activant, rien ne se passe si ce n'est un flash noir et retour écran normal.
J'ai installé Optimus, vérifié qu'il est bien actif (systemctl status optimus-manager.service), pour être en mode hybrid (ce que je souhaite au final). Le second écran est détecté, mais quand je l'active, mon écran de portable passe en noir, avec seulement le curseur qui s'affiche. Je reviens à la normale en débranchant le second écran.

Malgré de nombreux forums suivis, je n'ai pas trouvé de réponse. Auriez-vous des pistes ?

Second écran non détecté, reste noir (NVIDIA OPTIMUS)

#2Messageil y a 3 semaines

bonjour

tu peux nous fournir

inxi -Fza
sudo mhwd-kernel -li 
sudo mhwd -li 

Second écran non détecté, reste noir (NVIDIA OPTIMUS)

#3Messageil y a 3 semaines

Bonjour Stéphane,

inxi -Fza
me donne

System:    Kernel: 5.11.14-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.11-x86_64 root=UUID=20f122ab-93d9-4369-a7da-7afdb2484426 ro quiet apparmor=1 
           security=apparmor udev.log_priority=3 
           Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux 
           base: Arch Linux 
Machine:   Type: Laptop System: TUXEDO product: TUXEDO Polaris 17 AMD Gen1 v: Standard serial: <filter> 
           Mobo: TUXEDO s model: POLARIS1701A2060 v: Standard serial: <filter> UEFI: American Megatrends v: N.1.16.A01 
           date: 09/02/2020 
Battery:   ID-1: BAT0 charge: 61.7 Wh (99.0%) condition: 62.3/62.3 Wh (100.0%) volts: 16.9 min: 15.2 model: standard 
           type: Li-ion serial: <filter> status: Unknown 
           Device-1: hidpp_battery_0 model: Logitech Wireless Touch Keyboard K400 serial: <filter> 
           charge: 50% (should be ignored) rechargeable: yes status: N/A 
CPU:       Info: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) 
           model-id: 60 (96) stepping: 1 microcode: 8600103 cache: L2: 4 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 92660 
           Speed: 1397 MHz min/max: 1400/2900 MHz boost: enabled Core speeds (MHz): 1: 1397 2: 1397 3: 1268 4: 1467 5: 1456 
           6: 1490 7: 1373 8: 1356 9: 1397 10: 1397 11: 1397 12: 1397 13: 1397 14: 1395 15: 1380 16: 1356 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Tongfang Hongkong Limited driver: nvidia v: 460.67 
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f15 class-ID: 0300 
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir vendor: Tongfang Hongkong Limited driver: amdgpu v: kernel 
           bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300 
           Device-3: Chicony HD Webcam type: USB driver: uvcvideo bus-ID: 3-4:5 chip-ID: 04f2:b641 class-ID: 0e02 
           Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: modesetting,nvidia display-ID: :0 
           screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP-1 res: 1920x1080 hz: 144 dpi: 128 size: 382x215mm (15.0x8.5") diag: 438mm (17.3") 
           OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.11.14-1-MANJARO LLVM 11.1.0) v: 4.6 Mesa 21.0.2 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Tongfang Hongkong Limited driver: snd_hda_intel 
           v: kernel bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403 
           Device-2: C-Media BIRD UM1 type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-3.4:8 chip-ID: 0d8c:0134 
           class-ID: 0300 
           Sound Server-1: ALSA v: k5.11.14-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.25 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Tongfang Hongkong Limited driver: r8168 
           v: 8.048.03-NAPI modules: r8169 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: e000 bus-ID: 03:00.0 chip-ID: 8086:2723 
           class-ID: 0280 
           IF: wlo1 state: up mac: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 5-4:3 chip-ID: 8087:0029 class-ID: e001 
           Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
Drives:    Local Storage: total: 465.76 GiB used: 209.83 GiB (45.1%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 500GB size: 465.76 GiB block-size: 
           physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: 1B2QGXA7 temp: 30.9 C 
           scheme: GPT 
Partition: ID-1: / raw-size: 50.88 GiB size: 49.83 GiB (97.94%) used: 23.17 GiB (46.5%) fs: ext4 dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
           ID-3: /home raw-size: 414.58 GiB size: 407.08 GiB (98.19%) used: 186.67 GiB (45.9%) fs: ext4 dev: /dev/nvme0n1p3 
           maj-min: 259:3 
Swap:      Alert: No swap data was found. 
Sensors:   System Temperatures: cpu: 55.9 C mobo: 0 C gpu: amdgpu temp: 39.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 409 Uptime: 33m wakeups: 4 Memory: 30.85 GiB used: 7.08 GiB (23.0%) Init: systemd v: 247 tool: systemctl 
           Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: 1496 pacman: 1491 lib: 432 flatpak: 0 snap: 5 Shell: Bash v: 5.1.0 
           running-in: konsole inxi: 3.3.04 

sudo mhwd-kernel -li
me donne

Currently running: 5.11.14-1-MANJARO (linux511)
The following kernels are installed in your system:
   * linux511
   * linux59

sudo mhwd -li
me donne

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI
           video-linux            2018.05.04                true            PCI
video-hybrid-amd-nvidia-prime            2020.11.30               false            PCI


Warning: No installed USB configs!

Second écran non détecté, reste noir (NVIDIA OPTIMUS)

#4Messageil y a 3 semaines

Bonjour,
Currently running: 5.11.14-1-MANJARO (linux511)
The following kernels are installed in your system:
* linux511
* linux59
Dans un premier temps je te conseil de retirer le noyau 59 qui si je me souviens bien est en EOL (fin de vie) et d'ajouter le noyau 54 qui est en LTS.
Le noyau 511 est très récent, donc déjà regarde si avec le 54 ça fonctionne.

Second écran non détecté, reste noir (NVIDIA OPTIMUS)

#5Messageil y a 3 semaines

J'ai essayé de booter avec le noyau 5.4, mais l'ordi reste bloqué sur le splashscreen Tuxedo au démarrage.
Je ne sais pas pourquoi cela bloque.

L'install du noyau 5.10 (LTS) fonctionne par contre (je boot correctement).
Mais cela ne change pas le fait que le second écran ne peut être activé :-/

Second écran non détecté, reste noir (NVIDIA OPTIMUS)

#6Messageil y a 3 semaines

bonjour

pour ton architecture il faut que la version noyau soit à partir de la version 5.10 LTS
tu ne peux pas utiliser une version 5.4 LTS

essaye aussi de voir pour si maj UEFI a faire pour le portable.

question à poser a inter pour la gestion de 2 écrans avec cartes hybrides

Second écran non détecté, reste noir (NVIDIA OPTIMUS)

#7Messageil y a 3 semaines

Merci, je vais regarder pour la MAJ UEFI.
question à poser a inter pour la gestion de 2 écrans avec cartes hybrides
Désolé, je ne comprends pas ta phrase ':-)

Second écran non détecté, reste noir (NVIDIA OPTIMUS)

#8Messageil y a 3 semaines

faire la demande sur le forum.manjaro.org en anglais (c'est le forum inter)

Second écran non détecté, reste noir (NVIDIA OPTIMUS)

#9Messageil y a 3 semaines

Bonjour,
avec pas mal d'appréhensions (fruits d'expériences passées ratées sur d'autres pc avec ce satané driver nvidia), je me suis résolu à suivre les instructions trouvées sur un sujet du forum international.
https://archived.forum.manjaro.org/t/ho ... iver/40225
Et bien ça a marché nickel. Je suis en optimus (prime à la demande) et en dual screen !
Merci de votre patience et de vos conseils.

Second écran non détecté, reste noir (NVIDIA OPTIMUS)

#10Messageil y a 2 semaines

Bonjour,
avec pas mal d'appréhensions (fruits d'expériences passées ratées sur d'autres pc avec ce satané driver nvidia), je me suis résolu à suivre les instructions trouvées sur un sujet du forum international.
Https:/www.archived.forum.manjaro.org/t/ho ... iver/40225
Et bien ça a marché nickel. Je suis en optimus (prime à la demande) et en dual screen !
Merci de votre patience et de vos conseils.
Je vous conseil aussi les écrans à 144Hz :clap:clap
Répondre