Postez ici vos trucs & astuces.
Répondre

Ancien pot de yaourt !

#1Messageil y a 4 ans

'LLo,

Si vous cherchez des paquets AUR3, voici la piste avec les PKGBUILD idoines, tout ceci à employer avec beaucoup énormemment de circonspection puisqu'ils ne sont + maintenus, cela va sans dire.. :siffle

Ancien pot de yaourt !

#2Messageil y a 4 ans

'llo Fassil :bjr:
Pour ma part, j'ai téléchargé directement le miroir.

    git clone  git://pkgbuild.com/aur-mirror.git

On en parle ici
Mieux vaut prendre son temps.... :siffle

Ancien pot de yaourt !

#3Messageil y a 4 ans

'LLo,

Ouaip, j'avais pas vu passer ce post, mais vous avez de la place à revendre sur vos DD, dites donc...
J'ai pour ma part trouvé mon paquet dans la liste ci-dessus, copié le texte du PKGBUILD, collé chez moi & roule mon makepkg ! :clindoeil:

Ps: Pour trouver le bon paquet sur la page, ctrl + F dans le panda, c'pas mal !

Ancien pot de yaourt !

#4Messageil y a 4 ans

au passage, si vous utilisez des logiciels qui étaient dans AUR3 et ne sont plus dans AUR4, que vous avez besoin de ces logiciels, et qu'ils sont toujours maintenus upstream, vous pouvez devenir mainteneurs de ces softs; ce n'est pas très dur, d'autant que dans un premier temps il suffira juste de récupérer le PKGBUILD dans AUR3 et de le placer dans AUR4 en changeant juste la version.
il ne faut pas oublier que AUR fonctionne grâce aux contributeurs, et qu'il n'y a pas besoin d'avoir des talents de développeur pour s'occuper d'un paquet AUR.

Ancien pot de yaourt !

#5Messageil y a 4 ans

Loubrix a écrit :au passage, si vous utilisez des logiciels qui étaient dans AUR3 et ne sont plus dans AUR4, que vous avez besoin de ces logiciels, et qu'ils sont toujours maintenus upstream, vous pouvez devenir mainteneurs de ces softs; ce n'est pas très dur, d'autant que dans un premier temps il suffira juste de récupérer le PKGBUILD dans AUR3 et de le placer dans AUR4 en changeant juste la version.
il ne faut pas oublier que AUR fonctionne grâce aux contributeurs, et qu'il n'y a pas besoin d'avoir des talents de développeur pour s'occuper d'un paquet AUR.

Salut

Le cas s'est posé pour mon imprimante Brother ; celui qui le maintenait dans aur3 ne s'en occupe plus, je lui ai demandé la permission (par correction) de m'en occuper dorénavant pour aur4, ce qu'il a accepté.
J'ai donc récupéré les sources, et j'ai appliqué cette procédure que je détaille ici.

Maintenant, je vais voir de temps à autre, si la maison Brother met à jour les pilotes concernant mon imprimante ; ensuite il ne me reste qu'à modifier le PKGBUILD et regarder toujours la même procédure (en bas de celle-ci).

Voili-voilou comment on peut se rendre utile pour la communauté :sourire:

Ancien pot de yaourt !

#6Messageil y a 4 ans

après, il y a des cas où il vaut mieux s'abstenir: j'utilisais ImapQuickCheck comme notifieur de mail, et il n'est pas passé dans AUR4; du coup, je me suis dit que j'allais le prendre, mais en allant voir le site du développeur, je me suis aperçu qu'il n'y avait plus de mises à jour depuis 2010, donc j'ai laché l'affaire et me contente de l'indicateur natif de Xfce.

Répondre