Questions sur l'installation et la configuration de Manjaro Linux.
Répondre

Des misères avec grub et os-prober

#1Messageil y a 1 an

Bonjour,
Je viens d'installer pour la tester, la version d'open-suse tumbleweed sur une partition btrfs de mon ssd.
Pas de blème pendant l'installe, j'ai refusée l'installation du grub sur mon mbr pour que ma manjaro garde la main.
De retour sur cette dernière, un sudo update-grub plus tard, voici ce que me dit la console:

Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
mount: /var/lib/os-prober/mount : échec de l’appel système mount(2) : Aucun fichier ou dossier de ce type.
Manjaro Linux (17.1.10) trouvé sur /dev/sda2
openSUSE Tumbleweed trouvé sur /dev/sda3
Pour être sur, j'ai refait la manip, même chose.
Du coup, après avoir lu quelques fil sur le sujet, j'ai lancé os-prober, voici le résultat:

sudo os-prober
[sudo] Mot de passe de alkiros : 
/dev/sda2:Manjaro Linux (17.1.10):ManjaroLinux:linux
/dev/sda3:openSUSE Tumbleweed:openSUSE:linux:btrfs:UUID=baae1790-160e-4df3-9d54-268d8cc62bfa:subvol=@
mount: /var/lib/os-prober/mount : échec de l’appel système mount(2) : Aucun fichier ou dossier de ce type.
Là, a ce stade, j'ai besoin des spécialistes! :sos:

Des misères avec grub et os-prober

#2Messageil y a 1 an

c'est par hasard une partition en LVM ?
manjaro ne gère pas en standard une partition LVM

Des misères avec grub et os-prober

#3Messageil y a 1 an

bonjour,

tu ne nous donnes pas le résultat du grub. Il trouve bien les 2 linux donc aparemment il n'y a pas d'erreurs.
Je suppose que l'erreur vient du fait qu'il n'arrive pas à monter sda1 ou autre ? pas grave si pas besoin dans ton grub

un petit retour de ta config:

lsblk -o "NAME,LABEL,SIZE,ROTA,FSTYPE,PARTTYPE,MOUNTPOINT" 

Des misères avec grub et os-prober

#4Messageil y a 1 an

Pas de LVM, non!

lsblk -o "NAME,LABEL,SIZE,ROTA,FSTYPE,PARTTYPE,MOUNTPOINT" 
NAME   LABEL        SIZE ROTA FSTYPE PARTTYPE MOUNTPOINT
sda               111,8G    0                 
├─sda1             56,1G    0 ext4   0x83     /
├─sda2             27,5G    0 ext4   0x83     /run/media/alkiros/c4678a12-62fd-4f
└─sda3             28,2G    0 btrfs  0x83     /run/media/alkiros/baae1790-160e-4d
sdb               465,8G    1                 
├─sdb1 Sauvegarde 232,9G    1 ext4   0x83     /run/media/alkiros/Sauvegarde
└─sdb2 Reserve    232,9G    1 ext4   0x83     /run/media/alkiros/Reserve
sdc               931,5G    1                 
└─sdc1 Multimedia 931,5G    1 ext4   0x83     /run/media/alkiros/Multimedia
sdd               465,8G    1                 
├─sdd2 Datas      290,3G    1 ext4   0x83     /run/media/alkiros/Datas
└─sdd3 Transferts 175,5G    1 ext4   0x83     /run/media/alkiros/Transferts
sr0                1024M    1     
Et pour faire bonne mesure, voilà grub au complet:

Création du fichier de configuration GRUB…
Arrière-plan trouvé : /usr/share/grub/background.png
Image Linux trouvée : /boot/vmlinuz-4.17-x86_64
Image mémoire initiale trouvée : /boot/intel-ucode.img /boot/initramfs-4.17-x86_64.img
Found initrd fallback image: /boot/initramfs-4.17-x86_64-fallback.img
Image Linux trouvée : /boot/vmlinuz-4.16-x86_64
Image mémoire initiale trouvée : /boot/intel-ucode.img /boot/initramfs-4.16-x86_64.img
Found initrd fallback image: /boot/initramfs-4.16-x86_64-fallback.img
Image Linux trouvée : /boot/vmlinuz-4.14-x86_64
Image mémoire initiale trouvée : /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
mount: /var/lib/os-prober/mount : échec de l’appel système mount(2) : Aucun fichier ou dossier de ce type.
Manjaro Linux (17.1.10) trouvé sur /dev/sda2
openSUSE Tumbleweed trouvé sur /dev/sda3
J'espère que ça vous dira qq.chose!

Des misères avec grub et os-prober

#5Messageil y a 1 an

grub te trouve bien tes 3 os sur ssd et te les propose au boot
Il n'y a donc pas d'erreur particulière ?

os_prober essaye de monter toutes tes partitions présentes, il te dit juste qu'il ne peut pas pour une
(dans sdb, sdc ou sdd) - pas grave si pas d'os dessus

Des misères avec grub et os-prober

#6Messageil y a 1 an

papajoke a écrit :
il y a 1 an
grub te trouve bien tes 3 os sur ssd et te les propose au boot
Il n'y a donc pas d'erreur particulière ?

os_prober essaye de monter toutes tes partitions présentes, il te dit juste qu'il ne peut pas pour une
(dans sdb, sdc ou sdd) - pas grave si pas d'os dessus
Et bien non, pas d'opensuse dans l'affichage au boot, donc impossible d'en faire le choix!
et la partition qu'os-prober ne parvient pas à monter est justement celle où se trouve la suse, sda3.

Répondre