Questions générales sur Manjaro Linux.
S'il vous plaît, avant de poster, essayez la fonction de recherche du forum.
Répondre

Carte son externe qui "décroche"

#1Messageil y a 3 semaines

Bonjour à toutes et à tous.
Après plusieurs années passées à utiliser Xubuntu, j'essaie Manjaro.
L'installation ne m'a posé aucun problème.
Je rencontre un petit souci au fonctionnement.
J'ai une carte son externe reliée en USB à ma machine.
S'il n'y a aucun son joué pendant un petit temps, la carte "décroche"... Les LEDS de facade sont éteintes, ce qui signifie qu'elle n'est plus alimentée. Or, quand elle s'éteint, cela fait "ploc" dans mes enceintes amplifiées. Ça m'embête un peu.
Il suffit que je mette en lecture quoi que ce soit de sonore pour que la carte soit à nouveau alimentée. (Et re "ploc".)
On dirait que, quand le son n'est pas utilisé, le port USB se met "en veille".
Comment puis-je remédier à cela ?
Merci par avance pour vos réponses.

Carte son externe qui "décroche"

#2Messageil y a 3 semaines

bonsoir

peux tu nous fournir

inxi -Fza 

Carte son externe qui "décroche"

#3Messageil y a 3 semaines

Voilà ce que retourne la commande inxi -Fza :

System:    Kernel: 5.10.26-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=cc37de24-08dc-4853-9888-b2e59ba15b91 rw quiet apparmor=1 
           security=apparmor resume=UUID=f20e7cc0-288a-4d97-8dfd-2ce0e9355781 udev.log_priority=3 
           Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux 
           base: Arch Linux 
Machine:   Type: Desktop System: MSI product: MS-7788 v: 4.0 serial: <filter> 
           Mobo: MSI model: H61M-P32/W8 (MS-7788) v: 4.0 serial: <filter> BIOS: American Megatrends v: 10.7 date: 12/24/2012 
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter> charge: 55% (should be ignored) 
           rechargeable: yes status: Discharging 
CPU:       Info: Dual Core model: Intel Pentium G645 bits: 64 type: MCP arch: Sandy Bridge family: 6 model-id: 2A (42) 
           stepping: 7 microcode: 2F cache: L2: 3 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 11605 
           Speed: 1885 MHz min/max: 1600/2900 MHz Core speeds (MHz): 1: 1885 2: 1621 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Micro-Star MSI driver: i915 
           v: kernel bus-ID: 00:02.0 chip-ID: 8086:0102 class-ID: 0300 
           Display: x11 server: X.Org 1.20.10 driver: loaded: intel unloaded: modesetting alternate: fbdev,vesa 
           display-ID: :0.0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: VGA1 res: 1920x1080 hz: 60 dpi: 102 size: 480x270mm (18.9x10.6") diag: 551mm (21.7") 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 2000 (SNB GT1) v: 3.3 Mesa 21.0.1 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20 class-ID: 0403 
           Device-2: Focusrite-Novation Focusrite Scarlett 2i2 2nd Gen type: USB driver: snd-usb-audio bus-ID: 1-1.1:3 
           chip-ID: 1235:8202 class-ID: 0102 
           Sound Server-1: ALSA v: k5.10.26-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.24 running: no 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 232.89 GiB used: 12.75 GiB (5.5%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/sda maj-min: 8:0 vendor: Maxtor model: STM3250318AS size: 232.89 GiB block-size: physical: 512 B 
           logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC38 scheme: MBR 
Partition: ID-1: / raw-size: 224.08 GiB size: 219.51 GiB (97.96%) used: 12.75 GiB (5.8%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 8.8 GiB used: 1.3 MiB (0.0%) priority: -2 dev: /dev/sda2 maj-min: 8:2 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 178 Uptime: 5h 15m wakeups: 54 Memory: 7.66 GiB used: 2.52 GiB (32.9%) Init: systemd v: 247 
           tool: systemctl Compilers: gcc: 10.2.0 Packages: 1131 pacman: 1125 lib: 327 flatpak: 6 Shell: Bash v: 5.1.0 
           running-in: xfce4-terminal inxi: 3.3.03

Carte son externe qui "décroche"

#4Messageil y a 3 semaines

effectue d'abord une vérification avec pavucontrol pour les réglages

Carte son externe qui "décroche"

#5Messageil y a 3 semaines

stephane a écrit : il y a 3 semaines effectue d'abord une vérification avec pavucontrol pour les réglages
Merci mais... J'ai déjà fait et tout me semble correct.

Carte son externe qui "décroche"

#6Messageil y a 3 semaines

Bonjour.
Essaye de brancher la clé sur un Hub-USB. J'ai parfois des soucis avec un Contrôleur DJ qui n'est fonctionnel qui si je le branche via un lecteur de cartes externe.
A essayer aussi de mettre un kernel plus ancien comme le 4.19 pour voir.
Sinon, il faudra peut-être créer une règle Udev spécifique a ta clé.
Un truc que tu peux faire est de lancer journalctl -afk puis de brancher/débrancher ta carte et de noter l'activité du kernel.

Edit:Je viens de voir la bête sur LinuxMao. Apparemment elle fonctionne nativement mais il faut passer par Jack comme serveur son.
Autre point qui m'interpelle, n'aurais tu pas la ligne phantom active sur un câble asymétrique ? Ça génère des retours de jus dans le point froid et la carte se met en protection. Il faut impérativement un câble symétrique XLR 3 points+ blindage.

Carte son externe qui "décroche"

#7Messageil y a 3 semaines

yaumegui a écrit : il y a 3 semaines Merci mais... J'ai déjà fait et tout me semble correct.
Assure toi que ta carte son est bien la carte par défaut et/ou que la carte interne est configurée sur "éteint", ça peut éviter des soucis de priorités dans pulseaudio.
lemust83 a écrit : il y a 3 semaines Autre point qui m'interpelle, n'aurais tu pas la ligne phantom active sur un câble asymétrique ? Ça génère des retours de jus dans le point froid et la carte se met en protection. Il faut impérativement un câble symétrique XLR 3 points+ blindage.
À priori il n'utilise pas les connections XLR, plutôt une config classique, PC/Sortie USB -->Scarlett/Sorties Jack-->enceintes.
Répondre