Actualités & Annonces de l'équipe de développement et des administrateurs du forum.

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#1Messageil y a 8 mois

Bonjour à toutes et à tous :bjr:

Une mise à jour est annoncée.

Avec cette mise à jour , nous avons maintenant les derniers Deepin, KDE Framework, des bibliothèques Haskell et Python, ainsi que la plupart de nos Kernels.

Attention, la dernière version de pacman-mirrorlist corrige un problème important de pacman-mirrors. Donc pour une fois ne faites pas un pacman-mirrors avant cette mise à jour mais après.
Uniquement si vous êtes déjà impacté par ce bug (pas de synchronisation des miroirs, Impossible de joindre le serveur), il va falloir insérer manuellement une ligne au tout début du fichier/etc/pacman.d/mirrorlist avec cette commande :

sudo sed -i '1iServer = http://mirror.netzspielplatz.de/manjaro/packages/stable/$repo/$arch' /etc/pacman.d/mirrorlist


manjaro-system s'occupe automatiquement du passage délicat de ca-certificates-utils

Attention les noyaux 3.18 et 4.8 sont en fin de vie, pensez à les remplacer.


Le détail est disponible ici.

-------------------------------------------------------------------------------------
Mise à jour possible par pamac, octopi ou par pacman (de préférence) :

sudo pacman -Syu && yaourt -Syua
-------------------------------------------------------------------------------------

Noyaux pris en charge :
  • linux310 3.10.105
  • linux312 3.12.70
  • linux316 3.16.41
  • linux318 3.18.48 [EOL] En fin de vie
  • linux41 4.1.39
  • linux44 4.4.54
  • linux48 4.8.17 [EOL] En fin de vie
  • linux49 4.9.15
  • linux410 4.10.3
  • linux-RT-LTS 4.4.50_rt62
  • linux-RT 4.9.13_rt11


Les changements en détail :
  • stable community i686: 365 nouveaux et 351 paquets retirés
  • stable community x86_64: 368 nouveaux et 353 paquets retirés
  • stable core i686: 21 nouveaux et 21 paquets retirés
  • stable core x86_64: 21 nouveaux et 21 paquets retirés
  • stable extra i686: 265 nouveaux et 257 paquets retirés
  • stable extra x86_64: 265 nouveaux et 257 paquets retirés
  • stable multilib x86_64: 20 nouveaux et 14 paquets retirés

pour architecture x86_64, 5 paquets supprimés :

modemmanager-pk-rules  networkmanager-elogind  nototools  smlnj  zopfli

pour architecture x86_64, 17 nouveaux paquets :

dbus-elogind:  Freedesktop.org message bus system
deepin-clutter:  A toolkit for creating fast, portable, compelling dynamic UIs for Deepin
deepin-voice-recorder:  Deepin Voice Recorder
fasm:  Fast and efficient self-assembling x86 assembler for DOS, Windows and Linux operating systems
haskell-cryptonite-conduit:  Conduit bridge for cryptonite
haskell-microlens-th:  Automatic generation of record lenses for microlens
knetattach:  Wizard which makes it easier to integrate network resources with the Plasma Desktop
libelogind:  elogind client libraries
perl-test-requiresinternet:  Easily test network connectivity
python2-pyaes:  Pure-Python Implementation of the AES block-cipher and common modes of operation
python2-unicorn:  Lightweight, multi-platform, multi-architecture CPU emulator framework based on QEMU
python-pyaes:  Pure-Python Implementation of the AES block-cipher and common modes of operation
python-unicorn:  Lightweight, multi-platform, multi-architecture CPU emulator framework based on QEMU
ruby-unicorn:  Lightweight, multi-platform, multi-architecture CPU emulator framework based on QEMU
sddm-elogind:  QML based X11 display manager
spacefm:  Multi-panel tabbed file manager
unicorn:  Lightweight, multi-platform, multi-architecture CPU emulator framework based on QEMU
les elogind sont des paquets spécifiques pour openrc


-------------------------------------------------------------------------------------


-------------------------------------------------------------------------------------
ERREUR : conflit de fichiers
Si lors de la mise à jour vous avez le type d'erreur comme ci-dessous (tlp est un exemple) :

erreur : la validation de la transaction a échoué (conflit de fichiers)
tlp : /etc/acpi/events/thinkpad-radiosw est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.

il convient de passer la commande suivante en l'adaptant à votre cas particulier :

sudo pacman -S --force tlp

Ensuite, vous pouvez faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
ERREUR de clés
Si lors de la mise à jour vous avez des problèmes de clés, essayez de passer les commandes suivantes :

sudo pacman-mirrors -g
sudo pacman -Syy
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys

Ensuite, vous devriez pouvoir faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#2Messageil y a 8 mois

60 MAJ sur XFCE RAS !

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#3Messageil y a 8 mois

Bonjour,

Ca marche pô ! ca-certificates-utils-20170307-1 KO :saispas:
Je réessaierai plus tard ...

Denis

Synchronisation des bases de données des paquets...
Actualisation de core...
Actualisation de extra...
Actualisation de community...
Actualisation de multilib...

Début de la mise à jour complète du système...
Préparation...
Résolution des dépendances...
Recherche des conflits entre paquets...
Téléchargement...
Téléchargement de manjaro-system-20170319-1-any.pkg.tar.xz...
Vérification du trousseau...
Vérification de l'intégrité des paquets...
Chargement des fichiers des paquets...
Analyse des conflits entre fichiers...
Mise à jour de manjaro-system (20170305-1 -> 20170319-1)...
==> Fix ca-certificates-utils upgrade ...
résolution des dépendances...

Paquets (1) ca-certificates-utils-20170307-1

Taille totale du téléchargement :  0,01 MiB

:: Procéder au téléchargement ? [O/n]
:: Récupération des paquets...
téléchargement de ca-certificates-utils-20170307-1-any.pkg.tar.xz...
vérification de l’intégrité des paquets...
analyse de l’intégrité des paquets...
résolution des dépendances...
recherche des conflits entre paquets...

Paquets (1) ca-certificates-utils-20170307-1

Taille totale installée :     0,01 MiB
Taille de mise à jour nette :  0,00 MiB

:: Procéder à l’installation ? [O/n]
vérification de l’intégrité des paquets...
analyse de l’intégrité des paquets...
chargement des fichiers des paquets...
recherche des conflits entre fichiers...
:: Traitement des changements du paquet...
mise à jour de ca-certificates-utils...
:: Exécution des crochets de post-transaction...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Rebuilding certificate stores...
Transaction terminée avec succès.


Début de la mise à jour complète du système...
Résolution des dépendances...
Recherche des conflits entre paquets...
[b]Erreur: l’ouverture du fichier /var/lib/pacman/local/ca-certificates-utils-20160507-1/files a échoué : Aucun fichier ou dossier de ce type
Avertissement: les métadonnées pour le paquet ca-certificates-utils-20160507-1 n’ont pas pu être totalement chargées.[/b]

La préparation de la transaction a échoué:
paquet invalide ou corrompu

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#4Messageil y a 8 mois

liberodark a écrit :60 MAJ sur XFCE RAS !


Idem pour moi :gsourire:

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#5Messageil y a 8 mois

Denis-pom a écrit :Bonjour,

Ca marche pô ! ca-certificates-utils-20170307-1 KO :saispas:
Je réessaierai plus tard ...

Denis


Bon, j'ai viré les 3 paquets ca-certif... de la mise à jour et elle s'est faite sans problème.

- Toujours le même problème ensuite sur ce paquet si je relance la mise à jour
- Reboot : OK.
- il ne reste plus que 2 paquets ca-certif... au lieu de 3 dans la mise à jour ???
- mise à jour OK avec ces 2 paquets : le système est à jour :sourire:

Je n'ai pas compris pourquoi ce paquet cassé a disparu :saispas: mais comme c'est tout bon :sourire:

Bonne journée,
Denis

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#6Messageil y a 8 mois

Sur XFCE je n'ai eu qu'une mise à jour concernant les miroirs mais j'ai une petite question...
Au moment de l'écriture des miroirs la chose s'est arrêtée sur Bulgaria : http:// sans rien d'autre après, est-ce que c'est normal ?
J'ai peur de fermer pamac alors que çà n'a pas l'air "terminé" :oops:
Au dessus la fenêtre dit que mon système est à jour...

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#7Messageil y a 8 mois

:bjr: merci bien pour l'annonce. Pas de problème pour ce qui me concerne, le script manjaro à fonctionné, ca-certificates-utils est à jour ;)

Au moment de l'écriture des miroirs la chose s'est arrêtée sur Bulgaria : http:// sans rien d'autre après, est-ce que c'est normal ?
J'ai peur de fermer pamac alors que çà n'a pas l'air "terminé"
Logiquement si l'icone de mise à jour de pamac a disparue du panel, cela signifie que la mise à jour s'est exécutée correctement, tu peux donc fermer cette fenêtre ;)

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#8Messageil y a 8 mois

Erwan a écrit :
Au moment de l'écriture des miroirs la chose s'est arrêtée sur Bulgaria : http:// sans rien d'autre après, est-ce que c'est normal ?
J'ai peur de fermer pamac alors que çà n'a pas l'air "terminé"
Logiquement si l'icone de mise à jour de pamac a disparue du panel, cela signifie que la mise à jour s'est exécutée correctement, tu peux donc fermer cette fenêtre ;)


Ah super merci beaucoup Erwan ! Oui tout semble nickel :)

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#9Messageil y a 8 mois

Bonjour,

J'ai fait comme d'habitude :
sudo pacman-mirrors -g -c France,United_Kingdom,Germany,Netherlands,Italy && sudo pacman -Syu
j'ai eu seulement un message d'erreur:
Erreur: Impossible de joindre le serveur: [Errno 101] Network is unreachable
j'ai bien vu :
==> Fix ca-certificates-utils upgrade ...
puis mes 56 paquets se sont bien mis à jour.
Ensuite, j'ai refait un la même commande pour être sur, et j'ai eu un timeout sur les trois premiers serveurs lors de la récupération de core.files.
Je ne le fais pas dans les meilleures conditions je dois dire, la majeure partie de ma bande passante est occupée par bittorrent.

À l'instant, si je reprends sudo pacman-mirrors -g -c France,United_Kingdom,Germany,Netherlands,Italy, j'ai deux serveurs en vrac :

Erreur: Impossible de joindre le serveur: timed out
et
Erreur: Impossible de joindre le serveur: [Errno -2] Name or service not known

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#10Messageil y a 8 mois

Smurf a écrit :Bonjour,
J'ai fait comme d'habitude :
sudo pacman-mirrors -g -c France,United_Kingdom,Germany,Netherlands,Italy && sudo pacman -Syu

Hello Smurf, tu n'as pas lu attentivement l'annonce de papajoke (en gras) :gsourire:
essaye ceci sudo pacman-mirrors -i -m random;)

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#11Messageil y a 8 mois

Au moment de mes mises à jour, il y avait peu de serveurs à jour sur :
http://repo.manjaro.org/
De plus, je ne trouve pas les infos de synchronisation avec pacman-mirrors -i fiables par rapport à l'adresse ci dessus.
Enfin, je ne me suis pas retrouvé sans serveurs à jour, donc rien d'important en ce qui me concerne. :sourire:

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#12Messageil y a 8 mois

Uniquement si vous êtes déjà impacté par ce bug (pas de synchronisation des miroirs, Impossible de joindre le serveur), il va falloir insérer manuellement une ligne au tout début du fichier/etc/pacman.d/mirrorlist avec cette commande :

sudo sed -i '1iServer = http://mirror.netzspielplatz.de/manjaro/packages/stable/$repo/$arch' /etc/pacman.d/mirrorlist


ps: pacman-mirrors random n'était pas une bonne idée car certains serveurs ne sont pas à jour et peuvent être lents

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#13Messageil y a 8 mois

128 paquets (KDE) mis à jour sans pb !
Par contre j'ai remarqué, mais ça n'a pas posé de pb à ce jour, qu'à chaque mise à jour j'ai :
Erreur: Impossible de joindre le serveur: [Errno 101] Network is unreachable

Pour ca-certificates-utils, j'ai un avertissement à la fin :
mise à jour de ca-certificates-utils...
:: Exécution des crochets de post-transaction...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Rebuilding certificate stores...
avertissement : fichier de verrou manquant /var/lib/pacman/db.lck

Est-ce que cela peut poser un problème ?

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#14Messageil y a 8 mois

Mise à jour OK pour moi :bien

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#15Messageil y a 8 mois

michel ruiz a écrit :Pour ca-certificates-utils, j'ai un avertissement à la fin :

avertissement : fichier de verrou manquant /var/lib/pacman/db.lck

Avertissement tout a fait normal ! manjaro-system a supprimé le fichier ne pas s’inquiéter.

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#16Messageil y a 8 mois

Mises à jour faites sans souci tant sur le fixe que sur le portable. Le fixe a d"ailleurs fait le voyage Plasma -> Cinnamon sans problème non plus (à ma grande surprise :gsourire: ) avant la mise à jour.

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#17Messageil y a 8 mois

No problemo. Ça devient lassant à force ces mises à jour qui se passent immanquablement bien !

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#18Messageil y a 8 mois

@ Papajoke
:merci:

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#19Messageil y a 8 mois

Bonsoir à tous et toutes,
MAJ faite sans problèmes (125 paquets), tout est ok.
Bonne soirée à tous et toutes.

[STABLE]17.00 Gellivara - Mise à jour 20.03.2017

#20Messageil y a 8 mois

Bonsoir à tous,

Depuis cette mise à jour, je ne peux plus brancher de clé USB : rien n'est reconnu... :saispas: Une idée pour corriger ce bug ? :idee:

Même Gparted ne détecte plus la clé USB...

Merci par avance !

Répondre