Comment bien utiliser le forum - Règles générales s'appliquant au site.

Pilote pour ethernet dans Manjaro

#1Messageil y a 9 mois

Bonjour,
Je ne suis pas du tout calé en informatique, merci de votre indulgence. Je me sers d'un laptop Dell inspiron avec Manjaro 5.10 et, apparemment depuis la dernière mise à jour du noyau, je ne peux plus me connecter en filaire ethernet. Or, j'aimerais éviter de laisser la Wifi allumée toute la journée. J'ai vu qu'il y avait un problème avec les drivers Realtek RTL8168 et 8169. J'ai réinstallé le 8168 et le 8169 est blacklisté, mais ça ne marche toujours pas. Quelqu'un aurait-il une idée ? Merci beaucoup d'avance.

Pilote pour ethernet dans Manjaro

#2Messageil y a 9 mois

bonjour et bienvenue

As-tu essayé avec un autre noyau ? toujours bon à faire

merci de nous retourner ta config:

inxi --admin --verbosity=7 --filter --no-host --width
copie texte de ta sortie ;)

Pilote pour ethernet dans Manjaro

#3Messageil y a 9 mois

Merci de me répondre. Je n'ose pas car il est indiqué que c'est le seul qui soit stable (LTS et recommandé) parmi les derniers noyaux.

Pilote pour ethernet dans Manjaro

#4Messageil y a 9 mois

La réponse dans la console est très longue :
USB:
Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0
speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
Device-1: 1-1:2 info: Areson Corp 2.4G Receiver type: Keyboard,Mouse
driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s
power: 100mA chip-ID: 25a7:fa23 class-ID: 0301
Device-2: 1-5:3 info: Shenzhen Goodix FingerPrint type: <vendor specific>
driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
chip-ID: 27c6:538d class-ID: ff00
Device-3: 1-6:4 info: Realtek Integrated_Webcam_HD type: Video
driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
chip-ID: 0bda:5520 class-ID: 0e02 serial: <filter>
Device-4: 1-10:5 info: Qualcomm Atheros type: Bluetooth driver: btusb
interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 0cf3:e009
class-ID: e001
Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 speed: 10 Gb/s
chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
System Temperatures: cpu: 66.0 C mobo: N/A
Fan Speeds (RPM): cpu: 0
Info:
Processes: 187 Uptime: 7m wakeups: 1 Init: systemd v: 248 tool: systemctl
Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1562 lib: 450
flatpak: 0 Shell: Bash v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.06
[nicrom@nicolas-inspiron5593 ~]$ ^C
[nicrom@nicolas-inspiron5593 ~]$ ^C
[nicrom@nicolas-inspiron5593 ~]$

Pilote pour ethernet dans Manjaro

#5Messageil y a 9 mois

Tu as un soucis réseau et tu nous affiches la partie usb ??? :tetu!
fais un
inxi --admin --verbosity=7 --filter --no-host --width >> help.txt
ensuite partage le fichier via un lien ce sera plus simple. :mrgreen:
allez courage!

Pilote pour ethernet dans Manjaro

#6Messageil y a 9 mois

Je suis désolé, je sais que c'est pénible de tout expliquer aux débutants, mais comme je disais je ne suis pas calé en informatique... La première fois j'ai copié-collé la ligne que vous m'avez envoyé et cette fois je ne comprends pas comment je peux le faire via un lien. Voilà ce que ça donne sur la console :

Unmounted:
Message: No unmounted partitions found.
USB:
Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0
speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
Device-1: 1-1:2 info: Areson Corp 2.4G Receiver type: Keyboard,Mouse
driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s
power: 100mA chip-ID: 25a7:fa23 class-ID: 0301
Device-2: 1-5:3 info: Shenzhen Goodix FingerPrint type: <vendor specific>
driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
chip-ID: 27c6:538d class-ID: ff00
Device-3: 1-6:4 info: Realtek Integrated_Webcam_HD type: Video
driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
chip-ID: 0bda:5520 class-ID: 0e02 serial: <filter>
Device-4: 1-10:5 info: Qualcomm Atheros type: Bluetooth driver: btusb
interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 0cf3:e009
class-ID: e001
Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 speed: 10 Gb/s
chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
System Temperatures: cpu: 55.0 C mobo: N/A
Fan Speeds (RPM): cpu: 0
Info:
Processes: 187 Uptime: 3h 2m wakeups: 1 Init: systemd v: 248 tool: systemctl
Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1562 lib: 450
flatpak: 0 Shell: Bash v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.06
[nicrom@nicolas-inspiron5593 ~]$

Pilote pour ethernet dans Manjaro

#7Messageil y a 9 mois

La commande : inxi --admin --verbosity=7 --filter --no-host --width >> help.txt va créer dans ton /home un fichier help.txt ou le nom que tu lui auras donné.
Il suffit de copier l’intégralité de ce fichier que tu auras ouvert avec un éditeur de texte quelconque et que tu colleras ici entre balise </>.

Pilote pour ethernet dans Manjaro

#8Messageil y a 9 mois

System:
  Kernel: 5.10.53-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=0bd97366-6009-43a6-912f-dbf0a24915f3 rw quiet apparmor=1 
  security=apparmor resume=UUID=3b62a64d-bad2-4fc1-bfa5-853da59798dd 
  udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel, plank 
  wm: xfwm 4.16.1 vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux 
  base: Arch Linux 
Machine:
  Type: Laptop System: Dell product: Inspiron 5593 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0RFXWC v: A00 serial: <filter> UEFI: Dell v: 1.9.1 
  date: 06/11/2020 
Battery:
  ID-1: BAT0 charge: 2.3 Wh (6.6%) condition: 34.9/42.0 Wh (83.2%) volts: 10.5 
  min: 11.4 model: BYD DELL 1VX1H07 type: Li-poly serial: <filter> 
  status: Discharging 
Memory:
  RAM: total: 7.43 GiB used: 3.02 GiB (40.6%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Info: Dual Core model: Intel Core i3-1005G1 bits: 64 type: MT MCP 
  arch: Ice Lake family: 6 model-id: 7E (126) stepping: 5 microcode: A6 cache: 
  L2: 4 MiB bogomips: 9524 
  Speed: 997 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 997 2: 1068 
  3: 1026 4: 1041 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2 avx512_vnni 
  avx512_vpopcntdq avx512bw avx512cd avx512dq avx512f avx512ifma avx512vbmi 
  avx512vl bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp 
  hwp_act_window hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida 
  intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor 
  movbe msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm 
  pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed rdtscp 
  rep_good sdbg sep sha_ni smap smep split_lock_detect ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi vpclmulqdq vpid 
  x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:8a56 class-ID: 0300 
  Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus-ID: 1-6:4 chip-ID: 0bda:5520 class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.11 compositor: xfwm4 v: 4.16.1 driver: 
  loaded: intel unloaded: fbdev,modesetting,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 21.1.5 
  direct render: Yes 
Audio:
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Dell 
  driver: snd_hda_intel v: kernel alternate: snd_sof_pci bus-ID: 00:1f.3 
  chip-ID: 8086:34c8 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.53-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.32 running: no 
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
  driver: N/A modules: r8169 port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8136 
  class-ID: 0200 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Dell driver: ath10k_pci v: kernel port: 3000 bus-ID: 02:00.0 
  chip-ID: 168c:0042 class-ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
Bluetooth:
  Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-10:5 
  chip-ID: 0cf3:e009 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
Logical:
  Message: No logical block device data found. 
RAID:
  Message: No RAID data found. 
Drives:
  Local Storage: total: 238.47 GiB used: 116.38 GiB (48.8%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba 
  model: KBG40ZNS256G NVMe KIOXIA 256GB size: 238.47 GiB block-size: 
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD 
  serial: <filter> rev: 10410104 temp: 19.9 C scheme: GPT 
  Message: No optical or floppy data found. 
Partition:
  ID-1: / raw-size: 229.37 GiB size: 224.77 GiB (97.99%) 
  used: 116.38 GiB (51.8%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: 0bd97366-6009-43a6-912f-dbf0a24915f3 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A 
  uuid: 2F35-438F 
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A 
  uuid: 3b62a64d-bad2-4fc1-bfa5-853da59798dd 
Unmounted:
  Message: No unmounted partitions found. 
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-1:2 info: Areson Corp 2.4G Receiver type: Keyboard,Mouse 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s 
  power: 100mA chip-ID: 25a7:fa23 class-ID: 0301 
  Device-2: 1-5:3 info: Shenzhen Goodix FingerPrint type: <vendor specific> 
  driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 27c6:538d class-ID: ff00 
  Device-3: 1-6:4 info: Realtek Integrated_Webcam_HD type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 0bda:5520 class-ID: 0e02 serial: <filter> 
  Device-4: 1-10:5 info: Qualcomm Atheros type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 0cf3:e009 
  class-ID: e001 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
Sensors:
  System Temperatures: cpu: 50.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 194 Uptime: 17h 12m wakeups: 4 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1562 
  lib: 450 flatpak: 0 Shell: Bash v: 5.1.8 running-in: xfce4-terminal 
  inxi: 3.3.06  

Fait pour toi :siffle
administration/modération

Pilote pour ethernet dans Manjaro

#9Messageil y a 9 mois

Nicrom a écrit : il y a 9 mois J'ai réinstallé le 8168 et le 8169 est blacklisté, mais ça ne marche toujours pas.
Nicrom a écrit : il y a 9 mois

Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
  driver: N/A modules: r8169 port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8136 
Tu utilises donc encore le 8169:confus:

Nicrom a écrit : il y a 9 mois je n'ose pas car il est indiqué que c'est le seul qui soit stable (LTS et recommandé) parmi les derniers noyaux.
pas compris ... LTS ne veut pas dire "stable" - seul le 5.10 fonctionne bien pour toi ?
Il n'y a aucun risque à ajouter(pas remplacer :wink: ) un autre noyau (c'est même fortement recommandé)

Pilote pour ethernet dans Manjaro

#10Messageil y a 9 mois

D'accord je vais essayer, lequel me conseilles-tu ?

Pilote pour ethernet dans Manjaro

#11Messageil y a 9 mois

Bon, alors j'ai installé un deuxième noyau le 414 et navigué dans les forums pour comprendre comment réactiver ethernet dans mon ordi. Il semble qu'il faudrait blacklister r8169 puisque apparemment il ne l'est pas, mais je ne sais pas comment on fait.

Pilote pour ethernet dans Manjaro

#12Messageil y a 9 mois

Bonjour.
Il faut créer un fichier /etc/modprobe.d/r8169_blacklist.conf avec nano par exemple dans lequel tu mets : blacklist r8169.
Ensuite il faut faire sudo mkinitcpio -P et reboot.

et tu as la commande inxi vue plus haut pour vérifier

Pilote pour ethernet dans Manjaro

#14Messageil y a 9 mois

Bonjour et merci à vous de vos conseils. J'ai fait ce que vous disiez et rien de nouveau ne s'est produit concernant ethernet. Puis j'ai fait une recherche dans la console avec nano et il ne trouve pas r8169. À vrai dire tout ça me dépasse.

Pilote pour ethernet dans Manjaro

#15Messageil y a 9 mois

Pourtant avec la commande inxi, il y a ça :

Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
driver: N/A modules: r8169 port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8136
class-ID: 0200
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Dell driver: ath10k_pci v: kernel port: 3000 bus-ID: 02:00.0
chip-ID: 168c:0042 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
IP v4: <filter> type: dynamic noprefixroute scope: global
broadcast: <filter>
IP v6: <filter> type: dynamic noprefixroute scope: global
IP v6: <filter> type: noprefixroute scope: link
WAN IP: <filter>

Pilote pour ethernet dans Manjaro

#16Messageil y a 9 mois

Sory mais, ne serait-ce pas plutôt le 8139 et non le 8169?

Pilote pour ethernet dans Manjaro

#17Messageil y a 9 mois

Je crois bien que c'est le 8169 qui doit être remplacé par le 8168, d'ailleurs c'est 8169 qui est marqué ci-dessus. Je vérifie.

Pilote pour ethernet dans Manjaro

#18Messageil y a 9 mois

Apparemment c'est bien ça, le problème d'utilisation du r8168 en blacklistant r8169 est discuté sur tous les forums que j'ai trouvés.

Pilote pour ethernet dans Manjaro

#19Messageil y a 9 mois

Device-1: Realtek RTL 810xE PCI Express Fast Ethernet vendor: Dell
c'est pourtant 8139!

Pilote pour ethernet dans Manjaro

#20Messageil y a 9 mois

Salut,
Nicrom a écrit : il y a 9 mois Je crois bien que c'est le 8169 qui doit être remplacé par le 8168, d'ailleurs c'est 8169 qui est marqué ci-dessus. Je vérifie.
tuxdata a écrit : il y a 9 mois Device-1: Realtek RTL 810xE PCI Express Fast Ethernet vendor: Dell
c'est pourtant 8139!
D'après la base de données officielle des pilotes Linux, c'est le r8169 qui est utilisé :
https://linux-hardware.org/index.php?id ... -17aa-3975

Sinon, il existe un pilote spécifique proposé par Realtek, c'est le r8101, qui permettait de corriger des problèmes de vitesse rencontrés avec le r8169. Il n'a pas été mis à jour depuis plus d'un an, mais ça ne coûte rien d'essayer si le r8169 n'est pas performant.
https://github.com/ghostrider-reborn/re ... nux-driver

On peut l'installer avec le paquet AUR r8101-dkms, dans ce cas, il faut blacklister le r8169.
Répondre