Actualités & Annonces de l'équipe de développement et des administrateurs du forum.

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#1Messageil y a 1 mois

Bonjour à toutes et à tous :bjr:

Une mise à jour est annoncée

Nous avons mis à jour tous nos noyaux
Note : les noyaux EOL linux518 et linux518-rt ont été retirés des dépôts.
  • Systemd est maintenant à 251.5
  • Firefox est maintenant à 105.0.2
  • Thunderbird a été renouvelé à 102.3.1
  • 0 AD introduit The Han via Alpha 26
  • Gnome a livré les paquets 42.5 .
  • Pamac a été préparé pour la sortie de GNOME 43.
  • Qemu 7 a reçu sa première version ponctuelle : 7.1.0
    Le support des microprogrammes est également disponible
  • Wine est maintenant à 7.18
  • Sortie de KDE Gear 22.08.1
  • KDE Frameworks 5.98.0 a beaucoup amélioré les logiciels KDE.
  • LibreOffice est maintenant en 7.3.6 et 7.4.1
  • Cinnemon et Deepin ont été corrigés et améliorés.
  • Qt a été mis à jour : 5.15.6 et 6.3.2
  • Pipewire est maintenant en 0.3.58 qui corrige une régression qui pouvait causer des craquements audio.
  • dkms 3.0.6-2 apporte un correctif pour fgrep déprécié.
  • Les pilotes Nvidia ont été renouvelés à 515.76
  • Deepin a reçu quelques mises à jour
  • Mises à jour régulières de Haskell et Python
  • Python2 a finalement été retiré des dépôts.
N'hésitez pas à nous donner vos commentaires sur les modifications apportées aux dépôts.

-------------------------------------------------------------------------------------
Mise à jour possible par pamac, octopi ou par pacman (de préférence) :

sudo pacman -Syu
ou encore

sudo pamac update
-------------------------------------------------------------------------------------


Noyaux pris en charge :
  • linux419 4.19.260
  • linux54 5.4.215
  • linux510 5.10.146
  • linux515 5.15.71
  • linux519 5.19.13
  • linux60 6.0.0rc7 expérimental
  • linux515-rt 5.15.71_rt51
  • linux519-rt 5.19.0_rt10
Les changements en détail :
  • community x86_64: 2289 nouveaux et 2205 paquets retirés
  • core x86_64: 74 nouveaux et 74 paquets retirés
  • extra x86_64: 1247 nouveaux et 1295 paquets retirés
  • kde-unstable x86_64: 419 nouveaux et 420 paquets retirés
  • multilib x86_64: 47 nouveaux et 47 paquets retirés
Une liste détaillée des changements est disponible ici

46 paquets supprimés :

calamares-git ceph ceph-libs ceph-mgr certbot-dns-cloudxns haskell-descriptive haskell-hjsonpointer ipw2100-fw ipw2200-fw kaidan keysmith libguess libvterm01 linux518-rt linux518-rt-acpi_call linux518-rt-broadcom-wl linux518-rt-headers linux518-rt-nvidia linux518-rt-nvidia-390xx linux518-rt-nvidia-470xx linux518-rt-r8168 linux518-rt-tp_smapi linux518-rt-vhba-module linux518-rt-virtualbox-host-modules mailman manjaro-documentation-en manjaro-documentation-fr manjaro-firmware mhwd-db obkey-gtk3 python-dateparser python-pygeoip python-raven python-svg.path python-trimesh python2 python2-dnspython python2-docs python2-idna python2-pycryptodome python2-setuptools python2-typing qxmpp rust-racer thunar-shares-plugin-gtk3 thunar-shares-plugin-manjaro
Détails des 148 nouveaux paquets :

adw-gtk3                     The theme from libadwaita ported to GTK-3 https://www.gnome-look.org/p/1779168
at-spi2-core-docs            Protocol definitions and daemon for D-Bus at-spi (documentation) https://gitlab.gnome.org/GNOME/at-spi2-core
budgie-control-center        Budgie s main interface to configure various aspects of the system https://github.com/BuddiesOfBudgie/budgie-control-center
cargo-binstall               Binary installation for Rust projects https://github.com/cargo-bins/cargo-binstall
cartridge-cli                Tarantool Cartridge command-line utility https://tarantool.io/
cloudflared                  Command-line client for Cloudflare Tunnel https://github.com/cloudflare/cloudflared
deepin-grand-search          System-wide desktop search for DDE https://github.com/linuxdeepin/dde-grand-search
dexed                        A software synth closely modelled on the Yamaha DX7 https://asb2m10.github.io/dexed
directx-shader-compiler      A compiler for HLSL to DXIL (DirectX Intermediate Language). https://github.com/microsoft/
faustpp                      A post-processor for faust, which allows to generate with more flexibility https://github.com/jpcima/faustpp
furnace                      A multi-system chiptune tracker compatible with DefleMask modules https://github.com/tildearrow/furnace
go-licenses                  Reports on the licenses used by a Go package and its dependencies https://github.com/google/go-licenses
go-swagger                   Swagger 2.0 implementation in Go https://goswagger.io
goattracker                  Cross-platform C64 music tracker https://sourceforge.net/projects/goattracker2
gradience                    Change the look of Adwaita, with ease https://gradienceteam.github.io
haskell-***
klystrack-plus               A tracker for making C64/NES/Amiga-style chiptunes on a modern platform https://github.com/LTVA1/klystrack
ladybird                     Web browser built from scratch using the SerenityOS LibWeb engine https://github.com/SerenityOS/ladybird
lf                           A terminal file manager inspired by ranger https://github.com/gokcehan/lf
libgpiod                     C library and tools for interacting with the linux GPIO character device https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git
libjaylink                   Library for accessing SEGGER J-Link and compatible devices https://gitlab.zapb.de/libjaylink/libjaylink
libsonic                     Simple library to speed up or slow down speech https://github.com/waywardgeek/sonic
libsoup3-docs                HTTP client/server library for GNOME (documentation) https://wiki.gnome.org/Projects/libsoup
linux519-rt-r8168            A kernel module for Realtek 8168 network cards http://www.realtek.com.tw
linux519-rt-rtl8723bu        A kernel module for Realtek 8723bu network cards http://www.realtek.com.tw
linux60-rtl8723bu            A kernel module for Realtek 8723bu network cards http://www.realtek.com.tw
lv2-docs                     Plugin standard for audio systems - documentation https://lv2plug.in/
lv2-example-plugins          Plugin standard for audio systems - example plugins https://lv2plug.in/
master_me                    Automatic mastering plugin for live streaming, podcasts and internet radio https://github.com/trummerschlunk/master_me
master_me-jack               Automatic mastering plugin for live streaming, podcasts and internet radio - standalone https://github.com/trummerschlunk/master_me
master_me-lv2                Automatic mastering plugin for live streaming, podcasts and internet radio - LV2 plugin https://github.com/trummerschlunk/master_me
master_me-vst                Automatic mastering plugin for live streaming, podcasts and internet radio - VST plugin https://github.com/trummerschlunk/master_me
master_me-vst3               Automatic mastering plugin for live streaming, podcasts and internet radio - VST3 plugin https://github.com/trummerschlunk/master_me
mod-lv2-extensions           Custom LV2 Extensions used by MOD Devices https://github.com/moddevices/mod-lv2-extensions
monitor                      Network forensics and sniffer tool https://github.com/jo-lund/monitor
munge                        An authentication service for creating and validating credentials. It is designed to be highly scalable for use in an HPC cluster environment. https://github.com/dun/munge/wiki
ob-xd                        Virtual analog synthesizer based on the Oberheim OB-X, OB-Xa and OB-8 synths https://github.com/reales/OB-Xd
odin2-synthesizer            24 voice polyphonic synthesizer with modulation and FX https://www.thewavewarden.com/odin2
opl-synth                    FM synthesizer that emulates the Yamaha OPL sound chip https://discodsp.com/opl/
pdfjs-legacy                 PDF reader in javascript - legacy distribution https://mozilla.github.io/pdf.js/
perl-***
plasma-settings              Settings application for Plasma Mobile https://plasma-mobile.org/
pyflow                       An installation and dependency system for Python https://github.com/David-OConnor/pyflow
python-***
qemu-system-alpha-firmware   Firmware for QEMU system emulator for Alpha https://www.qemu.org/
qemu-system-arm-firmware     Firmware for QEMU system emulator for ARM https://www.qemu.org/
qemu-system-hppa-firmware    Firmware for QEMU system emulator for HPPA https://www.qemu.org/
qemu-system-loongarch64      QEMU system emulator for LoongArch64 https://www.qemu.org/
qemu-system-microblaze-firmware Firmware for QEMU system emulator for Microblaze https://www.qemu.org/
qemu-system-ppc-firmware     Firmware for QEMU system emulator for PPC https://www.qemu.org/
qemu-system-riscv-firmware   Firmware for QEMU system emulator for RISC-V https://www.qemu.org/
qemu-system-sparc-firmware   Firmware for QEMU system emulator for SPARC https://www.qemu.org/
qemu-system-x86-firmware     Firmware for QEMU system emulator for x86 https://www.qemu.org/
qemu-user-binfmt             Binary format rules for QEMU user mode emulation https://www.qemu.org/
qemu-user-static             QEMU static user mode emulation https://www.qemu.org/
qemu-user-static-binfmt      Binary format rules for QEMU static user mode emulation https://www.qemu.org/
qperf                        OpenFabrics Alliance InfiniBand performance benchmark for bandwidth and latency (supports TCP/IP and RDMA) https://github.com/linux-rdma/qperf
qsopt-ex                     Exact linear programming solver https://github.com/jonls/qsopt-ex
qt6-httpserver               Qt HTTP Server https://www.qt.io
qt6-multimedia-ffmpeg        FFMpeg backend for qt6-multimedia https://www.qt.io
qt6-multimedia-gstreamer     Gstreamer backend for qt6-multimedia https://www.qt.io
qt6-quick3dphysics           Physics engine integration for Qt Quick 3D https://www.qt.io
qt6-speech                   Qt Speech support https://www.qt.io
rdma-core                    RDMA core userspace libraries and daemons https://github.com/linux-rdma/rdma-core
riff                         automatically provide external dependencies for Rust projects https://github.com/DeterminateSystems/riff
ruby-gdk4                    Ruby/GDK4 is a Ruby binding of GDK-4.x. http://ruby-gnome2.sourceforge.jp/
ruby-gtk4                    Ruby/GTK4 is a Ruby binding of GTK+-4.x. https://ruby-gnome2.osdn.jp/
ruby-vte3                    a Ruby binding of VTE. https://ruby-gnome2.osdn.jp/
schismtracker                An old-school sample-based music composition tool https://schismtracker.org
sequoia-wot                  An implementation of OpenPGP s web of trust https://gitlab.com/sequoia-pgp/sequoia-wot
serenity-wallpapers          SerenityOS wallpapers https://github.com/SerenityOS/ladybird
slimbook-qc71-dkms           Slimbook service implementation and adaptation of pobrn/qc71_laptop https://github.com/slimbook/slimbook-qc71-dkms
slimbook-rgb-keyboard        Utility to manage color and brightness of slimbook RGB keyboard https://gitlab.manjaro.org/hardware-projects/slimbook/packages/slimbook-rgb-keyboard
slimbook_service             Service for Slimbook laptops https://github.com/slimbook/slimbook_service
slurm-llnl                   Simple Linux Utility for Resource Management https://www.schedmd.com
surge-xt                     Subtractive hybrid synthesizer https://surge-synthesizer.github.io
taffybar                     A desktop bar similar to xmobar, but with more GUI http://github.com/taffybar/taffybar
ttf-nerd-fonts-symbols-common High number of extra glyphs from popular 'iconic fonts' https://github.com/ryanoasis/nerd-fonts
uasm                         A MASM-compatible assembler http://www.terraspace.co.uk/uasm.html
webkit2gtk-4.1-docs          Web content engine for GTK (documentation) https://webkitgtk.org
webkit2gtk-5.0-docs          Web content engine for GTK (documentation) https://webkitgtk.org
webkit2gtk-docs              Web content engine for GTK (documentation) https://webkitgtk.org
wpewebkit-docs               Embeddable web content engine (documentation) https://wpewebkit.org
xorg-xkbprint                Generates a PostScript description of an XKB keyboard description https://gitlab.freedesktop.org/xorg/app/xkbprint
yank                         Copy terminal output to clipboard https://github.com/mptre/yank
-------------------------------------------------------------------------------------


-------------------------------------------------------------------------------------
ERREUR : conflit de fichiers
Si lors de la mise à jour vous avez le type d'erreur comme ci-dessous (tlp est un exemple) :

erreur : la validation de la transaction a échoué (conflit de fichiers)
tlp : /etc/acpi/thinkpad est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.
il convient de passer la commande suivante en l'adaptant à votre cas particulier :

sudo pacman -S nom_paquet --overwrite '/etc/acpi/thinkpad'
Ensuite, vous pouvez faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
Problèmes liés à la synchronisation des miroirs

pacman-mirrors || sudo pacman-mirrors --continent; sudo pacman -Syu
Cette commande pacman-mirrorsva analyser le status des miroirs; si OK=> Synchronisation et Mise à jour.
Si KO, pacman-mirrors --continent synchronisera les miroirs les plus proches de votre situation géographique.
Attention si vous utilisez un vpn, dans ce cas, l'option -f0 sera plus appropriée. Ensuite la Mise à jour se lancera normalement.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
ERREUR de clés

Si lors de la mise à jour vous avez des problèmes de clés, essayez de passer les commandes suivantes :

sudo pacman -Syy
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
Ensuite, vous devriez pouvoir faire votre mise à jour générale sans problème.

-------------------------------------------------------------------------------------
Dernière modification par stephaneil y a 1 mois, modifié au total 1 fois.

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#2Messageil y a 1 mois

(260/260) checking for file conflicts                                                         [######################################################] 100%
error: failed to commit transaction (conflicting files)
glibc: /usr/share/i18n/SUPPORTED exists in filesystem (owned by locale-info)
Errors occurred, no packages were upgraded.
Il y avait un confit pour moi avec locale-info
C'est un ancien paquet manjaro plus présent dans nos dépôts : par conséquent plus utile (je l'ai donc supprimé)

-----------------
A noter que ceux qui ont ceph-libs, il vient d'être supprimé des dépôts, il peut être supprimé

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#3Messageil y a 1 mois

:salut:
La Communauté

KDE Plasma

386 Paquets et une petite demi heure plus tard que du bonheur ...
:sourire::sourire:

:pompom::clap:pompom::clap

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#4Messageil y a 1 mois

RAS (adios python 2) à part 2 petites choses:
- des sons système différents (à l'effacement d'un fichier par exemple)
- un pointeur de souris qui se comporte un peu différemment (je suis sous Oxygen Black): il change de forme sans raison apparente...

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#5Messageil y a 1 mois

Bonjour,

Il y a longtemps suite à une longue hospitalisation :salut:

J'essaie de faire ma mise à jour avec yay étant donné que j'ai des paquets AUR à mettre à jour, mais j'ai un problème de dépendances :

:: Synchronisation des bases de données de paquets…
 core est à jour
 extra est à jour
 community est à jour
 multilib est à jour
:: Début de la mise à jour complète du système…
:: Remplacer at-spi2-atk par extra/at-spi2-core ? [O/n] 
:: Remplacer atk par extra/at-spi2-core ? [O/n] 
résolution des dépendances…
recherche des conflits entre paquets…
erreur : un conflit de paquets impossible à résoudre a été détecté
erreur : la préparation de la transaction a échoué (conflit de dépendances )
:: manjaro-pulse et pipewire-jack sont en conflit
 -> error installing repo packages
Une idée de comment m'y prendre, car trop de logiciels installés dépendent de manjaro-pulse et de pipewire-jack

Merci

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#6Messageil y a 1 mois

Résolu grâce à l'inter, Manjaro-pulse n'avait aucune dépendance avec des paquets installés.

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#7Messageil y a 1 mois

Salut maj sans souci :clap

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#9Messageil y a 1 mois

Bonjour à tous,
MAJ OK sur mes machines, mise à part pour Dropbox qui a encore du Python2. J'ai eu un souci de clef mais pas le temps de m'y attarder. je verrai dans quelques jours et sinon je m'y pencherai plus.

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#10Messageil y a 1 mois

maj ras kde :bien:bien

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#11Messageil y a 1 mois

:bjr: tout le monde

451 paquets (1.7 Go) pour Kde et redémarrage sans problème.
:merci: et :bien à toutes les équipes.

Michel

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#12Messageil y a 1 mois

Bonjour,

Je n'ai pas réussi à faire la mise à jour. Le message est le suivant :

erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: l’installation de nvidia-utils (515.76-1) casse la dépendance « nvidia-utils=515.65.01 » requise par linux518-rt-nvidia

Merci pour votre aide.
Cordialement

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#13Messageil y a 1 mois

@framar77
peux tu nous fournir la liste des noyaux installés

sudo mhwd-kernel -li

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#14Messageil y a 1 mois

Tous les logiciels qui requièrent qt5-base (VLC, Flacon, KeePassXC…) ne se lançaient pas avec le message :

Cannot mix incompatible Qt library (5.15.5) with this library (5.15.6)
Abandon (core dumped)
RÉSOLU en réinstallant qt5-styleplugins : yay -S qt5-styleplugins

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#15Messageil y a 1 mois

Bonjour,

Maj de 633 paquets par pacman (580 selon pamac :roll: ).
Aucun soucis avec vlc au redemarrage, rien de notable à signaler.

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#16Messageil y a 1 mois

@Stéphane

Currently running: 5.19.7-1-MANJARO (linux519)
The following kernels are installed in your system:
* linux515
* linux518
* linux519
* linux518-rt
* linux519-rt

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#17Messageil y a 1 mois

alors , on a bien dit en annonce que les noyaux 5.18 etaient EOL ...
donc

sudo mhwd-kernel -r linux518
sudo mhwd-kernel -r linux518-rt
puis tu pourra faire la mise a jour
la version 6.0 ne devrait pas tarder

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#18Messageil y a 1 mois

@Stéphane : effectivement c'était bien noté ... merci.

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#19Messageil y a 1 mois

Sous Mate aucun souci sur deux unités : pc et Mac

[Stable] Mise à jour 05/10/2022 - Kernels, Systemd, AMDVLK, Deepin

#20Messageil y a 1 mois

549 paquets et 18,Go plus tard, KDE ok :)
merci pour cette mise à jour

ps : effectivement, le vpn cette fois a posé problème (pas constaté auparavant)
Répondre