Questions générales sur Manjaro Linux.
S'il vous plaît, avant de poster, essayez la fonction de recherche du forum.
Répondre

Mise a jour qui ne passe pas

#1Messageil y a 2 mois

Bonjour à tous, j'ai bien conscience que ce problème est un problème de débutant mais je n'arrive pas a m'en défaire, ou plutôt, j'aimerais avoir un avis avant d'effectuer l'opération que j'envisage.

petites précisions pour commencer :
pour faire mes mise a jour, je passe que par la ligne de commande (c'est pas vraiment une préférence personnel, juste que dans mes différentes lectures, les gens semblaient dire qu'on avait moins de problème en faisant cela qu'en interface graphique, et comme j'aime ne pas avoir de problème... :wink: )
et j'utilise la commande ''sudo pacman -Syyu ( De ce que j'ai pu lire, cette commande revient en arrière si elle trouve un problème et cela évite d'avoir une mise à jour partiel, ce qui semble contre-indiqué, là encore, point d'avis personnel, je ne fais qu'appliquer ce que j'ai pu lire sa et là).

Malheureusement ces derniers temps je n'arrive pas a mettre a jour car il trouve un conflit de fichier. du coup, la mise a jour a faire passé est de plus en plus grosse et cela me plait pas trop. le problème semble tous con :

Image

Visiblement c'est le thème d'icone pairus black qui déconne, sauf que PK??? je ne l'utilise pas donc je vois pas trop comment et pourquoi il déconne et surtout pourquoi il me bloque la mise a jour? cela me parait un peu bizarre.

Ainsi j'envisage tout simplement de supprimer le dossier Papirus-Dark. pensez vous que cela va régler mon problème? es ce qu'avec la mise a jour il va se réinstallé?

Mise a jour qui ne passe pas

#2Messageil y a 2 mois

Bonjour.
C'est un problème récurent qui peut survenir quand il y a des programmes installés hors dépôts.
Il suffit en général de forcer la réécriture des fichiers déjà présents:

sudo pacman -Syu --overwrite '/usr/share/icons/Papirus-Dark/*'
La double utilisation du paramètre y est en fait recommandée lorsqu'on a besoin de forcer la réinitialisation de la liste des paquets, ce qui devrait être une exception...

Mise a jour qui ne passe pas

#3Messageil y a 2 mois

Merci pour ton aide,
Je n'aurais jamais pensé un thème d'icone comme un "programme". ceci dit ta ligne de commande ne fonctionne pas ''erreur : option non valide << --overwrite>>.

Mise a jour qui ne passe pas

#4Messageil y a 2 mois

:salut:
VertOurs a écrit : il y a 2 mois la mise a jour a faire passé est de plus en plus grosse et cela me plait pas trop.
clair :mrgreen: c'est une fuite en avant ! entasser les mise à jour entraîne généralement des catastrophes
sauf que PK??? pourquoi il déconne et surtout pourquoi il me bloque la mise a jour? cela me parait un peu bizarre.
l'erreur est portant parlante:
conflit de fichiers : "/usr/share/truc..." est déjà présent dans le système de fichiers
pacman (et frères) se bloque dès qu'il doit "écraser" un fichier qui n'a pas été installé par pacman. Cela est une sécurité ; et oui pacman ne veut rien casser, il préfère attendre notre intervention.
Cela arrive à 99% lorsque nous avons installé des fichiers manuellement(sans pacman) dans notre système - si nous voulons absolument installer un truc, seul notre home est une bonne solution (car pacman n'écrit jamais dans notre home)
Je n'aurais jamais pensé un thème d'icone comme un "programme".
pacman ne connait que des fichiers ;) application ou autres, cela reste des fichiers
ceci dit ta ligne de commande ne fonctionne pas ''erreur : option non valide << --overwrite>>.
La commande donnée est valide (depuis 2..3 ans) :?

Si tu as un problème, il faut nous recopier ici la commande et son résultat - et au format texte (copier/coller) et non une copie écran comme au premier message

Mise a jour qui ne passe pas

#5Messageil y a 2 mois

Et bien les amis merci :bien ça marche. comme je ne consulte pas ce forum sur le même ordi que ma Manjaro, j'ai fait une bête faute de frappe, ce qui explique pk pacman j'aimais pas mon overwrite.

Grace à vous je viens de découvrir qu'installer des thèmes à la mano, comme sur ma zorin n'était pas une super idée(même si d'un autre coté je n'ai pas de thème dans les catégories du logiciel graphique ?).

Et surtout finalement il est préférable d'utiliser Syu a Syyu.
Répondre