Actualités & Annonces de l'équipe de développement et des administrateurs du forum.

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#1Messageil y a 2 ans

Bonjour à toutes et à tous :bjr:

Une mise à jour est annoncée.

Avec cette mise à jour , nous avons maintenant la dernière version 5.1.14 de Virtualbox , le dernier noyau 4.10, ainsi que les bureaux Lumina et Budgie. Nous amis codeurs peuvent trouver maintenant dans nos dépôts le dernier Ruby, comme le dernier php. Sont également inclus le framework KDE5.30 et la majorité des paquets Deepin 15.4rc. Chromium passe en version 56, Pulseaudio passe en 10.0

Concernant la précédente mise à jour stable, Hugo, Frede et Ramon ont récemment travaillé sur un grand nombre d'améliorations de pacman-miroirs, principalement sur l'interface graphique qui peut être appelée avec l'option -i . Une nouvelle option --verbose a été ajoutée (mais la prochaine version 3.1 remplacera --verbose par --quiet) et, quelques problèmes finalement résolus.

gstreamer v0.10 et quelques paquets attachés (gstreamer0.10-***) ont été retirés de nos dépôts. S'il vous plaît vérifier vos systèmes, ces paquets ont été transférés dans AUR. Nous avons quelques paquets à supprimer après cette mise à jour (-Rsn).

Linux48 a été étiqueté de fin de vie et sera supprimé dans un avenir proche.

Les correctifs Archlinux en amont sont maintenant du 27 Janvier.

-------------------------------------------------------------------------------------
Mise à jour possible par pamac, octopi ou par pacman (de préférence) :

sudo pacman-mirrors -g && sudo pacman -Syu && yaourt -Syua
-------------------------------------------------------------------------------------

Noyaux pris en charge :
  • linux310 3.10.104
  • linux312 3.12.69
  • linux316 3.16.39
  • linux318 3.18.47
  • linux41 4.1.38
  • linux44 4.4.45
  • linux48 4.8.17 [EOL] En fin de vie
  • linux49 4.9.6
  • linux410 4.10-rc5
  • linux-RT-LTS 4.4.39_rt50
  • linux-RT 4.9.4_rt2


Les changements en détail :
  • stable community i686: 750 nouveaux et 755 paquets retirés
  • stable community x86_64: 776 nouveaux et 781 paquets retirés
  • stable core i686: 36 nouveaux et 37 paquets retirés
  • stable core x86_64: 36 nouveaux et 37 paquets retirés
  • stable extra i686: 452 nouveaux et 504 paquets retirés
  • stable extra x86_64: 452 nouveaux et 504 paquets retirés
  • stable multilib x86_64: 22 nouveaux et 29 paquets retirés
La liste complète des modifications peut être trouvée ici .

-------------------------------------------------------------------------------------


-------------------------------------------------------------------------------------
ERREUR : conflit de fichiers
Si lors de la mise à jour vous avez le type d'erreur comme ci-dessous (tlp est un exemple) :

erreur : la validation de la transaction a échoué (conflit de fichiers)
tlp : /etc/acpi/events/thinkpad-radiosw est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.

il convient de passer la commande suivante en l'adaptant à votre cas particulier :

sudo pacman -S --force tlp

Ensuite, vous pouvez faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
ERREUR de clés
Si lors de la mise à jour vous avez des problèmes de clés, essayez de passer les commandes suivantes :

sudo pacman-mirrors -g
sudo pacman -Syy
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys

Ensuite, vous devriez pouvoir faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#2Messageil y a 2 ans

Suite à la mise à jour, écran noir au redémarrage, est-dû à la mise à jour de Budgie?

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#3Messageil y a 2 ans

130 paquets avec cinnamon et 230 sous kde ; rien ne change :siffle

@ace66130
je te conseille de démarrer uniquement en console puis de tester. Mais puisque tu dis que tu as un problème des le début, je suppose que le problème est avant Budgie (vidéo/kernel ou gestionnaire de connexion)
A tester aussi avec un autre noyau

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#4Messageil y a 2 ans

:salut:
166 paquets sous kde ça roule :bien

Je suis en train de d'installer le noyau 4.9, je vais voir si ça redémarre :siffle

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#5Messageil y a 2 ans

patri-arch a écrit :Je suis en train de d'installer le noyau 4.9, je vais voir si ça redémarre :siffle


C'est OK pour moi avec le dernier noyau
:clap et merci les dev :bien

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#6Messageil y a 2 ans

patri-arch a écrit :C'est OK pour moi avec le dernier noyau
le dernier c'est maintenant le 4.10 :gsourire: mais encore en rc ! donc prudence. Sortie prévue fin Février.

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#7Messageil y a 2 ans

RAS :bien

Très long à compiler les gtstreamer.

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#8Messageil y a 2 ans

justement maintenant qu'ils sont dans aur (les gstreamer0.10), ils sont remplacés et la pas de compilation (depot extra)

yaourt -Q | grep gst 
extra/gst-libav 1.10.2-1
extra/gst-plugins-bad 1.10.2-2
extra/gst-plugins-base 1.10.2-1
extra/gst-plugins-base-libs 1.10.2-1
extra/gst-plugins-good 1.10.2-1
extra/gst-plugins-ugly 1.10.2-1
extra/gstreamer 1.10.2-1

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#9Messageil y a 2 ans

Salut Papajoke,

Et donc, après la mise à jour on peux supprimer tous les gstreamer0.10 sans remord ?

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#10Messageil y a 2 ans

effectivement eux et quelques autres paquets qui viennent de aur (chez moi libgnome-media-profiles, wxgtk2.8, wxpython2.8 ...), normalement tu ne risques que de casser un paquet aur au maximum.
Si un paquet n'est plus dans les dépots officiels, c'est que automatiquement aucun paquet officiel ne l'utilise :clindoeil:

Si tu utilises des logiciels aur, c'est une autre histoire, il faut attendre que le mainteneur mettre à jour(ou non) sont paquet.

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#11Messageil y a 2 ans

Oui, j'utilise quelques paquets AUR, mais ceux la je compte bien les garder :P
Par contre la désinstallation de gstreamer ce mord un peu la queue.

[redhead@manjaro ~]$ yaourt -Rsn gstreamer0.10
[sudo] Mot de passe de redhead : 
vérification des dépendances...
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: gstreamer0.10-base : supprimer gstreamer0.10 casse la dépendance « gstreamer0.10>=0.10.36 »
[redhead@manjaro ~]$ yaourt -Rsn gstreamer0.10-base
vérification des dépendances...
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: gstreamer0.10-bad : supprimer gstreamer0.10-base casse la dépendance « gstreamer0.10-base>=0.10.34 »
:: gstreamer0.10-base-plugins : supprimer gstreamer0.10-base casse la dépendance « gstreamer0.10-base=0.10.36 »
:: gstreamer0.10-ffmpeg : supprimer gstreamer0.10-base casse la dépendance « gstreamer0.10-base »
:: gstreamer0.10-good : supprimer gstreamer0.10-base casse la dépendance « gstreamer0.10-base>=0.10.34 »
:: gstreamer0.10-ugly : supprimer gstreamer0.10-base casse la dépendance « gstreamer0.10-base>=0.10.34 »
:: wxgtk2.8 : supprimer gstreamer0.10-base casse la dépendance « gstreamer0.10-base »


Mais bon, je verrais ça demain. La, je fatigue. Bonsoir. :dormir:

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#12Messageil y a 2 ans

:bjr: Un peu déçu par cette mise à jour :pleure: J'avais espéré qu'un manjaro-script ferait le travail de désinstallation des vieux paquets gstreamer, xfce4-mixer, gnome-vfs... D'autre part, welcome-manjaro, ainsi que sa dépendance webkitgtk2, bien qu'obsolète n'est pas supprimé pour être remplacé par manjaro-hello et cela malgré ce message récurent en console :

> WARNING: WebKitGTK+ 2.4 is known to have many security vulnerabilities that
             will NOT be fixed. Avoid browsing with it.
On peut d'ailleurs trouver ce wekitgtk2 dans les paquets inutiles, qui peuvent donc être désinstallés (yaourt -Qdt) mais, une fois l'opération validée il est toujours installé, va comprendre... Il faut donc virer manjaro-welcome pour aboutir, je trouve que ça fait beaucoup de ménage à faire, à la main, pour un débutant, là franchement on se croirait sur une mise à jour classique d'Archlinux :siffle Bon, je tempère un peu car les devs font un excellent boulot et merci à eux, mais là c'est pas très user-friendly comme diraient les anglishes :gsourire:

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#13Messageil y a 2 ans

@redhead
pour trouver tous les paquets qui utilisent un autre paquet:

pacman -Qi gstreamer0.10 | grep "^Requi" | awk -F':' '{print $2}'
ou copier le résultat de pacman -Qi, la ligne "requis par:"
reste a tous les supprimer en une seule passe (et personne ne se mort la queue)

sinon il suffit de supprimer le(s) programme(s) aur qui demande gstreamer0.10 (mais il faut le connaitre...)

@Erwan
pour se passer de webkitgtk et qtwebkit, le travail est en cours de supression totale dans les dépôts officiels d'archlinux

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#14Messageil y a 2 ans


[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#15Messageil y a 2 ans

Bonjour

Mise à jour du portable sur KDE sans souci. 232 paquet plus 6 sur AUR. Juste surpris par le temps des mise a jour AUR (2h30). Tout c'est bien passer.

A bientôt pour la prochaine .

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#16Messageil y a 2 ans

@Papajoke

Exact, j'aurais du y penser. Merci à toi :)

[redhead@manjaro ~]$ yaourt -Rsn gstreamer0.10 gstreamer0.10-bad gstreamer0.10-bad-plugins gstreamer0.10-base gstreamer0.10-base-plugins gstreamer0.10-ffmpeg gstreamer0.10-good gstreamer0.10-good-plugins gstreamer0.10-ugly gstreamer0.10-ugly-plugins
vérification des dépendances...
:: ffmpeg peut nécessiter ladspa: LADSPA filters
:: mlt peut nécessiter ladspa: for LADSPA plugins

Paquets (16) ladspa-1.13-6  libcdaudio-0.99.12.p2-1  liblrdf-0.5.0-2  musicbrainz-2.1.5-7  spandsp-0.0.6-1  wildmidi-0.4.0-1  gstreamer0.10-0.10.36-11  gstreamer0.10-bad-0.10.23-23
             gstreamer0.10-bad-plugins-0.10.23-23  gstreamer0.10-base-0.10.36-8  gstreamer0.10-base-plugins-0.10.36-8  gstreamer0.10-ffmpeg-0.10.13-7  gstreamer0.10-good-0.10.31-16
             gstreamer0.10-good-plugins-0.10.31-16  gstreamer0.10-ugly-0.10.19-20  gstreamer0.10-ugly-plugins-0.10.19-20

Taille totale supprimée :  34,02 MiB

:: Voulez-vous désinstaller ces paquets ? [O/n]

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#17Messageil y a 2 ans

papajoke a écrit :@ace66130

Trouvé a l'inter, apparemment c'est le gestionnaire de connexion (Ldm) de Budgie et un theme ...


Merci, je fais startx pour retrouver ma session en attendant la solution ....

PS : J'ai installé GDM, cela règle le problème, je ne sais pas si cela alourdit beaucoup le système?

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#18Messageil y a 2 ans

255 paquets ici (KDE + XFCE), et aucun problème à signaler. Le noyau 4.9.6-1 boote sans problème. Merci beaucoup !

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#19Messageil y a 2 ans

:bjr: Ne pas oublier de virer les orphelins, il y en a un paquet ;)

yaourt -Qdt

[STABLE]16.10 Fringilla - Mise à jour 30.01.2017

#20Messageil y a 2 ans

Bonjour à tous et toutes,
MAJ faite sans problèmes (233 paquets), tout est ok. La compilation de gstreamer, quel calvaire ! :siffle
Bonne journée à tous et toutes.

Répondre