Actualités & Annonces de l'équipe de développement et des administrateurs du forum.
Répondre

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#1Messageil y a 5 mois

Bonjour à toutes et à tous :bjr:

Une mise à jour est annoncée

Attention : Un bug qui impacte la séquence de boot et qui concerne le kernel 4.9 a été rapporté ici et sur le forum inter.

Alors, qu'est-ce qu'on a avec celle-ci ?
  • Systemd a reçu quelques corrections et mises à jour supplémentaires 4
  • Pamac v6.4 introduit désormais une option de téléchargement automatique des mises à jour (désactivé par défaut) et en utilisant --search dans pamac, on démarrera pamac-manager directement en mode recherche.
  • Corrections sur Octopi
  • linux417 est finalement sorti
  • Les reconstructions en amont habituelles
Nous espérons qu'avec tous ces changements, Manjaro sera plus efficace pour nous tous.

N'hésitez pas à nous donner vos commentaires sur les modifications apportées aux dépôts.

Mise à jour faite en 2 fois.

-------------------------------------------------------------------------------------
Mise à jour possible par pamac, octopi ou par pacman (de préférence) :

sudo pacman-mirrors -f0 && sudo pacman -Syyu && yaourt -Sua
-------------------------------------------------------------------------------------


Noyaux pris en charge :
  • linux316 3.16.56
  • linux318 3.18.112 [EOL] En fin de vie
  • linux41 4.1.51
  • linux44 4.4.135
  • linux49 4.9.106
  • linux414 4.14.48
  • linux415 4.15.18 [EOL] En fin de vie
  • linux416 4.16.14
  • linux417 4.17.0
  • linux414-rt 4.14.40_rt30
  • linux416-rt 4.16.12_rt5
Les changements en détail :
  • community x86_64: 873 nouveaux et 859 paquets retirés
  • core x86_64: 20 nouveaux et 20 paquets retirés
  • extra x86_64: 142 nouveaux et 144 paquets retirés
  • multilib x86_64: 5 nouveaux et 6 paquets retirés
Une liste détaillée des changements peut être trouvée ici
6 paquets supprimés:

broadcom-wl dcadec faience-icon-theme iasl libfs manjaro-illyria-openbox-grub-theme 
17 nouveaux paquets:

acpica:  ACPI tools, including Intel ACPI Source Language compiler
bat:  cat clone with syntax highlighting and Git integration
diffpdf:  Diffing pdf files visually or textually
lib32-db:  The Berkeley DB embedded database system
lib32-db:  The Berkeley DB embedded database system
manjaro-lxde-settings-dev:  Manjaro Linux lxde settings
otf-cormorant:  Open-source display font family
otf-fira-code:  Monospaced font with programming ligatures
otf-latin-modern:  Improved version of Computer Modern fonts as used in LaTeX
otf-latinmodern-math:  Improved version of Computer Modern fonts as used in LaTeX – OpenType Math component
perl-test-more-utf8:  Enhancing Test
python2-netcdf4-openmpi:  Python/NumPy interface to the netCDF C library (openmpi version)
python2-objgraph:  Draws Python object reference graphs with graphviz
python-netcdf4-openmpi:  Python/NumPy interface to the netCDF C library (openmpi version)
python-objgraph:  Draws Python object reference graphs with graphviz
ttf-cormorant:  Open-source display font family
ttf-fira-code:  Monospaced font with programming ligatures
xpra:  multi-platform screen and application forwarding system screen for X11

-------------------------------------------------------------------------------------


-------------------------------------------------------------------------------------
ERREUR : conflit de fichiers
Si lors de la mise à jour vous avez le type d'erreur comme ci-dessous (tlp est un exemple) :

erreur : la validation de la transaction a échoué (conflit de fichiers)
tlp : /etc/acpi/events/thinkpad-radiosw est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.
il convient de passer la commande suivante en l'adaptant à votre cas particulier :

sudo pacman -S --force tlp
Ensuite, vous pouvez faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
ERREUR de clés
Si lors de la mise à jour vous avez des problèmes de clés, essayez de passer les commandes suivantes :

sudo pacman-mirrors -g
sudo pacman -Syy
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
Ensuite, vous devriez pouvoir faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------
Modifié en dernier par Erwan le 09 Jui 2018, 12:37, modifié 1 fois.

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#2Messageil y a 5 mois

79 paquets mis à jour, obligé de désinstaller python-pip à cause de conflits de fichiers, pour le reste, pas de souci.

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#3Messageil y a 5 mois

:bjr:
50 paquets , 96 Mo comme une lettre à la poste :gsourire:

Pour pamac, à voir si il n'existe pas un bug avec aur ?
EDIT : testé ce matin et rien vu chez moi ...

*********************************

Pour les rois de la console, arrivée dans les dépôts de bat, un cat colorisé
possible de forcer un langage avec -l [extension du langage] (-l sh)

bat ~/.bashrc --paging="never"

bat /etc/pacman.conf -l ini

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#4Messageil y a 5 mois

Bonjour :salut:

Merci pour l'annonce: Environ 250 paquets et 800 Mo sur KDE (j'en avais 2 de retard :roll: ), RAS...

Enfin...RAS grâce à papajoke:
papajoke a écrit :
il y a 5 mois
supprimer le méchant ! un pacman -R ffmpeg2.8 avant la mise à jour a été nécessaire

Donc merci à toi :wink::bien

Pas pu voir le bug avec AUR, car pas de maj en provenance de AUR...

:bjr:

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#5Messageil y a 5 mois

60 paquets pour 400Mo
Ras

pour information , le noyau stable est sorti 4.17 ,
vous pouvez donc le tester maintenant , surtout pour ceux qui sont en config AMD Ryzen

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#6Messageil y a 5 mois

:bjr:
Bonjour à tous

Une soixantaine de paquets mis à jour sans aucun problème .
Un grand Merci Messieurs les développeurs pour votre travail ! :merci:
:maître::maître:

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#7Messageil y a 5 mois

bonsoir !
248mo et tout va bien, mon vbox marche encore du tonnerre :)
très bonne soirée à tous

stéphane

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#8Messageil y a 5 mois

Bonsoir tout le monde
62 paquets pour KDE et redémarrage sans soucis .
Merci à toutes les équipes pour le boulot :bien
Michel

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#9Messageil y a 5 mois

Bonjour
Mise à jour de 69 paquets sous KDE sans anicroche :bien
Bon week-end à tous

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#10Messageil y a 5 mois

:bjr: Aucune difficulté sur cette mise à jour. :merci:

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#11Messageil y a 5 mois

Attention, comme indiqué à l'inter, un crash au boot peut arriver avec la nouvelle version linux49 4.9.106 (la -1 en fait) :desole:
Je le sais, j'y ai eu droit :siffle

Heureusement que j'avais vu le fil à l'inter qui en parlait. Du coup j'ai réinstallé un 4.4, ce qui m'a permis de booter dessus et de repasser en 4.9.105 avec :
pacman -U /var/cache/pacman/pkg/linux49-4.9.105-1-x86_64.pkg.tar.xz

Du coup, je viens d'installer le 4.14 :lol: Je vais voir si ça boote ou pas !

[Edit] 4.14 ok, 4.9.105 ok et mon vieux 4.4 ok. seul le 4.9.106-1 crashe au boot.

[Edit bis] le 4.9.107 règle le problème du crash au boot et est dispo dans la mise à jour du 10/06/18
Modifié en dernier par Denis-pom le 10 Jui 2018, 09:23, modifié 1 fois.

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#12Messageil y a 5 mois

Bonjour Denis-pom,

Je pensais que ce bug n'impactait que la branche unstable de Manjaro. Fassil a d'ailleurs évoqué ce problème, récemment : p113751
Un version de linux 4.9 insuffisamment testée donc. Cela peut arriver car beaucoup d'utilisateurs de testing et unstable préfèrent adopter les noyaux les plus récents.
Merci pour le retour :bien

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#13Messageil y a 5 mois

l'origine est la suivante
il y a eu une maj particulière sur la 4.9 , par rapport aux noyaux ,
qui concernait le compilateur version GCC 8.1 ,
c'est suite à cette mise à jour qu'il y a des soucis

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#14Messageil y a 5 mois

stephane a écrit :
il y a 5 mois
l'origine est la suivante
il y a eu une maj particulière sur la 4.9 , par rapport aux noyaux ,
qui concernait le compilateur version GCC 8.1 ,
c'est suite à cette mise à jour qu'il y a des soucis
Bonjour stephane, Peut-on attendre un correctif rapidement ou à défaut un déclassement du kernel dans sa version précédente, tout au moins dans la branche principale (stable) ?

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#15Messageil y a 5 mois

Erwan a écrit :
il y a 5 mois
Peut-on attendre un correctif rapidement
Vu par philm et corrigé dans la foulée
reste à le répercuter dans les dépôts (déjà en testing)...

**********
Au passage, le noyau 4.1 vient tout juste de passer en fin de vie (EOL)

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#16Messageil y a 5 mois

Merci pour l'info, papajoke, affaire réglée donc :clap

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#17Messageil y a 5 mois


[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#18Messageil y a 5 mois

ils sont forts Manjaro :maître:

Dans la stable de ce matin

[Stable] Mise à jour 07/06/2018 - Kernels, Systemd, Pamac, Octopi, Rebuilds

#19Messageil y a 5 mois

oui car , philm a patché le noyau 4.9 avec le correctif ,
on l'a avant qu'il ne soit diffusé en stable

Répondre