Actualités & Annonces de l'équipe de développement et des administrateurs du forum.

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#61Messageil y a 7 mois

Salut Juju.
T'as un peu de retard....
Ce conflit est du a une dépendance (libsoup-gnome) de l'ensemble des paquets gstreamer0.10. Il faut tous les virer d'un coup par l'option "cascade":

sudo pacman -Rcs gstreamer0.10
sudo pacman-mirrors -g
sudo pacman -Syyu

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#62Messageil y a 7 mois

Bonjour à tous ! :sourire:

Lors de ma dernière mise à jour, j'ai découvert un conflit entre libsoup (qui devait théoriquement s'installer) et libsoup-gnome déjà installé :
"la satisfaction des dépendances a achoué : gstreamer0.10-good-plugins : installer libsoup casse la dépendance de libsoup-gnome".
Donc j'ai décoché libsoup (v. 2.58.1-1), pour pouvoir tout de même mettre à jour mon système.
Ma question : que faut-il faire ensuite vis-à-vis de cela ?

Je laisse un lien pour que les pros identifient la source de cet élément (je ne connais pas non plus ce "gstreamer") :

https://wiki.gnome.org/Projects/libsoup

Merci pour votre aide ! :sourire:

Image

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#63Messageil y a 7 mois

Bonjour.
<libsoup> ou <gstreamer0.10> dans la recherche du Forum tu taperas, et la solution à toi apparaîtra....

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#64Messageil y a 7 mois

'LLo lemustyoda, :clindoeil:

Tu devrais sticker ça en tête de gondôle, parce que cela fait maintenant un moment que l'on se passe de gstreamer0.10, pfuuu..!
Dans le même ordre d'idée, je pense que le suivant sera gst-plugins-bad qui n'est requis par pas grand chose finalement (du moins avec Enlightenment)..? :siffle

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#65Messageil y a 7 mois

Salut,
fassil a écrit :Dans le même ordre d'idée, je pense que le suivant sera gst-plugins-bad qui n'est requis par pas grand chose finalement (du moins avec Enlightenment)..? :siffle

Oui, mais ça ne concerne pas que E. :sourire:

Requis par               : cheese  deepin-music  gnome-video-effects  grilo-plugins  gstreamer-vaapi
                           guayadeque  kamoso  pitivi  totem
Optionnel pour           : audience  beets  clementine  cutegram  farstream  gaupol  gloobus-preview
                           gnac  gnome-music  gnome-subtitles  liferea  mate-applet-streamer  muine
                           noise-player  parole  phonon-qt4-gstreamer  phonon-qt5-gstreamer  pragha
                           qt5-multimedia  quodlibet  qutebrowser  rhythmbox  rygel  seamonkey
                           snappy-player  soundconverter  sugar-activity-jukebox  transmageddon  xnoise

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#66Messageil y a 7 mois

Smurf a écrit :Salut,
fassil a écrit :Dans le même ordre d'idée, je pense que le suivant sera gst-plugins-bad qui n'est requis par pas grand chose finalement (du moins avec Enlightenment)..? :siffle

Oui, mais ça ne concerne pas que E. :sourire:

Requis par               : cheese  deepin-music  gnome-video-effects  grilo-plugins  gstreamer-vaapi
                           guayadeque  kamoso  pitivi  totem
Optionnel pour           : audience  beets  clementine  cutegram  farstream  gaupol  gloobus-preview
                           gnac  gnome-music  gnome-subtitles  liferea  mate-applet-streamer  muine
                           noise-player  parole  phonon-qt4-gstreamer  phonon-qt5-gstreamer  pragha
                           qt5-multimedia  quodlibet  qutebrowser  rhythmbox  rygel  seamonkey
                           snappy-player  soundconverter  sugar-activity-jukebox  transmageddon  xnoise



:salut: Oui mais, non ! gstreamer0.10-bad-plugins n'a plus aucune utilité et il est désormais remplacé par une version plus récente extra/gst-plugins-bad 1.12.0-1. Toute cette famille gstreamer0.10 n'a aucune raison de se trouver sur un système "rolling". :siffletous ces paquets Aur doivent être désinstallés, ils sont source de problèmes à venir.

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#67Messageil y a 7 mois

Merci pour vos remarques. J'ai donc désinstallé gstreamer0.10-bad-plugins mais ça n'a strictement rien changé... Toujours le même problème. :|

et si je veux supprimer gstreamer, voici ce qui se passe :

sudo pacman -R gstreamer
vérification des dépendances...
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: cinnamon : supprimer gstreamer casse la dépendance « gstreamer »
:: gst-plugins-base-libs : supprimer gstreamer casse la dépendance « gstreamer »
:: java-openjfx : supprimer gstreamer casse la dépendance « gstreamer »

Je vois pas trop quoi faire...

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#68Messageil y a 7 mois

Jivaro a écrit :Merci pour vos remarques. J'ai donc désinstallé gstreamer0.10-bad-plugins mais ça n'a strictement rien changé... Toujours le même problème. :|

et si je veux supprimer gstreamer, voici ce qui se passe :

sudo pacman -R gstreamer
vérification des dépendances...
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: cinnamon : supprimer gstreamer casse la dépendance « gstreamer »
:: gst-plugins-base-libs : supprimer gstreamer casse la dépendance « gstreamer »
:: java-openjfx : supprimer gstreamer casse la dépendance « gstreamer »

Je vois pas trop quoi faire...


si tu nous retourne stp
sudo pacman -Qdtq :gsourire:

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#69Messageil y a 7 mois

Erwan a écrit :Oui mais, non ! gstreamer0.10-bad-plugins n'a plus aucune utilité et il est désormais remplacé par une version plus récente extra/gst-plugins-bad 1.12.0-1. Toute cette famille gstreamer0.10 n'a aucune raison de se trouver sur un système "rolling". :siffletous ces paquets Aur doivent être désinstallés, ils sont source de problèmes à venir.

On parlait bien de gst-plugins-bad :sourire: , je donnais une partie du résultat de pacman -Sii gst-plugins-bad.

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#70Messageil y a 7 mois

@ Jivaro.
mhwd est pour installer les pilotes graphiques.Rien à voir avec libsoup-gnome....
Pour virer libsoup et les gstreamer0.10 dont il en fait partie, c'est

sudo pacman -Rcs gstreamer0.10
sudo pacman -Syu

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#71Messageil y a 7 mois

pour la fin de la mise à jour
supprimer les orphelins
sudo pacman -Rns $(pacman -Qdtq)

--
pour yaourt -C
les .pacnews sont de nouveaux fichiers de configs , les .pacsave les précédents
viewtopic.php?f=18&t=4270

en sélectionnant leur numéro , il va te demander pour chacun une action
soit Editer / Remplacer / etc ou ne rien faire : Entrée
Modifié en dernier par stephane le 20 Mai 2017, 14:46, modifié 2 fois.

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#72Messageil y a 7 mois

Voici le retour de ce qui manquait :

[zenux310a alpha]# pacman -Rns $(pacman -Qdtq)
vérification des dépendances...

Paquets (3) jsoncpp-1.8.0-1  libuv-1.11.0-1  cmake-3.8.0-1

Taille totale supprimée :  31.93 MiB

:: Voulez-vous désinstaller ces paquets ? [O/n]
:: Traitement des changements du paquet...
(1/3) désinstallation de cmake                     [-------------] 100%
(2/3) désinstallation de libuv                     [-------------] 100%
(3/3) désinstallation de jsoncpp                   [-------------] 100%
:: Exécution des crochets de post-transaction...
(1/4) Updating icon theme caches...
(2/4) Arming ConditionNeedsUpdate...
(3/4) Updating the desktop file MIME type cache...
(4/4) Updating the MIME type database...
[zenux310a alpha]# journalctl -b0 | grep nouveau
[zenux310a alpha]# journalctl -b0 | grep nvidia
[zenux310a alpha]#

stephan a écrit :en sélectionnant leur numéro , il va te demander pour chacun une action
soit Editer / Remplacer / etc ou ne rien faire : Entrée
Je suis en train de consulter le sujet de Loubrix et encore, ça me dépasse, je ne saurais juger de ce que je devrais éditer. remplacer, etc...

Ok, j'ai compris que pour le moment il me faut rester avec la carte GPU intel.

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#73Messageil y a 7 mois

Merci Stéphane :sourire:

@lemust83
Merci pour tes conseils ! Grâce à toi, tout est rentré dans l'ordre simplement ! :bien

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#74Messageil y a 7 mois

Bonjour à toutes et tous,
J'ai suivi le lien pour le cas ou on a un problème avec steam, et il est dit de faire l'un ou l'autre :

LD_PRELOAD='/usr/$LIB/openssl-1.0-compat/' %command%

Or create symlinks to: /usr/lib{32}/openssl-1.0-compat/libssl.so.1.0.0 and /usr/lib{32}/openssl-1.0-compat/libcrypto.so.1.0.0 within for example ~/.steam/steam/steamapps/common/Tomb Raider/lib/i686/

Est ce que je pourrais avoir des détails, parce que je ne comprend pas.
Il suffit de taper LD_PRELOAD='/usr/$LIB/openssl-1.0-compat/' %command% en console ?

Ensuite il donne 2 exemples pour une architecture x86_64:

ln -sfv /usr/lib32/openssl-1.0-compat/libssl.so.1.0.0 ~/.steam/steam/steamapps/common/Tomb Raider/lib/i686/libssl.so.1.0.0
ln -sfv /usr/lib32/openssl-1.0-compat/libcrypto.so.1.0.0 ~/.steam/steam/steamapps/common/Tomb Raider/lib/i686/libcrypto.so.1.0.0

Mais le répertoire n'existe pas. :sos:

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#75Messageil y a 7 mois

il faut d'abord les installer
-- ne concerne que Steam pour dépendance compatibilité openssl
sudo pacman -S openssl-1.0-compat

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#76Messageil y a 7 mois

Ok, c'est fait, mais ~/.steam/steam/steamapps/common/peut importe/lib/i686/libssl.so.1.0.0 et ~/.steam/steam/steamapps/common/peut importe/lib/i686/libcrypto.so.1.0.0 n’existent toujours pas.

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#77Messageil y a 7 mois

Ce sont des repertoires utilisateurs, donc cahés dans ton home.
Crées les et le lien devrait fonctionner.
Tiens ? On peut jouer à Tomb Raider ...

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#78Messageil y a 7 mois

Ouais on peut jouer à Tomb Raider.
Que celui la : ici mais il est bien.

Sinon je sais que ce sont des fichiers cachés et je suis aller voir.
Tout va bien jusqu'à /lib, ensuite /i686 n'existe pas, seulement /x86_64 et donc, sous /lib/x86_64, libssl.so.1.0.0 et libcrypto.so.1.0.0 n'existent pas.
J'ai quand même tenter de créer les liens et donc:
ln: impossible de créer le lien symbolique '/home/redhead/.steam/steam/steamapps/common/Deus Ex Mankind Divided/lib/i686/libssl.so.1.0.0': Aucun fichier ou dossier de ce type
Et pareil pour l'autre.

Une idée ?

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#79Messageil y a 7 mois

Je ne l'ai pas installé, donc je ne peux te donner le chemin exacte, mais ça devrait être un truc du genre...
En simple utilisateur:

mkdir -p /home/redhead/.steam/steam/steamapps/common/Deus.....

Ensuite tu retente ton lien.
C'est quoi ce Ex Mankind Divided/lib/i686/ ? Ex suivi de 2 mots séparés par des blancs ne sont pas des dénominations propres à un chemin absolu.

[STABLE]17.00 Gellivara - Mise à jour 12.05.2017

#80Messageil y a 7 mois

Merci Lemust83,
en fait en cherchant un peu et en réfléchissant 2 secondes (sisi ça m'arrive des fois :gsourire: )
les bonne commandes à passer sont :

ln -sfv /usr/lib32/openssl-1.0-compat/libssl.so.1.0.0 ~/.steam/steam/steamapps/common/Deus\ Ex\ Mankind\ Divided/lib/x86_64/libssl.so.1.0.0
ln -sfv /usr/lib32/openssl-1.0-compat/libcrypto.so.1.0.0 ~/.steam/steam/steamapps/common/Deus\ Ex\ Mankind\ Divided/lib/x86_64/libcrypto.so.1.0.0

Ne sachant pas ce qu'était un lien, je pensais que les fichiers ~/.steam/steam/steamapps/common/Deus\ Ex\ Mankind\ Divided/lib/x86_64/libssl.so.1.0.0
et ~/.steam/steam/steamapps/common/Deus\ Ex\ Mankind\ Divided/lib/x86_64/libcrypto.so.1.0.0 devaient exister, mais ce n'est pas le cas.

Cela dis les 2 commandes ci dessus crées bien les liens, mais ça ne marche pas mieux. :tetu!

ça sert à rien de rebooter après la création d'un lien, hein ?

Lemust83 a écrit :C'est quoi ce Ex Mankind Divided/lib/i686/ ? Ex suivi de 2 mots séparés par des blancs ne sont pas des dénominations propres à un chemin absolu.

Oui, mais les retours ne remettent pas les \

[redhead@manjaro ~]$ ln -sfv /usr/lib32/openssl-1.0-compat/libcrypto.so.1.0.0 ~/.steam/steam/steamapps/common/Deus\ Ex\ Mankind\ Divided/lib/i686/libssl.so.1.0.0
ln: impossible de créer le lien symbolique '/home/redhead/.steam/steam/steamapps/common/Deus Ex Mankind Divided/lib/i686/libssl.so.1.0.0: Aucun fichier ou dossier de ce type
[redhead@manjaro ~]$ ln -sfv /usr/lib32/openssl-1.0-compat/libcrypto.so.1.0.0 ~/.steam/steam/steamapps/common/Deus\ Ex\ Mankind\ Divided/lib/i686/libcrypto.so.1.0.0
ln: impossible de créer le lien symbolique '/home/redhead/.steam/steam/steamapps/common/Deus Ex Mankind Divided/lib/i686/libcrypto.so.1.0.0': Aucun fichier ou dossier de ce type

[redhead@manjaro ~]$ ln -sfv /usr/lib32/openssl-1.0-compat/libssl.so.1.0.0 ~/.steam/steam/steamapps/common/Deus\ Ex\ Mankind\ Divided/lib/x86_64/libssl.so.1.0.0
'/home/redhead/.steam/steam/steamapps/common/Deus Ex Mankind Divided/lib/x86_64/libssl.so.1.0.0' -> '/usr/lib32/openssl-1.0-compat/libssl.so.1.0.0'
[redhead@manjaro ~]$ ln -sfv /usr/lib32/openssl-1.0-compat/libcrypto.so.1.0.0 ~/.steam/steam/steamapps/common/Deus\ Ex\ Mankind\ Divided/lib/x86_64/libcrypto.so.1.0.0
'/home/redhead/.steam/steam/steamapps/common/Deus Ex Mankind Divided/lib/x86_64/libcrypto.so.1.0.0' -> '/usr/lib32/openssl-1.0-compat/libcrypto.so.1.0.0'
Modifié en dernier par redhead le 20 Mai 2017, 17:49, modifié 1 fois.

Répondre