Clavier sans fil rebascule en QWERTY au démarrage

Problèmes et questions concernant les éditions Fluxbox - LXDE - LXQT - Netbook.

Clavier sans fil rebascule en QWERTY au démarrage

Message par 120 » 04 Déc 2015, 10:50

Bonjour,
j'ai installé une petite machine sur la TV familiale, sous Manjaro Fluxbox, et j'ai quelques soucis de comportement, à commencer par le clavier sans fil qui est en QWERTY à chaque démarrage...
Il s'agit d'un LOGITECH K400r, par ailleurs parfaitement reconnu sur les autres PC de la maison (Mageia 5, Xubuntu 14.04).
En passant par Manjaro Settings Manager/clavier, je vois que le système est bien en FR/fr... je fais appliquer et tout rentre dans l'ordre!

Comment faire pour que la configuration clavier soit bien appliquée au démarrage? Car là c'est agaçant, en plus il faut se souvenir de la conversion AZERTY/QWERTY pour taper le mot de passe... Du coup le PC ne plait pas à mon épouse!

Quelques infos sur cette machine :
Code : Tout sélectionner
cat /proc/cpuinfo | grep 'model name'
model name   : Intel(R) Atom(TM) CPU  230   @ 1.60GHz
model name   : Intel(R) Atom(TM) CPU  230   @ 1.60GHz
[dubsv@TV ~]$ lspci|grep -i 'vga'
03:00.0 VGA compatible controller: NVIDIA Corporation ION VGA (rev b1)
[dubsv@TV ~]$ lspci|grep -i 'audio'
00:08.0 Audio device: NVIDIA Corporation MCP79 High Definition Audio (rev b1)
[dubsv@TV ~]$ uname -a
Linux TV 3.18.24-1-MANJARO #1 SMP PREEMPT Tue Nov 3 23:03:22 UTC 2015 i686 GNU/Linux


Merci,
Vincent.
Dernière édition par 120 le 01 Avr 2016, 13:56, édité 1 fois.
120
 
Message(s) : 40
Inscription : 15 Oct 2015, 13:02

Re: Clavier sans fil rebascule en QWERTY au démarrage

Message par papajoke » 04 Déc 2015, 11:18

voir le wiki arch pour la langue
pour le clavier, la commande localectl set-locale et son fichier /etc/vconsole.conf, le wiki arch
pour vérifier :
Code : Tout sélectionner
locale
localectl
Manjaro STABLE - Linux 3.18 - zsh - Kde5/Cinnamon - Intel Core i3 - 6Go RAM - GeForce 405 video-nouveau - DD en MBR
portable Manjaro TESTING - zsh - XFCE - AMD V140 - 2Go RAM - ATI Radeon HD 4200
#mount /dev/archlinux /mnt/manjaro
Avatar de l’utilisateur
papajoke
Modérateur
 
Message(s) : 3952
Inscription : 02 Avr 2013, 18:25
Localisation : Nevers

Re: Clavier sans fil rebascule en QWERTY au démarrage

Message par 120 » 04 Déc 2015, 17:15

Merci pour cette réponse rapide : Pas encore eu le temps d'aller voir le lien Arch, mais coté configuration locale, cela me semble bon, même au démarrage :
Code : Tout sélectionner
$ locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=
[~]$ localectl
   System Locale: LANG=fr_FR.UTF-8
       VC Keymap: fr
      X11 Layout: fr
       X11 Model: logicd
     X11 Options: terminate:ctrl_alt_bksp,grp:alt_shift_toggle
[~]$ more /etc/vconsole.conf
KEYMAP=fr



J'ai l'impression que ce serait plutôt lié au chargement du pilote du clavier? (clavier+touchpad intégré)
Je regarde cela demain.
120
 
Message(s) : 40
Inscription : 15 Oct 2015, 13:02

Re: Clavier sans fil rebascule en QWERTY au démarrage

Message par Loubrix » 04 Déc 2015, 20:42

aucun rapport avec le pilote...
par contre il faudrait savoir si ton clavier est en qwerty dans l'environnement graphique, dans le TTY, ou dans les deux, parce que ça se règle pas au même endroit
Asus AIO - AMD E2 - Radeon HD 7340 - Manjaro 64 + Kf5 + Linux 3.14
Avatar de l’utilisateur
Loubrix
 
Message(s) : 6309
Inscription : 03 Déc 2012, 14:32
Localisation : Bessèges - 30

Re: Clavier sans fil rebascule en QWERTY au démarrage

Message par 120 » 05 Déc 2015, 17:26

Effectivement, uniquement dans l'environnement graphique, et semble t'il avec ce clavier (pas refait l'essai avec l'adaptateur USB/PS2 et clavier filaire). En ouvrant une session texte par Alt+Ctrl+F2 (avant correction du clavier sous X), il est bien en azerty.
Un lien pour comprendre cela? Merci.

J'ai lu les liens Arch Linux, habituellement extrêmement détaillé, mais là, c'est assez court! 8-)
120
 
Message(s) : 40
Inscription : 15 Oct 2015, 13:02

Re: Clavier sans fil rebascule en QWERTY au démarrage

Message par Loubrix » 06 Déc 2015, 03:53

as-tu un fichier /etc/xorg.conf.d/20-keyboard.conf et que contient-il ?
Asus AIO - AMD E2 - Radeon HD 7340 - Manjaro 64 + Kf5 + Linux 3.14
Avatar de l’utilisateur
Loubrix
 
Message(s) : 6309
Inscription : 03 Déc 2012, 14:32
Localisation : Bessèges - 30

Re: Clavier sans fil rebascule en QWERTY au démarrage

Message par 120 » 06 Déc 2015, 14:55

Bonjour,
Alors, dans /etc/X11/xorg.conf.d/00-keyboard.conf, j'ai :
Code : Tout sélectionner
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "fr"
        Option "XkbModel" "a4techKB21"
        Option "XkbOptions" "terminate:ctrl_alt_bksp,grp:alt_shift_toggle"
EndSection

Mais je l'ai édité après avoir repasser le clavier en azerty.. je redémarre...

Modération: Les retours de commandes se mettent entre balises [Code]
120
 
Message(s) : 40
Inscription : 15 Oct 2015, 13:02

Re: Clavier sans fil rebascule en QWERTY au démarrage

Message par 120 » 06 Déc 2015, 15:18

Bon, idem au démarrage, l'option "a4techKB21" est celle par défaut de l'application graphique du gestionnaire de paramètres de Manjaro (rappel : version FluxBox), mais même comportement en sélectionnant Logitech cordless.
Une idée, une autre piste?
Merci.
120
 
Message(s) : 40
Inscription : 15 Oct 2015, 13:02

Re: Clavier sans fil rebascule en QWERTY au démarrage

Message par 120 » 06 Déc 2015, 21:34

Ok pour la balise [Code], je pensais que ce n'était pas nécessaire au vu de la longueur, mais c'est vrai que c'est plus lisible.
J'ai parcouru cette page du wiki de ArchLinux concernant la configuration clavier sous X11. Il semble que là aussi ce soit correct... Du coup je vais sans doute tenter un switch pour l'activer à la souris sans avoir à taper le mot de passe admin.

Sauf si une idée ou autre piste?
Merci!
120
 
Message(s) : 40
Inscription : 15 Oct 2015, 13:02

Re: Clavier sans fil rebascule en QWERTY au démarrage

Message par Loubrix » 07 Déc 2015, 07:30

comme tu utilises un keymap spécial, c'est peut-être avec celui-ci qu'il y a un problème, mais ça métonne.
tu utilises quel gestionnaire de mot de passe ? ça peut aussi être lui le fautif, et Fluxbox suit...
Asus AIO - AMD E2 - Radeon HD 7340 - Manjaro 64 + Kf5 + Linux 3.14
Avatar de l’utilisateur
Loubrix
 
Message(s) : 6309
Inscription : 03 Déc 2012, 14:32
Localisation : Bessèges - 30

Re: Clavier sans fil rebascule en QWERTY au démarrage

Message par 120 » 07 Déc 2015, 09:32

Bonjour,
En fait, je n'ai choisi que les options par défaut, avec login automatique (pas d'invite).
Pourquoi écris-tu que j'utilise un keymap spécial? KEYMAP=fr
Faut il tester avec un fr-latin9?
Comment savoir quel gestionnaire de mot de passe est utilisé?
Merci.
120
 
Message(s) : 40
Inscription : 15 Oct 2015, 13:02

Re: Clavier sans fil rebascule en QWERTY au démarrage

Message par 120 » 07 Déc 2015, 20:46

Bonsoir,
En cherchant sur le net, il semble que ce bug soit effectivement lié à Xorg. Et justement, je n'ai pas de fichier xorg.conf !
Bon, comme c'est le PC de la TV, il est peu accessible... Je vais regarder sur mont petit EEEPC, à l'architecture assez proche, sur lequel j'ai également installé une Manjaro@FluxBox en multiboot - mais il fonctionne globalement mieux, et la carte graphique est du Radeon, pas du ION@Nvidia. Cela me fait penser que j'ai testé tous le pilotes graphiques, proprio inclus, pour tenter d'utiliser le HDMI (en fait, c'est ma TV qui semble foireuse sur ce point) avant de basculer en VGA.
A suivre...
120
 
Message(s) : 40
Inscription : 15 Oct 2015, 13:02

Re: Clavier sans fil rebascule en QWERTY au démarrage

Message par 120 » 07 Déc 2015, 21:01

Bon, pas de xorg.conf non plus et très peu de différences dans le fichier /etc/X11/xorg.conf.d/00-keyboard.conf :
Code : Tout sélectionner
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "fr,us"
        Option "XkbModel" "pc105"
        Option "XkbVariant" ","
        Option "XkbOptions" "terminate:ctrl_alt_bksp,grp:alt_shift_toggle"
EndSection
120
 
Message(s) : 40
Inscription : 15 Oct 2015, 13:02

Re: Clavier sans fil rebascule en QWERTY au démarrage

Message par Loubrix » 08 Déc 2015, 00:37

oui, petit lapsus, c'était pas du keymap que je voulais parler, mais du "XkbModel" "a4techKB21".
pour savoir quel est le gestionnaire de login, essaie systemctl cat display-manager.service
Asus AIO - AMD E2 - Radeon HD 7340 - Manjaro 64 + Kf5 + Linux 3.14
Avatar de l’utilisateur
Loubrix
 
Message(s) : 6309
Inscription : 03 Déc 2012, 14:32
Localisation : Bessèges - 30

Re: Clavier sans fil rebascule en QWERTY au démarrage

Message par 120 » 08 Déc 2015, 20:36

Ok, pour le modèle, j'ai essayé avec plusieurs autres, d'ailleurs actuellement il a bien mémorisé un Logitech Cordless, mais cela ne change rien : il faut faire appliquer pour que ce soit pris en compte.
Pour le gestionnaire de login cela donne :
Code : Tout sélectionner
$ systemctl cat display-manager.service
# /usr/lib/systemd/system/lightdm-plymouth.service
[Unit]
Description=Light Display Manager
Conflicts=getty@tty1.service plymouth-quit.service
After=systemd-user-sessions.service getty@tty1.service plymouth-quit.service

[Service]
ExecStart=/usr/bin/lightdm
Restart=always
IgnoreSIGPIPE=no
BusName=org.freedesktop.DisplayManager

[Install]
Alias=display-manager.service

J'avoue que cela ne me parle pas du tout!
Avant d'essayer d'installer/utiliser un switch, aurais tu une idée? Est-ce que ça vaut le coup de créer un fichier xorg.conf?

Merci!
120
 
Message(s) : 40
Inscription : 15 Oct 2015, 13:02

Re: Clavier sans fil rebascule en QWERTY au démarrage

Message par 120 » 08 Déc 2015, 20:49

Remarque : entre ce PC et mon Netbook, il y a 2 lignes de commentaires automatiques rajoutées dans le fichier /etc/X11/xorg.conf.d/00-keyboard.conf de celui qui démarre en QWERTY.
Code : Tout sélectionner
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.

Ce n'est peut-être pas si anodin?
120
 
Message(s) : 40
Inscription : 15 Oct 2015, 13:02

Re: Clavier sans fil rebascule en QWERTY au démarrage

Message par 120 » 01 Avr 2016, 13:55

Bonjour,
même si je n'ai trouvé l'origine du problème, j'ai trouvé un moyen de contournement.
J'ai tenté d'installer un switch clavier... puis de l'insérer dans la barre d'outils par ibus... etc!
Au final, j'ai juste éditer le fichier ~/.flubox/startup en décommentant la ligne :
sbxkb & # keyboard layout switcher for the tray
et ajouter la ligne :
setxkbmap fr &

Je pense que la 2ème suffit, mais la première me met un petit drapeau français qui me rassure, du coup je ne l'ai pas encore commenté...

A+
120
 
Message(s) : 40
Inscription : 15 Oct 2015, 13:02


Retour vers Support pour les éditions Fluxbox - LXDE - LXQT - Netbook

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité