Problèmes et questions concernant les éditions Gnome, Deepin et Budgie.
Répondre

Activer le clavier

#1Messageil y a 2 ans

Bonjour,

le titre peut paraître un peu farfelu... je m'explique.

Mon nouveau laptop est un asus hybrid qui peut se mettre en mode tablette. Le soir, j'aimerai le brancher en hdmi sur ma télé, écran replié en mode tablette et pouvoir juste utiliser le clavier ( l'image étant sur la tv) .

Problème : quand il est en mode tablette, le clavier se désactive. ( normal pour un comportement tablette, mais pas pour l'utilisation que je souhaiterai en faire).

Question : comment réactiver le clavier ?

J'avais trouvé qq part xinput list ...

$ xinput list
⎡ Virtual core pointer                       id=2   [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                 id=4   [slave  pointer  (2)]
⎜   ↳ ELAN1300:00 04F3:3028 Touchpad             id=12   [slave  pointer  (2)]
⎜   ↳ FTSC1000:00 2808:5120                      id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                      id=3   [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                id=5   [slave  keyboard (3)]
    ↳ Power Button                               id=6   [slave  keyboard (3)]
    ↳ Asus Wireless Radio Control                id=7   [slave  keyboard (3)]
    ↳ Video Bus                                  id=8   [slave  keyboard (3)]
    ↳ Power Button                               id=9   [slave  keyboard (3)]
    ↳ Sleep Button                               id=10   [slave  keyboard (3)]
    ↳ USB2.0 HD UVC WebCam                       id=11   [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                           id=14   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard               id=15   [slave  keyboard (3)]


... qui permet a priori d'activer ou non le péripherique que l'on veut, ici a priori c'est 3 pour le clavier (jai essayé 5 et 15 aussi) :

 xinput set-prop 3 "Device Enabled" 1 


cependant, en lançant la commande en mode tablette, le clavier n'est toujours pas activé alors que quand je fais un xinput -list, il semble l'être :

xinput --list-props 3
Device 'Virtual core keyboard':
   Device Enabled (138):   1
   Coordinate Transformation Matrix (140):   1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000


Je me demande s'il n'y a une commande gnome qui permet l'activation / désactivation du clavier lors de son passage en mode tablette indépendamment de X.

Si quelqu'un a une idée .... Merci d'avance !

Répondre