Problèmes et questions concernant les éditions Gnome, Deepin et Budgie.
Répondre

systemd timeout at-spi-dbus-bus.service

#1Messageil y a 3 ans

Bonjour,

J'ai un petit souci à l'arrêt de mon PC. Systemd n'arrive pas à arrêter un processus et fini par le killer. Le problème n'est pas systématique mais très fréquent.
J'ai trouvé un contournement, lorsque je me déconnecte avant d'arrêter la machine j'ai pas le souci, mais bon j'y pense pas toujours et attendre 90 sec c'est long ;rale:

Voici l'extrait de la log de systemd. J'ai l'impression que ça vient de ma carte wifi wlp14s0.

-- Subject: L'unité (unit) mkinitcpio-generate-shutdown-ramfs.service a terminé son démarrage
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/li ... temd-devel
--
-- L'unité (unit) mkinitcpio-generate-shutdown-ramfs.service a terminé son démarrage, avec le résultat done.
mars 29 15:35:22 manjaro systemd[1]: Stopped Bumblebee C Daemon.
-- Subject: L'unité (unit) bumblebeed.service a terminé son arrêt
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/li ... temd-devel
--
-- L'unité (unit) bumblebeed.service a terminé son arrêt.
mars 29 15:35:33 manjaro kernel: [UFW BLOCK] IN=wlp14s0 OUT= MAC=01:00:5e:00:00:01:18:62:2c:9e:54:f5:08:00 SRC=192.168.1.1 DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0x80 TTL=1 ID=0 DF PROTO=2
mars 29 15:36:13 manjaro kernel: [UFW BLOCK] IN=wlp14s0 OUT= MAC=01:00:5e:00:00:01:18:62:2c:9e:54:f5:08:00 SRC=192.168.1.1 DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0x80 TTL=1 ID=0 DF PROTO=2
mars 29 15:36:51 manjaro systemd[529]: at-spi-dbus-bus.service: State 'stop-sigterm' timed out. Killing.
mars 29 15:36:51 manjaro systemd[1]: session-c1.scope: Stopping timed out. Killing.
mars 29 15:36:51 manjaro systemd[1]: session-c1.scope: Killing process 538 (Xorg) with signal SIGKILL.
mars 29 15:36:51 manjaro systemd[529]: at-spi-dbus-bus.service: Killing process 552 (at-spi-bus-laun) with signal SIGKILL.
mars 29 15:36:51 manjaro systemd[529]: at-spi-dbus-bus.service: Main process exited, code=killed, status=9/KILL
mars 29 15:36:51 manjaro systemd[529]: Stopped Accessibility services bus.
-- Subject: L'unité (unit) UNIT a terminé son arrêt
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/li ... temd-devel


~ >>> inxi -i
Network: Card-1: Realtek RTL8723BE PCIe Wireless Network Adapter
driver: rtl8723be
IF: wlp14s0 state: up mac: 60:02:b4:ff:64:b2
Card-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet
driver: atl1c
IF: enp15s0 state: down mac: 60:02:92:24:0f:20
WAN IP: 90.41.175.58 IF: wlp14s0 ip-v4: 192.168.1.19
IF: enp15s0 ip-v4: N/A


J'ai le problème avec mes deux noyaux 4.4 et 4.9.

Si quelqu'un a une idée...
Merci
Dernière modification par chocardil y a 3 ans, modifié au total 1 fois.

systemd timeout at-spi-dbus-bus.service

#2Messageil y a 3 ans

Bonsoir, après quelques recherches, il semble bien que ton problème soit lié à un bug de gdm (gdm3 & wayland). Il serait intéressant de désactiver provisoirement gdm et de booter en console pendant quelques temps, histoire de confirmer ou d'exclure l'implication de ton gestionnaire de connexion. tu trouveras ici la procédure. Essaie une première fois sans désactiver gdm et si tu aboutis, passe cette commande :

sudo systemctl disable gdm.service

et redémarre en console (startx)

systemd timeout at-spi-dbus-bus.service

#3Messageil y a 3 ans

Merci Erwan je test ce soir. Vu que j'ai pas le problème en me déconnectant je pense que tu as raison.
Si jamais ça se confirme, il y a déjà un bug d'ouvert ? sinon faut que je l'ouvre de quel coté ? gnome ? manjaro ?

systemd timeout at-spi-dbus-bus.service

#4Messageil y a 3 ans

Bon j'ai pu tester ce midi sur une VM ou j'avais également le pb et sans gdm sur deux tests je n'ai plus eu le soucis.

Je vais peu être rester comme ça car je gagne 100Mo de RAM et 0.3 sec au démarrage :gsourire:
Dites moi si vous voulez que j'ouvre un bug, mais comme Erwan a trouvé l'info sur le net je pense que c'est déjà fait.

PS: en désactivant toutes les extensions gnome-shell je suis à moins de 700Mo au démarrage :gsourire:

systemd timeout at-spi-dbus-bus.service

#5Messageil y a 3 ans

Salut,
Si le problème est lié à Wayland, il y a aussi la possibilité d'utiliser gdm sans celui-ci. Pour cela, il faut avoir cette ligne dans /etc/gdm/custom.conf :
WaylandEnable=false sans dièse (#) devant.
Dans ce cas, Gnome démarrera avec Xorg.

systemd timeout at-spi-dbus-bus.service

#6Messageil y a 3 ans

'LLo,

@chocard:
Tu peux désinstaller tracker aussi si tu veux, juste pour voir..! :siffle

systemd timeout at-spi-dbus-bus.service

#7Messageil y a 3 ans

chocard a écrit :Bon j'ai pu tester ce midi sur une VM ou j'avais également le pb et sans gdm sur deux tests je n'ai plus eu le soucis.

Je vais peu être rester comme ça car je gagne 100Mo de RAM et 0.3 sec au démarrage :gsourire:
Dites moi si vous voulez que j'ouvre un bug, mais comme Erwan a trouvé l'info sur le net je pense que c'est déjà fait.

PS: en désactivant toutes les extensions gnome-shell je suis à moins de 700Mo au démarrage :gsourire:

Non je ne pense pas qu'il soit indispensable de remonter ce bug sur le forum inter, c'est un bug spécifique à gdm3 mais tu fais comme tu le sens :clindoeil:
La solution donnée par Smurf, un peu plus haut, semble bien fonctionner... sur Debian ! :saispas: Sinon il y a d'autres gestionnaires de connexion dont certains ont le mérite d'être assez légers : slim, lxdm... mais, un gestionnaire de connexion, au final, ne sert pas à grand chose si tu n'as qu'un seul utilisateur sur ta machine, c'est un choix personnel, lié à l'esthétique du démarrage.
Bon, je pense que vous serez tous d'accord pour qu'on déplace ce sujet dans la rubrique support de l'édition gnome ? Gnome étant à présent une version officielle, on peut imaginer que ce fil pourra servir à d'autres utilisateurs ;)

systemd timeout at-spi-dbus-bus.service

#8Messageil y a 3 ans

Erwan a écrit :La solution donnée par Smurf, un peu plus haut, semble bien fonctionner... sur Debian ! :saispas: Sinon il y a d'autres gestionnaires de connexion dont certains ont le mérite d'être assez légers : slim, lxdm... mais, un gestionnaire de connexion, au final, ne sert pas à grand chose si tu n'as qu'un seul utilisateur sur ta machine, c'est un choix personnel, lié à l'esthétique du démarrage.
Bon, je pense que vous serez tous d'accord pour qu'on déplace ce sujet dans la rubrique support de l'édition gnome ? Gnome étant à présent une version officielle, on peut imaginer que ce fil pourra servir à d'autres utilisateurs ;)

Solution trouvée sur le forum inter, mais à l'inverse, c'était pour passer de Xorg à Wayland en commentant la ligne. Pas sur que tous les gestionnaires de connections supportent Wayland.

systemd timeout at-spi-dbus-bus.service

#9Messageil y a 3 ans

Smurf a écrit :Solution trouvée sur le forum inter, mais à l'inverse, c'était pour passer de Xorg à Wayland en commentant la ligne. Pas sur que tous les gestionnaires de connections supportent Wayland.
:bien c'est donc la solution de contournement à mettre en œuvre pour ceux qui sont concernés par ce bug ;)

systemd timeout at-spi-dbus-bus.service

#10Messageil y a 3 ans

Smurf a écrit :Salut,
Si le problème est lié à Wayland, il y a aussi la possibilité d'utiliser gdm sans celui-ci. Pour cela, il faut avoir cette ligne dans /etc/gdm/custom.conf :
WaylandEnable=false sans dièse (#) devant.
Dans ce cas, Gnome démarrera avec Xorg.

Bizarre sur mon pc physique il est déjà positionner dans mon fichier (je n'y ai jamais touché). Est ce que le faite de démarrer un session xorg au lieu de wayland le positionne automatiquement ? :saispas:
Je viens de faire 1 test j'ai pas eu le problème (mais il était pas systématique) à voir. Je regarde demain sur ma VM.

fassil a écrit :'LLo,

@chocard:
Tu peux désinstaller tracker aussi si tu veux, juste pour voir..! :siffle

Il prend que 20Mo, je vais le garder :gsourire:

Erwan a écrit :Non je ne pense pas qu'il soit indispensable de remonter ce bug sur le forum inter, c'est un bug spécifique à gdm3 mais tu fais comme tu le sens :clindoeil:
La solution donnée par Smurf, un peu plus haut, semble bien fonctionner... sur Debian ! :saispas: Sinon il y a d'autres gestionnaires de connexion dont certains ont le mérite d'être assez légers : slim, lxdm... mais, un gestionnaire de connexion, au final, ne sert pas à grand chose si tu n'as qu'un seul utilisateur sur ta machine, c'est un choix personnel, lié à l'esthétique du démarrage.

Perso j'en ai pas l’utilité plus que ça. Ça me dérange de ne pas en avoir ;)

systemd timeout at-spi-dbus-bus.service

#11Messageil y a 3 ans

chocard a écrit :Bizarre sur mon pc physique il est déjà positionner dans mon fichier (je n'y ai jamais touché). Est ce que le faite de démarrer un session xorg au lieu de wayland le positionne automatiquement ? :saispas:
Je viens de faire 1 test j'ai pas eu le problème (mais il était pas systématique) à voir. Je regarde demain sur ma VM.

Je ne pense pas que le fichier de config soit modifié automatiquement, ce qui veut dire que tu ne démarres pas avec Wayland, mais Xorg.
Si c'est le cas, tes soucis ne sont pas liés au bug gdm+Wayland mentionné plus haut.

Il faut apparemment lancer cette commande dans un terminal pour voir si tu es sous Xorg :
echo $XDG_SESSION_TYPE
le résultat devrait être x11.

systemd timeout at-spi-dbus-bus.service

#12Messageil y a 3 ans

Smurf a écrit :
chocard a écrit :Bizarre sur mon pc physique il est déjà positionner dans mon fichier (je n'y ai jamais touché). Est ce que le faite de démarrer un session xorg au lieu de wayland le positionne automatiquement ? :saispas:
Je viens de faire 1 test j'ai pas eu le problème (mais il était pas systématique) à voir. Je regarde demain sur ma VM.

Je ne pense pas que le fichier de config soit modifié automatiquement, ce qui veut dire que tu ne démarres pas avec Wayland, mais Xorg.
Si c'est le cas, tes soucis ne sont pas liés au bug gdm+Wayland mentionné plus haut.

Il faut apparemment lancer cette commande dans un terminal pour voir si tu es sous Xorg :
echo $XDG_SESSION_TYPE
le résultat devrait être x11.


Oui je suis sous xorg même si je choisi wayland au niveau de ma session.
Pour l'instant ça fonctionne :sourire:
Répondre