Problèmes et questions concernant les éditions Gnome, Deepin et Budgie.
Répondre

gnome-terminal et ttf-monaco

#1Messageil y a 1 semaine

Bonjour,

J'ai installé la font ttf-monaco depuis AUR mais elle n’apparaît dans la liste des fonts sur gnome-terminal.
Sur mon vieux PC avec XFCE, je la vois bien au niveau de xfce4-terminal.

Avez-vous déjà rencontré ce type de problème avec gnome-terminal ?

Merci
2
administration/modération
Modifié en dernier par Erwan le 09 Jui 2018, 11:57, modifié 1 fois.
Raison :code 2

gnome-terminal et ttf-monaco

#2Messageil y a 1 semaine

Bonjour.
N'aurais tu pas la case Édition ▸ Préférences du profil ▸ Général "Utiliser la police à chasse fixe du système" de cochée ?

gnome-terminal et ttf-monaco

#3Messageil y a 1 semaine

Tu es sur que cette option existe toujours ? (je suis en 3.28.2) car je la vois nulle part
Je n'ai pas d'onglet 'Général' au niveau des préférences de mon profil :desole:

gnome-terminal et ttf-monaco

#4Messageil y a 1 semaine

Pas sur du tout. Je n'ai pas touché un gnome depuis des lustres...
J'ai regardé le PKGBUILD, il installe bien dans /usr/share/fonts/TTF/.
Essaye de le copier dans ~/.local/share/fonts et vois après reconnexion.
Sinon, il faudra attendre qu'un "gnomiste" passe par là car il y a beaucoup de chamboulement depuis que Gnome est en GTK3.

gnome-terminal et ttf-monaco

#5Messageil y a 1 semaine

:bjr:
chocard a écrit : la font ttf-monaco depuis AUR [...] n’apparaît dans la liste des fonts sur gnome-terminal.
Confirmé avec gnome-terminal sous Manjaro 17.1.11 (Hakoila) gnome x86_64 - 4.14.53-1-MANJARO.
Sur le même système j'ai installé mate-terminal 1.20.0-1 et je vois bien Monaco and Co dans la liste.
___________
P.S. − Pas "gnomiste" non plus. Et c'est parce que j'en ai un sous le coude que je sais pourquoi. :lol:
chocard a écrit :Je n'ai pas d'onglet 'Général' au niveau des préférences de mon profil
Moi, si... enfin presque car ce n'est pas un onglet mais une rubrique dans la partie gauche de la fenêtre Préférences.
Terminal de GNOME 3.28.2 > menu Édition > Préférences ...

gnome-terminal et ttf-monaco

#6Messageil y a 1 semaine

coolinux a écrit :
il y a 1 semaine
Moi, si... enfin presque car ce n'est pas un onglet mais une rubrique dans la partie gauche de la fenêtre Préférences.
Terminal de GNOME 3.28.2 > menu Édition > Préférences ...
Je l'ai aussi mais il n'a pas l'option
lemust83 a écrit :
il y a 1 semaine
Essaye de le copier dans ~/.local/share/fonts et vois après reconnexion.
Ca fonctionne pas mieux :maisnon:

gnome-terminal et ttf-monaco

#7Messageil y a 1 semaine

:arrow: Ma réponse comportait deux parties.
As-tu écarté la première après, ou avant lecture ? :gsourire:

gnome-terminal et ttf-monaco

#8Messageil y a 1 semaine

Commences déjà par vérifier que la police d'écriture est installée avec un ls:

ls /usr/share/fonts/TTF/M*
je ne vois à priori pas ne raison pour qu'elle ne soit pas visible mais pourquoi pas, en tout cas si elle est installée tu vas dans les options de gnome-terminal sur ton profil et là tu sélectionnes la police d'écriture.

Maintenant je te donne mon avis je pense qu'aujourd'hui il n'y a plus vraiment de raison d'utiliser Monaco (il y a 4 à 5 ans je t'aurais compris mais là ...) car il y a des équivalents (comprends par là qu'elles se ressemblent beaucoup) tout aussi bien voir mieux : ttf-hack dans Extra et ttf-fantasque-sans-mono dans Aur .

Si tu veux regarder à quoi ça ressemble:
https://www.fontsquirrel.com/fonts/fantasque-sans-mono
https://www.fontsquirrel.com/fonts/hack

Après chacun ses préférences :-)
Allez courage.

gnome-terminal et ttf-monaco

#9Messageil y a 1 semaine

coolinux a écrit :
il y a 1 semaine
:arrow: Ma réponse comportait deux parties.
As-tu écarté la première après, ou avant lecture ? :gsourire:
Je l'ai bien vu mais bon je vais pas installer un autre terminal pour une font :gsourire:
Bimbada a écrit :
il y a 1 semaine

je ne vois à priori pas ne raison pour qu'elle ne soit pas visible mais pourquoi pas, en tout cas si elle est installée tu vas dans les options de gnome-terminal sur ton profil et là tu sélectionnes la police d'écriture.
Ça ne fonctionne pas c'est justement le problème. Bon c'est pas bien grave mais j'aurai voulu savoir d'ou ça venait.

PS: Hack c'est celle que manjaro positionne par défaut avec le bureau Gnome.

gnome-terminal et ttf-monaco

#10Messageil y a 1 semaine

Si ça ne fonctionne pas c'est que tu as fait quelque chose de travers puisque chez les autres il n'y a pas problème.
Comme dit précédemment vérifies que c'est installé correctement, ce serait un bon début :roll:

Soit la police d'écriture est mal/pas installée soit ton profil n'est pas configuré.
Dans les deux cas sans plus d'information de ta part ça va être compliqué. Ajoutes une photo d'écran pour qu'on puisse comprendre tes options, ou des explications plus détaillées sur tes manipulations, parce que "ça ne fonctionne pas" c'est léger pour t'aider.

Hack c'est celle que manjaro positionne par défaut avec le bureau Gnome.
C'est plutôt une bonne chose, merci je n'étais pas au courant

gnome-terminal et ttf-monaco

#11Messageil y a 1 semaine

Bimbada a écrit :
il y a 1 semaine
Si ça ne fonctionne pas c'est que tu as fait quelque chose de travers puisque chez les autres il n'y a pas problème.
coolinux confirme plus haut que ça fonctionne avec mate mais pas avec gnome-terminal ou j'ai pas compris sa phrase ....
Y a quelqu'un chez qui ça fonctionne ?

J'ai juste installer la font et rien fait d'autre (comme sous ma deuxième machine sous xfce sur laquelle ça fonctionne).
> pacman -Ql ttf-monaco
ttf-monaco /usr/
ttf-monaco /usr/share/
ttf-monaco /usr/share/fonts/
ttf-monaco /usr/share/fonts/TTF/
ttf-monaco /usr/share/fonts/TTF/Monaco_Linux.ttf

Au niveau de gnome-terminal je n'ai vu aucune option, donc j'y ai pas touché

gnome-terminal et ttf-monaco

#12Messageil y a 1 semaine

:bjr:
Si si chocard, tu as bien compris :
− gnome-terminal ne "voit" pas la fonte Monaco ;
− mate-terminal la voit bien et en conséquence peut l'utiliser.

A Bimbada : la lecture rapide dite "en diagonale" n'a pas que du bon :-P

gnome-terminal et ttf-monaco

#13Messageil y a 1 semaine

Je me pose des questions sur gnome-terminal car je ne vois rien d'officiel hormis un paquet émulateur venant de Fedora et dans [Community].

]$ pacman -Ss gnome-terminal
extra/gnome-terminal 3.28.2-1 (gnome)
    The GNOME Terminal Emulator
community/gnome-terminal-fedora 3.28.1-1
    The GNOME Terminal Emulator with Fedora patches
C'est donc un paquet validé par des TU (Trust Users) , mais avec des correctifs conçus pour Fedora et probablement pas suffisamment éprouvés pour Arch/Manjaro.
Si tu patientes un peu, ça devrait se corriger en amont sinon, ben ... Ctrl+Alt+F2 :gsourire:Image

gnome-terminal et ttf-monaco

#14Messageil y a 1 semaine

Oula oui désolé je n'ai pas lu très attentivement, coupe du monde oblige :fetard:

Tu peux tester celle-ci qui a été patchée pour voir ce que ça donne, parce qu'il semble que "l'original" pose problème effectivement, tu n'es pas le seul dans ce cas notamment avec gnome-terminal et konsole.
Télécharges l'archive que tu extrais dans ~/.local/share/fonts, vérifies bien les permissions et régénères le cache avec fc-cache -vf.

Sinon dans AUR il y a aussi un paquet nommé monaco-powerline-font, mais la présence d'un commentaire qui dit "This font is only for X11, not for console. " me laisse songeur mais il faudrait tester pour être sûr ce que je n'ai pas fait, je te laisse le soin de le faire.
https://aur.archlinux.org/packages/mona ... -font-git/

Quand je disais que depuis il y avait des équivalents tout aussi bien voir mieux c'était pas faux :)
Fantasque ressemble à Monaco mais est plus agréable à mon avis, son aspect moins alambiqué la rend plus appréciable à l’œil sur la longueur, mais c'est une affaire de goût personnel bien entendu.

gnome-terminal et ttf-monaco

#15Messageil y a 1 semaine

Merci à tous pour vos réponses :bien
Je vais patienter comme le suggère lemust83:merci:

gnome-terminal et ttf-monaco

#16Messageil y a 6 jours

A tout hasard, après un :

sudo fc-cache -fv
Ça donne quoi ? (il m'est arrivé de ne pas voir une police installée avant d'avoir fait la mise à jour par ce biais)

gnome-terminal et ttf-monaco

#17Messageil y a 6 jours

nam1962 a écrit :
il y a 6 jours
A tout hasard, après un :

sudo fc-cache -fv
Ça donne quoi ? (il m'est arrivé de ne pas voir une police installée avant d'avoir fait la mise à jour par ce biais)
J'avais déjà testé ça n'avait rien donné :wink:

gnome-terminal et ttf-monaco

#18Messageil y a 5 jours

Le problème existe depuis plusieurs années pour gnome-terminal ce qui me laisse penser qu'il n'y aura pas de correctif de la part de Gnome, pas pour ce type de problème. Faire une requête pour la détection d'une font en provenance de chez Apple c'est voué à l’échec surtout s'il existe des alternatives Open Source.

La solution à ta disposition reste l'installation d'une version de la police de caractère patchée:
_ soit comme je te l'ai indiqué dans mon message précédent il n'y a rien de compliqué et ça fonctionne, j'ai testé.
_ soit tu attends que quelqu'un fasse un paquet AUR en ayant pris soin de tester le paquet indiqué plus haut pour éviter un doublon d'autant plus que les deux s'appuient sur la font fournie par powerline.

Bye

Répondre