Problèmes et questions sur les applications multimédia.

Problème avec les logiciels d'enregistrement d'écran.

#1Messageil y a 7 mois

Bonjour,
Je suis sous Manjaro 17.1 Xfce et j'ai un problème avec les logiciels d'enregistrement d'écran tels que Kazam et SimpleScreenRecorder. En effet, le rendu est toujous buggé et n'affiche pas tout ce qui se passe à l'écran.
A noter que j'ai un portable Asus X541S avec une Intel HD Graphics 405, et que les mêmes logiciels fonctionnent nickel sur les distros Ubuntu-based.
Y'a-t-il une solution ?
Merci :)


Problème avec les logiciels d'enregistrement d'écran.

#3Messageil y a 7 mois

Bonjour.
Je m'étais amusé a utiliser une ligne de commande qui le faisait bien il y a quelques temps:

ffmpeg -f alsa -ac 2 -i pulse -f x11grab -s 1366x768 -i :0.0 -acodec flac -vcodec libx264 -preset veryfast CapVideo.mkv
Il faut adapter la résolution à celle de ton écran.
Je note toutefois une vitesse légèrement accélérée et un décalage son/image grandissant.
Je n'avais pas ce problème auparavant et je soupçonne les dernières compilations du kernel qui ne sont pas optimisées pour le son...
Va falloir regarder ça...

Problème avec les logiciels d'enregistrement d'écran.

#4Messageil y a 7 mois

Merci pour le tuyau. Hélas, ça donne plus ou moins le même résultat.

Problème avec les logiciels d'enregistrement d'écran.

#5Messageil y a 7 mois

:bjr:
Bonjour NyBac
Je viens d'essayer avec SimpleScreenRecorder et je n'ai eu aucun souci pour le faire fonctionner.
Que ce soit au niveau du rendu ou au niveau du son.
Il serait bon de savoir avec quel DE tu es ! Pour ma part tu pourras voir dans ma signature que je suis avec
Xfce et il serait pour toi aussi de renseigner cette signature. Il est ainsi plus facile de te répondre !
Pour cela tu vois ici :
viewtopic.php?f=12&t=775&sid=a04945bb74 ... 2444a79c50
:bien

Problème avec les logiciels d'enregistrement d'écran.

#6Messageil y a 7 mois

perso, après en avoir test plusieurs, je me suis arrêté sur Green Recorder

Problème avec les logiciels d'enregistrement d'écran.

#7Messageil y a 6 mois

nam1962 a écrit :
il y a 7 mois
perso, après en avoir test plusieurs, je me suis arrêté sur Green Recorder
je confirme --> mieux qu'avec SimpleScreenRecorder :--> Adopté !!
Merci à toi @nam1962
:merci:

Problème avec les logiciels d'enregistrement d'écran.

#8Messageil y a 6 mois

Je suis sous Xfce et même avec Green Recorder c'est pareil. Ce doit être mon matos qui déconne. :rendre:

Problème avec les logiciels d'enregistrement d'écran.

#9Messageil y a 6 mois

:bjr: Ton installation de Manjaro est récente ? Même question pour le bug, est-il récent avec ce logiciel ? Quel retour de : inxi -G

Problème avec les logiciels d'enregistrement d'écran.

#10Messageil y a 6 mois

Cette installation est récente sur mon nouveau laptop, mais sur l'ancien (qui avait aussi une carte graphique Intel), c'était pareil.
inxi -G donne :

Graphics:  Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
           Display Server: N/A drivers: intel (unloaded: modesetting)
           tty size: 80x24

Problème avec les logiciels d'enregistrement d'écran.

#11Messageil y a 6 mois

:salut: J'ai pas trouvé des tonnes de documentation sur ce matériel, mais il semble bien que ce gpu soit intégré au cpu. On va regarder quels sont les drivers disponibles et si un gpu indépendant est bien présent sur cette config dont la signature manque cruellement : mhwd -l et inxi -Fxzc0

Problème avec les logiciels d'enregistrement d'écran.

#12Messageil y a 6 mois

mhwd -l :

> 0000:00:02.0 (0300:8086:22b1) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-intel            2017.03.24                true            PCI
            video-vesa            2017.03.12                true            PCI
inxi -Fxzc0 :

System:    Host: nabylgrad Kernel: 4.14.13-1-MANJARO x86_64
           bits: 64 gcc: 7.2.1
           Desktop: Cinnamon 3.6.6 (Gtk 3.22.26) Distro: Manjaro Linux
Machine:   Device: laptop System: ASUSTeK product: X541SA v: 1.0 serial: N/A
           Mobo: ASUSTeK model: X541SA v: 1.0 serial: N/A
           UEFI: American Megatrends v: X541SA.301 date: 09/14/2016
Battery    BAT0: charge: 34.1 Wh 98.7% condition: 34.6/34.6 Wh (100%)
           model: ASUSTeK X550A26 status: N/A
CPU:       Quad core Intel Pentium N3710 (-MCP-)
           arch: Airmont rev.4 cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 12805
           clock speeds: max: 2560 MHz 1: 683 MHz 2: 725 MHz 3: 855 MHz
           4: 1150 MHz
Graphics:  Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: N/A drivers: intel (unloaded: modesetting)
           tty size: 80x24
Audio:     Card Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.14.13-1-MANJARO
Network:   Card-1: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
           driver: ath9k bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (33.3% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABF0 size: 500.1GB
Partition: ID-1: / size: 49G used: 20G (43%) fs: ext4 dev: /dev/sda4
           ID-2: swap-1 size: 4.29GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 66.0C mobo: 45.0C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 184 Uptime: 16:11 Memory: 1586.4/3833.9MB
           Init: systemd Gcc sys: 7.2.1
           Client: Shell (bash 4.4.121) inxi: 2.3.53
PS : Là je suis sous ma session Cinnamon, mais c'est pareil.

Problème avec les logiciels d'enregistrement d'écran.

#13Messageil y a 6 mois

Quand tu lances la ligne de commande, as tu des messages type "warnings" ou "critical" .?


Problème avec les logiciels d'enregistrement d'écran.

#15Messageil y a 6 mois

Ce qui m'étonne le plus est le bug dans les applications de capture vidéo uniquement Pas soucis lors du visionnage de vidéos ou la pratique de jeux vidéo, j'imagine ? essaye de lancer l'appli dans un terminal en tapant ceci : simplescreenrecorder et donne le retour ici.

Problème avec les logiciels d'enregistrement d'écran.

#16Messageil y a 6 mois

Bonjour,
NyBac a écrit :
il y a 6 mois
Cette installation est récente sur mon nouveau laptop, mais sur l'ancien (qui avait aussi une carte graphique Intel), c'était pareil.
inxi -G donne :

Graphics:  Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
           Display Server: N/A drivers: intel (unloaded: modesetting)
           tty size: 80x24
Ce qui est bizarre c'est qu'il n'y a aucune mention de rendu OpenGL, si ça se trouve l'accélération matérielle de la carte graphique n'est pas utilisée, ce qui peut jouer sur les performances. Il faudrait vérifier que au moins les paquets mesa et libva-driver-intel sont bien installé :

pacman -Qs mesa

pacman -Qs libva

Problème avec les logiciels d'enregistrement d'écran.

#17Messageil y a 6 mois

pacman -Qs mesa :

local/glu 9.0.0-4
    Mesa OpenGL Utility library
local/lib32-glu 9.0.0-3
    Mesa OpenGL utility library (32 bits)
local/lib32-mesa 17.3.2-2
    an open-source implementation of the OpenGL specification (32-bit)
local/lib32-mesa-demos 8.3.0-3
    Mesa demos and tools (32-bit)
local/lib32-vulkan-intel 17.3.2-2
    Intel's Vulkan mesa driver (32-bit)
local/libva-mesa-driver 17.3.2-2
    VA-API implementation for gallium
local/mesa 17.3.2-2
    an open-source implementation of the OpenGL specification
local/mesa-demos 8.3.0-4
    Mesa demos and tools incl. glxinfo + glxgears
local/vulkan-intel 17.3.2-2
    Intel's Vulkan mesa driver
pacman -Qs libva :

local/libva 2.0.0-2
    Video Acceleration (VA) API for Linux
local/libva-mesa-driver 17.3.2-2
    VA-API implementation for gallium

Problème avec les logiciels d'enregistrement d'écran.

#18Messageil y a 6 mois

Désolé, j'ai oublié de suivre ce fil. :oops:

Je pense qu'il manque le paquet libva-driver-intel. Dans le doute, vérifie que tu as bien l'accélération matérielle :

glxinfo|grep rendering
si la réponse est :

direct rendering: Yes
tu as bien l'acceleration matérielle, sinon il vaudrait mieux installer le paquet mentionné plus haut :
sudo pacman -S libva-driver-intel

Problème avec les logiciels d'enregistrement d'écran.

#19Messageil y a 6 mois

:bjr:
Smurf a écrit :
il y a 6 mois
Désolé, j'ai oublié de suivre ce fil. :oops:

Je pense qu'il manque le paquet libva-driver-intel. Dans le doute, vérifie que tu as bien l'accélération matérielle :

glxinfo|grep rendering
si la réponse est :

direct rendering: Yes
tu as bien l'acceleration matérielle, sinon il vaudrait mieux installer le paquet mentionné plus haut :
sudo pacman -S libva-driver-intel
Hummmm ....
libva-intel-driver ....?? :saispas:

sudo pacman -S libva-intel-driver
...enfin je crois !! :desole:

Problème avec les logiciels d'enregistrement d'écran.

#20Messageil y a 6 mois

J'ai le

direct rendering: Yes
J'ai aussi installé le paquet libva-intel-driver et rien n'y fait. :tetu!

Répondre