Manjaro : lecture saccadée des vidéos

Problèmes et questions sur les applications multimédia.

Manjaro : lecture saccadée des vidéos

Message par Mimile » 15 Jan 2013, 12:33

Avant toute chose, en tant que nouveau membre, je salue la communauté des aficionados de Manjaro et en particulier Esclapion avec qui nous avons déjà échangé sur d'autres fora notamment sur la difficulté que je rencontre et que voici :

Pourquoi X pompe-t'il 85 à 90 % de mon CPU lorsque je visionne une vidéo (*.avi, mp4, etc...) et ce, quel que soit le lecteur utilisé (smplayer, vlc, xine, etc...)

Image

De ce fait, vu la présence d'autres logiciels indispensable au fonctionnement de Manjaro, le CPU frôle les 100 % d'utilisation ce qui est de toute évidence à l'origine des saccades observées (tant au niveau video qu'audio).

En temps normal (je veux dire : quand je ne visionne aucun film), le CPU est utilisé par X à concurrence de 3 à 5 % grand max.

Image

Je précise aussi que quand j'utilise les différents lecteurs pour simplement écouter des MP3, il n'y a pas d'augmentation notable de l'utilisation du CPU.

Dernière précision : outre Manjaro, j'ai Archlinux dont la configuration des différents lecteurs est rigoureusement identique et qui ne phagocyte pas mon CPU, le visionnage des films étant correct.

Quelqu'un aurait-il une idée sur ce qui cause cette utilisation excessive de mon CPU sous Manjaro ?

Merci d'avance.

Amicalement,
Mimile
 
Message(s) : 14
Inscription : 15 Jan 2013, 12:05

Re: Manjaro : lecture saccadée des vidéos

Message par Esclapion » 15 Jan 2013, 13:56

Bonjour Mimile et bienvenue :bjr:

Content que tu viennes nous voir. :biere:

Quelles sont les versions respectives de noyau de ton Arch et de ta Manjaro ? Un des points forts de cette dernière est d'avoir très facilement 4 (voire 5) noyaux disponibles. Ça irait peut-être mieux avec un autre.
Esclapion
 

Re: Manjaro : lecture saccadée des vidéos

Message par Loubrix » 15 Jan 2013, 15:35

il faudrait aussi regarder quel est le pilote de sortie video utilisé par le lecteur, et en essayer un autre (par défaut ça doit être "xv")
Asus AIO - AMD E2 - Radeon HD 7340 - Manjaro 64 + Kf5 + Linux 3.14
Avatar de l’utilisateur
Loubrix
 
Message(s) : 6309
Inscription : 03 Déc 2012, 14:32
Localisation : Bessèges - 30

Re: Manjaro : lecture saccadée des vidéos

Message par Mimile » 15 Jan 2013, 16:08

Merci d'intervenir

@ Esclapion :
noyau Archlinux : 3.6.11-1-ARCH
noyau Manjaro : 3.4.25-1-MANJARO

à noter que depuis que j'ai installé Manjaro, le noyau a évolué à 3 ou 4 reprises sans que cela change quoi que ce soit au problème des saccades.

@ Loubrix : le pilote de sortie de mplayer et de ses front-end (gnome-mplayer et smplayer) est bien xv. A noter que les saccades s'observent aussi avec VLC. J'ai essayé divers autres pilotes de sorties en vain : soit les saccades étaient toujours observables, soit le lecteur plantait.
Mimile
 
Message(s) : 14
Inscription : 15 Jan 2013, 12:05

Re: Manjaro : lecture saccadée des vidéos

Message par Esclapion » 15 Jan 2013, 16:13

mhwd-kernel linux36 ?
Esclapion
 

Re: Manjaro : lecture saccadée des vidéos

Message par Mimile » 15 Jan 2013, 16:20

Ta réponse laconique me laisse perplexe.

Je suppose que tu me suggère d'installer un autre noyau.

Pourrais-tu m'indiquer, en pratique, comment faire sans planter tout
Mimile
 
Message(s) : 14
Inscription : 15 Jan 2013, 12:05

Re: Manjaro : lecture saccadée des vidéos

Message par Esclapion » 15 Jan 2013, 16:25

Oui, tout à fait, et par la commande que je t'ai passée.

De la doc ICI.

Ça ne prend que quelques minutes, et ça doit te créer une nouvelle entrée au Grub, vers l'autre noyau.

En facilement disponible comme ça, tu as le 3.4, le 3.5, le 3.6, le 3.7. Le 3.8 est dans testing.
Esclapion
 

Re: Manjaro : lecture saccadée des vidéos

Message par Mimile » 19 Jan 2013, 12:32

Bonjour,

Impecc cette commande mhwd-kernel

J'ai donc installé (et utilise actuellement) le noyau 3.6.11-1.

Malheureusement, aucun effet sur le problème de saccades des vidéos et de l'utilisation abusive du CPU par X

Dès que je démarre une vidéo, X part en flèche et monopolise 85 à 90 % du CPU

Finalement, compte tenu du fait que ce problème existe depuis le début et malgré l'utilisation de 3 ou 4 noyaux différents, il persiste, je pense qu'il n'est pas lié au noyau lui-même.

La question est de savoir d'où provient cette anomalie.

Je pense que je vais carrément réinstaller Manjaro en utilisant la dernière version.

Ca résoudra peut-être le problème.
Mimile
 
Message(s) : 14
Inscription : 15 Jan 2013, 12:05

Re: Manjaro : lecture saccadée des vidéos

Message par Mimile » 18 Fév 2013, 13:30

Bon, j'ai mis du temps et comme indiqué ci-dessus, j'ai écrasé ma Manjaro XFCE et j'ai installé - non sans mal - la version openbox.

J'ai toujours ce satané problème de lecture video.

Avec VLC, j'ai une image toutes les 5 secondes ...

Avec xnoise, j'ai d'office un message m'indiquant qu'un greffon est manquant et qu'il ne peut âs être installé automatiquement (H.264 : introuvable)

Avec certains autres *.avi, il est indiqué que c'est xvid mpeg-4 qui est manquant ; or, celui-ci est bel et bien installé.

Smplayer : en fenêtre réduite, petites saccades pas trop gênantes ; en full screen, saccades comme vlc.

J'espérais que la légèreté d'openbox résoudrait cette question mais hélas non ... Dès que je lance une video X pompe 75 à 80 % du CPU ...

Je crois que je vais définitivement abandonner cette distribution vu que ma Arch fonctionne parfaitement (même si elle me pose parfois de petits problèmes pour la plupart très vite résolus).

J'en suis désolé pour toi mais je rencontre vraiment trop de problème avec cette distro.

A bientôt sur le forum Arch ;)
Mimile
 
Message(s) : 14
Inscription : 15 Jan 2013, 12:05

Re: Manjaro : lecture saccadée des vidéos

Message par Esclapion » 18 Fév 2013, 13:38

:bjr:

N'en sois pas désolé. De toutes façons, tu fais le coup avec toutes les distributions, donc je m'y attendais. :rigole:

Je me souviens de toi avec LMDE, c'était pareil. :rire

Je préfère que les gens utilisent la distribution qui leur va, je ne suis pas actionnaire.

Quant au forum Arch, non, ils ne sont pas près de me revoir. J'y trouve l'ambiance mauvaise, trop guindée et trop élitiste. :maisnon: Dommage, d'ailleurs.
Esclapion
 

Re: Manjaro : lecture saccadée des vidéos

Message par patri-arch » 18 Fév 2013, 14:18

Et autrement, on aurait une idée du problème rencontré ? :idee:
( mis à part le noyau ou le driver vidéo )
Ordinosaure : Manjaro stable 32 bits XFCE/Mate
Laptop Toshiba Satellite A100 Intel Centrino Duo T2250 @ 1.73GHz - Ram 2Go
CG :AMD ATI Radeon Mobility X1400 - Carte son : Intel Corporation NM10/ICH7
+ EEPC 1001PXD manjaro 64 stable XFCE
Avatar de l’utilisateur
patri-arch
Contributeur
 
Message(s) : 727
Inscription : 23 Nov 2012, 17:40
Localisation : Du coté de Bordeaux (en bas du Médoc)

Re: Manjaro : lecture saccadée des vidéos

Message par Loubrix » 18 Fév 2013, 14:52

ça pourrait aussi venir d'un problème de pilotes graphique (libre ou propriétaire?); avec un peu plus de détails sur la config matérielle et les pilotes utilisés, on en saurait plus.
pour le reste, je vois mal comment ça pourrait fonctionner sous Arch et pas sous Manjaro: les paquets sont les mêmes...
Asus AIO - AMD E2 - Radeon HD 7340 - Manjaro 64 + Kf5 + Linux 3.14
Avatar de l’utilisateur
Loubrix
 
Message(s) : 6309
Inscription : 03 Déc 2012, 14:32
Localisation : Bessèges - 30

Re: Manjaro : lecture saccadée des vidéos

Message par Mimile » 19 Fév 2013, 13:39

Mon cher Patrice,

Permets-moi de te contredire quand tu me dis "tu fais le coup avec toutes les distributions".

En fait, je n'ai renoncé à LMDE que parce que je n'ai jamais réussi à y faire fonctionner mes imprimantes alors qu'elles tournent parfaitement sur tous mes autres OS (Lenny, Squeeze, Arch, Manjaro et d'autres distros que je n'ai pas conservées parce qu'elle ne me plaisaient pas).

Or, pour moi, ne pas pouvoir imprimer est rédhibitoire d'où mon abandon de LMDE.

Je n'évoquerais que pour la forme ses plantages à répétition et son pseudo-statut de "rolling release" qui est nettement surfait vu la lamentable cadence des mises à jour proposées ; ma vieille Debian Lenny que je conserve par nostalgie en reçoit encore régulièrement davantage.

En ce qui concerne Manjaro, c'est le problème du visionnage des vidéos qui n'a jamais trouvé de solution : dès que je lance un lecteur video, la consommation du CPU part en flèche pour atteindre 100 % dont 85 à 90 sont accaparés par X (voir mes captures d'écran en début de sujet).

Ce qui est déconcertant, c'est que j'ai configuré Manjaro de la même manière qu'Arch (module et driver nouveau vu l'ancienneté de ma carte graphique) et que sous Arch, le visionnage est parfait (à noter que j'ai dû désactiver le module "nouveau" et utiliser le driver "nv" depuis l'arrivée des noyaux 3.7.n.n).

Conclusion : J'ai délaissé LMDE et vais supprimer Manjaro vu que les autres distros que j'ai me donnent toutes satisfactions.

Il est dès lors excessif de ta part de me dire que j'abandonne toutes les distributions que je teste.

Quand à Arch, il est vrai que depuis que je l'ai installée (juillet 2012), elle a rudement évolué mais, malgré mes modestes connaissances de Linux, je n'ai jusqu'à présent pas été confronté à un problème insoluble et personnellement, je ne perçois pas le côté "élitiste" que tu lui attribues.

Bonne continuation avec Manjaro en espérant ne pas t'avoir contrarié avec mes commentaires.

Bien cordialement

Mimile
Mimile
 
Message(s) : 14
Inscription : 15 Jan 2013, 12:05

Re: Manjaro : lecture saccadée des vidéos

Message par Esclapion » 19 Fév 2013, 13:51

Bonjour Mimile,

Non, rassure-toi : tu m'as juste fait sourire.

Sur le forum Arch, Tuxce ( :bjr: ) m'a dit un jour : "J'espère que tu n'as pas un PC comme celui de Mimile, quand même !".

Venant de lui, qui est de ceux que j'apprécie, ça m'a surpris, d'autant qu'il ne savait pas qu'on se connaissait.

Tu y es donc très connu. :sourire:
Esclapion
 

Re: Manjaro : lecture saccadée des vidéos

Message par Mimile » 20 Fév 2013, 11:14

Ben oui, je suis connu sur le forum Arch pour la naïveté et/ou l'incongruité de mes questions, ce qui, évidemment prête à (sou)rire, ce dont je ne me formalise pas :rire ; pour ma défense, je préciserai que je suis un pur autodidacte qui a abordé Linux seul sans la moindre connaissance de ce système, ce qui m'a amené au départ (Mandrake 10.0) à poser des questions élémentaires sur le forum PCastuces à défaut de pouvoir échanger en temps réel avec des connaisseurs comme toi et d'autres.

Au fil du temps, j'ai acquis certaines notions ce qui m'a permis d'aborder des distributions a priori un peu plus complexes que Mandrake/Mandriva pour finir par Arch qui est pour moi accessible pour l'unique raison qu'il y a des tutoriaux très bien faits (encore que beaucoup soient devenus obsolètes depuis le passage à systemd) et un forum hyper-réactif.

Cela dit, mon PC est certes un ancêtre mais tant qu'il fonctionne correctement, je n'ai aucune envie de m'en débarrasser d'autant plus qu'au fil du temps, je l'ai amélioré physiquement (remplacement du disque unique d'origine de 40 Go 5400 t/m par deux DD de 200 Go 7200 t/m, installation d'une carte USB 2 (à l'origine c'était une USB 1.1), graveur DVD, barrettes mémoire, etc...) et logiciellement (je ne compte plus les modifications apportées ça et là pour améliorer le XP familial dont il est équipé.

Évidemment, aux yeux de ceux qui sont équipés de matériels récents et infiniment plus performants, mon PC est complètement obsolète (ce qui est vrai) mais il fait ce que je veux et c'est ce qui importe.

Il rencontre parfois des petits problèmes mais à en juger d'après les différents forums (fora), même les PC récents et performants n'en sont pas exempts.

Et pour en finir, nonobstant ses modestes performances, sous Arch, mon vieux PC boote en moins de 45 secondes entre le moment où je déclenche le boot (Grub 2 généré par Debian Squeeze) et le bureau gnome opérationnel (je fais abstraction du temps de chargement du BIOS vu qu'il s'allonge bêtement pendant quelques secondes pour afficher le screen splash Compaq)

Amicalement
Mimile
 
Message(s) : 14
Inscription : 15 Jan 2013, 12:05

Re: Manjaro : lecture saccadée des vidéos

Message par Esclapion » 20 Fév 2013, 11:31

Bonjour Mimile :bjr:

Oui, ça peut être marrant de gérer un ancêtre. J'en ai encore un dans un coin de ma pièce, en dépannage. :sourire: Mais il me semble que Logicien t'avait donné un conseil similaire.

Par contre, il ne devient plus possible de savoir si le problème est matériel ou logiciel, et on se prive de toutes les nouveautés.

Quant aux 45" sous Arch, quand je vois Yannu démarrer en 3"...
Esclapion
 

Re: Manjaro : lecture saccadée des vidéos

Message par Mimile » 21 Fév 2013, 13:58

3 secondes pour un boot complet depuis le bouton de démarrage de grub jusqu'à obtenir un bureau fonctionnel (gnome, KDE) ???

Permets moi de douter de cette information, vu que moi , il me faut déjà au moins 4 à 5 secondes pour écrire mon mot de passe (qui ne comporte que 8 caractères) pour lancer ma session gnome restreint.
Mimile
 
Message(s) : 14
Inscription : 15 Jan 2013, 12:05

Re: Manjaro : lecture saccadée des vidéos

Message par Esclapion » 21 Fév 2013, 14:06

:bjr:

Oui, ça m'a étonné aussi. Mais il a un ordinateur récent. Le mien a 3 ans, et j'ai :

Code : Tout sélectionner
[    8.021799] 5:1:1: cannot get freq at ep 0x5
[    8.153755] 5:1:1: cannot get freq at ep 0x5
[    8.194398] r8169 0000:02:00.0 enp2s0: link up
[    8.194404] IPv6: ADDRCONF(NETDEV_CHANGE): enp2s0: link becomes ready
[    8.261809] 5:1:1: cannot get freq at ep 0x5
[    8.593841] Bluetooth: RFCOMM TTY layer initialized
[    8.593851] Bluetooth: RFCOMM socket layer initialized
[    8.593852] Bluetooth: RFCOMM ver 1.11
[root@manjaro pat]# systemd-analyze
Startup finished in 4968ms (kernel) + 1165ms (userspace) = 6133ms
[root@manjaro pat]#


A noter que là, je suis particulèrement lent : d'habitude, vu de dmesg, je mets moins de 8". Et mon PC n'est pas optimisé du tout.

(edit)

Par contre, je suis en ouverture de session automatique, donc pas de mot de passe. Je pense que lui aussi.
Esclapion
 

Re: Manjaro : lecture saccadée des vidéos

Message par ewolnux » 21 Fév 2013, 14:18

Bonjour Mimile, bonjour Patrice

Comme Mimile je suis assez étonné de ces chiffres !

Sur le PC manjaro Mate, si je regarde ma montre, depuis le menu grub jusqu'au bureau fonctionnel (3 secondes de mdp comprises) > 31 secondes.

J'envoie un systemd-analyze qui me retourne :
Startup finished in 3653ms (kernel) + 7650ms (userspace) = 11303ms

edit : ma bécane n'est pas de toute première fraîcheur
Image
Desktop - Manjaro-KDE x86_64 Stable / Arch-KDE x86_64 - CPU : Intel® i5-3570K @ 3.40GHz - RAM 8 GO - Carte-mère : MSI Z77A-G45
Carte graphique : Intel® HD Graphics 4000 - Audio device: Intel Corporation Panther Point High Definition Audio Controller
Laptop – Manjaro-XFCE x86_64 - CPU : Intel Pentium Dual-Core B940 - Carte graphique : Intel HD Graphics 3000
Avatar de l’utilisateur
ewolnux
Administrateur
 
Message(s) : 9315
Inscription : 21 Nov 2012, 11:22
Localisation : Savoie

Re: Manjaro : lecture saccadée des vidéos

Message par Esclapion » 21 Fév 2013, 14:27

Chez moi, tout dépend du temps de la liaison Internet.

Je suis chez Free, et avec une Box pas du dernier modèle, mais c'est assez long.

Si la Box allait plus vite, je pourrais facilement gagner de 2 à 3". Pour le reste, j'ai bien un SSD, mais en Sata II, pas III, donc très bridé.

Reste ensuite la fréquence du CPU, qui est chez moi à 2,8 Ghz, pas à 3,5 comme les actuels, et on ne passe pas loin.
Esclapion
 

Suivant

Retour vers Multimédia

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 2 invité(s)