Trouvez ici les démarches courantes à faire en cas d'écran noir.

Ecran noir

#21Messageil y a 7 mois

imarco a écrit :
il y a 7 mois
sddm alors que je suis en login automatique?
Logiquement c'est bien sddm qui gère ton login auto donc le réinstaller peut être la solution.
Sinon quelle version du serveur X ?

pacman -Qi xorg-server
Il serait peut-être utile de le réinstaller :

sudo pacman -S xorg-server

Ecran noir

#22Messageil y a 7 mois

1.19.6-2
Paquet réinstallé mais startx donne le même retour.

Ecran noir

#23Messageil y a 7 mois

J'ai testé ça: 91400

mais niet...

Ecran noir

#24Messageil y a 7 mois

il reste le cas de downgrade sur sddm
en version 0.15x par downgrade
ou par maj
sudo pacman -U /var/cache/pacman/pkg/sddm-0.15.0-2-x86_64.pkg.tar.xz

Ecran noir

#25Messageil y a 7 mois

Fait: pas de changement :maisnon:
Et les news via quiterss apparaissent comme si de rien n'était comme d'habitude.

Ecran noir

#26Messageil y a 7 mois

alors j'ai tout de même plusieurs questions :
-initialement tu tente d'ajouter un noyau , et cette opération se passe mal.
c'est un noyau déjà présent dans le cache ( ancien ) ou bien par synchro pacman ?

- autre point , le chroot -a qui ne passe pas , cela n'est pas bon signe du tout :
et ce qui me surprends c'est ces message de non connexion , même après un reboot

- la version live est récente , ou c'est celle qui a permis d'installer sur ton ordi ?

- ton affichage est bien géré uniquement par le GPU Intel ?

- est ce qu'une version USB install plus récent démarre bien avec affichage graphique ?

j'ai bien peur que cela passe par sauvegarde /home et réinstall / uniquement

Ecran noir

#27Messageil y a 7 mois

1/ pour le noyau, je passe par le gestionnaire en graphique (4.4)
2/ pas d'explication mais le cd est très ancien (point 3)
4/ ton affichage est bien géré uniquement par le GPU Intel ? je dirais oui a priori
5/ pas de version usb (toujours du mal avec une clé bootable) mais je peux réessayer avec une version récente en live cd

Ecran noir

#28Messageil y a 7 mois

Gravé la dernière version de Manjaro et sudo manjaro-chroot -a se lance et identifie directement la partition sdd2 où est ma manjaro défectueuse.
Image

Si j'ai bien compris, cette commande magique monte directement la partition et ça évite de taper toutes les lignes qu'on tapait il y a encore quelques années?

Mais je fais quoi maintenant pour régler ce souci de boot?
Dans le Xorg server, il y a ces lignes:
19.686] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[ 19.686] Entry deleted from font path.
[ 19.686] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[ 19.687] Entry deleted from font path.
[ 19.687] (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[ 19.687] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[ 19.687] Entry deleted from font path.
[ 19.687] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
19.700] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[ 19.701] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 19.709] (--) PCI:*(0:0:2:0) 8086:1912:1462:7972 rev 6, Mem @ 0xde000000/16777216, 0xc0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[ 19.709] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
19.996] (WW) intel(0): Option "DRI3" is not used

Ecran noir

#29Messageil y a 7 mois

Sur la manjaro live, j'ai ça:

Image

et startkde au lieu de startx ne renvoie pas de message d'erreur mais juste une boîte de dialogue disant qu'il y a déjà une session de lancée.

Ecran noir

#30Messageil y a 7 mois

bonsoir ,

en démarrant sur l'install , si tu as l'interface graphique KDE ,
c'est ton environnement systeme sur tes disques qui a un problème.

le chroot hérite de ce qui a été lancé ,
par contre tu peux aller voir dans les logs système & dans /var/log.xorg0.log
tu connaîtra les raisons

essaye aussi de vérifier sous chroot

This command displays a list of broken symbolic links on your system. These links are not deleted by default. You have to decide yourself what to do with them. When you have doubt about deleting them, leave them on your system. They can sometimes cause problems, but they hardly use any hard drive space.

find -xtype l -print
(only if there are broken symlinks)

This command checks your local package r[/code] epository for consistency and shows missing packages, dependencies, or other errors. Please refer to "man pacman" for a more detailed explanation.

pacman -Dk

systemctl --failed

journalctl -p 3 -xb


a voir aussi depuis l'origine ce qui a été fait ( date lié à la demande de changement de noyau )

 
cat /var/log/pacman.log
pour les erreurs de Xorg :

 
more /var/log/Xorg0.log | grep 'EE'
Modifié en dernier par stephane le 16 Jan 2018, 07:36, modifié 1 fois.

Ecran noir

#31Messageil y a 7 mois

pas d'invalid symlinks
pacman -Dk donne database files for core extra community multilib does not exist

systemctl --failed 0 loaded units listed

journalctl -p 3 -xb
image ci-dessous
Image

cat /var/log/pacman.log et more (etc): no such file or directory

Image

Ecran noir

#32Messageil y a 7 mois

Et réinstaller le server x, non?

sudo apt-get remove --purge xserver-xorg-core à la sauce manjaro (pacman au lieu de apt-get)?
Vu ici: https://forum.ubuntu-fr.org/viewtopic.php?id=310201
Ou peut-être sudo dpkg-reconfigure xserver-xorg ?
Dans /var/log.xorg0.log il y a assez peu d'erreurs a priori (msg 28)

Je ne comprends pas ce qui bloque le boot (le bureau peut apparaître une seconde et disparaître juste après) :censure:

Ecran noir

#33Messageil y a 7 mois

On va tenter un truc..Renomme .config/ en Config par exemple et reconnecte toi.
Si c'est bon, tu devras refaire tes réglages persos.

Ecran noir

#34Messageil y a 7 mois

Salut le lève-tôt!!

Fait!
Je suis arrivé à l'écran de connexion et rentré mon mot de passe.

Et écran noir derrière avec la flèche de la souris opérationnelle...

startx donne le même message d'erreur.
startkde: $DISPLAY is not set or cannot connect to the X server.

Edit 5h47 je suis arrivé sur le bureau et j'ai pu accéder aux quelques fichiers présents mais quand j'ai cliqué sur le lanceur de bureau, il est reparti en écran noir...
lancé une console et mêmes messages d'erreur...

:café:

J'ai accès au pc mais le lanceur fait sauter la session...
:?:
Et là, j'écris depuis le pc en question...
Je me disais que j'allais devoir réinstaller mais là on est proche d'une solution moins extrême, non? Il y a la config à refaire mais mieux que de tout refaire...

Ecran noir

#35Messageil y a 7 mois

Lanceur supprimé

[marc@marc-pc ~]$ startx

/usr/lib/xorg-server/Xorg.wrap: Only console users are allowed to run the X server
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 7 requests (7 known processed) with 0 events remaining.
Couldn't get a file descriptor referring to the console
[marc@marc-pc ~]$ 

Sans lanceur, c'est quand même compliqué...

Ecran noir

#36Messageil y a 7 mois

erreur sur la commande

 
more /var/log/Xorg0.log | grep 'EE'

Ecran noir

#37Messageil y a 7 mois

toujours une erreur

ça sent la réinstallation...

Image

Ecran noir

#38Messageil y a 7 mois

ça sent la réinstallation...
oui en effet, le retour de pacman -Dk n'est pas bon du tout :? Avant de réinstaller, essaye de créer un nouvel utilisateur avec les mêmes droits que ton utilisateur courant. Cela te permettra de repartir sur du neuf, mais je crains que le problème soit davantage lié à la racine.

Ecran noir

#39Messageil y a 7 mois

il faut donc bien réinstaller et après ce sera ok?

Ecran noir

#40Messageil y a 7 mois

Pour créer un nouvel utilisateur tu peux le faire directement en graphique à l'aide manjaro-gestionnaire-de-paramètres ou via le terminal :

useradd -g users -m -s /bin/bash toto
passwd toto
Pour la réinstallation, il est possible de ne réinstaller que la racine (système) si tu as une partition de données séparée (/home) mais, il faudra virer, au préalable, l'ensemble des fichiers cachés de cette dernière.

Répondre