Problèmes et questions concernant l'édition Enlightenment.

Manjaro e22 17.1.5-stable

#21Messageil y a 7 mois

Cool & bien joué pour la manip. calamares (non mais, qui c'est le chef !) :bien
Est-ce seulement dans /etc/calamares/modules/welcome.conf que tu as "dressé" calamares en modifiant requiredRam: 1.0 pour la RAM nécessaire, tant que c'est frais ?
Parce qu'il y en partout du /calamares/modules/welcome.conf en live, pfuuu..!

Manjaro e22 17.1.5-stable

#22Messageil y a 7 mois

Oui, j'ai commencé par ça puis comme il râlait encore je lui ai cloué le bec en effaçant le test mémoire plus bas dans les lignes où est indiquée la liste des tests qu'il doit faire (je savais un peu ce que je faisais) je ne peux te donner l'intitulé exact parce le fichier n'est plus sur le pc une fois l'installation terminée...
Plutôt que modifier la taille de ram requise, c'est encore plus simple de supprimer le test...

Manjaro e22 17.1.5-stable

#23Messageil y a 7 mois

---
showSupportUrl: true
showKnownIssuesUrl: true
showReleaseNotesUrl: true

requirements:
requiredStorage: 7.9
requiredRam: 1.0
internetCheckUrl: https://manjaro.org
check:
- storage
- ram
- power
- internet
- root
required:
- storage
- ram
- root
En virant - ram de check: & required: dans /etc/bla/bla/welcome.conf donc ?

Manjaro e22 17.1.5-stable

#24Messageil y a 7 mois

C'est ça.
J'ai simplement effacé les lignes, sauvegardé puis relancé calamares...

Peut-être que la suppression de ram dans required est suffisant.

Manjaro e22 17.1.5-stable

#25Messageil y a 7 mois

Cool, bon à savoir, je vais d'ailleurs aller m'occuper de leur cas à ces check/required ! :bien

Yep, & merci pour le retour de test
Modifié en dernier par fassil le 03 Mar 2018, 17:17, modifié 1 fois.

Manjaro e22 17.1.5-stable

#26Messageil y a 7 mois

Je viens de réessayer :
Je confirme : la suppression de -ram dans la rubrique required suffit pour contourner un manque de ram.
Un warning indiquant la mémoire insuffisante s'affiche mais on peut continuer l'installation.

Et si on supprime également -ram dans la rubrique check ça passe sans aucun warning...

Ça serait peut-être une bonne idée d'enlever ce verrou pour les versions les plus légères.

Manjaro e22 17.1.5-stable

#27Messageil y a 7 mois

Bonjour,
Tentative vaine d'installer des paquets depuis AUR dans pamac :

Préparation...

Construction de ttf-ms-fonts...
Clonage dans 'ttf-ms-fonts'...
remote: Counting objects: 11, done.
remote: Compressing objects: 100% (11/11), done.
remote: Total 11 (delta 3), reused 4 (delta 0)
Dépaquetage des objets: 100% (11/11), fait.
==> ERREUR : Lancer makepkg en tant que root n'est pas autorisé car cela pourrait
causer des dommages catastrophiques et permanents à votre système.

==> ERREUR : An unknown error has occurred. Exiting...
Quelqu'un aurait-il une idée de l'origine du problème ?

Manjaro e22 17.1.5-stable

#28Messageil y a 7 mois

bonjour

il suffit de lire le message d'erreur
jns55 a écrit :
il y a 7 mois
==> ERREUR : Lancer makepkg en tant que root n'est pas autorisé car cela pourrait
causer des dommages catastrophiques et permanents à votre système.
Reste a comprendre pourquoi tu lances pamac en root :confus:

Manjaro e22 17.1.5-stable

#29Messageil y a 7 mois

Reste a comprendre pourquoi tu lances pamac en root
Ben, j'ai pas le choix : lorsque que je lance pamac, il me demande le mot de passe. D'ailleurs comment je pourrais installer des paquets sans avoir les droits root?

Et si je le lance en user, il me renvoie une erreur d'authentification lorsque j'essaie d'installer un paquet, et c'est normal non ?

Manjaro e22 17.1.5-stable

#30Messageil y a 7 mois

Il ne faut jamais lancer une application graphique en root , ou alors il faut passer par gksudo pour un environnement en GTK.
Ton problème semble venir d'un problème de reconnaissance de mot de passe, probablement saisi en qwerty ou avec des accents.
A noter que sudo demande le MP utilisateur et non root si différent.
Tu peux le modifier en te connectant en root via su - avec le MP root cette fois puis passwd toto
Après deux confirmations, tu auras un mp tout neuf que tu auras choisis simplement .

Manjaro e22 17.1.5-stable

#31Messageil y a 7 mois

Je précise mon problème :
Moi, je lance simplement l'application "Ajouter/suppr" des programmes à partir du menu principal.
Le mot de passe sudo est demandé et l'application s'ouvre normalement ce n'est donc pas un problème de reconnaissance du mdp.
Lorsque j'installe un paquet venant des dépôts principaux, pas de problème il s'installe correctement mais c'est lorsque j'installe un paquet venant de AUR que le problème survient et uniquement dans ce cas, les fichiers sont téléchargés normalement et c'est après que ça coince : il me reproche de lancer makepkg en root ! mais ce n'est pas moi qui lance makepkg, c'est pamac, moi j'ai juste lancé pamac en root et si je le lance en user j'ai un message d'erreur (c'est normal). Il doit y avoir un problème quelque part dans la config de pamac. Pourtant /etc/pamac.conf est un fichier très simple, je ne vois rien dedans qui puisse être la cause... Et j'ai essayé avec plusieurs paquets différents même problème.
J'utilise actuellement manjaro-e22-17.1.6 et c'est exactement le même problème avec la version e22-17.1.1.

Manjaro e22 17.1.5-stable

#32Messageil y a 7 mois

:bjr:
Bizarre
Normalement quand tu lances PAMAC, tu n'as pas besoin de donner ton mot de passe
C'est uniquement quand tu veux installer que tu dois renseigner ton mdp

En tous cas chez moi cela marche comme cela et je n'ai pas de soucis avec AUR

Essaie de lancer pamac depuis un terminal pour voir si tu as le même comportement

Manjaro e22 17.1.5-stable

#33Messageil y a 7 mois

En lançant pamac depuis le terminal, pas de demande de mdp mais erreur d'authentification lorsque je veux installer un paquet...

Manjaro e22 17.1.5-stable

#34Messageil y a 7 mois

c'est sans doute qu'il manque quelque chose avec cette version de E (polkit? je suppose) :saispas: polkit-efl ?
voir cela avec le créateur de l'iso (pas facile de se rappeler qui :gsourire: )

Manjaro e22 17.1.5-stable

#35Messageil y a 7 mois

papajoke a écrit :
il y a 7 mois
c'est sans doute qu'il manque quelque chose avec cette version de E (polkit? je suppose) :saispas: polkit-efl ?
Vérifié pour polkit-efl, ça change rien. :maisnon:

Manjaro e22 17.1.5-stable

#36Messageil y a 7 mois

attend le retour de fassil, il te donnera facilement la bonne réponse
Avec gnome il y bien un polkit à installer, mais c'est s'en doute très sale avec E.

Sinon , si tu es pressé, tu as la ligne de commande, ca n'a rien de difficile de faire un yaourt ttf-ms-fonts (sans sudo)

Manjaro e22 17.1.5-stable

#37Messageil y a 7 mois

'LLo,

Ouaip, il y a un polkit-efl-git fort capricieux qui marche en dur chez moi, mais pas moyen encore de l'intégrer à l'iso, pfuuu !
Pamac-manager (ajout/suppr) démarre donc via un gksu pour fonctionner normalement, mais pour AUR, marche pô ! (pas de yaourt en super-utilisateur/root !).
Il faudra donc passer par yaourt en cli & pour que cela fonctionne:
ajout autoconf automake binutils bison fakeroot gcc libtool package-query patch make
(ajout -> alias de sudo pacman -S)
Ensuite:
yaourt paquet-désiré
Un numéro, quel éditeur ? nano, éditer le BUILD Non, puis Oui à tout jusqu'à la demande de passwd une fois le paquet compilé & prêt à être installé (le train-train, quoi :siffle ).

Yaourt est toujours à utiliser avec modération (c'est pour cela qu'il n'est pas opérationnel directement dans l'iso, comme dans toutes celles de manjaro, sauf erreur...) !

Manjaro e22 17.1.5-stable

#38Messageil y a 7 mois

Bonjour,
il y a un polkit-efl-git fort capricieux qui marche en dur chez moi,
,
J'ai essayé : je l'ai installé, redémarré le pc, pas de changement.
Par contre, je n'avais pas supprimé le polkit qui était déjà installé, ça a pu jouer un rôle ?

Manjaro e22 17.1.5-stable

#39Messageil y a 7 mois

'LLo,

Nope, car polkit-efl-git est une dépendance de polkit, donc si tu vires polkit, l'autre suit (ainsi que pas mal de bricoles). Essaye sans valider, juste pour voir..! :siffle

Répondre