Problèmes et questions concernant l'édition Enlightenment.
Répondre

notifier

#1Messageil y a 4 ans

Bonjour
Je n'ai pas su faire...comment avoir octopi notifier, ou son équivalence, avec enlightnement?
Modifié en dernier par jyves le 06 Mai 2014, 17:44, modifié 1 fois.

notifier

#2Messageil y a 4 ans

fassil te répondra mieux, mais as-tu installé :

sudo pacman -S octopi octopi-notifier

Déconnexion - Connexion.

notifier

#3Messageil y a 4 ans

Oui, installé
Je suis en double, un bureau XFCE et Enlightnement, j'ai le joli fantôme chez Xfce, j'aimerais rester enlightnementé au quotidien, c'est le seul bémol qui me reste, l'info de mise à jour.

notifier

#4Messageil y a 4 ans

Plus qu'à attendre le passage du lynx ; il va te dépanner à coup sûr.

notifier

#5Messageil y a 4 ans

tu peux donner le retour de la commande:

ps aux | grep octopi

notifier

#6Messageil y a 4 ans

Hello,

Vérifier que tu l'as dans "applications aux démarrage" via Omni (taper dém...). ca devrait l'ajouter dans le systray (module -> zone de notification)
Vérifie aussi que le module est chargé (taper mod dans Omni), dans la section utlitaires.
Le systray, c'est un peu "Beyrouth" en ce moment chez E :siffle

notifier

#7Messageil y a 4 ans

Loubrix a écrit :tu peux donner le retour de la commande:

ps aux | grep octopi


Le retour:

ps aux | grep octopi
root      1570  0.0  0.2 147456  4740 ?        Sl   12:01   0:00 /usr/lib/octop /pacmanhelper
jyves     5534  0.0  0.0  10944  1100 pts/0    SN+  20:15   0:00 grep --color=tty -d skip octopi


fassil a écrit :Vérifier que tu l'as dans "applications aux démarrage" via Omni (taper dém...). ca devrait l'ajouter dans le systray (module -> zone de notification)
Vérifie aussi que le module est chargé (taper mod dans Omni), dans la section utlitaires.

L'est tout bon, mais peut-être n’apparaît-il qu'en cas d'alerte, pas de fantôme vert qui veille?

notifier

#8Messageil y a 4 ans

Tu dois trouver aussi un octopi-notifier.desktop ou équvalent dans /etc/xdg/autostart pour ếtre sur.

Ps: Y'en manquait un bout,pfuuu :siffle
Modifié en dernier par fassil le 05 Mai 2014, 19:51, modifié 1 fois.

notifier

#9Messageil y a 4 ans

sauf que là ton notifier n'est pas lancé, tu devrais avoir quelque chose comme ça:

jyves     1162  0.0  0.6 426644 22828 ?        Sl   mai04   0:02 octopi-notifier

il faudrait nous montrer le contenu du fichier /etc/xdg/autostart/octopi-notifier.desktop, et, s'il existe, /home/jyves/.config/autostart/octopi-notifier.desktop

notifier

#10Messageil y a 4 ans

Loubrix a écrit :sauf que là ton notifier n'est pas lancé, tu devrais avoir quelque chose comme ça:

jyves     1162  0.0  0.6 426644 22828 ?        Sl   mai04   0:02 octopi-notifier

il faudrait nous montrer le contenu du fichier /etc/xdg/autostart/octopi-notifier.desktop, et, s'il existe, /home/jyves/.config/autostart/octopi-notifier.desktop


/etc/xdg/autostart/octopi-notifier.desktop,:

[Desktop Entry]
Name=Octopi Notifier
Icon=octopi
Exec=octopi-notifier
Terminal=false
Type=Application
Categories=GNOME;GTK;System;
#NotShowIn=GNOME;XFCE;LXDE;KDE;
StartupNotify=true


/home/jyves/.config/autostart/octopi-notifier.desktop
n'existe pas

notifier

#11Messageil y a 4 ans

tout est en place pour que ça démarre, reste à voir pourquoi Enlightenment ne le lance pas, et pour ça, je passe la main à Fassil, grand maître de l'univers es-E17 ;)

notifier

#12Messageil y a 4 ans

Hello,

Cela doit venir du thème & si tu est sous E18, les thèmes E17 fonctionnent moyennement. Vérifie dans de le menu principal, enlightenment -> à propos & à propos de ce thème.
Tu peux aussi installer un utilitaire genre clipit ou parcellite (presse-papier à entrées multiples), si il n'apparait pas au reboot dans le systray , c'est ça.
Tu en as quelques uns par là pour E18 que tu dois copier soit dans ~/.elementary/themes (perso), soit dans /usr/share/elementary/themes (système).
& via Omni -> thè, ect...

notifier

#13Messageil y a 4 ans

@ Fassil: tu sembles penser à un problème de thème qui fait que l'icône d'Octopi ne s'affiche pas dans le tray (j'y ai pensé aussi), mais ici, le service octopi-notifier n'est carrément pas démarré; donc je me demande si Enlightenment prend en compte les services placés dans /etc/xdg/autostart, ou s'il y a quelque chose à activer pour ça ? un paquet à installer ?

déjà, on sait que ce n'est pas un problème avec Dbus, puisque d'une part octopi-notifier n'en a pas besoin, et d'autre part Pacman-helper, qui l'utilise, est bien lancé.

pour ce qui est du problème éventuel d'icône avec le thème, je propose d'essayer de lancer manuellement octopi-notifier depuis un terminal, pour voir si l'icône s'affiche bien dans le systray de E.

notifier

#14Messageil y a 4 ans

En lançant octopi-notifier en terminal, rien ne s'affiche.
Je jette un œil au systray-setting et active (au pif)"enable xembed), et là ça marche...
Merci de votre aide, je passe en résolu

notifier

#15Messageil y a 4 ans

sauf que pour le moment, tu l'as démarré manuellement, mais ça donne quoi au reboot ?

notifier

#16Messageil y a 4 ans

Il est présent au redémarrage.
L'icone est laide, trés laide et semble se diviser au fil du temps...

notifier

#17Messageil y a 4 ans

oui, Fassil t'en parlera mieux, mais il semble que le systray de E a des problèmes avec certaines icônes...

notifier

#18Messageil y a 4 ans

Salut,

Yep, & pour s'en convaincre, voir l'icône de parcellite en haut ici.
& comme c'est aléatoire, comme comportement, ça me laisse pantois...

A+

Répondre