Tout ce qui concerne internet

Comment rester en firefox gtk2

#21Messageil y a 2 ans

:bjr:

La version 47.0 est maintenant disponible toute compilée ici.
A installer, après téléchargement, avec un petit sudo pacman -U

Comment rester en firefox gtk2

#22Messageil y a 2 ans

:salut:
Exact sauf que cette fois pas de francisation... :saispas:

Comment rester en firefox gtk2

#23Messageil y a 2 ans

imarco a écrit ::salut:
Exact sauf que cette fois pas de francisation... :saispas:

:bjr:

Tu installes ce paquet.

Comment rester en firefox gtk2

#24Messageil y a 2 ans

Merci. :bien

Comment rester en firefox gtk2

#25Messageil y a 2 ans

Nouveau fichier pour passer en 47.0.2 mais après l'installation FF ne se lance pas...

J'ai ça en console:

[marc@manjaro ~]$ firefox-gtk2
bash: firefox-gtk2 : commande introuvable
[marc@manjaro ~]$ firefox
XPCOMGlueLoad error for file /usr/lib/firefox/libxul.so:
libhunspell-1.4.so.0: cannot open shared object file: No such file or directory
Couldn't load XPCOM.
[marc@manjaro ~]$


Sur AUR, un intervenant conseille de créer un lien symbolique de la librairie 1.4 vers là où se trouve la 1.3.
Je pense que je vais attendre le correctif "officiel"...

https://aur.archlinux.org/packages/firefox-gtk2/

Comment rester en firefox gtk2

#26Messageil y a 2 ans

imarco a écrit :Nouveau fichier pour passer en 47.0.2 mais après l'installation FF ne se lance pas...
J'ai ça en console:

[marc@manjaro ~]$ firefox-gtk2
bash: firefox-gtk2 : commande introuvable
[marc@manjaro ~]$ firefox
XPCOMGlueLoad error for file /usr/lib/firefox/libxul.so:
libhunspell-1.4.so.0: cannot open shared object file: No such file or directory
Couldn't load XPCOM.
[marc@manjaro ~]$

:bjr:

Idem chez moi ; j'ai remis la version 47.0.1.

Comment rester en firefox gtk2

#27Messageil y a 2 ans

Je voudrais signaler dans AUR le paquet oomox-git, un éditeur GTK simple, pour certains paramètres (couleurs, arrondi des boutons, gradient), qui permet de modifier et d'exporter les thèmes de la liste fournie pour les rendre compatibles GTK 3.20. Cela m'a permis de repasser en Firefox normal.

Comment rester en firefox gtk2

#28Messageil y a 2 ans

Smurf a écrit :Je voudrais signaler dans AUR le paquet oomox-git, un éditeur GTK simple, pour certains paramètres (couleurs, arrondi des boutons, gradient), qui permet de modifier et d'exporter les thèmes de la liste fournie pour les rendre compatibles GTK 3.20. Cela m'a permis de repasser en Firefox normal.

Bonsoir, :sourire:
Je ne sais pas l'utiliser....(pas intéressé...); mais, ce qu'il faut faire :
- installer Git sudo pacman -S git
- 1 petit yaourt oomox-git
choisir 1 , et le compiler.../ installer
une fois ces opérations effectuées, le lancer :
- oomox-gui
et au boulot :manger:

Comment rester en firefox gtk2

#29Messageil y a 2 ans

Choisir dans la liste le thème que l'on veut modifier, lui donner un nom en cliquant sur l'icône de gauche, faire les modifs puis sauvegarder avec l'icône qui représente une disquette et enfin exporter avec le bouton du même nom.
Le thème est enregistré dans ~/.themes sous oomox-nom_du_thème, on peut le voir apparaître dans la liste dans Xfce, Menu-->Apparence-->Style.
Une petite capture :
Image

Comment rester en firefox gtk2

#30Messageil y a 2 ans

Apparemment la version gtk2 ne passe plus chez moi (47.01 ou 2).
Avec oomox, on retrouve comment l'aspect du FF version gtk2?

Comment rester en firefox gtk2

#31Messageil y a 2 ans

oomox convertit un thème de la liste en un thème compatible GTK 3.20, ce qui permet un affichage correct dans Firefox et dans les autres applications utilisant GTK3.

Comment rester en firefox gtk2

#32Messageil y a 2 ans

Ok, merci.
Je vais trifouiller dans les thèmes.
:merci:

Comment rester en firefox gtk2

#33Messageil y a 2 ans

:bjr:

Peut-être donnée ailleurs, solution pour que la version firefox-gtk2 47.0.2 s'ouvre (firefox-gtk2 cherche /usr/lib/libhunspell-1.3.so.0) :
copier-coller /usr/lib/libhunspell-1.4.so.0 > /usr/lib/libhunspell-1.3.so.0

Comment rester en firefox gtk2

#34Messageil y a 2 ans

Oui et il semble même qu'un lien symbolique suffise.
J'attendais un correctif histoire de ne pas bidouiller. :gsourire:

Comment rester en firefox gtk2

#35Messageil y a 2 ans


Comment rester en firefox gtk2

#36Messageil y a 2 ans

:bjr:

:bien

Comment rester en firefox gtk2

#37Messageil y a 2 ans

Bonjour,

bon, peut-être que "c'est mal", mais perso je rajoute toujours le dépôt archlinuxcn dans mon pacman.conf. Une mine de logiciels précompilés, dont firefox-gtk2 actualisé que j'ai également installé (toujours des problèmes de thème avec la version gtk3 et gtk3 3.20), et on trouve aussi google-chrome ou encore le très bon freefilesync, etc...
Si vous ajoutez ce dépôt, notez qu'il faut en premier lieu installer le paquet archlinuxcn-keyring.

A+

Comment rester en firefox gtk2

#38Messageil y a 2 ans

En fait, on utilise les paquets confectionnés par markzz car la compil AUR échoue à chaque fois... :clindoeil:

Je ne connaissais pas l'astuce du paquet arch pour ma part...

Comment rester en firefox gtk2

#39Messageil y a 2 ans

papa33 a écrit :bon, peut-être que "c'est mal", mais perso je rajoute toujours le dépôt archlinuxcn dans mon pacman.conf.

le dépôt archlinuxcn est un dépot archlinux et non manjaro !
nous ne sonnes pas sous archlinux(?) il y a donc un décalage de versions, par exemple manjaro est passé à gtk3.2 2 mois après archlinux; aujourd’hui le kde archilinux est n'est pas la même que celle de arch...
Donc, ce décalage peut entraîner des problèmes de compatibilité à cause des versions.

De plus certains paquets manjaro sont modifiés par les développeurs manjaro (par exemple notre pacman n'est pas le même que celui de arch). Certains paquets de ce dépôts sont dans les paquets officiels de manjaro.

Comment rester en firefox gtk2

#40Messageil y a 2 ans

Je sais papajoke, mais en mettant le dépôt tout à la fin du pacman.conf (bien sûr), je n'ai jamais eu le moindre problème à titre personnel, je prends juste les paquets dont j'ai besoin. Je n'ai jamais vu de mise à jour de paquets officiels depuis archlinuxcn. A priori, ce ne sont que des packages qu'on ne trouve pas dans community. Je suppose que si je mettais le dépôt avant les dépôts officiels, alors là oui je risquerais d'avoir des problèmes. Si j'ai un souci, je ne manquerai pas de le signaler.

Répondre