Tout ce qui concerne internet

Problème cyberghost

#1Messageil y a 3 mois

Salut,
Depuis la version du noyau 5.9 mon vpn ne fonctionne plus. Il me signale simplement une erreur d'ip lors de la connection alors que je ne suis pas intervenu sur la configuration de cyberghost..
Pour info tout fonctionnait parfaitement avec le noyau 5.8
Comment résoudre ce soucis?

Problème cyberghost

#2Messageil y a 3 mois

Bonjour.
Honnêtement, je pense que le noyau 5.9 n'est pas encore au point.
J'ai des soucis de reconnaissance de ports USB2 qui disparaissent en repassant sur le 5.4.
Attendons qu'il soit plus abouti avant de migrer vers ce tout jeune kernel.

Problème cyberghost

#3Messageil y a 3 mois

Bonjour
même cas de figure avec le même fournisseur et le même noyau.

Problème cyberghost

#4Messageil y a 3 mois

Bonjour,

Personnellement, je n'ai pas de vpn. :shock:
Mais vu que le kernel principal a été changé (et que cela doit fonctionné en passant sur le kernel précédant principal sur lequel il fonctionnait), il doit juste suffir de lui indiqué l'ip afin que cela refonctionne encore. :o:roll:

Mes 2 cents.

Problème cyberghost

#5Messageil y a 3 mois

J'avoue ne pas comprendre, j'avais déjà galéré pour la mise en place de ce VPN (auto non prévu pour Manjaro).
Il va falloir que je me remette à la documentation.

Problème cyberghost

#6Messageil y a 3 mois

C'est un cli ou une gui ?

Si c'est un cli, normalement man nomduprog devrait suffir. A moins qu'ils aient un readthedoc ?
Après il doit certainement avoir un fichier de configuration caché à renseigner à la main. Mais la cli serait plus rapide à mon avis ..............à condition d'avoir la bonne commande. :rigole::rigole:

Problème cyberghost

#7Messageil y a 3 mois

bonjour

ton solf utilise openvpn il me semble ?

Il y a un bug avec openvpn 2.5.0-1 ... peut-être pas encore corrigé (somme avec une version supérieure) ? car dans les toutes dernières annonces inter ils préconisent de passer à la version 2.4 :saispas:

Problème cyberghost

#8Messageil y a 3 mois

Cenwen a écrit : il y a 3 mois C'est un cli ou une gui ?

Si c'est un cli, normalement man nomduprog devrait suffir. A moins qu'ils aient un readthedoc ?
Après il doit certainement avoir un fichier de configuration caché à renseigner à la main. Mais la cli serait plus rapide à mon avis ..............à condition d'avoir la bonne commande. :rigole::rigole:
Pour ma part suis pas assez au parfum pour te renseigner par contre je l'installe de cette façon(mais je vais vérifier car je crois qu' il y a une nouvelle autre possibilité sur cyberghost).
dans un dossier j'ai 4 fichiers: ca.crt client.crt client.key openvpn.ovpn
Comme le demandait papajoke, oui il utilise openvpn

Problème cyberghost

#9Messageil y a 3 mois

Merci eyzer24. Je n'ai jamais fait cela.
Le tutoviewtopic.php?t=4493 est-il toujours d'actualité ? Je ne voudrais pas faire une grosse bétise.

J'ai commencé à lancer la commande et voilà la réponse :

 downgrade openvpn                                                        

Downgrading from A.L.A. is disabled on the stable branch. To override this behavior, set DOWNGRADE_FROM_ALA to 1 .
See https://wiki.manjaro.org/index.php?title=Using_Downgrade  for more details.
et lorsque je vais à l'adresse indiquée j'ai
Using Downgrade
Sauter à la navigationSauter à la recherche
Il n’y a pour l’instant aucun texte sur cette page. Vous pouvez faire une recherche sur ce titre dans les autres pages, ou rechercher dans les journaux associés, mais vous n’avez pas la permission de créer cette page.
Y-a comme qui dirait un soucis.....

Problème cyberghost

#10Messageil y a 3 mois

ce message indique qu'il faut passer une variable d'environnement

DOWNGRADE_FROM_ALA=1 downgrade nom_du_paquet
c'est juste une sécurité car: ces paquets "distants" proviennent de archlinux et non de manjaro donc il faut bien savoir ce que l'on fait car il y a risque de casser sa distribution

le wiki manjaro (ancienne version est archived-wiki ;))

Problème cyberghost

#11Messageil y a 3 mois

Merci Papajoke,
ta phrase
donc il faut bien savoir ce que l'on fait car il y a risque de casser sa distribution
ne me fera pas aller plus loin.......
Je vais donc attendre et espérer que ...la solution m'arrive toute faîte :roll: ou tenté sur un de mes anciens PC pour essayer de comprendre comment faire, encore faut-il que je le rebranche....

Problème cyberghost

#12Messageil y a 3 mois

aucun problème avec openvpn :wink: le grand danger vient lorsque l'on downgrade un paquet manjaro (grub, pacman, ...) car on récupère la version archlinux non compatible avec nous
Au pire avec ton paquet c'est d'avoir une incompatibilité de version dans les dépendances : pas trop grave juste il ne vas pas fonctionner et ici il n'est pas indispensable au système, voire même il va refuser de s'installer.

Problème cyberghost

#13Messageil y a 3 mois

En fait le problème actuel de cyberghost ne vient pas du noyau 5.9 mais d'une autre mise à jour car je viens de restaurer une un de mes pc ma version manjaro précédente avec le noyau 5.8 et suite à des mises à jour le vpn ne fonctionne plus..
Quelle galère :snif

Problème cyberghost

#14Messageil y a 3 mois

eyzer24 a écrit : il y a 3 mois En fait le problème actuel de cyberghost ne vient pas du noyau 5.9 mais d'une autre mise à jour car je viens de restaurer une un de mes pc ma version manjaro précédente avec le noyau 5.8 et suite à des mises à jour le vpn ne fonctionne plus..
Quelle galère :snif
Tout a fait d'accord. J'attends des nouvelles de Cyberghost. La dernière fois il ont été réactif, j'espère qu'il seront dans ce cas de figure

Problème cyberghost

#15Messageil y a 3 mois

Puisque le problème semble venir de la version d'openvpn, la solution serait soit de donwgrader openvpn soit de changer pour wireguard. Il faudrait savoir si norvpn le fait, vu que vous êtes en contact, poser la question et quelle est la procédure. Perso j'opterai pour la 2eme solution cad WireGuard. De toutes façons, à terme, les jours openvpn sont compter car c'est son remplacant. :siffle

Problème cyberghost

#16Messageil y a 3 mois

Cenwen a écrit : il y a 3 mois Puisque le problème semble venir de la version d'openvpn, la solution serait soit de donwgrader openvpn soit de changer pour wireguard. Il faudrait savoir si norvpn le fait, vu que vous êtes en contact, poser la question et quelle est la procédure. Perso j'opterai pour la 2eme solution cad WireGuard. De toutes façons, à terme, les jours openvpn sont compter car c'est son remplacant. :siffle
Et comment remplacer remplacer openvpn par wireguard sans problemes? faudra t-il virer openvpn completement?

Problème cyberghost

#17Messageil y a 3 mois

Je ne pense pas. De toutes façons, en installant wireguard-tools et wireguard-dkms, il te le dira s'il faut le désinstaller. Mais perso je ne pense pas. Tout ce passe plutot dans des fichiers de configurations A mon avis.
Note : wireguard-dkms n'est peut-être pas nécessaire car on a des kernels superieur au 5.6 (ou l'inverse ?)
Le mieux serait de tester en live, en installant d'abord openvpn, le configurer pour cyberghost, puis faire install et modif pour wireguard. Ensuite indiquer probablement à cyberghost d'utiliser wireguard. Après c'est ce que moi je ferai au début.


Je ne peux malheureusement pas t'aider sur ce coup car je n'ai pas ni cyberghost ni de vpn. En en plus j'ai un routeur :clap:maisnon::pleure::pleure:

Un peu de lecture sur le sujet en français et en anglais :
flozz1
flozz2
flozz3
blog libre
archlinux
cyberghost1
cyberghost2
cyberghost3
cyberghost4

Problème cyberghost

#18Messageil y a 3 mois

Merci Cenwen, déjà ton 1er lien que je suis en train de lire me donne envie d'essayer ce changement.
Si je n'y arrive pas j'attendrai une nouvelle MAJ et suis en train de voir ça aussi avec cyberghost car ils font certains tutoriaux avec d'eutres distributions linux mais pas encore avec Manjaro, va falloir que eux aussi s'adaptent..
Merci :wink:

Problème cyberghost

#19Messageil y a 2 mois

je viens de contacter cyberghost et ils me donnent cette commande qui ne fonctionne pas:

sudo cyberghostvpn --traffic --country-code FR --city Paris --wireguard --connect
ensuite il me disent que cyberghost n'est pas compatible avec Manjaro lol
donc leur ai demandé le remboursement. C'est quand mm dommage :desole:

Problème cyberghost

#20Messageil y a 2 mois

Donc j'envisage de prendre un abonnement sur nordvpn et je regardais ce tuto https://wiki.archlinux.org/index.php/NordVPN
Juste pour être sur, à la section
Enable NordLynx (Wireguard)
je suppose que je dois avoir précédemment installé wireguard-tools ??
Ma connection de base actuelle via openvpn fonctionnera t'elle toujours ou faudra t'il l'adapter à wireguard?

Je clos ce post en j'en ouvre un autre ce sera plus clair
Répondre