Tout ce qui concerne internet

Flash installé mais toujours demandé

#1Messageil y a 6 mois

Bonjour

j'ai installé le navigateur Vivaldi, sur certain sites, comme Deezer, il est demandé d'installer flash-player.
Flash player n’étant pas dans pacman, je fais:

yaourt flash player
Malgré cela, Deezer me demande encore d'installer flash player, que dois je faire ?

Voici le déroulement de l’opération:

yaourt flash player
1 extra/flashplugin 28.0.0.137-1 [installed]
    Adobe Flash Player NPAPI
2 extra/pepper-flash 28.0.0.137-1 [installed]
    Adobe Flash Player PPAPI
3 community/minitube 2.9-3
    A native YouTube client in Qt. Watch YouTube videos without Flash Player
4 multilib/lib32-flashplugin 28.0.0.137-1
    Adobe Flash Player for 32-bit Mozilla-based browsers                                                                                                                
5 aur/cherrymusic 0.41.1-1 (12) (0,38)                                                                                                                                  
    A standalone HTML5 (with Flash fallback) music streaming server based on CherryPy and jPlayer.                                                                      
6 aur/cherrymusic-devel-git 20160210-1 (3) (0,00)                                                                                                                       
    A standalone HTML5 (with Flash fallback) music streaming server based on CherryPy and jPlayer. Git devel-branch.                                                    
7 aur/flashplayer-projector 28.0.0.126-1 (0) (0,00)                                                                                                                     
    Standalone (a.k.a. projector) version of Adobe's Flash Player                                                                                                       
8 aur/flashplayer-standalone 28.0.0.126-2 (138) (1,53)                                                                                                                  
    Adobe Flash Player (Standalone)                                                                                                                                     
9 aur/flashplayer-standalone-debug 28.0.0.137-1 (16) (0,17)                                                                                                             
    Standalone, debug version of Adobe Flash Player                                                                                                                     
10 aur/flashplugin-beta 25-1 (28) (0,00)                                                                                                                                
    Adobe Flash Player Beta                                                                                                                                             
11 aur/flashplugin-focusfix 1:1.0-1 (12) (0,00)                                                                                                                         
    Multi-monitor full-screen fix for Adobe Flash Player                                                                                                                
12 aur/lightspark-git 0.8.0.r45.g06d58822-1 (121) (0,54)                                                                                                                
    An open source flash player implementation                                                                                                                          
13 aur/pianobar-git 711.b534a3b-1 (52) (0,01)                                                                                                                           
    A free/open-source, console-based replacement for Pandora's Flash player                                                                                            
14 aur/swfdec-gnome 2.30.1-2 (65) (0,03)                                                                                                                                
    Standalone Flash player and thumbnailer for the GNOME desktop                                                                                                       
==> Numéro(s) des paquets à installer (ex: 1 2 3 ou 1-3)                                                                                                                
==> ----------------------------------------------------                                                                                                                
==> 1-3                                                                                                                                                                 
                                                                                                                                                                        
[sudo] Mot de passe de watoz :                                                                                                                                          
avertissement : pepper-flash-28.0.0.137-1 est à jour -- réinstalle                                                                                                      
avertissement : flashplugin-28.0.0.137-1 est à jour -- réinstalle                                                                                                       
résolution des dépendances...                                                                                                                                           
recherche des conflits entre paquets...                                                                                                                                 
                                                                                                                                                                        
Paquets (3) flashplugin-28.0.0.137-1  minitube-2.9-3  pepper-flash-28.0.0.137-1                                                                                         
                                                                                                                                                                        
Taille totale du téléchargement :   0,79 MiB                                                                                                                            
Taille totale installée :         42,58 MiB                                                                                                                             
Taille de mise à jour nette :      2,85 MiB                                                                                                                             
                                                                                                                                                                        
:: Procéder à l’installation ? [O/n] O                                                                                                                                  
:: Récupération des paquets...                                                                                                                                          
 minitube-2.9-3-x86_64                                                      805,2 KiB  3,37M/s 00:00 [############################################################] 100%
(3/3) vérification des clés dans le trousseau                                                        [############################################################] 100%
(3/3) vérification de l’intégrité des paquets                                                        [############################################################] 100%
(3/3) chargement des fichiers des paquets                                                            [############################################################] 100%
(3/3) analyse des conflits entre fichiers                                                            [############################################################] 100%
(3/3) vérification de l’espace disque disponible                                                     [############################################################] 100%
:: Traitement des changements du paquet...                                                                                                                              
(1/3) réinstallation pepper-flash                                                                    [############################################################] 100%
(2/3) réinstallation flashplugin                                                                     [############################################################] 100%
(3/3) installation de minitube                                                                       [############################################################] 100%
:: Exécution des crochets de post-transaction...                                                                                                                        
(1/3) Updating icon theme caches...                                                                                                                                     
(2/3) Arming ConditionNeedsUpdate...                                                                                                                                    
(3/3) Updating the desktop file MIME type cache...
[gaz@gaz88-pc ~]$
Modifié en dernier par Brooo le 30 Jan 2018, 18:18, modifié 1 fois.

Flash installé mais toujours demandé

#2Messageil y a 6 mois

Bonjour, Vivaldi ce serait plutôt pepperflash :

sudo pacman -S pepper-flash
mais je vois qu'il est aussi installé, peut-être que vider le cache du navigateur... :saispas:

Flash installé mais toujours demandé

#3Messageil y a 6 mois

Il est tout neuf, je viens de l' installer, j'ai quand même vidé le cache, pas de changement.

Flash installé mais toujours demandé

#4Messageil y a 6 mois

Dans Vivaldi, je suis allé dans Outils > Réglages > Page Web: Plugin Flash, il est sur:
"N'activer le plugin que pour les contenus Flash importants"
je mets sur:
"Toujours autoriser le plugin Flash"
pas de changement, je redémarre Vivaldi, pas de changements non plus, je retourne dans Outils > Réglages > Page Web: Plugin Flash, et la c'est de nouveau sur:
"N'activer le plugin que pour les contenus Flash importants"
Comment faire en sorte que ça reste sur: "Toujours autoriser le plugin Flash" ?

Flash installé mais toujours demandé

#5Messageil y a 6 mois


Flash installé mais toujours demandé

#6Messageil y a 6 mois

Plus haut, dans déroulement de l’opération en ligne de commande on voit que flashplugin est aussi déjà installé.
J'ai quand même retenté, pas de changement:

sudo pacman -S flashplugin
[sudo] Mot de passe de gaz : 
avertissement : flashplugin-28.0.0.137-1 est à jour -- réinstalle
résolution des dépendances...
recherche des conflits entre paquets...

Paquets (1) flashplugin-28.0.0.137-1

Taille totale installée :     19,12 MiB                                                                                                                                 
Taille de mise à jour nette :   0,00 MiB                                                                                                                                
                                                                                                                                                                        
:: Procéder à l’installation ? [O/n] O                                                                                                                                  
(1/1) vérification des clés dans le trousseau                                                        [############################################################] 100%
(1/1) vérification de l’intégrité des paquets                                                        [############################################################] 100%
(1/1) chargement des fichiers des paquets                                                            [############################################################] 100%
(1/1) analyse des conflits entre fichiers                                                            [############################################################] 100%
(1/1) vérification de l’espace disque disponible                                                     [############################################################] 100%
:: Traitement des changements du paquet...                                                                                                                              
(1/1) réinstallation flashplugin                                                                     [############################################################] 100%
:: Exécution des crochets de post-transaction...                                                                                                                        
(1/3) Updating icon theme caches...                                                                                                                                     
(2/3) Arming ConditionNeedsUpdate...                                                                                                                                    
(3/3) Updating the desktop file MIME type cache..

Flash installé mais toujours demandé

#7Messageil y a 6 mois

Plus haut, dans déroulement de l’opération en ligne de commande on voit que flashplugin est aussi déjà installé.
Logiquement c'est plutôt pepper-flash que doit utilisé vivaldi puisque ce navigateur est basé sur le moteur de chromium. Dans les navigateurs modernes, il y a désormais une option dans la barre d'url, permettant de configurer chaque site. Vérifie que l'option "flash" est activée sur le site de Deezer. Sinon, il est parfois intéressant de voir s'il n'y aurait pas de dépendances utiles pour vivaldi :

pacman -Qi vivaldi

Flash installé mais toujours demandé

#8Messageil y a 6 mois

Il fallait bien cliquer sur le petit cadenas dans la barre d'adresse, merci beaucoup :sourire:
mais c'est galère si il faut faire ça à chaque fois, il y a pas moyen d'autoriser définitivement pour tout les sites ?

pacman -Qi vivaldi
Nom                      : vivaldi
Version                  : 1.13.1008.40-2
Description              : An advanced browser made with the power user in
                           mind.
Architecture             : x86_64
URL                      : https://vivaldi.com
Licences                 : custom
Groupes                  : --
Fournit                  : --
Dépend de                : gtk3  libcups  nss  gconf  alsa-lib  libxss
                           ttf-font  desktop-file-utils  shared-mime-info
                           hicolor-icon-theme
Dépendances opt.         : vivaldi-ffmpeg-codecs: playback of proprietary
                           video/audio
                           pepper-flash: flash support [installé]
                           google-chrome: Widevine DRM Plugin
                           vivaldi-widevine: Widevine DRM Plugin
                           libnotify: native notifications [installé]
Requis par               : --
Optionnel pour           : --
Est en conflit avec      : --
Remplace                 : --
Taille installée         : 171,67 MiB
Paqueteur                : Unknown Packager
Compilé le               : ven. 19 janv. 2018 00:32:45 CET
Installé le              : ven. 19 janv. 2018 00:35:39 CET
Motif d’installation     : Explicitement installé
Script d’installation    : Non
Validé par               : --

Flash installé mais toujours demandé

#9Messageil y a 6 mois

il y a pas moyen d'autoriser définitivement pour tout les sites ?
Sur chromium et firefox c'est possible, il faut chercher dans les paramètres généraux. Je ne me souviens plus comment on y accède sur vivaldi (je ne l'ai plus). :saispas:

Flash installé mais toujours demandé

#10Messageil y a 6 mois

C'est dans: Outils > Réglages > Page Web: Plugin Flash, il est sur:
"N'activer le plugin que pour les contenus Flash importants"
je mets sur:
"Toujours autoriser le plugin Flash"
Je redémarre Vivaldi puis je retourne dans Outils > Réglages > Page Web: Plugin Flash, et la c'est de nouveau sur:
"N'activer le plugin que pour les contenus Flash importants"
Comment faire en sorte que ça reste sur: "Toujours autoriser le plugin Flash" ?
https://www.noelshack.com/2018-03-7-151 ... 141353.png

Sinon, je n'arrive pas a lire toute les videos, meme avec flash d'activé, exemple de site:
https://fr.sports.yahoo.com/news/video- ... 27118.html

Sur la video, j'obtiens "Le média n'a pas pu être lu." quae faut-il installer de plus ?

Flash installé mais toujours demandé

#11Messageil y a 6 mois

:bjr: Je viens d'installer vivaldi ainsi que pepper-flash et, effectivement le réglage "plugin-flash toujours activé" ne tient pas. Par contre si on choisi, à l'inverse, de le désactiver complètement... ça fonctionne!!! :confus::siffle Pour la page web incluant la vidéo, pareil... Alors que la lecture vidéo se déroule normalement sur chromium sans soucis et sans pepper-flash:siffle

Tu peux toujours installer leurs "dépendances maison" si tu le souhaites, la première notamment, cela permettra sans doute de résoudre le problème de lecture vidéo :

Dépendances optionnelles pour vivaldi
    vivaldi-ffmpeg-codecs: playback of proprietary video/audio
    pepper-flash: flash support
    google-chrome: Widevine DRM Plugin
    vivaldi-widevine: Widevine DRM Plugin
    libnotify: native notifications [installé]
Pour ma part, je n'irai pas plus loin dans l'expérience (décevante) et je vais le désinstaller sans aucun regret. Je trouve dommage de gaspiller de l’énergie à faire fonctionner un truc proprio notoirement incapable de rivaliser avec des projets libres tels Firefox et Chromium. Cela dit, je te souhaite bonne chance :wink:

Flash installé mais toujours demandé

#12Messageil y a 6 mois

Perso, Je trouve Vivaldi plus rapide que Firefox et Chromium.

Je n'arrive pas à installer vivaldi-ffmpeg-codecs
Voici:

ERREUR : L’extraction de chromium-62.0.3202.97.tar.xz a échoué
    Abandon...
==> ERREUR : Makepkg n'a pas pu construire vivaldi-ffmpeg-codecs.
==> Relancer la compilation de vivaldi-ffmpeg-codecs ? [o/N]
==> --------------------------------------------------------
==> o
==> Éditer PKGBUILD ? [O/n] ("A" pour annuler)
==> ------------------------------------------
==> n

/usr/lib/yaourt/pkgbuild.sh: ligne 219: impossible de créer un fichier temporaire pour le « here-document » : Aucun espace disponible sur le périphérique
/usr/lib/yaourt/pkgbuild.sh: ligne 74 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique
cat: erreur d'écriture: Aucun espace disponible sur le périphérique
/usr/lib/yaourt/pkgbuild.sh: ligne 76 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique
/usr/lib/yaourt/pkgbuild.sh: ligne 77 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique
/usr/lib/yaourt/pkgbuild.sh: ligne 78 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique
/usr/lib/yaourt/pkgbuild.sh: ligne 79 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique
/usr/lib/yaourt/pkgbuild.sh: ligne 80 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique
/usr/lib/yaourt/pkgbuild.sh: ligne 81 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique
/usr/lib/yaourt/pkgbuild.sh: ligne 82 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique
/usr/lib/yaourt/pkgbuild.sh: ligne 83 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique
/usr/lib/yaourt/pkgbuild.sh: ligne 84 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique
/usr/lib/yaourt/pkgbuild.sh: ligne 85 : echo: erreur d'écriture : Aucun espace disponible sur le périphérique
==> ERREUR :  n’est pas disponible pour l’architecture « x86_64 ».
==> ERREUR : pkgrel ne peut pas être vide.
==> ERREUR : pkgver ne peut pas être vide.
==> ERREUR : An unknown error has occurred. Exiting...
Impossible de lire le PKGBUILD

Flash installé mais toujours demandé

#13Messageil y a 6 mois

bonjour

Tu n'as plus d'espace ram dans /tmp/
Tu peux par exemple donner un autre répertoire temporaire (de ton choix)

yaourt -S xxxxxxx --tmp "/home/xxxxx/.cache"
EDIT: /tmp/ c'est déjà 50% de ta ram de pris, je ne vois pas l’intérêt d'augmenter cette taille ?

Flash installé mais toujours demandé

#14Messageil y a 6 mois

Bonjour
Comment augmenter l'espace ram dans /tmp/ ?

Flash installé mais toujours demandé

#15Messageil y a 6 mois

Ça peut se modifier en éditant /etc/fstab, mais sincèrement, c'est assez riqué et inutile. Le système monte /tmp en mémoire vive (tmpfs) et sa taille comme précisé par Papajoke, est automatiquement 50% de la ram. Si tu as un gros programme a compiler, il vaut mieux le faire dans ton /home.
Tu peux aussi faire :

yaourt -G paquet
cd paquet/
makepkg -si
1) On télécharge les source du paquet.
2 On s'y rend en console.
3) On compile le programme avec ses dépendances et on l'installe.

Flash installé mais toujours demandé

#16Messageil y a 6 mois

Ça donne :

yaourt -G paquet vivaldi-ffmpeg-codecs
cd paquet/home/vivaldi-ffmpeg-codecs
makepkg -si vivaldi-ffmpeg-codecs
C'est bien ça ?

Flash installé mais toujours demandé

#17Messageil y a 6 mois

yaourt -G vivaldi-ffmpeg-codec
cd vivaldi-ffmpeg-codec/
makepkg -si

Flash installé mais toujours demandé

#18Messageil y a 6 mois

ça bloque:

yaourt -G vivaldi-ffmpeg-codec
[jax@jax8-pc ~]$ cd vivaldi-ffmpeg-codec/
bash: cd: vivaldi-ffmpeg-codec/: Aucun fichier ou dossier de ce type

Flash installé mais toujours demandé

#19Messageil y a 6 mois

Arff, Il manquait un <s> à codecs...

Flash installé mais toujours demandé

#20Messageil y a 6 mois

Merci
C’était super long, ça à duré 1H, pour me dire à la fin que l'installation à échouée :lol: , j'ai les boules.

==> Quitte l’environnement fakeroot.
==> Création finie : vivaldi-ffmpeg-codecs 62.0.3202.97-1 (sam. janv. 27 01:21:18 CET 2018)
==> Installation du paquet vivaldi-ffmpeg-codecs avec pacman -U...
[sudo] Mot de passe de jax : 
==> ATTENTION : Échec à l’installation des paquets.
[jax@jax8-pc vivaldi-ffmpeg-codecs]$

Répondre