Problèmes et questions sur les environnements graphiques et les applications.

cairo-dock

#1Messageil y a 4 ans

Bonjour tous,https://www.manjaro.fr/forum/posting.php?mode=post&f=20#

J'ai découvert Manjaro depuis peu et j'y suis très bien. Je n'ai pas une grande expérience de Linux ( que 2 ans )... et évidemment chtit problème.

J'ai essayé yaourt cairo-dock
C'est le N 1 : aur/cairo-dock 3.1.2-2 (1004)
A light eye-candy fully themable animated dock for any Linux desktop. It
has a family-likeness with OSX dock, but with more options.

La réponse
cairo-dock 3.1.2-2
( Paquet non supporté : peut être dangereux ! )
==> Éditer PKGBUILD ? [O/n] ("A" pour annuler)
==> ------------------------------------------
==> o

==> Dépendances de cairo-dock :
- cairo (déjà installé)
- librsvg (déjà installé)
- dbus-glib (déjà installé)
- gtkglext (déjà installé)
- mesa (déjà installé)
- pangox-compat (déjà installé)
- cmake (déjà installé)
- libtool (déjà installé)
- pkgconfig (déjà installé)
- gettext (déjà installé)
- inputproto (déjà installé)


Je suis sur XFCE Manjaro 0.8.3

Quoi je fais, si c'est pas trop compliqué ???

En tout cas merci pour ce forum et pour le rapide et Hénorme travail du wiki. posting.php?mode=post&f=20#
Modifié en dernier par grald le 14 Jan 2013, 19:20, modifié 1 fois.

cairo-dock

#2Messageil y a 4 ans

Bonjour,


Tu veux vraiment éditer le PKGBUILD ? Perso, je répond "n" à la question.

Si tu ne veux pas qu'on te la pose, tu peux même utiliser l'option --noconfirm.

Genre :

yaourt -S cairo --noconfirm

cairo-dock

#3Messageil y a 4 ans

... je n'ai pas dû être assez clair, désolé. Le problème, c'est qu'il refuse d'installer cairo. Il me fait le coup d'ailleurs avec d'autres.

cairo-dock

#4Messageil y a 4 ans

Et il te dit quoi ?

Je viens d'essayer à l'instant d'installer cairo-dock par yaourt, et c'est passé. Mais mon installation est un peu spéciale.

Quel bureau as-tu, et quel serveur utilises-tu (évite le serveur UK, bien qu'il soit -normalement- redevenu OK tout à l'heure) ?

(edit)

Sous Cinnamon :

Image

cairo-dock

#5Messageil y a 4 ans

Je suis sur XFCE
Je crois me souvenir que jai choisi FR et D

Dans mon premier mail j'ai mis tout ce qu'il me dit, entre autre Paquet non supporté : peut être dangereux !

Dans certains cas, ça passe mais dans d'autres cas, que dalle ( par ex Kompozer )
Ca fait 2 ou 3 jours que j'essaie.

cairo-dock

#6Messageil y a 4 ans

Pour Kompozer, il faut installer d'abord un autre paquet (pangox-compat ?), si je me souviens bien. Ensuite, ça passe très bien.

Regarde les commentaires, dans AUR.

cairo-dock

#7Messageil y a 4 ans

Re,

Je viens d'essayer d'installer Cairo-Dock dans un openbox (testing) que j'ai dans uneVBox. Ça a foiré tant que je n'ai pas installé base-devel (et binutils, mais là, il te le dit tout de suite).

cairo-dock

#8Messageil y a 4 ans

Je viens d'essayer avec Mundus. J'ai installé toutes les dépendances et pareil, refus d'installer et même réponse.
Est-ce que je dois réinstaller yaourt ou j'ai fait une grosse c*****ie en bricolant Manjaro pour mieux le connaitre ?

cairo-dock

#9Messageil y a 4 ans

Salut
On ne voit pas quel message d'erreur s'affiche dans ton premier post.
J'ai comme un doute sur une méprise de ce que tu as lu sur ton terminal.
Refais la manip en répondant "n" a éditer PKGBUILD et colle nous la suite.

Dans mon premier mail j'ai mis tout ce qu'il me dit, entre autre Paquet non supporté : peut être dangereux !

=> Ça c'est normal si tu passe par AUR en utilisant la commande yaourt -S , mais la encore tu ne nous a pas mis le debut de ta commande.

cairo-dock

#10Messageil y a 4 ans

Paquet non supporté n'est pas une erreur, c'est un warning classique.

Mais si on ne voit pas d'autres erreurs lors de l'installation,on ne peut pas trouver, à moins d'y aller au pif ? Y en a-t-il ?

cairo-dock

#11Messageil y a 4 ans

en tous cas merci pour ta patience
j'ai refais en mettant no pour éditer pkgbuild
il y a du nouveau avec 2 erreurs


[grald@manjaro ~]$ yaourt -S cairo-dock

==> Téléchargement du PKGBUILD de cairo-dock depuis AUR...
x PKGBUILD



cairo-dock 3.1.2-2
( Paquet non supporté : peut être dangereux ! )
==> Éditer PKGBUILD ? [O/n] ("A" pour annuler)
==> ------------------------------------------
==> n

==> Dépendances de cairo-dock :
- cairo (déjà installé)
- librsvg (déjà installé)
- dbus-glib (déjà installé)
- gtkglext (déjà installé)
- mesa (déjà installé)
- pangox-compat (déjà installé)
- cmake (déjà installé)
- libtool (déjà installé)
- pkgconfig (déjà installé)
- gettext (déjà installé)
- inputproto (déjà installé)


==> Lancer la compilation de cairo-dock ? [O/n]
==> -------------------------------------------
==>
==> Construction et installation du paquet
==> ERREUR : Le fichier binaire fakeroot, requis pour la création en tant que simple utilisateur, est introuvable.
==> ERREUR: Makepkg n'a pas pu construire cairo-dock.
==> Relancer la compilation de cairo-dock ? [o/N]
==> ---------------------------------------------
==>
==> Éditer PKGBUILD ? [O/n] ("A" pour annuler)
==> ------------------------------------------
==> n

==> Dépendances de cairo-dock :
- cairo (déjà installé)
- librsvg (déjà installé)
- dbus-glib (déjà installé)
- gtkglext (déjà installé)
- mesa (déjà installé)
- pangox-compat (déjà installé)
- cmake (déjà installé)
- libtool (déjà installé)
- pkgconfig (déjà installé)
- gettext (déjà installé)
- inputproto (déjà installé)


==> Lancer la compilation de cairo-dock ? [O/n]
==> -------------------------------------------
==>
[grald@manjaro ~]$

cairo-dock

#12Messageil y a 4 ans

Tu n'as pas installé base-devel, ni probablement binutils, comme je te le dis plus haut. Donc, il te manque la commande fakeroot.

Installe ces deux paquets, et ça va marcher.

cairo-dock

#13Messageil y a 4 ans

binutils et base-devel étaient chargés
je viens de charger fakeroot qui lui ne l'était pas
la réponse
==> Lancer la compilation de cairo-dock ? [O/n]
==> -------------------------------------------
==>
==> Construction et installation du paquet
==> Création du paquet cairo-dock 3.1.2-2 (lun. janv. 14 19:34:41 CET 2013)
==> Vérification des dépendances pour l'exécution...
==> Vérification des dépendances pour la compilation...
==> Récupération des sources...
-> Téléchargement de cairo-dock-3.1.2.1.tar.gz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
100 2392k 100 2392k 0 0 364k 0 0:00:06 0:00:06 --:--:-- 378k
==> Validation des fichiers sources avec md5sums...
cairo-dock-3.1.2.1.tar.gz ... Réussite
==> Extraction des sources...
-> Extraction de cairo-dock-3.1.2.1.tar.gz avec bsdtar
==> Lancement de build()...
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.27.1")
CMake Error: CMake was unable to find a build program corresponding to "Unix Makefiles". CMAKE_MAKE_PROGRAM is not set. You probably need to select a different build tool.
CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly.
Missing variable is:
CMAKE_C_COMPILER_ENV_VAR
CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly.
Missing variable is:
CMAKE_C_COMPILER
CMake Error: Could not find cmake module file:/tmp/yaourt-tmp-grald/aur-cairo-dock/src/cairo-dock-3.1.2/build/CMakeFiles/2.8.10.2/CMakeCCompiler.cmake
CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly.
Missing variable is:
CMAKE_CXX_COMPILER_ENV_VAR
CMake Error: Error required internal CMake variable not set, cmake may be not be built correctly.
Missing variable is:
CMAKE_CXX_COMPILER
CMake Error: Could not find cmake module file:/tmp/yaourt-tmp-grald/aur-cairo-dock/src/cairo-dock-3.1.2/build/CMakeFiles/2.8.10.2/CMakeCXXCompiler.cmake
CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage
CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
-- Configuring incomplete, errors occurred!
==> ERREUR : Une erreur s'est produite dans build().
Abandon...
==> ERREUR: Makepkg n'a pas pu construire cairo-dock.
==> Relancer la compilation de cairo-dock ? [o/N]
==> ---------------------------------------------
==>

cairo-dock

#14Messageil y a 4 ans

(Ré-)Installe make (tout court).

cairo-dock

#15Messageil y a 4 ans

SUPER !!!! gros merci, sans toi je n'étais pas pret d'y arriver ( je venais d'installer cmake pour rien... )

Bonne soirée

cairo-dock

#16Messageil y a 4 ans

Bizarre d'arriver à casser "make"
Perso j'ai installé CAIR0-DOCK depuis une XFCE, je n'ai pas eu tous ces problèmes.

Peut être vider le cache de PACMAN dans un premier temps.

cairo-dock

#17Messageil y a 4 ans

grald a écrit :SUPER !!!! gros merci, sans toi je n'étais pas pret d'y arriver ( je venais d'installer cmake pour rien... )

Bonne soirée


Tant mieux , oublie mon message et passe à résolu !!!!!!!!!!!!!!!!!!!!!!!

cairo-dock

#18Messageil y a 4 ans

j'aimerais bien mais je fais comment poru mettre RESOLU ?

j'ai pourtant regardé partout

cairo-dock

#19Messageil y a 4 ans

Si tu édites ton premier message, c'est la deuxième icône à partir de la gauche, au-dessus de la boîte.

cairo-dock

#20Messageil y a 4 ans

Esclapion a écrit :Si tu édites ton premier message, c'est la deuxième icône à partir de la gauche, au-dessus de la boîte.

Ne serait-ce pas la première cher ami ? :gsourire:
Image

Répondre