Problèmes et questions sur les environnements graphiques et les applications.
Répondre

installation de grisbi 1.1.96

#1Messageil y a 3 mois

bonjour
je voulais savoir de quel façon installé un logiciel qui n'est pas dans les dépôts ( grisbi 1.1.96 ) pour pouvoir le tester et sachant que grisbi 1.04 est dans les dépôts. le fichier à télécharger je pense le tar.bz2 mais je n'ai pas trouver la procédure d'installe

https://sourceforge.net/projects/grisbi ... le/1.1.96/

je vous remercie d'avance pour votre aide

ritch :rendre:
Modifié en dernier par ritch le 22 Jan 2019, 00:16, modifié 1 fois.

installation de grisbi 1.1.96

#2Messageil y a 3 mois

bonjour,
Tu désires toucher au grisbi ! :lolfou

Le première chose à faire est juste , à l'installation du aur, de modifier la version dans le fichier PKGBUILD ... avec de la chance cela va passer comme une lettre à la poste :cool:

En tout cas c'est l'idée : modifier le PKGBUILD + ou - jusqu'au bon fonctionnement :roll:

EDIT: je viens de voir que maintenant il y a une version git dans aur ... mais je pense que c'est une mauvaise idée de l'utiliser avec tes données : le risque est quand même grand d'avoir à un moment les données corrompues - ok si c'est pour un test

installation de grisbi 1.1.96

#3Messageil y a 2 mois

voila grisbi 1.1.96
sur le site j ai telecharger les sources
https://sourceforge.net/projects/grisb ... 2/download
puis j ai suivi l'install

How to install Grisbi : 
=======================

Requirements:

 - GTK 2.24
 - libofx (optional)
 - goffice (optional)

Installation steps:

 - ./configure --prefix=/path_to_install_grisbi
 - make
 - make install

Grisbi will now be installed.  Just run <prefix>/bin/grisbi and have
fun !

OFX support is optional and can be disabled by using the --without-ofx
parameter.


-- Grisbi development team <team@grisbi.org>
merci pour moi le problème est résolu

merci pour l'aide :pompom:

installation de grisbi 1.1.96

#4Messageil y a 2 mois

Oui, sauf que tu l'as installé sans passer par pacman ou pamac et tôt ou tard, tu auras des problèmes de conflits de dépendances.
Il fallait modifier le PKGBUILD en adaptant les sources et la somme de contrôle .

installation de grisbi 1.1.96

#5Messageil y a 2 mois

+1 vraiment pas bon de l'installer de cette façon :pleure:
Tu ne pourras plus installer directement la prochaine version aur :pleure:


-----
La traduction en ligne de commande de ce que je disais : simplement changer la version + divers petits ajustements

git clone https://aur.archlinux.org/grisbi.git 
cd grisbi
nano PKGBUILD # ou avec ton éditeur graphique
remplacer pkgver=1.0.4 par la bonne version pkgver=1.1.96
et depends=('desktop-file-utils' 'gtk2') par depends=('gtk3' 'libgsf')
et pour finir sha256sums=('c6dd******8e02e6') par sha256sums=('SKIP')
ps: j'ai un doute pour le remplacement de gtk2 en gtk3 :saispas: pas grave on a les 2 de déjà installé

et on installe notre version 1.1.96:

makepkg -scfi
puis supprimer le répertoire "grisbi"

ps: il est aussi possible de faire cette manipulation directement lorsque le helpeur aur nous propose d'éditer le fichier PKGBUILD

installation de grisbi 1.1.96

#6Messageil y a 2 mois

Bonjour,
Vu sur le site http://fr.grisbi.org/
Dernières versions de grisbi stable et de développement
Par Pierre Biava le samedi 1 décembre 2018, 06:16

La dernière version stable de grisbi est la 1.0.4.

Adresse de téléchargement :

https://sourceforge.net/projects/grisbi/files/grisbi stable/1.0.x/

La dernière version de développement est la 1.1.96. Elle est disponible :

https://sourceforge.net/projects/grisbi/files/grisbi unstable/1.1.96/
La version 1.1.96 est donc une version de développement. J'utilise la version 1.0.4 depuis pas mal de temps et elle fonctionne impeccablement. C'est celle qui est dans AUR.

installation de grisbi 1.1.96

#7Messageil y a 2 mois

ok ok :tetu!
bon si je dois le désinstallé proprement de quelle manière je procède ??
je supprime le repertoire qu'il ma crée " /path_to_install_grisbi/" ?? ainsi que le repertoire " /usr/share/grisbi/"

ritch

installation de grisbi 1.1.96

#8Messageil y a 2 mois

Non, il faut regarder si dans le dossier de construction se trouve un fichier uninstall. Sinon, un sudo make uninstall depuis le dossier où tu as le makefile pourrait suffire.
Ensuite, il faudra traquer les orphelins.

installation de grisbi 1.1.96

#9Messageil y a 2 mois

j ai pu désinstallé par pamac n'ayant pas trouver le fichier uninstall par contre dans pamac dans AUR j'ai les 2 grisbi
Image
Image
Image

par contre a l'installation manuelle il ma crée le dépot grisbi-git avec le fichier PKGBUILD
comme tu me disais Papajoke
119008

ce qui fait que j'ai les deux grisbi dans AUR ceux la peut il posé des problèmes ?
ou faut il que j’enlève le dépôt grisbi-git ? et de quelle manière?

merci de votre aide

installation de grisbi 1.1.96

#10Messageil y a 2 mois

Tu n'as pas les deux Grisbi dans Aur. Il sont tout simplement dans ce dépôt et pamac t'offre la possibilité d'en installer un des deux.
La commande sudo make uninstall depuis le dossier Grisbi/ a t'elle pu passer ?
Lance pacman -Qem et pacman -Qdt pour voir .

installation de grisbi 1.1.96

#11Messageil y a 2 mois

si tu as suivi mon post tu as grisbi d'installé et non grisbi-git(version pour développeur)
Sur tes copies écran grisbi n'est pas coché donc tu ne l'as pas encore installé :?

Dans ma procédure tu installes "grisbi", lorsqu'il y aura une maj > à ta version spécifique, pas de problème, pamac te proposera la mise à jour de ton grisbi 1.1.96

installation de grisbi 1.1.96

#12Messageil y a 2 mois

119028
non la commande

sudo make uninstall
n'est pas passé cd que me donne "pacman -Qem"

ffdiaporama 2.2.D759-3
gcstar 1.7.1-1
gksu 2.0.2-6
grub2-theme-archlinux 1.0-4
gtkdialog 0.8.3-1
imagination 3.4-1
kazam 1.4.5-7
lightning 2.1.2-1
multisystem 1.0426-1
pcmciautils 018-8
pdfshuffler 0.6.0-4
teamviewer 14.1.3399-9
ttf-ms-fonts 2.0-10
ubuntu-sounds 0.13-3
vte-legacy 0.28.2-10
xfce4-goodies-meta 4.12-1
zd1211-firmware 1.5-3
et "pacman -Qdt"

bamf 0.5.3-2
daala 0.0.r1696.g7278368-1
docbook-xsl 1.79.2-4
gegl02 0.2.0-8
gmime3 3.2.3-1
hunspell-en_GB 2018.04.16-5
js 24.2.0-4
lcms 1.19-7
lib32-libjpeg6-turbo 1.5.3-1
lib32-libpng12 1.2.59-1
liborcus 0.14.1-1
mhwd-nvidia-304xx 1:304.137-1
poppler-qt5 0.72.0-1
python-sip 4.19.13-1
python2-cssutils 1.0.2-2
schroedinger 1.0.11-5
sidplay2-libs 2.1.1-1
sip 4.19.13-1
sndio 20180120-1
119029
sur mes copie d’écran effectivement il n'y en aucune qui est coché car je venais de désinstallé totalement grisbi car je l'avais installé d'une mauvaise façon et pour éviter les conflits de dépendances par la suite. maintenant je voulais uniquement tester la version 1.1.96 et avant mon install pamac ne me proposer pas les deux versions mais uniquement la version 1.0.4

installation de grisbi 1.1.96

#13Messageil y a 2 mois

si tu l'a bien dé-installé alors il n'y a pas de problème
au pire, lorsque tu vas installer ta version, (pacman) va te dire qu'il y a conflit de fichier - reste à les effacer et re-install

du coup à la place d'un simple makepkg -scfi le faire plutôt en 2 étapes (ce qui évite de re-compiler 36 fois)

makepkg -scf
pacman -U *.pkg.tar.xz
# si erreur conflit de fichier , rm ces fichiers puis recommencer pacman -U ...

-----------------------
EDIT
Version aur en 1.2 , donc problème bien réglé :gsourire:

Répondre