Problèmes et questions sur les environnements graphiques et les applications.
Répondre

Problème phpmyadmin

#1Messageil y a 1 mois

Bonjour, voilà j'ai installer phpmyadmin et du jours au lendemain il ne fonctionne plus et me dit :
phpMyAdmin - Error

The mysqli extension is missing. Please check your PHP configuration. See our documentation for more information.
j ai vérifié les extensions dans php.ini et elle est bien decommenté si quelqu'un a une solution ?
Du coup j'ai voulu essayer mysql workbench et meme chose ca ne fonctionne pas :(
HELP ME PLEASE ;)
Modifié en dernier par Erwan le 16 Jan 2019, 12:07, modifié 1 fois.
Raison :ajout balises code

Problème phpmyadmin

#2Messageil y a 1 mois

Bonjour.
A mon avis, il faudrait plutôt regarder dans etc/webapps/phpmyadmin/config.inc.php.
Je ne l'ai pas installé, donc il faut chercher la ligne.

Problème phpmyadmin

#3Messageil y a 1 mois

Bonjour,

Les lignes a décommenté sont : ( Je sais que tu la fait mais je préfère vérifier que ce sont les bonnes )

Dans /etc/php/php.ini

extension=bz2.so
extension=mcrypt.so
extension=mysqli.so
Dans le terminal si tu fait " php -m " Le plugin est écrit dans la liste ?

Ps : Si tu peut me donner le retour de " php --version " Merci

Problème phpmyadmin

#4Messageil y a 1 mois

retour de php -m

Core
ctype
date
dom
fileinfo
filter
hash
json
libxml
mbstring
mysqlnd
openssl
pcntl
pcre
PDO
Phar
posix
readline
Reflection
session
SimpleXML
SPL
standard
tokenizer
xml
xmlreader
xmlwriter
zlib

[Zend Modules]
et pourtant je les ai décommenté par contre j'ai du ajouter le
extention=mcrypt.so

retour de php --version

PHP:  syntax error, unexpected '&' in /etc/php/php.ini on line 107
PHP 7.3.0 (cli) (built: Dec  8 2018 12:11:20) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.0-dev, Copyright (c) 1998-2018 Zend Technologies

Problème phpmyadmin

#5Messageil y a 1 mois

Tu dois avoir un php.ini en .pacnew ou .pacsave.
Sinon, le code erreur est à la ligne 107.
Je regarderai sur la tour ce soir.

Problème phpmyadmin

#6Messageil y a 1 mois

lemust83 a écrit :
il y a 1 mois
Bonjour.
A mon avis, il faudrait plutôt regarder dans etc/webapps/phpmyadmin/config.inc.php.
Je ne l'ai pas installé, donc il faut chercher la ligne.
j'ai regarder un peu mais je n'y connait rien je commence seulement l'informatique :s

Problème phpmyadmin

#7Messageil y a 1 mois

Le soucis est que le plugin n'est pas déclarer dans le fichier de config. Tu peut le rajouter et redémarrer le serveur et refaire un php -m pour voir si il est bien dans la liste.

Pour ce qui est des pacnew effectivement j'en ai aussi sur mon serveur mais ce sont des nouveau fichier de config sans aucune modification.

Problème phpmyadmin

#8Messageil y a 1 mois

comment le rajouter ?? quelle plugin et ou le rajouter ? :s Déso je debute

Problème phpmyadmin

#9Messageil y a 1 mois

Pas de soucis.

Pour le serveur le miens retourne cela :

PHP 7.3.1 (cli) (built: Jan  8 2019 16:39:04) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.1, Copyright (c) 1998-2018 Zend Technologies
Regarde donc si tu a bien fait toutes les majs disponible sur ton système.

Pour ce qui est des réglages dans mon fichier de config :

;extension=bcmath
extension=bz2
;extension=calendar
extension=curl
;extension=dba
;extension=enchant
;extension=exif
;extension=ftp
;extension=gd
;extension=gettext
;extension=gmp
;extension=iconv
;extension=imap
;extension=intl
;extension=sodium
;extension=ldap
extension=mysqli
;extension=odbc
;zend_extension=opcache
;extension=pdo_dblib
;extension=pdo_mysql
;extension=pdo_odbc
;extension=pdo_pgsql
;extension=pdo_sqlite
;extension=pgsql
;extension=pspell
;extension=shmop
;extension=snmp
;extension=soap
;extension=sockets
;extension=sqlite3
;extension=sysvmsg
;extension=sysvsem
;extension=sysvshm
;extension=tidy
;extension=xmlrpc
;extension=xsl
extension=zip
extension=php_pdo_mysql.so 
Si tu regarde bien j'ai décommenté certaines extentions pour faire marcher phpmyadmin ( J'en ai activer d'autre pour mes besoin perso )

Tu peut rajouter la ligne

extension=mysqli
Ce que je trouve étrange c'est que tout marchais bien avant.
Au cas ou tu n'a pas un .pacnew ou autre en plus de ton fichier de config ?

Edit : Voilà un tuto complet si jamais tu veux voir si tu a oublier des étapes durant l'install

https://forum.manjaro.org/t/install-apa ... -2016/1243

Problème phpmyadmin

#10Messageil y a 1 mois

pour se qui est de php.ini :

;extension=bcmath
extension=bz2
;extension=calendar
extension=curl
;extension=dba
;extension=enchant
;extension=exif
;extension=ftp
;extension=gd
;extension=gettext
;extension=gmp
;extension=iconv
;extension=imap
;extension=intl
;extension=sodium
;extension=ldap
extension=mysqli.so
extension=mcrypt.so
;extension=odbc
;zend_extension=opcache
;extension=pdo_dblib
extension=pdo_mysqli
;extension=pdo_odbc
;extension=pdo_pgsql
;extension=pdo_sqlite
;extension=pgsql
;extension=pspell
;extension=shmop
;extension=snmp
;extension=soap
;extension=sockets
;extension=sqlite3
;extension=sysvmsg
;extension=sysvsem
;extension=sysvshm
;extension=tidy
;extension=xmlrpc
;extension=xsl
extension=zip
comprends pas

et mon systeme est a jours

Problème phpmyadmin

#11Messageil y a 1 mois

bonjour

perso, j'utilise en local adminer à la place de phpmyadmin, adminer nécessite moins de config

Attention, il faut relancer le serveur après chaque modification de config de apache/php sinon elle n'est pas prise en compte.
Attention, tu dois absolument régler ton problème de mauvaise syntaxe dans ton php.ini sinon php ne peut pas bien fonctionner ("error_reporting" ligne 107 ?).
Gr33nParadise a écrit :
il y a 1 mois
par contre j'ai du ajouter le extention=mcrypt.so
non non, depuis pas mal de temps (php 7.2) cette extension n'existe plus , aujourd'hui c'est sodium

:o tu nous retournes :

extension=pdo_mysqli
:confus: c'est pas plutôt pdo_mysql (sans i)


ps: je ne modifie JAMAIS php.ini mais ajoute des mini fichiers .ini dans /etc/php.conf.d/, ce qui évite à gérer des .pacnews à chaque maj

Problème phpmyadmin

#12Messageil y a 1 mois

papajoke a écrit :
il y a 1 mois

:o tu nous retournes :

extension=pdo_mysqli
:confus: c'est pas plutôt pdo_mysql (sans i)
j' ai rien ou je m'y prend mal :s

et mtn j ai en retour de php -m après avoir resolu l'erreure de syntaxe

PHP Warning:  PHP Startup: Unable to load dynamic library 'pdo_mysqli' (tried: /usr/lib/php/modules/pdo_mysqli (/usr/lib/php/modules/pdo_mysqli: cannot open shared object file: No such file or directory), /usr/lib/php/modules/pdo_mysqli.so (/usr/lib/php/modules/pdo_mysqli.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
[PHP Modules]
bz2
Core
ctype
curl
date
dom
fileinfo
filter
hash
json
libxml
mbstring
mysqlnd
openssl
pcntl
pcre
PDO
Phar
posix
readline
Reflection
session
SimpleXML
SPL
standard
tokenizer
xml
xmlreader
xmlwriter
zip
zlib

[Zend Modules]

Problème phpmyadmin

#13Messageil y a 1 mois

bien si, c'est le retour que tu nous as indiqué il y a 2 post (ton php.ini) et c'est bien l'erreur qui est retournée maintenant par php : tu désires installer une extension pdo qui n'existe pas . par défaut, phpmyadmin doit utiliser pdo et non directement mysql

Problème phpmyadmin

#14Messageil y a 1 mois

merci a papajoke c'etait bien pdo_mysql sans le i
quand tu dis que tu crées un autre .ini pour pas modifier php.ini il faut un lien symbolique ou juste le mettre dans le même dossier?

Problème phpmyadmin

#15Messageil y a 1 mois

je parle de créer le répertoire /etc/php.conf.d/ si il n'existe pas
Puis, dedans, mettre de petits fichiers .ini (avec nom libre) qui vont écraser le fichier /etc/php.ini

par exemple un fichier /etc/php.conf.d/ma_config_generale.ini

[php]
; il me faut plus de mémoire pour exécuter trucmachinchose
memory_limit = 2666M
; il me faut plus de temps pour faire une maj avec bidulemachinchose
max_execution_time = 190
ici, je ne réécris que 2 valeurs de mon php.ini qui lui reste d'origine - ET je commente clairement, histoire de comprendre le pourquoi dans 1..2 ans

par exemple un fichier /etc/php.conf.d/debug.ini
...
par exemple un fichier /etc/php.conf.d/wordpress.ini
avec les extensions pour ce logiciel

Répondre