Problèmes et questions concernant le noyau et le support matériel.
Répondre

Noyau : éviter le chargement d'un module

#1Messageil y a 2 mois

Bonjour,
Ma carte mère (CM gigabyte GA-78LMT-USB3 rev 5.0) active un contrôleur de disquette (rien derrière bien entendu), ce qui ralentit terriblement toutes les opérations de détection type fdisk, gparted etc.
Voilà ce que j'ai essayé, sans succès :

1) désactiver le contrôleur dans le bios : impossible, l'option est aux abonnés absents. Il n'existe pas de nouvelle version du bios (v. FA). Voir aussi ici : https://forums.opensuse.org/showthread.php/526242-BIOS-not-deactivating-non-existent-floppy-drive-(GA-78LMT-USB3)-on-Motherboard

2) Blacklister le module floppy (cf le wiki arch):
J'ai créé un 1er fichier blacklist-floppy.conf dans /etc/modprobe.d contenant ceci :

blacklist floppy
install floppy /bin/false

Puis un 2ème avec le même contenu mais avec pour libellé : blacklist.conf au cas où...

3) Passer le paramètre au noyau via grub :

sudo nano /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet modprobe.blacklist=floppy
sudo grub-mkconfig -o /boot/grub/grub.cfg


Donc, tout ça ne fonctionne pas. :tetu! Peut-être ai-je fait une erreur quelque part ?
En tout cas, un

sudo rmmod floppy
me débarrasse du problème pour la session, il suffirait donc que le blacklist fonctionne.
Dans l'absolu ce n'est pas trop grave mais c'est quand même très gênant, surtout quand on oublie de décharger le module et qu'on bricole. :café:

Merci
Modifié en dernier par samguili le 25 Sep 2017, 17:06, modifié 1 fois.

Noyau : éviter le chargement d'un module

#2Messageil y a 2 mois

Bonsoir.
Normalement, il faudrait identifier le module du lecteur de disquette par lsmod
C'est ensuite en fonction qu'on blacklist dans /etc/modprobe.d/
Désolé, je n'en ai pas et ne peux tester cette méthode.

Noyau : éviter le chargement d'un module

#3Messageil y a 2 mois

lsmod me confirme bien que le module disquette est floppy

floppy                 65536  0

D'ailleurs, le

sudo rmmod floppy
décharge bien le module et je n'ai plus le problème.
:saispas:

Noyau : éviter le chargement d'un module

#4Messageil y a 2 mois

Démarres-tu sur la version normale du kernel et non la version fallback ? Quel noyau as tu?

Noyau : éviter le chargement d'un module

#5Messageil y a 2 mois

version normale : 4.9.50-1-MANJARO x86_64
merci de t’intéresser à mon problème :merci:

Noyau : éviter le chargement d'un module

#6Messageil y a 1 mois

Je suis en Testing avec la version 4.9.51-1 (après reboot sur ce noyau) donc juste un peu plus récente, mais dans ce cas, je ne pense pas que ça fasse de différences.
Il faudrait avoir des retours avec un autre kernel, mais je pense que c'est gravé par w$ dans le marbre de la carte-mère dès l'usinage...
Voir peut être du côté de fastboot ou de l'option "Eteindre" de W$ .

Noyau : éviter le chargement d'un module

#7Messageil y a 1 mois

Bonjour,
j'ai résolu mon problème, voici ce que j'ai fait :
- création d'un script contenant rmmod floppy
- création et activation d'un service systemd qui lance ce script au démarrage
c'est un peu le bazooka pour tuer une mouche mais vu ce que j'avais fait avant... :siffle
merci lemust83 pour m'avoir consacré du temps !

Répondre