scanner canon / page noire

Problèmes et questions concernant le noyau et le support matériel.

scanner canon / page noire

Message par CB18 » 08 Déc 2015, 19:23

Bonjour,

J'utilise un scanner canon canoscan LIDE 20. Mon problème est que la lampe ne se déplace plus lorsque je demande la numérisation avec simple scan. Sur la prévisualisation de la page je vois le balayage en cours mais une page noire apparaît après le scan. Le problème se présente quelque soit la résolution en texte ou en photo.
J'ai changé de port usb, le scanner a fonctionné une fois puis le problème s'est représenté. La lampe a commencé à remonter puis s'est arrêtée à mi-course. Lors d'une autre tentative de scan la lampe a fini de remonter mais le scan de la page n'a pas commencé.
Mon scanner fonctionnait très bien il y a 3/4 mois. Je me demande aussi si mon scanner n'est pas trop vieux (problème de support par manjaro).

Merci pour votre aide.
Dernière édition par CB18 le 09 Déc 2015, 15:52, édité 1 fois.
Tour: Manjaro XFCE 64bits
carte mère: asus P8H67-M Rev 3.0 cpu: Intel i5-2500K 3.30GHz Ram: 8 Go
carte graph.: NVIDIA GF116 [GeForce GTX 550 Ti] (rev a1) carte son: creative soundblaster audigy
Avatar de l’utilisateur
CB18
 
Message(s) : 74
Inscription : 21 Sep 2014, 10:38
Localisation : Grenoble

Re: scanner canon / page noire

Message par Loubrix » 08 Déc 2015, 20:12

il faudrait surtout être sûr que le scanner n'est pas tout simplement en train de rendre l'âme, parce que selon moi, l'OS ne pilote pas la cellule, ne décide pas son mouvement; l'OS demande la numérisation (avec éventuellement des paramètres additionnels), et le scanner s'exécute.
as-tu un autre système d'exploitation pour tester ? autre Linux, MacOSX, Windows,...etc
Asus AIO - AMD E2 - Radeon HD 7340 - Manjaro 64 + Kf5 + Linux 3.14
Avatar de l’utilisateur
Loubrix
 
Message(s) : 6309
Inscription : 03 Déc 2012, 14:32
Localisation : Bessèges - 30

Re: scanner canon / page noire

Message par CB18 » 08 Déc 2015, 21:00

J'ai essayé de la faire fonctionner sous windows 10 mais windows ne le reconnaît pas. Je suppose qu'il y a au moins un problème 32/64 bits. Je n'ai pas d'autre Linux.
Tour: Manjaro XFCE 64bits
carte mère: asus P8H67-M Rev 3.0 cpu: Intel i5-2500K 3.30GHz Ram: 8 Go
carte graph.: NVIDIA GF116 [GeForce GTX 550 Ti] (rev a1) carte son: creative soundblaster audigy
Avatar de l’utilisateur
CB18
 
Message(s) : 74
Inscription : 21 Sep 2014, 10:38
Localisation : Grenoble

Re: scanner canon / page noire

Message par N3mesis98 » 08 Déc 2015, 22:14

Je suis de l'avis de Loubrix, pour moi le déplacement de la lampe est géré par le scanner en lui même et pas par le PC.
Du coup le problème est probablement physique. J'irais même jusqu'à dire que c'est probablement un problème électronique, peut être un court circuit ou une soudure qui a sautée ?
Laptop : Archlinux 64b + GNOME : Intel Ivybridge Mobile + Nvidia GeForce 630M (bumblebee)
Avatar de l’utilisateur
N3mesis98
 
Message(s) : 359
Inscription : 12 Avr 2013, 07:54
Localisation : Compiègne - 60

Re: scanner canon / page noire

Message par CB18 » 09 Déc 2015, 15:52

Je considère que mon scanner est HS.

Merci encore pour votre aide.
Tour: Manjaro XFCE 64bits
carte mère: asus P8H67-M Rev 3.0 cpu: Intel i5-2500K 3.30GHz Ram: 8 Go
carte graph.: NVIDIA GF116 [GeForce GTX 550 Ti] (rev a1) carte son: creative soundblaster audigy
Avatar de l’utilisateur
CB18
 
Message(s) : 74
Inscription : 21 Sep 2014, 10:38
Localisation : Grenoble

Re: scanner canon / page noire

Message par cdtpepette » 16 Jan 2017, 13:47

J'ai exactement le même problème avec le même scanner. J'ai lancé ubuntu 16.04 LTS en live et le scanner fonctionne parfaitement.
cdtpepette
 
Message(s) : 2
Inscription : 16 Fév 2016, 04:04

Re: scanner canon / page noire

Message par tower41000 » 16 Jan 2017, 19:12

bon le lide20 il date quand meme.j ai du l avoir au debut des annees 2000... il est rentabilisé maintenant...
Host: T410 Kernel: 4.11.7-1-MANJARO x86_64 (64 bit)
Desktop: Cinnamon 3.4.2 Distro: Manjaro Linux
Device: laptop System: LENOVO product: 2537UC9 v: ThinkPad T410
Avatar de l’utilisateur
tower41000
 
Message(s) : 169
Inscription : 15 Jan 2017, 19:37

Re: scanner canon / page noire

Message par chilperik » 13 Sep 2017, 12:40

Bonjour,

Je up le sujet avec mon canon lide20, mème problème, Page noire à la numérisation.

le scanner fonctionne parfaitement avec :
- vuescan sous manjaro, mais j'ai le filigram et je ne souhaite pas utiliser un programme fermé
- simple scan sous ubuntu / linux mint (aucun bug)

Avec scanimage ça fonctionne à peu près, mais j'ai qu'une vignette et pas ma page en A4 ?

Simple scan à marché deux ou trois fois avec ma manjaro
Xsane n'a jamais réussi a scanner quoi que ce soit...

Je vous mets ici ma config :

Code : Tout sélectionner
[chilperik@robin ~]$ lsusb
Bus 002 Device 004: ID 04a9:220d Canon, Inc. CanoScan N670U/N676U/LiDE 20


Code : Tout sélectionner
[chilperik@robin ~]$ scanimage -L
device `plustek:libusb:002:004' is a Canon CanoScan N670U/N676U/LiDE20 flatbed scanner


Code : Tout sélectionner
[chilperik@robin ~]$ id
uid=1000(chilperik) gid=1000(chilperik) groupes=1000(chilperik),3(sys),6(disk),7(lp),10(wheel),90(network),91(video),92(audio),93(optical),95(storage),96(scanner),98(power)


Code : Tout sélectionner
/etc/udev/rules.d/96-scanner.rules
BUS=="usb", SYSFS{product}=="CanoScan", MODE="664", GROUP="scanner"


Cette commande a réussi à faire fonctionner simple scan une fois sans que je comprenne vraiment le sens :
Code : Tout sélectionner
[chilperik@robin ~]$ sudo install -d -m 775 -g scanner /run/lock/sane


SI vous avez des pistes pour faire fonctionner mon scanner avec simple scan sous manjaro sans bug et sans refaire la config au démarrage je suis preneur ! :)
D'avance merci
chilperik
 
Message(s) : 3
Inscription : 13 Sep 2017, 12:25

Re: scanner canon / page noire

Message par Denis-pom » 13 Sep 2017, 13:21

J'ai le même scanner et il marche très bien :gsourire:
J'ai eu des problèmes il y a 8 mois quand je l'ai acheté (viewtopic.php?f=19&t=8057) mais ça a été réglé via AUR.

Quand j'ai changé de PC et installé une 17.02, ça a marché de suite : simplescan et xsane.

Le problème était que sane était en version 1.0.25 et qu'il fallait une "1.0.26" mini. Aujourd'hui, sane est en 1.0.27.

Regarde donc ta version de sane et des autres applis.
CPU : AMD A8-7600, carte mère ASRock FM2A88M-HD+ R3.0 - 8Go RAM
Graph. : AMD Radeon R7
1 SSD 120Go, 1HD 1 To
Manjaro xfce depuis mars 2016, après Ubuntu Voyager 12.04 (et bien d'autres)
Denis-pom
 
Message(s) : 118
Inscription : 27 Mars 2016, 14:02

Re: scanner canon / page noire

Message par chilperik » 13 Sep 2017, 13:44

Merci pour ta reponse denis-pom mais ma manjaro est à jour donc sane aussi en version 1.0.27-1 ... :(

Quand tu dis les autres logiciels tu parles de simple scan ? Eux aussi sont à jour en principe.

Franchement je vois pas où se situe le probleme ??
chilperik
 
Message(s) : 3
Inscription : 13 Sep 2017, 12:25

Re: scanner canon / page noire

Message par Denis-pom » 13 Sep 2017, 14:00

Regarde aussi :
grep 'CanoScan LiDE 1' /lib/udev/rules.d/49-sane.rules -A1
# Canon CanoScan LiDE 100
ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="1904", MODE="0664", GROUP="scanner", ENV{libsane_matched}="yes"
# Canon CanoScan LiDE 110
ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="1909", MODE="0664", GROUP="scanner", ENV{libsane_matched}="yes"

ajout de :
# Canon CanoScan LiDE 120
ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="190e", MODE="0664", GROUP="scanner", ENV{libsane_matched}="yes"


Joue aussi avec la luminosité, et ne la mets surtout pas à fond.
CPU : AMD A8-7600, carte mère ASRock FM2A88M-HD+ R3.0 - 8Go RAM
Graph. : AMD Radeon R7
1 SSD 120Go, 1HD 1 To
Manjaro xfce depuis mars 2016, après Ubuntu Voyager 12.04 (et bien d'autres)
Denis-pom
 
Message(s) : 118
Inscription : 27 Mars 2016, 14:02

Re: scanner canon / page noire

Message par chilperik » 13 Sep 2017, 15:38

le grep est ok mais toujours cette satané page noire ! :' (
Code : Tout sélectionner
[chilperik@robin ~]$ grep 'CanoScan LiDE 1' /lib/udev/rules.d/49-sane.rules -A1
# Canon CanoScan LiDE 100
ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="1904", MODE="0664", GROUP="scanner", ENV{libsane_matched}="yes"
--
# Canon CanoScan LiDE 110
ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="1909", MODE="0664", GROUP="scanner", ENV{libsane_matched}="yes"
--
# Canon CanoScan LiDE 120
ATTRS{idVendor}=="04a9", ATTRS{idProduct}=="190e", MODE="0664", GROUP="scanner", ENV{libsane_matched}="yes"
chilperik
 
Message(s) : 3
Inscription : 13 Sep 2017, 12:25

Re: scanner canon / page noire

Message par Denis-pom » 13 Sep 2017, 17:16

Regarde aussi dans /etc/sane.d/genesys.conf
# Canon LiDE 120
usb 0x04a9 0x190e

mais chez moi, ça n'avait alors pas changé grand chose.

Redémarre aussi ton PC si tu as fait des modifs, certaines (fichiers rules entre autres) ne sont prises en compte qu'à ce moment ou avec une commande spéciale (que je connais pas :saispas: )

Et joue avec les Préférences de simplescan.
CPU : AMD A8-7600, carte mère ASRock FM2A88M-HD+ R3.0 - 8Go RAM
Graph. : AMD Radeon R7
1 SSD 120Go, 1HD 1 To
Manjaro xfce depuis mars 2016, après Ubuntu Voyager 12.04 (et bien d'autres)
Denis-pom
 
Message(s) : 118
Inscription : 27 Mars 2016, 14:02


Retour vers Support Matériel & Kernel

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 4 invité(s)